15:02:58 <NikitaKonovalov> #startmeeting StoryBoard
15:02:59 <openstack> Meeting started Mon Jun  9 15:02:58 2014 UTC and is due to finish in 60 minutes.  The chair is NikitaKonovalov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:03 <openstack> The meeting name has been set to 'storyboard'
15:03:37 <NikitaKonovalov> Agenda as always is here https://wiki.openstack.org/wiki/StoryBoard
15:04:33 <NikitaKonovalov> #topic Roadmap(ttx)
15:04:38 <ttx> hey
15:04:58 <ttx> So we had a high-level roadmap on the etherpad from the juno design summit session
15:05:08 <ttx> I turned it into a wikipage for a bit more... permanence
15:05:17 <ttx> #link https://wiki.openstack.org/wiki/StoryBoard/Roadmap
15:05:43 <ttx> First task is to <strike></strike> the items we have completed
15:06:16 <ttx> NikitaKonovalov: do you see anything that should be marked as completed?
15:06:28 <NikitaKonovalov> I think "UI to find tasks assigned to you" is already implemented by krotscheck's commit
15:06:52 <ttx> NikitaKonovalov: thought so too, but the prod instance is not showing it?
15:08:11 <ttx> Second thing to note, I split what was MVP 1.2 on the etherpad into two slightly separate steps (1.2 and 1.2.1)
15:08:21 <ttx> following a suggestion from mordred
15:08:43 <ttx> that integrated projects could switch to using storyboard for blueprints sooner that they switch to using storyboard for bugs
15:09:04 <ttx> (which makes sense, since launchpad blueprints are so horrible, while bugs are pretty decent)
15:09:15 <NikitaKonovalov> sounds resonable to me
15:09:18 <ttx> so that lets us having a slightly shorter list at 1.2
15:09:27 <ttx> and prioritize in a useful way
15:09:47 <ttx> for example we don't need secret features or backport tasks for blueprints
15:10:44 <ttx> OK, that's all I had on this topic
15:11:05 <NikitaKonovalov> I've noticed LP import before using for blueprints
15:11:13 <NikitaKonovalov> what sohuld we import?
15:12:52 <ttx> NikitaKonovalov: it's a bit unclear
15:13:17 <ttx> NikitaKonovalov: basically I'm not 100% certain there is so much value to import from LP until we hit 1.2.1
15:13:23 <ttx> (integrated projects bugs)
15:13:52 <NikitaKonovalov> ok, let's get back to that later
15:13:55 <ttx> existing infra bugs and integrated projects blueprints may not have that much value to import
15:14:01 <ttx> It's a discussion with those stakeholders
15:14:19 <ttx> It's something we'll need to support for sure
15:14:51 <ttx> just not entirely clear how critical it is for the various groups, so in which milestone it should land
15:15:14 <ttx> hence the "?" on that line :)
15:15:58 <NikitaKonovalov> agree, we need to practice importing stuff at some point before big projects decide to move to SB
15:16:24 <NikitaKonovalov> ok, next topic is specs
15:16:29 <NikitaKonovalov> #topic Specs
15:16:40 <ttx> OK, let's try to find those in infra-specs
15:17:02 <ttx> I'll add them to the agenda
15:17:39 <ttx> OK, same list
15:18:13 <ttx> refreshed agenda page
15:18:42 <ttx> i didn't get any review on the tags spec
15:19:15 <ttx> I need to review the search spec
15:19:29 <NikitaKonovalov> ttx: I've looked through the tags spec
15:20:34 <NikitaKonovalov> I think we should also have tags for projects, so that a User could mark a project
15:20:57 <ttx> NikitaKonovalov: could you give an example of what you would use that for ?
15:21:13 <ttx> I'd rather have "project groups" to do random project grouping
15:22:23 <ttx> because i can't think of a project "tag" that wouldn't actually make sense as a project group instead
15:22:24 <NikitaKonovalov> Let's say a User wants to tag all python-whateverclient project with a "client" tag
15:22:48 <NikitaKonovalov> and then subscribe to all stories that affect client libraries
15:22:58 <ttx> NikitaKonovalov: I think we should have a "client libraries" project group then
15:23:12 <ttx> It makes sense to be centrally administered
15:23:51 <ttx> I fear if we allow random tagging of projects, they will end up with a long list of them
15:24:09 <ttx> we should rather identify the needs for grouping and provide them as project groups
15:24:26 <ttx> "client" is a valid project group
15:24:31 <ttx> as would be "infra"
15:24:38 <ttx> or "all-storyboard"
15:24:56 <NikitaKonovalov> that makes sense
15:25:11 <ttx> NikitaKonovalov: I guess we could implement projectgroups as project tags though, if we restrict tagging to admins
15:25:27 <ttx> but I'd rather not overload the meaning of "tags"
15:25:46 <NikitaKonovalov> agree let's keep tags for Stories only
15:26:09 <ttx> a given project (code repo) will just be a part of a number of project groups. And if one group is missing, we should just create it
15:26:25 <ttx> havign them centrally administered will let us be coherent
15:26:37 <ttx> (if we had a new client project somwhere, we'll add it to the clients projectgroup)
15:26:41 <ttx> add*
15:26:53 <ttx> anyway, I digress :)
15:27:09 <NikitaKonovalov> at least we can create groups based on project prefix like openstack-infra/nodepool is definitlly going under openstack-infa group
15:27:55 <ttx> NikitaKonovalov: let's see if anything else on MVP1.1 needs a spec
15:28:21 <ttx> NikitaKonovalov: project groups maybe?
15:28:44 <NikitaKonovalov> looks so
15:28:48 <ttx> I seem to remember there were some bits of it already landed, though ?
15:29:16 * ttx adds spec links to the roadmap
15:29:30 <NikitaKonovalov> There is an API that allows all necessary operations for project groups and projects inside those
15:30:27 <NikitaKonovalov> may be the load_projects script needs an update to create groups in a smarter way
15:30:34 <NikitaKonovalov> and there is no UI at all
15:30:41 <ttx> NikitaKonovalov: ok, so probably not needing a spec if it's half-implmeented already
15:31:20 <NikitaKonovalov> I think a Story should be enough to describe that
15:31:40 <ttx> ack
15:31:53 <NikitaKonovalov> #action NikitaKonovalov create a Story for Project Groups
15:32:01 <ttx> updated https://wiki.openstack.org/wiki/StoryBoard/Roadmap with links to specs
15:32:22 <NikitaKonovalov> great
15:32:23 <ttx> I guess we could add links to stories there too
15:33:02 <NikitaKonovalov> so the next spec is for Search
15:33:28 <NikitaKonovalov> I've got some comments from krotscheck
15:33:55 <ttx> i'll review it soon
15:34:03 <NikitaKonovalov> the main thing missing there is "What should the query strings look like?"
15:34:55 <ttx> ok, will keep an eye on that
15:34:55 <NikitaKonovalov> We can postpone that until we have a quorum for a discussion
15:35:16 <mordred> morning
15:35:21 <NikitaKonovalov> o/
15:36:57 <NikitaKonovalov> so we have a spec for subscriptions
15:37:38 <ttx> I like it
15:37:46 <NikitaKonovalov> and it looks like the most complex
15:41:08 <NikitaKonovalov> I guess we should wait for some reviews before implementing that
15:42:20 <NikitaKonovalov> Looks like that's all for the specs
15:42:32 <NikitaKonovalov> #topic Ongoing work
15:42:59 <ttx> NikitaKonovalov: you go first
15:43:18 <NikitaKonovalov> I'm working on name fields validation
15:44:23 <NikitaKonovalov> The name fields of projects and project groups should be url friendly
15:45:05 <NikitaKonovalov> So there is a bunch of changes to introduce that validation
15:45:10 <NikitaKonovalov> and some testing for it
15:46:19 <NikitaKonovalov> That's pretty much all from my side because I was a bit busy last week with my University graduation work
15:47:11 <NikitaKonovalov> And I guess I'll be for this week too
15:47:20 <ttx> NikitaKonovalov: heh
15:47:43 <ttx> OK, on my side, I worked on the roadmap and need to work on spec review
15:47:51 <ttx> I try to keep up with reviews
15:48:13 <ttx> I might work on more documentation around the project, to clarify the intent and goals
15:48:22 <ttx> and status
15:48:33 <ttx> as there seems to be a bit of misunderstanding on that side
15:49:03 <ttx> EOF
15:49:38 <NikitaKonovalov> time for an open discussion
15:49:45 <NikitaKonovalov> #topic Open discussion
15:51:16 <ttx> NikitaKonovalov: nothing to add
15:51:24 <ttx> Thanks for running the meeting!
15:51:45 <NikitaKonovalov> we have holidays on Thursday and Friday in Russia this week
15:52:11 <ttx> I have a holiday today here. (don't ask)
15:52:22 <NikitaKonovalov> ok
15:52:26 <NikitaKonovalov> #endmeeting