15:00:09 <krotscheck> #startmeeting Storyboard
15:00:10 <openstack> Meeting started Mon Jul 28 15:00:09 2014 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'storyboard'
15:00:15 <krotscheck> Agenda: https://wiki.openstack.org/wiki/StoryBoard#Agenda
15:00:23 <jeblair> o/
15:00:23 <krotscheck> #topic Urgent items
15:00:27 <NikitaKonovalov> hi
15:00:35 <krotscheck> Woo, it’s a jeblair !
15:00:49 <Ish__> Hi all..
15:00:50 * krotscheck is mildly jealous of Germany + Oscon :)
15:01:01 <jeblair> krotscheck: we missed you!
15:01:28 <krotscheck> jeblair: I missed you too! It was Ish__’s first week though, It was better for me to stay put.
15:01:37 <krotscheck> Anyway.
15:02:25 <krotscheck> We’ve still got a bit of a block on getting rabbit onto our server, mostly because big puppet module reviews are big.
15:03:15 <krotscheck> So general question: Should we continue to wait on https://review.openstack.org/#/c/98007 getting reviewed, or should I add rabbit direct off of master and then rebuild the big refactor on top of that?
15:03:20 <jeblair> yeah, the infra review rate has been low for the past 2 weeks; i'm personally anticipating doing a lot of reviews this week.
15:03:57 <krotscheck> For the sake of getting the work for subscriptions, notifications, and emails going a bit faster I’m leaning towards the latter.
15:03:59 <ttx> o/
15:04:12 <krotscheck> jeblair: I figured as much. Conventions & stuff  :)
15:04:45 * ttx tried to push a number of reviews through today, will continue review work over the week
15:05:11 * krotscheck is very happy about the cadence we’re getting now.
15:05:37 <krotscheck> It’s basically: Work happens throughout the week, Nikita and krotscheck argue about things, and nything we agree on ttx will get to on monday morning :)
15:06:11 <jeblair> krotscheck: has the big puppet refactor patch been tested?
15:06:17 <krotscheck> Back to the rabbit thing though. Stick with what we have (big refactor, rabbit on top of that) or rearrange things (rabbit first, then big refactor with rabbit in it)
15:06:33 <krotscheck> jeblair: I’ve tested it on my local box, but I haven’t tested it in infra.
15:06:50 <krotscheck> jeblair: I’m not certain what needs to happen there.
15:07:23 <jeblair> krotscheck: that's cool -- local testing can catch a lot of stuff
15:07:52 <jeblair> krotscheck: when we're ready, we can manually run a puppet apply --noop on it to try to catch any last minute issues before actually pushing it to production
15:08:09 <krotscheck> jeblair: Got it.
15:08:20 <krotscheck> So stick with the chain we have?
15:08:29 <jeblair> krotscheck: i kind of think it's been reviewed enough at this point that (since it's tested) it might be worth while to push for a final set of reviews this week
15:08:48 <krotscheck> Alright, let’s do that!
15:08:52 <krotscheck> And then I can do rabbit things :)
15:09:00 <krotscheck> Onwards.
15:09:03 <krotscheck> #topic MVP1.1
15:09:30 <NikitaKonovalov> Search is mostly ready
15:09:56 <NikitaKonovalov> the missing part is MySQL 5.5 upgrade to 5.6
15:09:58 <krotscheck> NikitaKonovalov: So it is. We’ve got a neat new interface, and I have a few refactors and updates coming that’ll bring that UI to stories and proejcts.
15:10:20 <krotscheck> #topic MVP 1.1 ( Search )
15:10:34 <NikitaKonovalov> Am I right that there are no objections to upgrade MySQL?
15:11:03 <NikitaKonovalov> I've already talked to SergeyLukjanov and he promissed to help with that
15:11:22 <krotscheck> NikitaKonovalov: None here, but I’m not sure it’ll be possible? We’re using Trove right now, and I don’t know whether the cloud provider storyboard is on supports that.
15:11:53 <krotscheck> I had a talk with the trove guys on friday, and they weren’t aware that 5.6 was in upstream yet.
15:11:56 <NikitaKonovalov> The provider is rackspace and we with SergeyLukjanov have already checked that the db is 5.6
15:12:08 <krotscheck> Oh good!
15:12:23 <krotscheck> No objections then.
15:12:28 * krotscheck will have to update the storyboard puppet module
15:12:29 <NikitaKonovalov> The gate issue is already soved by skipping the full-text migration
15:12:45 <krotscheck> #action krotscheck Update storyboard puppet module to require mysql 5.6
15:13:10 <NikitaKonovalov> here is the api side change for full-text
15:13:11 <NikitaKonovalov> https://review.openstack.org/#/c/101476/
15:13:31 <NikitaKonovalov> and here is the client https://review.openstack.org/#/c/102536/
15:13:31 <krotscheck> So once we get the upgrade, we can get those search patches in, and then propagate it to the UI, and we’ll finally have search done :)
15:13:41 <NikitaKonovalov> krotscheck: yes
15:14:00 <krotscheck> Cool. NikitaKonovalov, I assume that you and SergeyLukjanov will focus on getting the upgrade this week?
15:14:11 <NikitaKonovalov> that's the plan
15:14:19 <krotscheck> ALrightey
15:14:29 <krotscheck> #topic MVP1.1 (Subscription)
15:15:08 <krotscheck> So, rabbit issues aside, what needs to happen for this feature to drop?
15:16:03 <NikitaKonovalov> The change with timeline event based subscriptions is here https://review.openstack.org/#/c/102842/
15:16:11 <NikitaKonovalov> (need a rebase though)
15:16:31 <krotscheck> What about Ish__’s work?
15:16:44 <NikitaKonovalov> and Ish__ has started a new one https://review.openstack.org/#/c/109405/
15:17:27 <NikitaKonovalov> the difference is that it handles not the timeline events but the low level http requests
15:17:51 <krotscheck> I kindof prefer that version, actually.
15:18:48 <krotscheck> Because it’ll make things like https://review.openstack.org/#/c/105252/ a bit easier to handle, without giving up subscription.
15:20:23 <krotscheck> Ok, so a bit more discussion needs to happen on the code reviews regarding all those approaches.
15:20:47 <krotscheck> Given that we’re at least a week away from having rabbit anyway, I’m happy tabling this.
15:21:00 <krotscheck> #topic MVP 1.1 (Project Groups)
15:21:12 <krotscheck> I added project group admin to the UI the other day.
15:21:53 <krotscheck> Next (and last) piece is to reveal project groups in the search and in the UI.
15:22:17 <krotscheck> I don’t anticipate any major problems there.
15:22:22 <krotscheck> Anyone have questions on that?
15:23:09 <NikitaKonovalov> krotscheck: by revealing in search you mean filter results by a project group?
15:23:16 <krotscheck> NikitaKonovalov: Yes.
15:23:39 <krotscheck> NikitaKonovalov: Additional query parameter for stories, tasks, and projects I think.
15:24:07 <NikitaKonovalov> krotscheck: I just wanted to be sure we are not indexing the groups
15:24:32 <NikitaKonovalov> no more  questions from me
15:24:35 <krotscheck> Cool.
15:24:43 <krotscheck> #topic MVP1.1(Tags)
15:24:52 <krotscheck> Spec is ready, no coding has been done.
15:24:59 <krotscheck> (I think. Someone correct me if I’m wrong)
15:25:28 <NikitaKonovalov> no coding from me, but it can become my secondary target for this week
15:25:44 <krotscheck> Sure!
15:25:47 <krotscheck> Alrightey.
15:25:49 <krotscheck> #topic MVP 1.1 (Emails)
15:25:58 <krotscheck> I’m starting to make room in the UI for personal email preferences.
15:26:44 <krotscheck> Most of the backend work is likely going to have to wait until notification subscriptions are up and running, and we’ll want to discuss exactly how we want emails to work.
15:27:35 <krotscheck> The review is here https://review.openstack.org/#/c/109441/
15:27:49 <NikitaKonovalov> I remember somene saying that Launchpad does a good aggregation of events before sending e-mail
15:28:04 <krotscheck> Yeah, I’d like something like that as well.
15:28:06 <ttx> yeah -- I'm not totally convinced how much we need to do there
15:28:26 <ttx> i.e. how many people rely on LP email notifications in their workflows today
15:28:35 <krotscheck> I _would_ like to get a better usage profile on how people want to consume emails.
15:28:42 <ttx> personally i don't use them that much
15:28:58 <krotscheck> Like: Would people prefer a once-a-day summary email? Would they use the subscription timeline more?
15:29:03 <ttx> and I tend to think that if we need email notifications that means we failed somewhere
15:29:04 <krotscheck> Are emails redundant altogether?
15:29:21 <jeblair> i'd be interested in email notifications of new bugs and comments
15:29:31 <jeblair> basically -- things that keep me up to date with the conversation
15:29:41 <ttx> but I'd agree my email consumption case is a bit of an edge case
15:29:53 <jeblair> i don't think i'd personally find other kinds of events to be very useful
15:30:01 <krotscheck> Hrmmm....
15:30:22 <ttx> jeblair: as far as MVP 1.1 is concerned, that means email supprting the infra team usage
15:30:35 <krotscheck> Ok, need more research. Anyone have objections for me putting a Google Form together and posting it to Openstack-dev as a survey?
15:30:43 <ttx> jeblair: so would you like to do a quick survey of how you use email there ?
15:30:45 <krotscheck> (Or openstack-infra)?
15:30:55 <jeblair> ttx: did we put email on an mvp list?
15:31:03 <ttx> jeblair: you did
15:31:10 <ttx> iirc
15:31:33 <jeblair> does someone have a link to that handy?
15:31:53 <ttx> krotscheck: note that LP has an email command interface. I have no idea how many people use it, but it might be worth to add it to your survey
15:32:12 <krotscheck> jeblair: https://storyboard.openstack.org/#!/story/99 is the story I created off of the MVP wiki doc...
15:32:25 <ttx> MVP doc @ https://wiki.openstack.org/wiki/StoryBoard/Roadmap
15:32:27 <krotscheck> Here’s the roadmap: https://wiki.openstack.org/wiki/StoryBoard/Roadmap
15:33:15 <ttx> krotscheck: I /hope/ the survey won't result in us considering implementing an EmailInterface, but it's still good data to know how many people use it and like it
15:33:36 <jeblair> hrm
15:33:42 <jeblair> https://etherpad.openstack.org/p/StoryboardMeetup
15:33:54 <jeblair> has it listed under 'lp feature parity', and with a '?'
15:34:26 <krotscheck> I think the roadmap is more recent, wasn’t that what came out of the summit?
15:34:53 <ttx> I seem to remember it was promoted when we revisited the list (and added that mvp 1.1.1 thing)
15:35:00 <jeblair> https://etherpad.openstack.org/p/juno-infra-storyboard
15:35:01 <krotscheck> https://etherpad.openstack.org/p/juno-infra-storyboard
15:35:24 <krotscheck> ARgh, people keep beating me to links.
15:35:33 <krotscheck> Ok, so: Email in 1.1. Yes/no?
15:35:48 <jeblair> mordred, fungi: do you recall why email notifications are listed in storyboard mvp 1.1?
15:36:33 <jeblair> i don't recall thinking they are required for infra use, but perhaps we just wanted to get them in there before openstack use to make sure they were tested
15:36:44 <ttx> krotscheck: when you have the survey ready, I can proofread it if you want
15:37:15 <jeblair> at any rate, the only listed use case seems to be 'notification of new stories related to a project'
15:37:35 <krotscheck> #action krotscheck Make survey for email usage.
15:38:57 <ttx> yeah -- project or projectgroup
15:39:34 <krotscheck> Ok, so it sounds like we want the email engine _working_ with a small, usable use case?
15:40:13 <jeblair> sounds reasonable, but not one of the more critical tasks
15:40:35 <ttx> krotscheck: ++
15:40:41 <krotscheck> Got it.
15:40:45 <krotscheck> I’ll update the story.
15:40:55 <krotscheck> #topic MVP1.1 Launchpad Data Import
15:41:06 <krotscheck> No work has happened on this yet.
15:41:16 <fungi> jeblair: i don't recall, no
15:41:23 <ttx> that's MVP 1.1.1, right
15:41:40 <krotscheck> ….goes to check
15:41:41 * ttx looks at https://wiki.openstack.org/wiki/StoryBoard/Roadmap
15:41:56 <krotscheck> Oh, neat!
15:42:01 <krotscheck> Must have been a typo in storyboard.
15:42:31 <jeblair> serious infra usage of storyboard is more or less blocked on this; i'm not sure why it would be 1.1.1
15:42:36 <jeblair> the juno etherpad says 1.1
15:42:45 <NikitaKonovalov> and the python-client is in the section, which I think should be above the import
15:42:56 <jeblair> NikitaKonovalov: i agree
15:43:04 <jeblair> though that is 1.1.1
15:43:11 <jeblair> so i'm not sure what the thinking was there either :)
15:43:34 <krotscheck> The thinking was that for 1.1 we could write a DB dump script.
15:43:58 <krotscheck> i.e. direct from DB to DB
15:44:22 <jeblair> well, we can't dump lp's db, so it would be lp-api > sql... but that sounds quite hard
15:44:34 <jeblair> because we already have a database with data in it
15:44:53 <ttx> jeblair: your call on 1.1 vs. 1.1.1
15:45:11 <ttx> 1.1. was "bare minimum" and 1.1.1 was "usable"
15:46:32 <jeblair> i want to be really clear that we're basically not using storyboard at all -- we can only use it for storyboard itself
15:46:40 <jeblair> i'd very much like that to change
15:46:47 <jeblair> sooner rather than later
15:47:55 <jeblair> if we can't import data soon, then i'd like to just manually move important bugs over and drop the rest
15:48:11 <krotscheck> jeblair: The way I read that is “We have a list of features, let’s focus on getting some done quickly than all of them done at the same time"
15:48:42 <ttx> jeblair: I think MVP 1.1 targets lets you migrate for a set of projects that do not have that much history
15:48:44 <jeblair> krotscheck: sure, it's just that the overall strategy is "get infra dogfooding as early as possible"
15:48:53 <ttx> while we take on the task of handling LP migration
15:49:23 <ttx> but yeah, it hardly seems more uregnt than email notifications
15:49:31 <ttx> err
15:49:34 <ttx> I mean the opposite
15:49:36 <krotscheck> Yeah, well, version semantics are secondary to “Hey we can’t actually use this thing”.
15:49:52 <krotscheck> Ok, so LP data import gets moved to the top.
15:50:04 <ttx> email notifications seem hardly more urgent than LP migration
15:50:39 <ttx> krotscheck: on that roadmap, I think we can safely mark "UI to find tasks assigned to you" done, right ?
15:51:09 <mordred> jeblair: I do not remember why it was in 1.1
15:51:11 <mordred> email
15:51:18 <krotscheck> I think so.
15:51:23 <krotscheck> ttx: I think so.
15:51:33 <ttx> mordred: I lookes up the etherpad history, it seems to have been directly added there during the discussion
15:51:55 <ttx> so someone must have said "email notifications are awesome!"
15:52:00 <jeblair> i could probably live with waiting a bit more for the sync script (1.1.1) except that we seem to be letting more and more projects use this
15:52:07 <jeblair> and that was not the plan
15:52:15 <jeblair> the plan was infra first, then move out from there
15:52:25 <mordred> ok - so I think a sync script is easy and I've been meaning to write one - I apologize for not having it done by now
15:52:36 <mordred> I do _not_ think it needs python-storyboardclient to exist
15:52:51 <ttx> krotscheck: ok done. Also moved LP migration to 1.1
15:52:59 <ttx> so that we are in sync
15:52:59 <krotscheck> Cool
15:53:10 <jeblair> mordred: how will you import data?
15:53:27 <mordred> jeblair: sqlalchemy commands, same as the project creation script
15:53:31 <jeblair> ok
15:53:39 <mordred> jeblair: from a script making launchpadlib calls
15:53:56 <krotscheck> We only have 5 minutes left and I want to give time for open discussion, can we put migration into mordred’s lap and sit on his head this week?
15:54:25 <mordred> krotscheck: yah. I should have time a little later this week to hack that up - if I can focus for 2 hours I think I can knock it out
15:54:48 <krotscheck> mordred: Alrightey. Throw disrupting people in my direction if you need to clear up time.
15:54:53 <krotscheck> #topic Open Discussion
15:55:31 <krotscheck> I’ve been working on the javascript build in infra, and I’ve added a patch that’ll let us create projects in storyboard without a corresponding git repository to support UX.
15:55:45 <krotscheck> Anyone have anything else?
15:55:54 <NikitaKonovalov> nothing from my side
15:56:31 <krotscheck> Alrightey.
15:56:33 <ttx> nothing
15:56:38 <krotscheck> Thanks everyone!
15:56:38 <krotscheck> #endmeeting