16:00:22 <krotscheck> #startmeeting StoryBoard
16:00:23 <openstack> Meeting started Mon Nov 10 16:00:22 2014 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:24 <krotscheck> Woo, new time!
16:00:27 <openstack> The meeting name has been set to 'storyboard'
16:00:39 <krotscheck> And new channel!
16:00:51 <fungi> exciting
16:01:11 <fungi> new bat time, new bat channel
16:01:23 <krotscheck> Indeed!
16:01:28 <krotscheck> Also, new bat timezone.
16:01:41 <fungi> timezones are for losers
16:02:06 <krotscheck> Anyway, I want to use this meeting to rejigger our meeting agenda post summit.
16:02:14 <krotscheck> Since it’s unlikely that much happened last week, and it’ll get us organized moving foward.
16:02:20 <fungi> sounds like a great idea
16:02:53 <krotscheck> So let’s start here, and I’ll paste the new priorities, and the old agenda, into it:
16:02:54 <krotscheck> https://etherpad.openstack.org/p/rejigger-all-the-things
16:03:36 <krotscheck> First though, urgent items.
16:03:46 <krotscheck> #topic Urgent Items
16:03:59 <krotscheck> I think the only one I’m aware of is identified bugs in the migration script.
16:04:17 <krotscheck> I got reasonably far with that, but I can’t reproduce the user import bug we had a problem with.
16:04:23 <fungi> unfortunate
16:04:32 <fungi> i can rerun once you're ready to dig deeper
16:04:45 <krotscheck> fungi: Do you think you’ll be able to give me an SQL dump of the users table so I can use that to test with?
16:04:54 <fungi> krotscheck: absolutely
16:04:58 <krotscheck> Awesome.
16:05:04 <fungi> get up with me after the meeting when you're ready
16:05:08 <krotscheck> Roger wilco.
16:05:22 <fungi> i can mysqldump it on prod and scp it over to dev
16:05:22 * krotscheck files that under urgent items.
16:05:36 <krotscheck> I don’t think we have a dev...
16:05:51 <fungi> oh, right. in that case i'll stick it somewhere you can retrieve
16:06:26 <krotscheck> kk
16:06:30 <krotscheck> Any other urgent items?
16:06:40 <krotscheck> (Other than telling the rest of the team that our meeting time changed? :D
16:06:48 <fungi> none from me, though i think there's not anyone else paying attention
16:06:52 <krotscheck> point
16:07:12 <krotscheck> Ok, so moving on with that...
16:07:13 <fungi> so, er, make your own priorities? ;)
16:07:19 <krotscheck> Don’t we always? :D
16:07:20 <fungi> ttx: around?
16:07:22 <ttx> o/
16:07:25 <krotscheck> oot
16:07:26 <krotscheck> woot
16:07:29 <fungi> (and then there were three)
16:07:34 * ttx reads backlog
16:07:47 <krotscheck> #topic Discussion Topics
16:08:13 * ttx first fixes ical
16:08:23 <krotscheck> We still have story types on this list, I don’t think that’s moving off the agenda just yet.
16:08:36 <krotscheck> Although from discussions I’ve had at the summit it’s DEFINITELY a thing we care about.
16:10:00 <krotscheck> For some reason the etherpad is acting up.
16:10:30 <krotscheck> Other discussion topics that were raised at summit: User adoption and documentation.
16:10:33 <fungi> it was probably not a fan of something you pasted in
16:10:49 <persia> Or not a fan of my browser choices (as the coincidence of timing might indicate)
16:10:51 <ttx> krotscheck: is projectgroups all landed or do you need more approvals ?
16:10:58 <krotscheck> I feel that’s a larger discussion, because we’ve got lots of different audiences. Users, Devs, Intallers, etc.
16:11:24 <krotscheck> ttx: Project groups is landed, with one outstanding bug that’s currently up for approval, but it’s not super high importance because I went in and fixed the thing manually.
16:11:35 <ttx> ok
16:11:47 <ttx> shall we add "import bugs" to the 1.1 list ?
16:12:06 <krotscheck> Hrm, methinks that’s an urgent item.
16:12:17 <ttx> feels like that's the only blocker at this point
16:12:32 <krotscheck> yep
16:13:39 <krotscheck> Other discussion topics?
16:13:48 <krotscheck> Maybe put the PM awareness bit on?
16:13:56 <ttx> In the 1.2 list, is there anything I should probably draft a spec for ? Nebulous things like "milestone support" maybe ?
16:14:27 <krotscheck> Yes
16:14:30 <krotscheck> Def that.
16:14:38 <krotscheck> Should we bounce to 1.2?
16:16:08 <krotscheck> #topic MVP 1.2 Agenda
16:16:34 <krotscheck> What is “In progress feature import?”
16:16:46 <ttx> krotscheck: hmmm
16:17:07 <persia> I thought it was "Feature: Import, Status: In Progress"
16:17:09 <ttx> probably that we need to be able to import Launchpad features that are not completed yet into Storyboard
16:17:28 <ttx> ISTR we said we don't need to import completed features that much
16:17:34 <krotscheck> ttx: That suggests some kind of blueprint scraping?
16:17:54 <ttx> krotscheck: that suggests hell. We'll have to circle back to stakeholders on this one
16:17:59 <ttx> make sure it's REALLY needed
16:18:25 <ttx> features are sufficiently volatile that it may not be worth it
16:18:54 <krotscheck> ttx: Good point. Adding to discussion topics.
16:18:58 <ttx> and launchpad blueprints contain a *lot* of stale old BPs
16:19:00 * krotscheck is not certain who the stakeholders there are.
16:19:46 <ttx> krotscheck: I'd say, the groups which want to jump in storyboard next after infra
16:20:03 <krotscheck> Alrightey.
16:20:08 <ttx> I can reach out
16:20:19 <krotscheck> Oooh, we need to draft an infra adoption email.
16:20:24 <krotscheck> We can include it in that.
16:21:11 <fungi> yeah, infra explicitly avoided blueprints
16:21:42 <fungi> i think we have one or two which people filed because nova, neutron et al had them in the habit of doing so
16:22:05 <fungi> but if infra's aren't imported, no great loss
16:22:36 <krotscheck> kk
16:23:06 <krotscheck> What does FFE in FFE workflow stand for?
16:23:14 <ttx> Feature freeze exception
16:23:28 <ttx> The idea here is to have some way of tracking a spec was granted an exception
16:23:39 <ttx> currently it's all etherpads and custom lists
16:23:40 <fungi> as opposed to the more popular abbreviation, "ffs"
16:23:48 <ttx> I suspect we can use some protected tag
16:23:53 <krotscheck> kk
16:24:03 <krotscheck> Or ffx :)
16:24:15 <krotscheck> I don’t see security bugs here somewhere.
16:24:23 <krotscheck> Added
16:24:34 <ttx> to be honest, we don't need FFE workflow for feature parity with LP
16:24:34 <fungi> this will be tricky. importing private bugs is likely to be hard
16:24:41 <ttx> since we don't have any there
16:25:47 <krotscheck> fungi: Seems like we need the import script to be able to log in as someone, and then have all the people with all the security access do the import.
16:26:19 <fungi> it's worth noodling on whether we need the import user to be a superuser granted read access to all private bugs, or whether we just punt and manually move private security bugs in (since the private state is transient and we don't usually have more than a dozen or so in flight at any particular time)
16:26:47 <persia> Do we need explicit hardcoded FFE support?  Generally, I think it better to make generic features, and have policy independent (e.g. don't approve a new feature past date X unless conditions A, B, and C are met.  Indicate conditions with flags or tags or something.
16:27:15 <ttx> fungi: private bugs are volatile enough.. if we don't import them, no biggie
16:27:37 <krotscheck> Seems like a discussion to be had as soon as we add private bug feature support.
16:27:44 <fungi> persia: yeah, i think the position is that ffe doesn't need any special features, but we might add features to make tracking them more efficient down the road?
16:28:11 <ttx> persia: yes, I think we can do it with tag
16:28:43 <ttx> krotscheck: removed FFE from 1.3
16:28:53 <ttx> pushed to wishlist
16:29:09 <ttx> LP doesn't have it, so no need to have it for parity/migration
16:30:06 <ttx> krotscheck: so.. I'd move file attachments to 1.3, if only because LP has them and we want to import
16:30:37 <krotscheck> kk
16:30:42 <ttx> krotscheck: on the other hand, Integration with Specs, Project Stats/Graphs/Reporting,Etherpad Summit Design Session Markup Import...
16:30:52 <ttx> or UX Support... are wishlist
16:31:02 <ttx> Up in the wishlist for sure
16:31:11 <krotscheck> Well, the wishlist is unscheduled
16:31:43 <ttx> Top part of 1.3 is what we need to migrate off LP
16:31:45 <persia> I actively don't like attachments, but am happy to argue my case some other day
16:31:56 <ttx> Bottom part are nice features that will make people love Storyboard
16:33:00 <krotscheck> Point.
16:33:03 <ttx> krotscheck: should we put the bottom part in some 1.4 or 1.3.1 ?
16:33:38 <krotscheck> ttx: Honestly, I think doing a version more than “the one we’re working on rigth now” isn’t that helpful.
16:33:45 <ttx> right
16:34:54 <krotscheck> Ok, so I think I have all the features from Juno and from Kilo in the etherpad now prioritized based on the discussion that was had.
16:36:17 <ttx> OK, looks like I have 3 specs to work on
16:36:24 <krotscheck> I feel that we’ve got plenty to do.
16:36:40 <krotscheck> MVP 1.2 might stand to be prioritized.
16:37:05 <krotscheck> #action krotscheck Copy all the StoryBoard todo items into StoryBoard.
16:38:18 <krotscheck> I moved Email to the top, since it’s currently most complete of those items
16:38:34 <krotscheck> I’ll put tags after that, because we actually have that data in the database and need to surface it.
16:38:48 <fungi> sounds great
16:39:04 <ttx> Maybe story types after that, since we have a spec for it
16:39:13 <krotscheck> I’d like to have the Issue-Auth-Tokens bit in after that, since it’s actively blocking zaro’s work to do API integration.
16:39:22 <ttx> or one of the ones which don't require specs
16:39:25 <krotscheck> Right.
16:39:49 <krotscheck> Actually, maybe User Auth goes before tags?
16:39:51 <krotscheck> Dunno.
16:39:57 <fungi> also, when did we want to try switching it from lp openid to openstackid.org now that it's available?
16:40:34 <ttx> fungi: I'd say ASAP
16:40:44 <ttx> sounds like a good test fo it
16:40:46 <krotscheck> Wait, that’s a thing now?
16:40:56 <krotscheck> Yes. Asap.
16:40:57 <ttx> krotscheck: yes, just don't tell the world
16:40:58 <fungi> the migration task might be complex since i'm assuming we'll need to map lp accounts to foundation member accounts by some shared key to figure out who is who
16:41:13 <krotscheck> yeah, that could be tricky.
16:41:14 <fungi> e-mail address maybe
16:41:22 <fungi> except that lp lets you hide your e-mail address
16:41:23 <krotscheck> LP doesn’t give us email addresses.
16:41:32 <fungi> yeah, bollocks
16:41:40 <krotscheck> Poly-auth?
16:42:06 <krotscheck> The guys at Forj really want a pluggable Auth system anyway. Might be worth trying to do it that way.
16:42:15 <krotscheck> But the link-two-accounts flow is going to be a pain.
16:42:37 <fungi> i'm not immediately groking how that would work, but maybe a writeup or very tiny spec would help me visualize
16:42:53 <krotscheck> fungi: You got it.
16:43:06 <fungi> we're going to run into similar challenges when migrating other systems over anyway
16:43:30 <fungi> (for gerrit we actually have at least some mapping data, but the wiki is another story)
16:44:10 <krotscheck> That mapping, in general, might be a really helpful thing to build.
16:45:10 <fungi> right, i'll try to come up with options for how we might piece that together once i'm able to brain a little better
16:45:22 <krotscheck> Brains are overrated, just use AFS
16:45:28 <fungi> undeed
16:45:43 <krotscheck> Anyone see any other missing items on that list?
16:46:10 <ttx> krotscheck: nothing jumps at me
16:46:58 <krotscheck> Yeah, There’s a few things in there that should probably be grouped. Status auto-update for instance is part of the broader integration story
16:47:11 <krotscheck> Gerrit Links is related to rich text editing and rendering
16:47:38 * ttx adds "Milestone support spec" to his TODO list
16:48:39 <krotscheck> I’ll rearrange those later though, still need to think about the impact there.
16:48:57 <krotscheck> If that’s all, I’ll move to open discussion to see if there’s anything else to bring up.
16:49:27 <fungi> nothin'
16:49:27 <krotscheck> #action krotscheck Transfer meeting rejigger etherpad to agenda wiki
16:49:33 <krotscheck> #topic Open Discussion
16:49:55 <krotscheck> So, I got a code drop from Codethink with a storyboard kanban board from persia.
16:49:59 <fungi> so was the storyboard exposure in our design summit sessions generally helpful?
16:50:04 <fungi> actionable feedback?
16:50:05 <ttx> krotscheck: did you manage to get any user testing done last week?
16:50:35 <krotscheck> I dug through it on the plane right back, and there are definitely pieces that I can use, though I have to peel apart an abstraction layer that was added.
16:51:10 <krotscheck> I feel that the exposure was mostly helpful, but all of the Product level discussions that I had on Monday, as wella s the hidden influencer meeting, was very much “Oh we’ll wait and see” responses.
16:51:32 <krotscheck> ttx: No user testing, the two people I signed up were no-shows.
16:52:06 <krotscheck> ttx: But I do have a standing invitation from Blue Box to wander down to teir offices in seattle and do tests with them.
16:52:34 <fungi> that's cool at least
16:52:44 <krotscheck> fungi: The main actionable feedback I’ve received is “Where’s the install guide".
16:53:02 <fungi> sometimes the connections you make are worth more than anything directly accomplished during the short amount of time allotted
16:53:16 <krotscheck> Yeah, that’s what I’m hoping.
16:53:26 <krotscheck> I also made a good connection with the guys in Budapest.
16:53:59 <krotscheck> Anyone else have things that they did that worked out well for StoryBoard?
16:54:58 * fungi takes the silence as a resounding "no"
16:55:11 <krotscheck> yep
16:55:20 <krotscheck> Alright, let’s call it. Thanks everyone!
16:55:23 <krotscheck> #endmeeting