16:00:28 <krotscheck> #startmeeting Storyboard
16:00:30 <openstack> Meeting started Mon Nov 17 16:00:28 2014 UTC and is due to finish in 60 minutes. The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:33 <openstack> The meeting name has been set to 'storyboard'
16:00:33 <ttx> o/
16:00:44 <krotscheck> Hey hey!
16:00:45 <krotscheck> Anyone other than ttx here?
16:01:11 <krotscheck> ‘cause if not we’ll just do a summary of what I did last week.
16:01:32 * kashyap lurking here as someone interested in Storyboard's functionality
16:01:33 <krotscheck> Agenda: https://wiki.openstack.org/wiki/StoryBoard#Agenda
16:01:53 <krotscheck> Thanks, kashyap!
16:02:10 <krotscheck> #topic Urgent Items
16:02:16 <krotscheck> #topic Urgent Items: Infra Migration
16:02:27 * krotscheck peers at meetingbot
16:02:49 <krotscheck> ttx: I think meetbot died.
16:02:56 <ttx> krotscheck: you killed it!
16:03:01 <krotscheck> Dead!
16:03:06 * krotscheck is good at killing bots
16:03:26 * ttx checks
16:03:27 <krotscheck> Well, while I have everyone’s attention.
16:03:41 <krotscheck> Let’s make all the decisions that we don’t want to be recorded.
16:03:54 <krotscheck> First of all, we’re migrating our auth system to LDAP and refactoring to use OracleDB
16:04:29 <ttx> Looks like it's still logging: http://eavesdrop.openstack.org/meetings/storyboard/2014/storyboard.2014-11-17-16.00.log.txt
16:04:33 <fungi> krotscheck: i think it's working, just not setting channel topics because it lost chanops
16:04:37 <krotscheck> Gotcha
16:04:44 <fungi> i can fix it after
16:04:48 <krotscheck> kk
16:04:55 <krotscheck> Back to Infra Migration
16:04:57 <fungi> there was much gnashing of teeth within freenode over the weekend, so not surprising
16:05:19 <krotscheck> So fungi and I worked on the migration during the week, and encountered a few other hiccups that we’ve since resolved.
16:05:33 <krotscheck> Upside: All the things are now migrated, and the script is way more intelligent about de-duplication.
16:05:36 <fungi> and the import script is incremental now too
16:05:41 <krotscheck> Downside: We lost about a week or so.
16:05:50 <krotscheck> Right, that too.
16:05:57 <fungi> not a week of data, just a week of fiddling and futzing
16:06:02 <krotscheck> So we can go back and do an incremental migration for stragglers.
16:06:24 <krotscheck> Either way, infra data has all now been transferred as of… thursday?
16:06:47 <krotscheck> And the remaining tasks are to A) fli the bit on launchpad to point at storyboard, and B) Land the various doc updates.
16:07:19 <ttx> krotscheck: want me to help in the bit flipping ?
16:07:34 <krotscheck> ttx: Yes please. I don’t actually know what to do there.
16:08:00 <fungi> or i can too. the sticky wicket will be openstack-ci because it needs to stay open for elastic-recheck use
16:08:24 <ttx> Ah. Actually I can't. Damn project doesn't follow the guidelines and didn't abdicate to the ~openstack-admins overlords
16:08:35 * fungi can fix that too
16:08:49 <krotscheck> fungi: Aren’t you swamped?
16:09:01 <ttx> we live in swamps
16:09:20 <fungi> sure. but i get to choose the swamp
16:09:22 <krotscheck> That would make ttx an amphibian
16:09:27 <krotscheck> Or a reptile
16:09:30 <krotscheck> Point
16:09:47 <ttx> Just don't cut anything off me to check
16:10:23 <krotscheck> Ok, so fungi will flip the bit on launchpad, as well as fixing the openstack admin thing.
16:10:44 <krotscheck> And I will pester people to land the doc updates.
16:10:48 <fungi> #action fungi flip the bit on launchpad
16:10:56 <fungi> #action fungi fix the openstack admin thing
16:11:07 <krotscheck> #action krotscheck Pester people to land storyboard doc updates.
16:11:19 <krotscheck> #action krotscheck Put migration onto infra agenda for tomorrow.
16:11:34 <krotscheck> #topic Discussion Topics
16:12:08 <krotscheck> #action krotscheck Draft infra-adoption email.
16:12:27 <krotscheck> On discussion topics, is there anything someone wants to raise? I don’t personally feel ready to talk about most of these yet.
16:13:09 <fungi> i know there's at least concern from two jenkins-job-builder core reviewers about lack of e-mail notification for storyboard
16:13:21 <ttx> fungi: that's good!
16:13:36 <ttx> if we incovenience them enough they may RMS it
16:13:41 <fungi> heh
16:13:52 <krotscheck> RMS?
16:14:13 <fungi> richard m. stallman of course!
16:14:30 <ttx> Richard M. Stallman -- pun on the legendary story about the printer driver he was inconvenienced enough to fix in open source
16:14:31 <fungi> (or root mean square maybe)
16:14:34 <ttx> err free software
16:14:35 <krotscheck> Oh, gotcha.
16:15:02 <krotscheck> Well, they can definitely help :)
16:15:25 <krotscheck> I did some patch maintenance and other feature work on thursday and friday, so I haven’t been able to get to email.
16:15:25 <ttx> we rely on inconveniencing people enough for them to help fix storyboard.
16:15:38 <ttx> did some reviewing today as usual
16:15:49 <krotscheck> Well, zaro and I did a tradeoff, I do User Auth for his api, and he does email.
16:15:56 <krotscheck> And then he went on 2 weeks of vacation (starting today)
16:16:27 <krotscheck> ttx: Always appreciated. Your reviews are like clockwork.
16:16:42 * krotscheck would be happy if monday morning became the “Review all the things” day.
16:17:29 <krotscheck> I’m curious about progress from persia on documentaiton.
16:17:41 <krotscheck> #topic Discussion Topics: Documentation
16:18:13 <krotscheck> persia: Any progress there?
16:18:24 * krotscheck will wait 2 minutes to see if he’s around, and then move on.
16:19:40 <krotscheck> Ok, let’s assume he’s not here.
16:19:51 <krotscheck> #topic Discussion Topics: PM Awareness
16:20:11 <krotscheck> rainya isn’t in this room, so I’ll poke her offline to see what her plan is.
16:20:25 <krotscheck> #action krotscheck Poke rainya about PM awareness work.
16:20:47 <krotscheck> #topic Discussion Topics: In progress features.
16:20:57 <krotscheck> ttx: I still don’t know what in-progress-feature-report is.
16:21:13 <ttx> hmm
16:21:39 <ttx> "In progress feature import " you mean ?
16:22:00 <krotscheck> Right
16:22:01 <krotscheck> That
16:22:06 <ttx> I guess that means "ability to import currently incomplete blueprints"
16:22:23 <ttx> i.e. import blueprints from Launchpad
16:22:37 <ttx> but only the ones that are in progress, not the completed ones
16:22:42 <krotscheck> Does launchpad currently have a strong association between bugs and blueprints, or are those separate?
16:23:02 <ttx> separate tables
16:23:13 <ttx> I think it's overkill
16:23:31 <ttx> as projects regularly flush their pile of blueprints so that the "open" ones are relevant
16:23:43 <ttx> it doesn't sound that much difficult to start from zero
16:24:03 <krotscheck> ttx: Is there any good way of linking a blueprint with a ticket? Because if that’s the case we can go grab the associated stories and rewrite the whole kit-n-kaboodle into one big story
16:24:36 <fungi> i think there's no strict association between thm
16:24:39 <fungi> them
16:24:40 <ttx> krotscheck: blueprints have associated bugs
16:25:18 * ttx fetches an example
16:25:19 <krotscheck> ttx: Oh good. So if we _want_ to import blueprints, we can create associations inside of storyboard, however that might end up looking.
16:25:36 <krotscheck> Linking strategy TBD
16:26:00 <ttx> krotscheck: not sure I follow
16:26:04 <krotscheck> It sounds to me like Blueprint import is something that should be tracked as a feature, and discussed when we’re ready to work on that.
16:26:41 <ttx> yes, at the very least we should provide a CLI tool to import most details of a LP blueprint in a new StoryBoard story
16:26:46 <krotscheck> ttx: So, we can import blueprints. If we import them, it might be possible to convert them into a story and roll all the associated tasks up underneath it. But whether we import, and how, is still up for debate.
16:27:14 <krotscheck> Either way, it sounds like it’s something that’s not too difficult, and thus should be something we work on.
16:27:24 <krotscheck> ttx: What version, 1.3?
16:27:32 <ttx> sure. Technically it's not difficult. There is only one task in a LP Blueprint (which is why they fail so badly)
16:27:38 <krotscheck> I dunno, this feels like part of the feature tracking support.
16:27:49 <ttx> it's just that starting from a clean slate might actually be a good idea :)
16:28:13 <krotscheck> I’m up for that too :)
16:28:26 <ttx> definitely not at the top of our list in all cases
16:29:04 <krotscheck> Ok, so 1.2?
16:29:08 <krotscheck> Or 1.3
16:29:22 <ttx> depends on the adopting project I guess
16:29:51 <ttx> Some projects may require blueprint-import feature before they accept to move their feature tracking to Storyboard
16:30:03 <ttx> but we may just be able to convince them ALL otherwise
16:30:19 <krotscheck> Ok, so unprioritized/wishlist?
16:30:29 <fungi> i thought it was possible to have a blueprint with no associated bug at all, but perhaps i'm wrong about that
16:30:30 <ttx> so it's 1.2... but after discussion we may just remove it
16:31:06 <ttx> we need to engage with candidates for migration, see if they really care
16:31:33 <krotscheck> Ok, I’ll add it.
16:31:39 <ttx> if they don't, we can remove that point from 1.2, basically
16:31:50 <krotscheck> kk
16:31:53 <krotscheck> #topic MVP 1.1
16:31:59 <krotscheck> So, migration is ready.
16:32:01 <krotscheck> I think we’re done.
16:32:58 <krotscheck> Any disagreements?
16:33:14 <ttx> nope
16:33:29 <krotscheck> #topic MVP 1.2
16:34:01 <krotscheck> #topic MVP 1.2: Email
16:34:04 <krotscheck> No progress.
16:34:09 <krotscheck> Wait.
16:34:25 <krotscheck> There’s a discussion going on on this patch: https://review.openstack.org/#/c/130649/
16:34:35 <krotscheck> Which requires some talks.
16:35:17 <krotscheck> So, the original intent here was to create a space, much like /var/lib/apache2, where storyboard can store any of its own config files and/or runtime on-disk things.
16:35:57 <krotscheck> There’s some concern that storing things on disk isn’t performant.
16:36:05 <krotscheck> Which to some extent I agree with.
16:36:41 <krotscheck> yolanda has coments, but I don’t think she’s in this channel.
16:37:05 <krotscheck> So I guess my question is what the best way is to store intermediary data required by the email plugin.
16:38:10 <krotscheck> Anyone?
16:38:12 <krotscheck> Oookay.
16:39:06 <krotscheck> We’ll belay that until next week then.
16:39:47 <krotscheck> #topic MVP 1.2: User Auth Endpoint
16:39:52 <ttx> I just fear email will be a pain
16:39:55 <krotscheck> The API side of this is https://review.openstack.org/#/c/134409/
16:40:04 <krotscheck> ttx: Well, it’s already turning out to be contentious.
16:40:06 <ttx> It's what made LP timeout after all :)
16:40:25 <krotscheck> The UI side is coming.
16:40:44 <krotscheck> And once that’s done a user will be able to issue and revoke their own tokens.
16:40:51 <ttx> I want to make sure the benefit is absolutely worth the cost
16:41:19 <krotscheck> ttx: On email?
16:41:22 <ttx> yes
16:41:33 <ttx> sorry for out of sync answer
16:41:40 <krotscheck> No worries
16:41:44 * ttx blames kid on lap
16:41:52 <krotscheck> #topic MVP 1.2: Email
16:41:59 <krotscheck> We can always just go back to it.
16:42:04 <ttx> but then I have a nice princess drawing now
16:42:31 <krotscheck> Dawwwww
16:42:34 * krotscheck melts
16:43:02 <krotscheck> So wht are your concerns about emails?
16:43:18 <krotscheck> Other than the fact that most ticketing systems do them so horribly that everyone just ends up ignoring them.
16:44:20 <ttx> I just wish we could have a system that would not need email
16:44:46 <ttx> but we had that discussion already
16:44:58 <krotscheck> ttx: Yeah.
16:44:59 <ttx> I'm not the only stakeholder :)
16:45:30 <krotscheck> There are so many other significant touchpoints that people have access to now, email should be a minor thing.
16:45:41 <ttx> every time we'll run into a hurdle I'll ask myself, is it really worth the pain
16:45:42 <krotscheck> Like, how about mobile? We could do push notifications instead.
16:46:48 <ttx> krotscheck: sorry, my rant is just a distraction
16:47:21 <ttx> if that's a need-to-have for a lot of people, I guess we have to bite the bullet
16:47:52 <krotscheck> I think it’s a need-to-have for non-people-who-use-storyboard
16:48:44 <krotscheck> Wait
16:48:50 <krotscheck> that made no sesnse
16:49:02 <krotscheck> It’s a neet-to-have for people who don’t regularly use storyboard.
16:49:40 <ttx> krotscheck: we'll have some of those, definitely
16:49:46 <krotscheck> yep
16:51:27 <krotscheck> Ok, so, there’s no other work that happened on storyboard things other than the two that I mentioned.
16:52:48 <krotscheck> So I’m going to bounce on to open discussion.
16:52:52 <krotscheck> #topic Open Discussion
16:52:53 <krotscheck> Anything?
16:53:07 <ttx> nope
16:53:47 <krotscheck> Okay!
16:53:54 <krotscheck> That’s all, thanks everyone!
16:53:55 <krotscheck> #endmeeting