16:00:32 <krotscheck> #startmeeting Storyboard
16:00:32 <openstack> Meeting started Mon Feb 23 16:00:32 2015 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:36 <openstack> The meeting name has been set to 'storyboard'
16:00:57 <yolanda> o/
16:01:06 <krotscheck> Agenda: https://wiki.openstack.org/wiki/StoryBoard#Agenda
16:01:11 <krotscheck> Who's here?
16:01:19 <yolanda> hi hi
16:01:24 <rcarrillocruz> hi
16:01:30 <krotscheck> wooooo
16:01:31 <krotscheck> people!
16:01:36 <jeblair> and other persons
16:01:52 <krotscheck> People, and other persons? Wow, do we get some personalities too?
16:02:05 <krotscheck> #topic Actions from Last Week: DB Refactor Spec
16:02:14 <krotscheck> NikitaKonovalov: You around? Any work on the spec?
16:03:08 <ttx> o/
16:03:14 <krotscheck> I'll take that as a no. Leaving it on the agenda.
16:03:21 <krotscheck> #topic Urgent Items
16:03:25 <krotscheck> Did anything major come up?
16:04:12 <krotscheck> Also silence!
16:04:20 * krotscheck is happy when that topic has silence.
16:04:29 <krotscheck> I did bring one up though
16:04:36 <krotscheck> #topic Urgent Items: HP Things
16:04:42 <yolanda> :(
16:04:55 <krotscheck> So, as some of you may have seen on the TripleO threads on channel, there've been some changes inside of HP.
16:05:19 <krotscheck> I cannot comment on details from inside of HP
16:05:35 <krotscheck> However at this point it's becoming clear that our team will be impacted as well.
16:05:35 * ttx doesn't want to see the insides
16:05:52 <jeblair> krotscheck: in what way?
16:06:30 <krotscheck> jeblair: There is significant concern that yolanda, rcarrillocruz, and jedimike won't be able to contribute much anymore.
16:06:39 <yolanda> i will do on free time
16:06:44 * krotscheck notes that some of them have been doing so on free time already.
16:06:46 <yolanda> i'm really commited with storyboard
16:07:03 <rcarrillocruz> i will as well, but obv. this will impact SB...
16:07:05 <jeblair> krotscheck: this is news to me
16:07:28 <krotscheck> jeblair: I'd be happy to discuss internal HP things with you in internal HP channels, or you could reach out to them direclty.
16:07:41 <jeblair> yolanda, rcarrillocruz: has someone told you such?
16:07:47 <rcarrillocruz> likewise, i'm happy to share our thoughts and concerns
16:08:03 <yolanda> jeblair, we cannot share so much but it will be like that
16:08:07 <rcarrillocruz> in private or an internal HP channel
16:08:09 <yolanda> yes
16:08:11 <yolanda> private
16:08:42 <jeblair> krotscheck: ok, i'm just confused, because yolanda and rcarrillocruz were not on the tripleo team.
16:08:45 <krotscheck> With that in mind though, we do not yet know any details.
16:09:24 <yolanda> jeblair, krotscheck, we can create later some channel and talk  about it
16:09:29 <jeblair> krotscheck: i do not believe what you say should be the case
16:09:34 <jeblair> i'm happy to talk about it privately
16:09:37 <rcarrillocruz> agree
16:09:38 <jeblair> but i did not bring it up publicly
16:10:01 <krotscheck> jeblair: I agree, I am saying there's concern, and that we don't know much yet.
16:10:06 <jeblair> so, i will say publicly that i don't think it should be the case, there may be a misunderstanding
16:10:28 <krotscheck> Again, I agree, and I am saying publicly that the situation remains unresolved.
16:10:29 <jeblair> krotscheck: yes, but saying "i have concern that hp is cutting support for 3 people who are working on this project" is a dangerous thing to say
16:11:01 <krotscheck> jeblair: Dangerous how? I am being honest.
16:11:05 <jeblair> krotscheck: i wish you would have said nothing until you knew something factual.  i believe you have just muddied the waters.
16:11:51 <jeblair> krotscheck: because now people will think that hp is less committed to storyboard, and this is all based on a reorganization of an unrelated team.
16:12:02 <ttx> I for one appreciate the heads-up. Let me know how that evolves (one way or another)
16:13:23 <krotscheck> Well, I'm not a fan of hiding things until facts develop. Concerns need to be raised so they can be addressed, and I welcome public statements to address those concerns.
16:14:00 <mordred> I have no reason to believe that anyone at HP will be prevented from working on storyboard
16:14:10 <jeblair> krotscheck: sure, but "at this point it's becoming clear that our team will be impacted as well" seems counterfactual to me
16:14:45 <krotscheck> mordred: Good to hear.
16:15:33 <mordred> or, let me rephrase, there are no priorities that have been changed that I am aware of for any of the people at HP other than krotscheck who have been hacking on storyboard.
16:15:35 <krotscheck> Listen: There's an elephant in the room. I am not a fan of ignoring the elephant until we know whether it's pink or not. I am worried, lots of people are worried.
16:15:43 <yolanda> mordred, so i think we all need to have better clarification, and expose the situation clearly
16:15:48 <yolanda> that's not the moment btw
16:16:11 <krotscheck> I say we recognize that there's an elephant, and express our color preferences.
16:16:13 <mordred> they have always had a primary job description that could trump for moments of time their ability to have a ton of time to devote
16:16:27 <mordred> given that they are responsible for a production service and outages take priority
16:16:36 <mordred> nothing about that has changed
16:17:04 <krotscheck> Guys, I'm not trying to put anyone on the defensive here.
16:17:06 <mordred> similarly, their production service is based on openstack-infra, so being involved with usptream infra efforts has been and remains to be a priority
16:17:20 <mordred> sure - I just want to be clear about what the situation has been and is now
16:17:38 <mordred> I apoligize for any lack of clarity that is causing stress
16:17:46 <mordred> apologize
16:17:55 <mordred> apoligize is not a word :)
16:18:05 <krotscheck> It is in some parts of the states.
16:18:11 <mordred> touche
16:18:42 <krotscheck> Ok, so my intent with bringing this up was to just say: Hey, things inside of HP are really uncertain right now, there's a bunch of people who contribute to this project who are worried.
16:18:58 <krotscheck> If something similar happened to Mirantis, I would hope they bring it up as well.
16:19:03 <mordred> indeed. I'll make a note to try to clarify with everyone
16:19:16 <mordred> there is actually not uncertainty - but that may be unclear and uncertain
16:19:41 <krotscheck> mordred: Oh good.
16:19:59 <krotscheck> Anyone have anything else to say on this before we move on?
16:20:02 <mordred> I had meant to follow up with everyone towards the end of last week, but I am only just now really back online
16:20:12 <mordred> so sorry for stress my company causes sometimes
16:21:04 <krotscheck> Alright, let's move on.
16:21:41 <krotscheck> #topic Discussion Topics: Google Summer of Code
16:21:54 <yolanda> not related, but haven't seen Jovanka for some days
16:22:05 <krotscheck> yolanda: Where's she based out of?
16:22:10 <yolanda> Macedonia
16:22:13 <krotscheck> kk.
16:22:27 <krotscheck> So we've got the UX team support as a potential project. Does anyone else have ideas?
16:23:49 <krotscheck> Oh, comeon. Does anyone else have off-roadmap pet projects they want to see in storyboard?
16:23:50 <yolanda> only UX ? why not a full feature?
16:24:23 <jeblair> yolanda: the full feature is adding support for interactive annotation of attached images in support of the ux team
16:24:44 <yolanda> attached images will be covered by Jovanka
16:24:53 <yolanda> but i need to contact her again, not sure what happens
16:25:11 <krotscheck> mordred: What about a storyboard IRC bot?
16:26:31 <jeblair> krotscheck: we're discussing alternative bot frameworks, but i don't think we've quite settled how that will work.  we may not be ready for that.
16:26:44 <krotscheck> jeblair: Will that discussion have settled by may?
16:27:32 <jeblair> krotscheck: probably.  it will also be a very small project; probably 50 lines of code.
16:27:45 <ttx> krotscheck: I suggested the file attachment stuff :)
16:27:54 <krotscheck> ttx: Right!
16:27:57 <krotscheck> SOrry, forgot about that.
16:28:05 <krotscheck> If jovanka's able to work on that, great.
16:28:12 * ttx tries to remember the other idea he had
16:28:44 <ttx> oh, markup comments
16:29:05 <krotscheck> ttx: Could you explain that one a bit more?
16:29:28 <ttx> well, the ability to use rich(er) text in comments
16:29:33 <krotscheck> Oh, nice.
16:29:38 * krotscheck puts that on the list.
16:29:43 <ttx> (and descriptions for that matter)
16:29:53 <ttx> I see two items that correspond in the Roadmap:
16:29:58 <ttx> Etherpad Summit Design Session Markup Import
16:30:04 <ttx> Rich Text Comments (markdown?)
16:30:13 <ttx> Oh oh oh
16:30:23 <ttx> I remember now: "task ordering".
16:30:26 <krotscheck> The ability to push our code back to the various node/bower repositories would be nice too.
16:30:26 <ttx> That was the other idea
16:30:39 <krotscheck> Brilliant.
16:30:46 <ttx> I think that's sufficiently standalone
16:30:50 <krotscheck> That gives us 6 projects to propose.
16:30:58 <ttx> All the others are pretty deep in the code
16:31:21 <krotscheck> Yeah, and who knows how much code someone can get. It'll take at least a month to get into the codebase.
16:31:34 <krotscheck> s/get/get done/
16:31:36 <ttx> File attachments and task ordering neatly touch transversally without depending on too much other's work
16:31:40 <jeblair> btw, i worked on a story the other day that is almost certainly going to want task ordering
16:32:12 <krotscheck> jeblair: Is that the one that was entered on friday?
16:32:15 <jeblair> ya
16:32:36 <jeblair> we were brainstorming into the story, and i'm certain we didn't get all the things we need to do in the right order the first time :)
16:33:04 <krotscheck> So just to be clear, we're talking about a simple ordering mechanism, not something like task dependencies?
16:33:11 <ttx> krotscheck: exact
16:33:20 <krotscheck> Cool.
16:33:25 <ttx> ideally with awesome UI to match
16:33:27 <krotscheck> :)
16:33:34 * krotscheck really wants to work on the UI again :(
16:33:46 * krotscheck gets annoyed at that yack not being shaved.
16:34:19 <ttx> The idea being to be lightweight enough so that people can ignore ordering when it doesn't matter but can order when it does
16:34:51 <krotscheck> Alright, it's on the list.
16:35:35 <krotscheck> Does anyone object to settling this topic? YOu can marinate on it in our free time and add thigns later.
16:35:50 <krotscheck> Currently I have UX Feature, File attachments, Rich Text markup, and Task Ordering
16:37:05 <krotscheck> #action Krotscheck Get GSoC onto the wiki with some descriptions.
16:37:16 <krotscheck> #topic InProgress (krotscheck)
16:37:44 <krotscheck> So, last week I was working on puppet. There's enough features lined up on the storyboard codebase that it warrants an update to the module.
16:37:58 <krotscheck> The hope being that storyboard-dev will soon become a thing.
16:38:37 <krotscheck> I do have a few patches that won't pass because they're interdependent with ones on system-config, so I'll be poking the infra channel about figuring out the depends-on tag for that one.
16:39:24 <krotscheck> The pile starts here: https://review.openstack.org/#/c/156755/2
16:39:33 <ttx> krotscheck: I still couldn't get auth through -draft to work, still "Oh No"
16:39:45 <krotscheck> ttx: Yep. That's what that first patch is there for.
16:39:56 <krotscheck> Wait, i lied.
16:39:59 <krotscheck> It's the second one in the chain
16:40:04 <krotscheck> This one: https://review.openstack.org/#/c/157464/
16:40:10 <krotscheck> I think
16:40:14 <krotscheck> Or did I lie again?
16:40:24 <ttx> ack -- don't have +2 there and seems to have enough +1s
16:40:32 <krotscheck> Yep.
16:40:56 <krotscheck> That one'll make the configuration flag available, we'll need to add a similar patch in system-config to move things.
16:41:07 * krotscheck doesn't have +2 there either
16:41:32 <jeblair> krotscheck: then in your system-config patch, add "Depends-On: I29495a0b640c3ca097cca8c17349df5cc42388de" to the commit message
16:42:03 <krotscheck> jeblair: I did for some of them. There's a bit of a chicken-egg problem on one of the patches though, will flag you later if I can't figure it out.
16:42:08 <jeblair> kk
16:42:16 <krotscheck> That stack happens to start here: https://review.openstack.org/#/c/157981/2/modules/openstack_project/manifests/storyboard.pp
16:42:49 <krotscheck> I'm going to continue working on that, because I have too many things on my plate and I want to get some of them off.
16:42:52 <krotscheck> Next.
16:42:57 <krotscheck> #topic InProgress (yolanda)
16:42:59 <krotscheck> What's up?
16:43:09 <yolanda> so...
16:43:17 <yolanda> https://review.openstack.org/156543
16:43:20 <yolanda> needs review
16:43:26 <yolanda> the index for access_token
16:44:30 * krotscheck rechecks that patch now that python34 is voting.
16:44:40 <krotscheck> (Oh yeah, I forgot to mention that python34 is voting now!)
16:44:41 <yolanda> specs for integration tests had a +2 https://review.openstack.org/150743
16:45:06 <krotscheck> +1 from me.
16:45:26 <yolanda> and i started working on it even the spec wasn't approved 100%
16:45:44 <yolanda> so this one is for adding the tooling in the backend to run the tests
16:45:47 <yolanda> https://review.openstack.org/155975
16:46:04 <yolanda> and this one to create the configuration in project-config
16:46:05 <yolanda> https://review.openstack.org/156044
16:46:58 <yolanda> and that's all from my side
16:47:03 <krotscheck> Neat!
16:47:27 <krotscheck> #topic InProgress (greghaynes)
16:47:33 <krotscheck> He's... not here.
16:47:36 <krotscheck> I'll give his update.
16:47:40 <krotscheck> He made python 34 work!
16:47:48 <yolanda> woot!
16:48:03 * krotscheck is looking forward to the land of no more six.
16:48:08 <rcarrillocruz> good, i was fed up of getting tox failures :-)
16:48:22 <krotscheck> rcarrillocruz: Me too :)
16:48:34 <CTtpollard> cool
16:48:53 <krotscheck> Does anyone have major objections to eventually getting rid of python27? Right now the only issue seems to be older debian versions (ubuntu-precise-ish) that don't have a py34 distor.
16:48:56 <krotscheck> *distro
16:49:48 <krotscheck> Well, if so, we can argue that on gerrit.
16:50:03 <krotscheck> #topic InProgress (rcarrillocruz)
16:50:05 <krotscheck> Hi hi!
16:50:12 <rcarrillocruz> nothing i'm afraid
16:50:22 <rcarrillocruz> drowned by dayjob the whole week
16:50:30 <rcarrillocruz> sorry :(
16:50:52 <krotscheck> No worries!
16:51:15 <krotscheck> #topic InProgress (NikitaKonovalov)
16:51:16 <krotscheck> You here?
16:51:23 <krotscheck> ....wait a sec.
16:51:40 <krotscheck> Oh, it's "Defend the Fatherland" day in russia.
16:51:53 <krotscheck> (Defender of)
16:51:59 <krotscheck> They're probably on holiday.
16:52:11 <krotscheck> #topic InProgress (jedimike)
16:52:12 <krotscheck> You here?
16:52:15 <jeblair> krotscheck: i'd like to keep python27 for a while; it's the default python in the current ubuntu lts
16:52:27 <krotscheck> jeblair: You got it.
16:52:29 <yolanda> jedimike had day off
16:52:39 <krotscheck> Cool!
16:52:43 <krotscheck> #topic Open Discussion.
16:52:52 <krotscheck> We have 8 minutes!
16:52:57 <ttx> woohoo
16:53:15 <ttx> (says the guy attending two meetings in parallel)
16:53:36 <krotscheck> I wnt to apologize fro dragging my feet on email, dev.storyboard, and other things.
16:53:44 <yolanda> so for the integration tests, i hope the project and the tools are merged this week, and i want to do some more tests than just testing an empty api result
16:53:53 <krotscheck> I don't know why it's been tough to focus on that, but something else keeps getting in the way.
16:55:20 <krotscheck> yolanda: The only question on that I have is about the DB_ADMIN user - isnt' there a ci_openstacktest user that we can use?
16:55:40 <yolanda> well, i wanted to do the tool more generic
16:55:54 <yolanda> so you can run the tests in your own environment
16:56:15 <yolanda> so i added the flag that indicates if you want to create the initial user
16:56:34 <krotscheck> yolanda: Right, I see that. I was thinking more here -> https://review.openstack.org/#/c/156044/12/jenkins/jobs/javascript.yaml
16:56:58 <yolanda> ah, ok
16:56:59 <krotscheck> The DB_ADMIN_USER field
16:57:37 <yolanda> but in that case you install mysql from scratch, no user will be present at this moment
16:57:46 <yolanda> you need to connect as root and create the initial users
16:59:01 <krotscheck> yolanda: Right. So we've got two use cases, the need to install things from scratch, and the need to use something sane on the jenkins instance.
16:59:17 <krotscheck> We're out of time though, I'll comment on the review.
16:59:23 <krotscheck> Thanks everyone!
16:59:24 <krotscheck> #endmeeting