16:04:43 <krotscheck> #startmeeting Storyboard
16:04:44 <openstack> Meeting started Mon Apr 13 16:04:43 2015 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:47 <openstack> The meeting name has been set to 'storyboard'
16:05:10 <krotscheck> #topic Meeting Time
16:05:25 <krotscheck> I'm putting this frist because we've had... what, one real meeting in the last month?
16:05:44 <krotscheck> Is there a better time, or has everyone started to focus on other projects/
16:05:45 <krotscheck> ?
16:05:47 <yolanda> yes, sorry that i've been unavailable for long
16:06:07 <yolanda> i've been tied between meeting, being on-call and holiday
16:06:16 <krotscheck> Right.
16:06:19 <ttx> I'd rather move one hour earlier, at this hour I have a kid to care for
16:06:20 <NikitaKonovalov> The current time is fine for me
16:06:30 <krotscheck> Well, we can move the meeting earlier an hour because the U.S. has switched over to silly daylight savings.
16:06:52 <yolanda> it's fine for me, situation for myself should be the same being a bit earlier or later
16:06:53 <ttx> sounds good to me
16:06:54 <krotscheck> NikitaKonovalov: Any objection to moving an hour earlier? yolanda ?
16:07:10 <NikitaKonovalov> krotscheck: I'm fine with tat too
16:07:13 <krotscheck> Ok, let's do that. Having ttx around will definitely help things
16:07:13 <NikitaKonovalov> that*
16:07:20 <krotscheck> #agreed Move meeting an hour earlier
16:07:27 <krotscheck> Any volunteers to update the wiki>?
16:07:40 <yolanda> i can do it
16:07:50 <NikitaKonovalov> what about chanel availability btw
16:07:55 <krotscheck> #action yolanda Update wiki to move storyboard meeting an horu earlier.
16:08:02 <krotscheck> Good question!
16:08:19 <NikitaKonovalov> this one seems to be free
16:08:24 <yolanda> i was logged here an hour later, and no meetings
16:08:30 <yolanda> hour earlier i mean
16:08:34 <NikitaKonovalov> I've not seen any either
16:08:55 <ttx> just make sure to push it to https://wiki.openstack.org/wiki/Meetings too so that we book the slot
16:09:19 <ttx> -3 is free the hour before
16:09:19 <krotscheck> I don't see anything in this channel on the meeting list.
16:09:25 <krotscheck> So let's stay in this channel
16:09:37 <krotscheck> Agenda :https://wiki.openstack.org/wiki/StoryBoard#Agenda
16:09:46 <krotscheck> #topic Actions from last week.
16:09:49 <krotscheck> I don't think we have anything.
16:09:56 <krotscheck> That review is relatively old
16:10:14 <krotscheck> #topic Urgent Items
16:10:16 <krotscheck> Anything?
16:10:33 <ttx> nothing on fire as far as I know
16:10:44 <NikitaKonovalov> is import script fine now?
16:10:59 <krotscheck> NikitaKonovalov: I believe so
16:11:09 <krotscheck> #topic User Feedback
16:11:09 <yolanda> ok, wiki updated
16:11:18 <krotscheck> #topic User Feedback (lots of comments)
16:11:38 <krotscheck> Ok, so we landed the patch that removes API-based page limits. It's not optimal - for instance the project group page is crazy big now.
16:11:54 <krotscheck> But at least the project group page now filters properly :).
16:12:13 <yolanda> i got some private pings asking for SB situation and replacement, since Monty's announcement
16:12:39 <krotscheck> yolanda: There's a discussion on Infra about replacing it with Phabricator
16:12:53 <yolanda> i know yes, i just told people about that option
16:13:11 <krotscheck> #link https://www.mail-archive.com/openstack-infra@lists.openstack.org/msg02591.html
16:13:36 <krotscheck> That discussions eems to have fizzled, and nobody's stepped up to provide the resources to integrate it into infra.
16:13:52 <ttx> right, it's a bit stalled until we have the discussion in-person in Vancouver
16:14:05 <krotscheck> So without something _actually_ replacing storyboard, we're still a live project through may
16:14:07 <ttx> We should have a shiny demo ready to show current status of SB
16:14:08 <yolanda> yes, i think that Vancouver should be the ideal place to discuss about it
16:14:33 <yolanda> it may involve more effort to start and adapt a new project, than continue working on SB
16:14:50 <krotscheck> I guess the question is: Do we care?
16:15:21 <krotscheck> We have users. We have users who _like_ storyboard.
16:15:27 <ttx> At this point I'd say we should continue with the limited resources we have. At least until Vancouver
16:15:34 <krotscheck> We have a vision, a roadmap, and some really awesome thigns that get people excited.
16:15:44 <yolanda> i'm sorry to say that i'm very very limited to contribute now
16:16:07 <ttx> also LP -> Phab -> SB could be a thing too
16:16:21 <krotscheck> Yet Another Ticket Tracker
16:17:31 <krotscheck> Sounds like we want to talk in Vancouver then.
16:17:36 <krotscheck> ttx: Do we have a venue and/or time?
16:17:54 <NikitaKonovalov> unfortunatelly, I'll not be able to make it to Vancouver
16:18:09 <yolanda> i will be there
16:18:09 <krotscheck> NikitaKonovalov: Argh!
16:18:18 <krotscheck> NikitaKonovalov: will aripinen be able to make it?
16:18:36 <NikitaKonovalov> krotscheck: neither he will
16:18:40 <krotscheck> That sucks.
16:18:44 <yolanda> :(
16:19:00 <krotscheck> NikitaKonovalov: Well, I hope you can make it to Tokyo, because I will very likely not be able to make it.
16:19:17 * krotscheck isn't willing to leave his wife alone at home with a newborn.
16:19:25 <ttx> krotscheck: not yet
16:20:23 <krotscheck> ttx: Do you have a recommendation? Infra track, working rooms, etc etc.
16:21:37 <krotscheck> #topic Vancouver Summit
16:21:39 <ttx> That will likely be a fishbowl Infra session
16:21:53 <krotscheck> Ok.
16:21:58 <krotscheck> Seems like the best place to put it.
16:22:18 <krotscheck> #topic Discussion Topics
16:22:24 <krotscheck> Manuall data fix or migration with no downgrades: That's fixed.
16:22:38 <krotscheck> Email Spooling: No progress, I have that on my plate for this week.
16:22:58 <krotscheck> #topic Pagination/Search
16:23:31 <krotscheck> Still an outstanding disagreement on this, and there's been no progress. Nikki's been absorbed by gozer, so I propose we abandon that spec.
16:23:51 <yolanda> i guess Nikki won't be able to work on that for now
16:24:08 <ttx> absorbed by gozer sounds like a painful death
16:24:08 <krotscheck> Actually, let me adjust the topic....
16:24:18 <krotscheck> #topic Old Specs
16:25:05 <krotscheck> We've got a bunch of these. Permissions, Streaming, Story Types (looks like impl), Task Milestone, Paging
16:25:21 <krotscheck> Story Tyupes and Task Milestones already have code against it, however the specs have not been approved.
16:25:26 <ttx> yeah, we've had some stuckj because none of us has infra-specs +2
16:25:34 <krotscheck> That seems like...
16:25:38 <krotscheck> ....infra is blocking us.
16:25:44 <krotscheck> Do we need our own specs repo?
16:26:20 <yolanda> i'd like if SB was more isolated from infra
16:26:22 <ttx> well, I guess that ties into the previous discussion -- is SB still an infra project
16:26:31 <krotscheck> Yep.
16:26:35 <krotscheck> I agree with yolanda
16:26:39 <ttx> and we won't have the answer until a few weeks I think
16:26:43 <krotscheck> In fact, it should have been from the outset.
16:27:03 <ttx> If it's no longer an infra thing, then we can spin out to stackforge and let it live its life
16:27:16 <krotscheck> Allowing infra to continually weigh in on features, and to force us to adhere to a much slower approval process, has not done us any favors.
16:27:49 <krotscheck> Well, I've pinged the infra channel to start weighing in on our specs.
16:27:50 <ttx> I wouldn't say exactly that, but there has been misalignment between the two teams for sure
16:28:14 <krotscheck> ttx: I'm way angrier than you are :)
16:28:37 <krotscheck> Anyway, a good conversation for Vancouver.
16:29:00 <yolanda> yes, sounds like a good topic to discuss in face to face meetings
16:29:07 <ttx> but it's true it's difficult to make progress in one direction or another until we have that direct discussion
16:29:21 <krotscheck> Personally, I hate how one single -1 from someone basically kills a feature.
16:29:32 <krotscheck> Because nobody else is willing to weigh in
16:29:53 <krotscheck> It doesn't matter who it is - if there's one single -1, it feels like nobody actually bothers to look at the code.
16:29:54 <yolanda> this shouldn't be like that
16:29:59 <yolanda> as any core can have their own opinion
16:30:22 <yolanda> but krotscheck, i agree that it's the reality, i find myself trying to fix all -1 when i have them to get the change accepted
16:30:41 <krotscheck> Yep. And when the -1 is a philosophical disagreement, there's no way to get around it.
16:31:13 <ttx> right, that's one issue of growing a solution that is already adopted by its main user
16:31:22 <krotscheck> btw: NikitaKonovalov can we get aripinen to show up to meetings? He's been coding off in the weeds without any engagement with our roadmap.
16:31:47 * krotscheck would love to have his opinion.
16:31:49 <krotscheck> Anyway
16:31:52 <krotscheck> (sorry to derail)
16:32:11 <NikitaKonovalov> krotscheck: shifting an hour earlier may actually help
16:32:21 <krotscheck> ttx: I would have no problem accepting those opinions if it was done by someone engaged in the project.
16:32:28 <krotscheck> And willing to contribute.
16:32:43 <krotscheck> Either way: Vancouver discussion
16:32:44 <ttx> right, one of the reasons I tried to stay active
16:33:20 <ttx> have a hard stop in 10 min -- anything urgent to discuss ?
16:33:21 <krotscheck> With relation to the actual discussion topic, there's nothing we can do right now except wait for infra to get around to +2'ing things
16:33:30 <krotscheck> #topic InProgress (roadmap)
16:33:37 <krotscheck> ttx: What's up with the new roadmap?
16:33:38 <yolanda> krotscheck, that can derive from my -1 on the unassigned tasks an the discussion we had there
16:34:11 <krotscheck> yolanda: That's... actually in a different brainspace for me.
16:34:18 <krotscheck> yolanda: I'll poke you in channel about it.
16:34:26 <yolanda> ok, let's talk later
16:35:05 <ttx> krotscheck: nothing really -- just the idea that we should refresh the prioritized feature list
16:35:08 <ttx> and that was done
16:35:16 <krotscheck> ttx: Ok, so tnothing on the discussion topics.
16:35:19 <ttx> making sure that page reflects current status
16:35:27 <ttx> nope
16:35:36 <krotscheck> Ok, moving to open discussion
16:35:40 <krotscheck> #topic Open Discussion
16:35:44 <krotscheck> Let's add thigns to the agenda !
16:36:46 <krotscheck> I'm going to put vancouver discussion on the agenda next week.
16:37:12 <krotscheck> Because it feels like we've got a lot of unanswered questions. Let's come up with a list of things we need to settle in vancouver so we have a hit list.
16:37:35 <yolanda> krotscheck, will be good to have an etherpad for collaboration on topics to raise
16:37:43 <krotscheck> yolanda: You got it.
16:38:02 <NikitaKonovalov> yep, etherpad is the right thing to use here
16:38:45 <krotscheck> https://etherpad.openstack.org/p/storyboard-vancouver-may-2015
16:39:12 <ttx> Alright, talk to you all next week, hopefully less busy
16:39:21 <krotscheck> Alright, anything else someone wants to bring up?
16:39:35 <krotscheck> I _kindof_ do
16:39:51 <NikitaKonovalov> nothing from me
16:39:51 <krotscheck> So, I've been working on javascript-related infra things now that the future of StoryBoard is unclear.
16:40:00 <krotscheck> And, so far, I've managed to get real npm builds into Infra.
16:40:26 <krotscheck> I'm also currently in a discussion with the bower team to see if we can help extend bower to support openstack-like release tooling.
16:41:02 <krotscheck> Furthermore, I've managed to land CORS middleware in oslo.middleware, so we can deprecate our own internal implementation once that becomves available
16:41:05 <yolanda> what are the features needed for that?
16:41:17 <yolanda> for bower, i mean
16:41:26 <krotscheck> yolanda: Well, here's the discussion: https://github.com/bower/bower/issues/1775
16:41:52 <krotscheck> That's part of it. The other part is that bower needs to learn how to resolve variable-injected URI's.
16:42:22 <krotscheck> Say, if I tell it that my libraries live at https://foo.openstack.org/libname/{{version}}/libname-{{version}}.tgz
16:42:31 <krotscheck> bower should be smart enough to regex out the version
16:43:10 <krotscheck> The security discussion I just linked is all about making our package managers for debian and redhat happy
16:43:13 <yolanda> is that easy to collaborate with them?
16:43:25 <krotscheck> yolanda: Well, it's about a 12 hour turnaround on comments.
16:43:32 <krotscheck> And nobody's really in the bower channel.
16:43:45 <krotscheck> So it's not super easy, but it sounds like they're happy to accept contributions.
16:43:59 <yolanda> yes, sometimes is a matter of project owners being receptive
16:44:25 <krotscheck> If I tried the same with the NPM people I suspect I might get a different response :)
16:44:32 <krotscheck> Because OMG Why is that built on couchdb?
16:44:42 <krotscheck> Aaaanyway
16:44:48 <krotscheck> That's what I have to mention.
16:45:06 <krotscheck> (Incidentally, if you think landing something in openstack is hard, try oslo :/
16:45:08 <yolanda> i'm sorry for not being able to collaborate so much but it's quite heavy for me now
16:45:22 <krotscheck> yolanda: No worries.
16:45:35 <yolanda> if you look at my changes i've been mostly involved on downstream-puppet and nodepool recently
16:45:50 <krotscheck> I'm going to assume we have nothing else really to discuss at the moment. Want to switch over into channel?
16:45:56 <yolanda> ok
16:45:57 <krotscheck> Thanks everyone.
16:45:59 <krotscheck> #endmeeting