15:01:20 <SotK> #startmeeting storyboard
15:01:21 <openstack> Meeting started Wed Jul 29 15:01:20 2015 UTC and is due to finish in 60 minutes. The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:25 <openstack> The meeting name has been set to 'storyboard'
15:01:46 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard#Agenda_for_next_meeting Agenda
15:01:49 <SotK> #topic Urgent Items
15:01:52 <SotK> #info Reviews are still a bit of a blocker. There are a whole bunch of patches which need review from someone other than myself or Zara.
15:01:55 <SotK> #link https://review.openstack.org/#/q/(project:openstack-infra/storyboard-webclient+OR+project:openstack-infra/storyboard)+AND+status:open,n,z Outstanding patches
15:02:37 <SotK> It'd be great if we could persuade some folks to do some reviews for us!
15:04:21 <SotK> I'm not sure how to achieve that easily
15:05:21 <Zara> same here, not sure what to do beyond donning disguises and give out +1s ourselves.
15:05:26 <Zara> *giving
15:06:23 <SotK> I guess we just keep prodding in #storyboard for now
15:06:54 <SotK> There are no other urgent items that I'm aware of
15:07:04 <SotK> Anyone disagree?
15:07:13 <Zara> _o_
15:07:45 <SotK> #topic Spec Review
15:07:45 <SotK> #info There are a bunch of partially implemented accepted specs. We should decide what we think of these.
15:07:48 <SotK> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/storyboard_integration_tests.html Integration Tests
15:07:51 <SotK> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/storyboard_story_tags.html Story Tags
15:07:54 <SotK> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/storyboard_subscription_pub_sub.html Subscriptions and Events
15:07:57 <SotK> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/storyboard_task_branches.html Support for Branches
15:09:03 * SotK confesses to it being long enough since he read these that he can't remember any particularly strong opinions he had
15:09:36 <Zara> I'd suggest that since there are only two of us actively working on this atm, the first step might be to prioritise which spec (or maybe specs) to look at.
15:10:04 <SotK> I agree with that
15:10:58 <Zara> My preference would be for subscriptions and events, because in their current form, these seem to slow storyboard down, which I think is a very big problem. second choice would be tags.
15:11:17 <SotK> I agree with that too
15:11:58 <SotK> I had some thoughts about how to quickly improve subscriptions to at least alleviate some of the slowdown for now
15:12:13 <Zara> oh?
15:13:11 <SotK> Basically "get the current user's subscription list when the page is loaded, pass that to the code which decides whether to show a solid star or an edged star"
15:13:44 <SotK> rather than "do a GET request for each item on the current page that can be subscribed to"
15:14:19 <Zara> sounds sensible.
15:15:34 <SotK> I don't know if I'll have time to actually do that though
15:17:11 <Zara> okay, I could start to look at it next, if that seems like a good idea, and leave tags for later.
15:18:32 <SotK> seems sensible to me, though I'm happy to take a break from writing the worklists API to look at it if you'd rather do tags :)
15:20:02 <Zara> :) I don't really have a preference; I think it's more urgent than worklists or tags so at least one of us should look at it now.
15:21:09 <SotK> #agreed Subscriptions should be prioritised, followed by Tags.
15:21:55 <Zara> :)
15:22:06 <SotK> #action SotK or Zara to look at speeding up the subscription resolution code
15:23:55 <SotK> #topic In-Progress Work
15:23:56 <SotK> #info SotK is currently looking at implementing worklists and boards.
15:23:56 <SotK> #link https://review.openstack.org/202989/ Spec
15:23:56 <SotK> The plan is for these to be used to provide detailed, personal prioritisation, along with the ability to use a kanban workflow with StoryBoard tasks and stories.
15:23:58 <SotK> I'm currently working on writing the API for worklists and boards, whilst waiting for any comments on the spec.
15:24:01 <SotK> I've previously shown a mock-up UI for a kanban which people have given thoughts about.
15:25:05 <SotK> It'd be great to get some opinions on the spec from folks
15:25:19 <SotK> (it feels weird working to a not-yet-approved spec)
15:26:50 * Zara can confirm that the mock-up was pretty
15:28:25 <SotK> I'll populate a publically accessible mockup which won't randomly disappear or change IP repeatedly soon
15:28:48 <SotK> I'll put the link to it somewhere when I do that, and mention it in #storyboard
15:29:17 <SotK> #action SotK to create publically-viewable mockup of a kanban view
15:30:31 <SotK> Zara: what is your in-progress work at the moment?
15:31:03 <SotK> (I think you can also use #info and #link)
15:31:09 <Zara> This week I've been looking at making the UI more consistent, so making the project groups page look more like the Stories and Projects pages
15:31:50 <Zara> easier to explain by linking the patch: https://review.openstack.org/#/c/206108/
15:32:38 <Zara> there are some things that I don't yet know how to do, so it would be nice if someone who knows angularjs better than I do could take a look and help out.
15:32:43 <SotK> #link https://review.openstack.org/#/c/206108/ Patch to make Project Groups page look more like Stories and Projects pages
15:33:02 <Zara> thanks. :) see the comments on the patch for more!
15:33:52 * SotK beats the "we need reviews" horse some more
15:34:27 <Zara> I should have phrased that like clickbait.
15:34:47 <Zara> 'you won't BELIEVE what this developer said in this patch!!!'
15:35:03 <SotK> :D
15:35:14 <SotK> Anyone have anything else to say about in-progress work?
15:36:09 <Zara> not from me. I'll continue to try to fix misc bugs as they appear on my radar.
15:36:25 <SotK> excellent
15:36:40 <SotK> #topic Open Discussion
15:36:53 <SotK> Anyone have anything they want to raise?
15:38:54 <SotK> I guess not :)
15:39:03 <SotK> Meeting ends in 5...
15:39:04 <SotK> 4...
15:39:06 <SotK> 3...
15:39:08 <SotK> 2...
15:39:10 <SotK> 1...
15:39:13 <SotK> #endmeeting