15:02:56 <SotK> #startmeeting storyboard
15:02:57 <openstack> Meeting started Wed Sep 9 15:02:56 2015 UTC and is due to finish in 60 minutes. The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:00 <openstack> The meeting name has been set to 'storyboard'
15:03:10 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard Agenda
15:03:33 <SotK> I don't think there are any announcements or urgent items?
15:03:51 <Zara> nope, same old same old with the 'more reviews would be nice' thing!
15:04:11 <Zara> we had a few before I went on holiday, but they seem to have trailed off again.
15:04:35 <Zara> we don't bite, honest.
15:05:07 <SotK> #topic In-Progress Work
15:05:17 <SotK> #info SotK is still looking at worklists and boards.
15:05:18 <SotK> #link https://review.openstack.org/#/c/202989/ Spec
15:05:18 <SotK> The spec now has some +1s, I'm hoping it can be merged pretty soon.
15:05:18 <SotK> The API for boards and worklists is taking shape nicely, basic functionality is almost all there.
15:05:20 <SotK> Still need to add the ability to "add people" to boards and worklists, and also think about the automatic worklist concept sometime.
15:05:23 <SotK> The UI is also getting there, I'll update the test instance I mentioned ages ago with the shiny new kanban UI which is more than a concept soon.
15:05:31 <Zara> :D
15:06:04 <Zara> Subscriptions are still trudging along, mainly because I'm used to very different engineering work (build instructions for custom OS).
15:06:26 <SotK> #info Zara is continuing with subscriptions speedups
15:06:37 <Zara> So it's fun and I understand the principles, but the angular and html side is rather new to me and I don't know the languages in depth.
15:06:55 <Zara> it'd be great if we could get some people with more web-development expertise interested.
15:08:23 <Zara> since more pairs of eyes is always better for the codebase and all that. :)
15:08:27 <SotK> Indeed
15:08:56 <Zara> So yeah, I have a hacky half-solution and it needs to be better than that before I submit a patch.
15:09:16 * SotK is excited for the speedups :)
15:09:29 <Zara> me too; should make all our lives easier :)
15:09:34 <SotK> That is all the in-progress stuff I'm aware of.
15:09:37 <SotK> Anyone disagree?
15:09:40 <Zara> nope
15:09:53 <SotK> There are no discussion points on the agenda, so...
15:09:58 <SotK> #topic Open Discussion
15:10:24 <Zara> I believe you went to an OpenStack meetup! How was it?
15:10:45 <SotK> It was interesting!
15:11:11 <SotK> Good to learn more about the core parts of OpenStack.
15:11:29 <Zara> heh, yeah, we're a bit isolated over here atm; it would be nice to be more integrated.
15:11:56 * SotK failed to obtain any opinions on StoryBoard from OpenStack contributors who were there sadly
15:12:09 <Zara> :(
15:12:17 <Zara> still, at least that's not negative opinions.
15:12:39 <Zara> any interesting stuff people did say?
15:13:33 <SotK> There was an interesting talk on how CERN use OpenStack
15:13:44 <SotK> (tl;dr - for almost everything)
15:14:02 <Zara> wow, cool
15:15:40 <Zara> (saw a great talk on CERN a while ago but it was more of a 'this is how it works' thing, at a meetup about ethics and science. it was when there was all the stuff in the media about the hadron collider causing black holes... :P)
15:15:54 <Zara> (tl;dr: it doesn't, don't be ridiculous.)
15:16:01 <SotK> :D
15:16:21 <SotK> Yup. There was also an "Introduction to OpenStack" talk which touched on some interesting stuff about using Logstash and other tools for monitoring your OpenStack cloud.
15:16:47 * SotK believes there is likely to be a talk specifically on that at a future meetup, but might be wrong :)
15:17:12 <Zara> :) cool, it sounds like a good night; interesting to get a bigger picture so we can see where we might fit in in the future. Any storyboard stuff left to discuss?
15:17:21 <SotK> Yes!
15:17:27 <Zara> :D
15:17:36 <SotK> I actually have something to discuss that I forgot to add to the agenda :)
15:17:50 <Zara> haha, go for it; I believe we have 43 minutes left
15:17:56 <Zara> hence my waffling about meetups xD
15:18:07 <SotK> haha
15:18:47 <SotK> I was thinking about the "Rich markup in descriptions" story earlier to take my mind off boards for a bit
15:18:57 <SotK> #link https://storyboard.openstack.org/#!/story/94 Rich markup story
15:19:29 <Zara> I see it
15:20:18 <SotK> I figured that a quick and easy way to solve it would be to just do the rendering part for now and leave a proper "Rich editor" for later
15:20:41 <SotK> I'd like to suggest we officially decide that story descriptions can be Markdown
15:21:18 <SotK> (since I found multiple JS markdown parsers which work nicely, and no JS ReStructured Text parsers)
15:21:34 <Zara> okay, that's fine with me; I don't know much about it but it seems to be the view of people who have actually investigated it.
15:22:29 <SotK> excellent!
15:23:07 <SotK> #agreed Support Markdown in descriptions and comments
15:23:29 <Zara> \o/
15:23:41 <SotK> I will look at sending a small patch to do some magic for that then
15:24:04 <SotK> hopefully I can solve the "syntax highlighting" story with the same patch
15:24:41 <SotK> #link https://storyboard.openstack.org/#!/story/2000014 Syntax highlighting
15:25:16 <SotK> I also think we should hope to support other formats in future too
15:25:54 <Zara> I think so, but for now I still have the subscriptions and tags after that on my worklist
15:26:30 <SotK> #info Look at support for other formats as a future task
15:26:43 <SotK> I have no other points!
15:26:45 <SotK> Anyone else?
15:27:04 <Zara> I guess all that's left is for me to say that if you have some time to look at what I have on subscriptions so far, that'd be helpful, since I feel like I'm going round in circles a bit.
15:28:16 <Zara> other than that, _o_
15:28:32 * SotK will have time either later or tomorrow, depending on how long he takes to finish implementing card movement
15:29:17 <Zara> okay, great, thanks. I think I've overcomplicated everything and have way more code than I need... :)
15:29:26 <SotK> No problem :)
15:29:28 <SotK> If there are no other points, I guess we can end the meeting...
15:29:31 <SotK> ..
15:29:32 <SotK> .
15:29:36 <SotK> #endmeeting