15:00:04 <Zara> #startmeeting storyboard
15:00:04 <openstack> Meeting started Wed Nov 18 15:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is Zara. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <openstack> The meeting name has been set to 'storyboard'
15:00:30 <Zara> #Announcements
15:01:02 <Zara> SotK is still on holiday. He should be back from Tuesday.
15:01:35 <Zara> # Urgent Items
15:01:48 <Zara> Nothing on the agenda
15:01:56 <Zara> will move on!
15:02:02 <Zara> # In Progress Work
15:02:33 <Zara> #info worklists and boards-- SotK has been working on these, patches are in review currently
15:02:56 * Zara finds link...
15:03:28 <Zara> #link https://review.openstack.org/#/q/owner:%22Adam+Coldrick%22+status:open,n,z
15:03:32 <Zara> probably the best quick list
15:04:20 <Zara> #info email notifications-- SotK again, these are waiting for him to update a couple of patches
15:04:48 <Zara> I don't think there's much we can do with those until after Tuesday, though always good to have a look if there's time
15:05:17 <Zara> So onto me...
15:06:20 <Zara> I've started looking at creating a roadmap for storyboard, since the things that are currently up on the wiki came about when things were pretty different.
15:06:52 <Zara> the main thing I've found is that a spec would be very helpful.
15:07:10 <betherly> ++ - yes that would be great to have
15:07:36 <Zara> there are a million and one things to do; I have a rough guide of what to prioritise in the short term but I'd like more direction
15:07:40 <betherly> and a clear path forward re areas of focus for this cycle
15:07:53 <persia> ++
15:08:10 <Zara> yes.
15:08:32 <betherly> i would suggest focusing down on really small areas to work on and very specific ones and tasks we can check off
15:08:49 <betherly> the broader the focuses the more room for expansion out of control
15:09:06 <Zara> I agree with that, the more uncertainty, the less gets done
15:09:07 <betherly> and suddenly they're not focuses any more
15:10:52 <Zara> right now the very rough roadmap goes: 1) email notifications when a subscribed resource updates, 2) worklists and boards, 3: Fix search (there is an ongoing story for this), 4. Tags -- so these get steadily more vague as the map moves on
15:11:28 <Zara> they should be ordered in terms of priority, but in practice they're as much ordered in terms of 'what we have a clear spec for'
15:12:18 <Zara> so I think we should move on to getting a spec...
15:12:36 <Zara> # Discussion topics-- spec for task tracker
15:13:03 <Zara> so, we want a spec-- how do we get one? I've asked around in infra a bit but I don't know that anyone is currently working on this.
15:13:22 <Zara> I'm wondering if we should try to sketch something out
15:13:37 <persia> The general model is to write one and propose it to infra-specs
15:14:04 <Zara> okay, I've seen some for individual parts of a task tracker, but never the tracker as a whole
15:15:03 <persia> The right way to do that is to have the task tracker manage it :)  Some folk seem to use etherpads for now, linking to specs.
15:16:39 <Zara> I can look in storyboard.openstack.org for people's requirements (and have been), but the use of etherpads means that those requirements aren't always listed...
15:17:42 <betherly> can we take the basic requirements we have so far, write a spec based on that and then open it to the community for suggestions for a time
15:17:46 <betherly> ?
15:18:41 <betherly> ultimately everyone is going to want a million different things though and so we need to develop an mvp and develop it more as interest increases again and we have a clearer picture of more specific requirements
15:19:24 <Zara> just to clarify, when you say basic requirements, are you referring to the stuff in my roadmap of sorts, or something else?
15:20:27 <Zara> I agree on the approach
15:22:31 <Zara> I'm less clear that anyone outside of storyboard can agree on what the basic requirements are, hehe. :) That said, we could come up with our own list and then change things later if we need to.
15:23:22 <betherly> Zara: yep sorry for not specifying
15:23:25 <persia> Maybe just updates to the StoryBoard wiki is the place to do things: avoids the evenescence of etherpads.
15:23:52 <betherly> I think that is really my suggestion tbh, create our list and then open it to suggestions on that
15:24:21 <betherly> trying to compile a never ending list of what everyone in the community might potentially want at this point would be impossible
15:24:48 <Zara> betherly: Okay, makes sense to me and I think this will ensure it happens! :)
15:25:59 <Zara> I'd like to make that an action
15:26:21 <betherly> Zara: exactly. if we dont make hard decisions at this point and just compile data there will be so much of it nothing will ever happen lol
15:27:25 <Zara> betherly: yeah, I've been trying that for long enough at this point, would like to try a different approach. :)
15:27:31 <betherly> :)
15:27:40 <Zara> #action Zara come up with minimal requirements for a task tracker
15:28:01 <Zara> I named me there, but that's really me and you and SotK and anyone who's interested enough to seek us out and actively help with the development
15:28:30 <Zara> we should work out a time that suits, but we can probably do that in #storyboard
15:29:17 <Zara> if that seems fair, I think that's the end of that discussion, okay to move onto open discussion?
15:30:06 <Zara> seems so
15:30:10 <Zara> # Open Discussion
15:30:14 <Zara> anyone have any points to raise?
15:30:39 <pedroalvarez> I failed so far on my attempt of testing openstackid with storyboard
15:31:02 <Zara> that's concerning.
15:31:12 <pedroalvarez> I've been pointed to smarcet in -infra. seems he will be able to help
15:31:22 <Zara> ah, great
15:32:18 <Zara> I think I use my ubuntu one ID at the moment; I'm not sure if that's the same thing
15:32:24 <Zara> I should really know more about this :/
15:32:40 <pedroalvarez> is difficult to know about everything :)
15:32:45 * Zara adds it to the enormous list of things
15:32:46 <Zara> heh
15:33:19 <Zara> I'm glad there's someone who can help with it, anyway; I think that's something that would be on the list of minimum requirements
15:33:22 <Zara> so it ties in
15:34:14 <persia> These shouldn't be framed as "minimum": we did those a couple years ago, and reached MVP a couple times.
15:34:47 <persia> Rather, there should be a (relatively narrow) set of priority features.
15:34:57 <betherly> persia: ++
15:34:58 <persia> And the process should be revisited when those are done.
15:35:04 <betherly> totally agree
15:35:20 <Zara> heh, fine by me.
15:35:29 <betherly> do a couple of small things really flipping well
15:35:34 <betherly> then move on
15:38:44 <Zara> makes sense to me
15:39:40 <Zara> anything else?
15:40:04 <Zara> my action should be revised
15:40:18 <Zara> #action Zara to come up with narrow set of priority features for a task tracker
15:42:21 <betherly> im all good on things i think
15:42:44 <Zara> okay, in that case let's free this up for the next team!
15:42:54 <Zara> Thanks, everyone, was nice to have a lot of productive discussion today :)
15:42:59 <Zara> #endmeeting