15:01:12 <SotK> #startmeeting storyboard
15:01:13 <openstack> Meeting started Wed Dec  2 15:01:12 2015 UTC and is due to finish in 60 minutes.  The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:17 <openstack> The meeting name has been set to 'storyboard'
15:01:44 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard Agenda
15:02:00 <SotK> #topic Announcements
15:02:15 <SotK> #info We merged the first part of the boards and worklists work!
15:02:20 <Zara> \o/
15:02:32 <SotK> it's now possible to create a kanban board that is only useable by you!
15:02:39 <Zara> hehehe
15:03:03 <Zara> and I believe the permissions stuff is still in review, but needs some tweaking?
15:03:10 <SotK> indeed
15:03:17 <Zara> so after that we should have boards that are more widely usable
15:03:33 <SotK> yup, hopefully that will be soon-ish
15:03:46 <Zara> yeah, seems like it's nearly there
15:04:03 <SotK> I don't know of anything else to announce?
15:04:12 <Zara> not that I can think of
15:04:27 <SotK> I also don't know of any urgent items
15:04:49 <Zara> nope
15:04:51 <SotK> #topic In Progress Work
15:05:23 <SotK> #info Boards and Worklists initial support is merged, it is now possible to create and use boards and worklists!
15:05:33 <Zara> getting deja vu
15:05:46 <Zara> but yes, we have buttons to create them and buttons to view them
15:05:54 <persia> how?  I was just looking at that, and didn7t see the opportunity to create one after logging in.
15:06:01 <SotK> #info Further work to allow more than one person to use them is in review
15:06:17 <SotK> persia: "Create new... --> Board"
15:06:19 <Zara> persia: there should be a 'create new' button at the top for now
15:06:28 <Zara> the placement of buttons and things needs tweaking
15:06:30 <persia> Aha!  Thanks.
15:06:35 <Zara> but yeah, it's a start.
15:07:36 <SotK> we should probably do some user documentation for storyboard sometime
15:07:56 <Zara> yes, especially for boards and worklists, since that's new
15:08:17 <Zara> I should be able to take care of that
15:08:17 <SotK> #info Emails are in the same place as last week
15:08:23 <SotK> #undo
15:08:24 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x97f6e10>
15:08:28 <SotK> #info Emails are in the same state as last week
15:08:42 <Zara> so, waiting on replies to your comments in review?
15:08:49 * SotK hasn't got round to chasing for replies yet :/
15:09:47 <SotK> Is it worth sending an email to the infra list when we merge the multi-user boards stuff?
15:09:56 <SotK> to announce we've added it etc.
15:10:00 <Zara> I think so
15:10:04 <SotK> and give some guidance on usage
15:10:11 <Zara> it's a significant new feature.
15:10:23 <Zara> we should probably get the [storyboard] mailing list started again
15:11:41 * SotK will write one in preparation then :)
15:11:45 <Zara> (if it has its own list, anyway, might just be the infra list with [storyboard] in the subject...)
15:12:13 <SotK> #action SotK to send an email to the infra list about boards and worklists, once they are usable by multiple people.
15:13:37 * SotK wonders how the roadmap is going
15:14:29 <Zara> # info notifications spec/roadmap planning in progress here: https://wiki.openstack.org/wiki/StoryBoard/Notifications
15:15:04 <Zara> it now lists the current implementation pretty comprehensively, I think (maybe missing some backend stuff, but in terms of features and UX, I think it's pretty well covered)
15:15:12 <SotK> \o/
15:15:18 <Zara> so the main thing to move onto is what we *want*, and where that implementation falls short
15:15:35 <Zara> I've noted the issue of subscriptions behing a bit too, er, heavy-handed
15:15:57 <Zara> that is, you can't subscribe to 'a project except x story that's currently listed in that project'
15:17:00 <Zara> beyond that, I think it's a matter of getting more input. I think I've noted that we want email notifications (or at least implied that by saying that patches are in review, can't remember if it's explicit)
15:17:16 <Zara> but as far as user configuration options, etc, I'm not sure what people would want to add
15:17:20 <SotK> indeed, I have a little plan I want to test out for handling that situation
15:17:50 <Zara> yeah. I've tried to list the current options, at least.
15:18:41 <SotK> Any other in progress work?
15:18:41 <Zara> that way I have some idea what to put in a roadmap. I think 'work out where things are at atm' was the first step in the planned roadmap, but didn't get written down except on irc, oops.
15:18:49 <Zara> mainly just testing and reviewing
15:19:07 <SotK> oh, I looked at the preferences being broken thing
15:19:07 <Zara> discovering the many ways databases can do strange things
15:20:01 <SotK> I sent a couple of patches which will avoid the issue for new users, and alleviate it for existing ones
15:20:12 <Zara> :)
15:20:57 <Zara> thanks. I'll try to get round to testing them today to see if anything breaks.
15:21:08 <SotK> thanks :)
15:21:19 <SotK> #topic Open Discussion
15:22:33 <Zara> so re: notifications spec, I'd like to find out where people think the current implementation falls short. I should have posed this question before the meeting, though, to allow people to think about it. so this might not be the best time to discuss
15:22:56 <Zara> but I'd like to have some sort of discussion, maybe end of this week?
15:23:40 <Zara> it's not something I can easily decide on my own, because I'm used to working around storyboard's notification idiosyncracies by this point.
15:24:46 <SotK> beyond the obvious "it needs to send emails", I am in the same situation as you
15:24:53 <persia> Zara: Are you familiar with LP's notifications model at all?  That might be one source of information regarding people's expectations (as most OpenStack folk use LP today)
15:25:45 <Zara> persia: not really familiar with it. given they want to come off launchpad, I'm wondering how useful it would be, but I don't know if that's an area where users have a problem with it.
15:26:07 <Zara> (that=notification)
15:26:21 <persia> I personally never liked LP's notification model, but I know lots of people who depend on it in all sorts of ways, so it is worth understanding.
15:27:01 <persia> The LP limitations are more about how bugs affect multiple projects, priorities, release tracking, spec tracking, etc., as I understand it, but I've not been privy to all the discussions.
15:27:26 <Zara> okay, will try to take a look
15:28:01 <Zara> if people would be fine with sb just sending emails, I'd suggest we switch priority after that, but I would suspect that we might get more feedback after people start getting the emails
15:28:11 <Zara> which I'd like to predict
15:28:14 <Zara> before pitchforks
15:28:21 <Zara> probably not possible, but I can dream
15:29:22 <persia> Maybe there can be a global preference as to whether folk want email, defaulting to "no", so that people can turn it on as they are willing to participate, and turn it off before polishing pitchforks?
15:30:08 <Zara> yeah, I believe SotK has made a patch for that.
15:30:30 <Zara> It's just going to be harder to get people to flip a switch to 'yes' again once they've turned it off
15:30:41 <Zara> so I'd like to avoid giving people a reason to flip it, but I suspect that won't be possible
15:31:35 <SotK> indeed, I wouldn't force the emails upon people
15:31:42 <persia> If the default is "no", then your early adopters will likely provide vocal input on their desires.
15:31:58 <persia> Changing the default can happen later, to avoid the "make it all go away and never come back" problem.
15:32:32 * SotK agrees with that
15:32:51 <Zara> true, wfm
15:33:01 <SotK> I suspect that people who willingly turn them on will be more likely to give useful feedback than pitchforks
15:33:25 <Zara> I just wonder how big that sample of people will be, but agree in theory.
15:33:50 <Zara> right, well that'll be a better time to get feedback, then; I don't think we can get much yet.
15:33:55 <SotK> given that a fair number of people seem to want email notifications, I'd hope there is at least a few who try xD
15:34:34 <SotK> I imagine all we'll get before we do a first-pass is hopes, dreams, and demands for the moon on a stick :)
15:34:49 <Zara> yeah. I'll look into launchpad, then, in the meantime, probably best to concentrate on getting current email patches merged before we add much to the spec/roadmap (other than info on current backend implementation details)
15:44:10 <SotK> hello again
15:44:48 <SotK> I hear some stuff I said got lost in the netsplit
15:44:53 <SotK> 15:35:17 < SotK> + other bits we need for notifications to be nice
15:44:55 <SotK> 15:35:25 < SotK> eg. a place to see all your subscriptions
15:44:58 <SotK> 15:35:32 < SotK> and manage them easily
15:45:00 <SotK> 15:35:59 < SotK> I'm feeling a big dashboard-related bikeshed coming on soon
15:45:46 <SotK> Anything else to discuss?
15:46:47 <SotK> #endmeeting