15:00:14 <SotK> #startmeeting storyboard
15:00:15 <openstack> Meeting started Wed Dec 16 15:00:14 2015 UTC and is due to finish in 60 minutes. The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:20 <openstack> The meeting name has been set to 'storyboard'
15:00:34 <Zara> \o/
15:01:10 <SotK> #chair Zara
15:01:12 <openstack> Current chairs: SotK Zara
15:01:38 <SotK> now we shouldn't have a repeat performance of last time's chairless chaos
15:01:48 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard Agenda
15:01:49 <Zara> heh
15:02:20 <SotK> I don't think we have anything urgent, or anything quite ready to announce yet
15:03:11 <SotK> #topic In Progress Work
15:03:58 <SotK> #info Worklists and boards has just a couple of outstanding patches, both almost ready to be merged, just needing +1s from any helpful reviewers
15:04:19 <SotK> then we'll have worklists and boards that can have multiple users!
15:04:47 <SotK> #info Initial email patches have been merged
15:04:56 <Zara> \o/
15:05:15 <SotK> we now have support for email notifications of changes to story titles/descriptions merged!
15:05:23 <pedroalvarez> \o/
15:05:28 <SotK> adding notifications for other changes is a matter of creating templates for them
15:05:52 <SotK> we haven't yet merged the button that allows them to be turned on though, since they aren't enabled in storyboard.o.o yet
15:05:53 <Zara> yeah, I believe ux patch isn't merged so we don't mislead people into thinking we have lots of templates (yet)
15:05:58 <Zara> ah snap
15:06:17 <pedroalvarez> fair enough
15:06:22 <Zara> so there's some puppet patching to be done?
15:06:45 <SotK> I think so, yeah
15:06:55 <pedroalvarez> did we ever increase the auth token lifetime?
15:07:05 <pedroalvarez> (might be useful to patch that too)
15:07:08 <SotK> nope, not yet
15:07:12 <SotK> indeed, it probably will be
15:07:27 <SotK> I was running in to problems trying to test changes to puppet-storyboard
15:07:27 <Zara> I'm a bit concerned about waiting on that because it means other storyboard users don't have access to email preferences-- but I think we should have more templates first, anyway, so that suits me for now
15:10:10 <SotK> indeed, but I don't know the best way to avoid confusion otherwise
15:10:17 <Zara> (ie: with the ux patch merged, theoretically anyone could set up a storyboard instance to work with a mail transfer agent, and receive emails from it when story titles and descriptions update. so I'd kind of rather not make everyone wait for puppet changes for openstack. but I also don't want openstack users to have a button that doesn't do anything for them, yet!)
15:10:35 <Zara> and infra are the biggest storyboard users, so.
15:10:46 <SotK> indeed
15:10:48 <pedroalvarez> that is true
15:11:00 <pedroalvarez> so let's change puppet's script asap :)
15:11:09 * SotK agrees with that
15:11:22 <SotK> I'll look at updating puppet after the meeting
15:11:37 <Zara> okay, great :)
15:11:57 <SotK> #action SotK to look at updating puppet to enable the emails plugin asap
15:12:43 <Zara> we've extensively tested the worklists and boards patches at this point, and turned SotK into a husk of his former self in the process
15:12:47 <pedroalvarez> let me know if I can help SotK
15:12:54 <Zara> #link https://review.openstack.org/#/c/235476/
15:13:02 <SotK> pedroalvarez: will do :)
15:13:25 <pedroalvarez> Zara: right, I'll review that patch today
15:13:28 <SotK> \o/
15:13:52 <Zara> #link https://review.openstack.org/#/c/256457/ is the other remaining patch, though more trivial
15:14:29 <Zara> there are other patches for subscriptions in review, and probably a few things I had left lying around but need to fix
15:15:03 <Zara> as for me, I need to update the spec thing now I understand the state of the email patches better!
15:15:07 <Zara> though I may wait 'til this evening
15:15:09 * SotK would like us to merge https://review.openstack.org/#/c/251409/ soon
15:15:32 <Zara> (since I don't want to write a bunch about waiting on upgrading puppet only for it to go out of date immediately)
15:15:39 * pedroalvarez will put that on the list
15:15:52 <pedroalvarez> SotK: so, is it really useful?
15:16:06 <Zara> hah, I forgot about that patch entirely.
15:16:56 <Zara> #info Zara to update spec with more info about email notifications
15:16:57 <SotK> pedroalvarez: the patch I just linked? It makes it quicker to see more recent stories
15:17:36 <pedroalvarez> which normally is what people looks for
15:17:41 <pedroalvarez> (I guess)
15:18:43 <Zara> (other than spec stuff, I'm mainly testing and reviewing at the moment, and making the odd tiny patch when I come across an issue that I can fix quickly.)
15:20:08 <SotK> yeah, I guess it is too
15:20:57 * SotK apologises for inundating Zara with reviews
15:21:32 <Zara> hahah, no problem! :) I'm probably more useful on the testing side for these ones.
15:21:33 <pedroalvarez> and me! :)
15:22:11 <SotK> pedroalvarez: indeed :)
15:22:37 <SotK> I don't know of any other in-progress work?
15:22:49 <SotK> #topic Open Discussion
15:22:56 <SotK> Anyone got anything to discuss?
15:23:28 <pedroalvarez> I want a board/worklist for storyboard :)
15:23:53 <pedroalvarez> no discussion needed
15:24:04 * SotK will probably make one when the multi-user patch is merged
15:24:32 <pedroalvarez> good good
15:24:51 <Zara> heh
15:25:21 <SotK> Anything else?
15:25:47 <Zara> I don't think so; seems like we all know what to concentrate on
15:25:56 <Zara> I guess should point out that xmas holidays are coming up
15:26:03 <pedroalvarez> oh, that's a good point
15:26:11 <SotK> oh yeah, I guess we aren't having meetings in the next two weeks?
15:26:21 <SotK> (23rd and 30th)
15:26:25 <Zara> yeah. well you could go on your own, buuuuut
15:26:29 <SotK> :)
15:26:40 <pedroalvarez> yeah, I'll be away too
15:26:46 <pedroalvarez> (those 2 weeks)
15:27:12 * SotK imagines he will probably be around intermittently in #storyboard
15:27:20 <Zara> and it'll be generally quiet. I'm away from this Friday, 'til the end of the year, though I'll be around a bit to check the gerrit upgrade has worked out okay.
15:27:33 <SotK> it makes sense to not have meetings for the next two weeks then
15:27:50 <SotK> #agreed No meetings for the next two weeks (23rd and 30th)
15:28:38 <SotK> Anything else?
15:28:44 * pedroalvarez will be around too
15:28:49 <Zara> er, I'm hoping we can get all of the stuff we've talked about today merged by the end of the week, part of the same point really
15:28:57 * SotK too
15:29:15 <pedroalvarez> yeah :)
15:29:37 <Zara> cool :) Nothing else from me
15:29:52 <SotK> nothing else from me either
15:29:58 <pedroalvarez> _o_
15:30:01 <SotK> #endmeeting