15:01:42 <SotK> #startmeeting storyboard
15:01:42 <openstack> Meeting started Wed Feb 24 15:01:42 2016 UTC and is due to finish in 60 minutes. The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:45 <openstack> The meeting name has been set to 'storyboard'
15:02:07 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard Agenda
15:02:22 <Zara> sorry, I tried to update the agenda in advance, but couldn't log in to the wiki
15:02:30 <SotK> no worries :)
15:02:38 <SotK> I'm pretty sure we already announced tags search
15:02:47 <Zara> yup
15:02:57 <SotK> anything urgent you know of?
15:03:37 <Zara> not really. would be nice to get eyes on email config patches, since it's hurting users, but that's as urgent as always.
15:04:00 <SotK> #topic Urgent Items
15:04:10 <SotK> #link https://review.openstack.org/#/c/270331/ Email config for storyboard
15:04:10 <betherly_> o/ sorry im late :)
15:04:15 <SotK> hi betherly_
15:04:29 <Zara> #link https://review.openstack.org/#/c/270329/
15:04:33 <Zara> ^ depends on that
15:05:06 <SotK> Anything else urgent?
15:05:09 * SotK thinks not
15:05:15 <Zara> nope
15:05:27 <SotK> #topic In Progress Work
15:05:54 <SotK> #info SotK is about to send patches for due dates in boards
15:05:59 <Zara> \o/
15:06:03 <SotK> patches for due dates in worklists will follow later in the week
15:06:43 <Zara> haha, worklists
15:06:46 <Zara> I mean, yay!
15:07:35 <Zara> okay, stuff on agenda about timeline events is old
15:07:51 <Zara> #info we debugged timeline events and a patch was merged to fix it
15:08:26 <Zara> events should now say something like "task status changed from 'todo' to 'merged'" instead of just "task updated"
15:08:43 <Zara> I can't remember the exact wording, but that's what that was about, for anyone missing context
15:08:44 * SotK would like to make it do similar for task names too
15:09:09 <Zara> and story descriptions... but that one requires some thought with the template
15:09:15 <SotK> (and story names/descriptions, but idk how to display that)
15:09:23 <SotK> snap again
15:09:27 <Zara> :D at any rate, the old behaviour is restored
15:09:47 <Zara> other in progress things...
15:10:09 <Zara> search is listed. I have some search patches in review
15:10:23 <Zara> #link https://review.openstack.org/#/c/278987/
15:10:55 <Zara> that makes it more obvious that the header search isn't the 'main' search place
15:11:20 <Zara> maybe helpful in the interim while we try to get search working a bit more intuitively
15:11:35 <Zara> #link https://review.openstack.org/#/c/279204/
15:11:53 <Zara> moves the search icon from the sidebar, to next to the header search
15:12:21 <Zara> mainly to free up room on the sidebar
15:12:40 * ttx looks up the worklists
15:13:22 <Zara> also because, as I understand it, eventually the page that button links to should be accessed the page of basic search results, as an 'advanced search'
15:13:44 <Zara> there's also a patch for a page to view all boards and worklists on an instance
15:14:20 <Zara> #link https://review.openstack.org/#/c/279753/
15:14:22 <persia> All of them? Another browse interface?
15:14:46 <Zara> which should make them more discoverable, since currently a user can only browse via the url unless they are an owner or a user
15:15:14 <Zara> persia: yes, all. it's not very useful, and not scalable, it's just more useful than nothing at all right now.
15:15:25 * SotK still isn't sure of the value of that page really
15:15:34 * persia either
15:15:58 <Zara> at this point, mainly so that people can demo things, without adding everyone to a board/worklist
15:16:21 <ttx> nice work there!
15:17:04 <Zara> ttx: thank you! :)
15:17:16 <Zara> (it's SotK's work but I'm saying thank you anyway, haha)
15:17:30 <SotK> ttx: thanks :)
15:17:56 <SotK> I think we may as well just share links, or make the search page show boards and worklists in its results the same way it does project groups
15:18:27 <Zara> the other reason for having a boards/worklists page is so that users can display, say 'all worklists including things in foo story'. I think there are better ways of displaying that, but it might be simplest to start there.
15:18:33 <persia> It might be nice to have a means of discovering lists from a user and/or a team, but that might just be sharing links on other resources.
15:18:53 <persia> Zara: That's another use case I don't understand.
15:19:23 <Zara> (my worry with linking from search is that it doesn't let people know boards and worklists exist.)
15:20:06 <Zara> persia: swap 'story' for task, then, and add extra filters as appropriate until it matches
15:20:15 <persia> Right, but I don't care.
15:20:50 <persia> I care about worklists created by a team in which I wish to participate, or by someone with authority to claim my time (or offering reward for tasks done in some other way).
15:21:12 <Zara> that's what I meant by 'extra filters as appropriate', sorry
15:22:09 <persia> I am also interested if several people are raising priority of a task (putting it on their worklist), and I may care who they are (because some "priority" statements are more important to others). I'm not sure how to get that from what is described.
15:23:13 <Zara> show all worklists for x user, show all worklists for y task, show some combination of the two, etc.
15:24:20 <persia> I suppose I shouldn't complain. After many years, there is finally an issue tracker with worklists, and it can grow specific features as people use it (plus, without a browse, worklists are less discoverable).
15:25:27 * SotK thinks that is a valid use for the page, and no longer objects (but still thinks that his dream search page would make all the lists un-needed)
15:25:56 <SotK> Any other in progress work?
15:26:38 <persia> 2000478 was mentioned. Is that complete now?
15:27:40 <SotK> I think so yeah
15:27:49 <Zara> can someone link?
15:28:00 <SotK> #link https://storyboard.openstack.org/#!/story/2000478
15:28:10 <Zara> ohh, story
15:28:20 <Zara> I thought it referred to a commit, heh
15:28:36 * SotK looked at gerrit first also :)
15:28:48 * persia was looking at the agenda
15:28:52 <SotK> (then realised it was too long)
15:30:10 <Zara> oh yeah!
15:30:12 <Zara> task links!
15:30:21 <Zara> these are still in review
15:30:38 <Zara> #link https://review.openstack.org/#/c/277481/
15:30:52 <Zara> #link https://review.openstack.org/#/c/277831/
15:31:06 <Zara> #link https://review.openstack.org/#/c/277882/
15:31:48 <Zara> we've had a bit of a review bottleneck this week because SotK has been drowned in due-dates work
15:32:13 * SotK will try to get some reviewing done in the near future :)
15:32:43 <Zara> the last one is listed as WIP, but that's just because of the appearance. removing the priority button fixes that, and there is a patch for that: https://review.openstack.org/#/c/280259/
15:33:38 <Zara> I'm mainly concerned there will be something strange on the python side, anyway.
15:33:55 <Zara> oh oh oh
15:33:57 <Zara> and finally
15:34:00 <Zara> make search boolean
15:34:03 <Zara> #link https://review.openstack.org/#/c/281890/
15:34:13 <Zara> that makes search work a bit better
15:34:21 <Zara> you can use operators
15:34:23 <Zara> sometimes
15:34:39 <Zara> quotation marks are interpreted literally, for some reason
15:34:50 <Zara> but + and - operators have worked for me while testing
15:35:17 <SotK> hm, I thought quotation marks were working correctly when I was testing the other day
15:35:31 <SotK> (where quotation marks are double quotes)
15:35:50 <Zara> I tried that and they didn't seem to work (or possibly they worked for some resources and not others, just for extra fun)
15:36:31 <SotK> :(
15:36:34 <Zara> I think they worked for projects but not stories, but I'd have to check. It improved search enough overall that I didn't dig down at that point.
15:37:03 <Zara> I was more interested in 'does this break anything that wasn't broken', heh
15:37:24 <SotK> any other in progress work?
15:37:37 <Zara> well, there's the task IDs patch...
15:37:46 <Zara> but that's only interesting to someone testing a gerrit plugin, for example
15:37:53 <Zara> and that person could cherry pick the change
15:38:09 <Zara> #link https://review.openstack.org/#/c/272667/
15:38:12 * Zara links anyway
15:38:28 <Zara> it doesn't look amazing, it might look weird with task links
15:38:34 <Zara> in which case, task links should come first imo
15:38:47 <Zara> because that's interesting/useful to more people right now
15:39:25 <SotK> so many things to review!
15:39:40 <SotK> any more?
15:39:44 <Zara> the roles are reversed! :D
15:39:51 <SotK> :D
15:39:55 <Zara> no, I think that's it. from me, anyway
15:40:04 <SotK> We've already mentioned the email config situation, so...
15:40:14 <SotK> #topic StoryBoard Meetup
15:40:31 <SotK> At the meetup, we said we'd decide on a date for the next one today
15:40:48 <Zara> so we did! I completely forgot! :)
15:41:29 <Zara> my notes say between May 16th and May 20th
15:41:33 <Zara> I assume there was a reason for that
15:42:02 * SotK recalls someone mentioning some dates a little later than those in #storyboard
15:42:05 <SotK> persia maybe?
15:42:55 <persia> I suggested somewhere in 22-25 May.
15:43:29 <persia> Reason being: ApacheCon (8-14 May), OSCON (14-21 May), pycon (27 May- 6 June)
15:43:40 <SotK> seems sensible
15:44:01 <persia> The dates quoted are a bit wider than the official dates, because they represent my estimation of "busy time", including travel, etc.
15:44:47 <Zara> I'm wondering why my notes say 16th-20th, since I wouldn't've written that at random. maybe another conference was mentioned at some point, and I didn't count in 'busy time'
15:45:34 <Zara> we may never know
15:45:43 <Zara> that seems fine, anyway
15:45:50 <SotK> does anyone who may wish to attend have a preference they want to express?
15:46:24 <SotK> betherly, anteaya, krotscheck, anyone else ^
15:46:28 <persia> Also, https://review.openstack.org/#/c/272667/ may be relevant. Doesn't affect May, but may mean rethinking about the following one.
15:46:39 <persia> Err, http://ttx.re/splitting-out-design-summit.html
15:47:14 <krotscheck> Eh?
15:47:15 <krotscheck> Ah
15:47:16 <krotscheck> Hrm.
15:47:30 <krotscheck> No preference. I my travel budget's already allocated, so I won't be able to come regardless.
15:47:36 <betherly> Im going to be away 19-27th may :/
15:48:03 <Zara> I don't think the split affects us much (except to avoid design summit dates). We benefited from a full day of storyboard talk and that's unlikely to happen at a summit.
15:48:17 <betherly> before/after then works for me :)
15:49:01 <Zara> for me the change looks like it will mean same expenses, same need for midcycle, and worse food, but I doubt that'll sway anyone's decision
15:50:01 <SotK> how would we feel about having it sometime after 27th May then?
15:50:37 <Zara> I'd rather try for earlier, and find out if anyone interested is actually going to OSCON or Apachecon.
15:50:59 <SotK> persia?
15:51:31 <persia> I'm not confident I can get to Manchester anytime in May right now, so don't let my schedule affect planning.
15:51:31 <Zara> (otherwise it has to be after 6th June)
15:52:29 * SotK is fine with earlier
15:52:51 * betherly is also fine with earlier
15:53:16 * Zara arbitrarily picks 16th May for now. It clashes with OSCON. register anger if you want to go to OSCON.
15:53:24 <Zara> that gives betherly a few days in between before travelling
15:53:56 <SotK> wfm
15:54:13 <betherly> ditto :)
15:55:01 <persia> Despite being unsure of my attendance, I think earlier is better in terms of not conflicting with other things.
15:55:11 <SotK> #info 16th May picked as the date for the next StoryBoard meetup (for now)
15:55:21 <SotK> #topic Open Discussion
15:55:42 <Zara> 3 mins left
15:55:50 <Zara> oh, my clock's outta sync
15:55:56 <Zara> *5* mins left
15:56:03 <SotK> anyone have anything to discuss?
15:56:06 <Zara> we should get dev instance
15:56:09 <Zara> I asked infra about it
15:56:24 <Zara> haven't noticed a response, if infra's too busy, can we set one up ourselves?
15:56:35 <Zara> or resurrect storyboard.sotk.co.uk
15:57:16 * SotK will look at resurrection (or reincarnation) when he's done with due dates
15:57:44 <Zara> okay, wfm
15:57:51 <Zara> I just didn't want it slipping through the cracks, thanks
15:57:57 <Zara> that's me done
15:58:26 <SotK> #action SotK to resurrect storyboard.sotk.co.uk for a playground instance until we get a proper dev instance sorted
15:58:32 <SotK> Anything else?
16:00:07 * SotK assumes not, and if there is it can go in #storyboard :)
16:00:08 <SotK> #endmeeting