15:01:59 <Zara> #startmeeting storyboard
15:02:00 <openstack> Meeting started Wed May 11 15:01:59 2016 UTC and is due to finish in 60 minutes.  The chair is Zara. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:04 <openstack> The meeting name has been set to 'storyboard'
15:02:17 <Zara> #topic Announcements
15:02:22 <Zara> I have three things!
15:02:40 <Zara> 1, and most urgent-- The next StoryBoard meetup is next Monday!
15:02:43 <Zara> The 16th May!
15:02:45 <Zara> Manchester, UK!
15:02:55 <Zara> standby while I find more info!
15:03:28 <Zara> #link https://wiki.openstack.org/wiki/StoryBoard/Milestone_1_Meetup
15:03:33 <Zara> That's the wiki page
15:03:43 <Zara> which links to this etherpad, which I'm also going to link, just because
15:03:53 <Zara> #link https://etherpad.openstack.org/p/StoryBoard_Newton_sprint
15:04:16 <Zara> some of that is copypasted from the last one
15:04:17 <Zara> hm
15:04:44 <Zara> It should get updated over the remainder of this week
15:04:56 <Zara> and as always, feel free to add things!
15:05:00 * SotK looks forward to cake and storyboard
15:05:19 * Zara hopes for cake and steak
15:05:27 <Zara> I mean st*oryboard*
15:05:28 * betherly is super sad cant be there
15:05:35 <Zara> next time!
15:05:45 <Zara> yeah, it also clashes with OSCON, we're masters at this
15:06:10 <Zara> anyone have anything else to say on that?
15:06:45 <SotK> _o_
15:06:47 <Zara> Announcement 2, then: newish feature (actually merged just before summit, but got lost in summit frenzy)
15:06:52 <Zara> automatic worklists in boards!
15:07:18 <Zara> we should be able to go into that more at the meetup
15:08:05 <Zara> it does what it says on the tin, but demos are always handy :)
15:08:31 <Zara> Announcement 3: brand new feature!
15:08:33 <Zara> Private stories!
15:08:58 <Zara> You can now make a story private, and whitelist users that can view it.
15:09:13 <Zara> This is very new so I'd recommend against putting anything super sensitive in one immediately
15:09:40 <SotK> people should play with them though
15:09:55 <Zara> yes. story here: https://storyboard.openstack.org/#!/story/2000568
15:10:00 <Zara> and thank you SotK for working so hard on this
15:10:06 <Zara> especially at the summit!
15:10:41 <Zara> we need people to play with them in order to find all the leaks; we've done a lot of testing but we always miss things, so... I guess it's in beta
15:10:58 <betherly> woot
15:10:59 * SotK will be surprised if there are leaks :)
15:11:23 <betherly> will take a look and play around as i go. looks awesome though
15:11:50 <Zara> I hope you don't get surprised then! :D I'm fine with being shown to be too pessimistic. :)
15:12:12 <Zara> but yeah, those should be useful for reporting security vulnerabilities in the future
15:13:24 <Zara> I'll move on, unless we've missed an annoucement
15:13:50 <Zara> oh, I guess
15:14:09 <Zara> #info search is throwing errors on storyboard.openstack.org, but it's a known bug and SotK fixed it this afternoon
15:14:29 <Zara> so we're just waiting for the relevant change to be merged and to build
15:15:00 <Zara> s.o.o was using an old version of sqlalchemy fulltext search, for the curious
15:15:04 <Zara> so thanks again SotK for that
15:15:23 <Zara> s.o.o should be normal again in a few hours, fingers crossed
15:16:20 <Zara> okay, I think *that*'s everything
15:16:26 <Zara> #topic Urgent Items
15:16:32 <Zara> anything?
15:16:59 <Zara> the search fix was the only thing I had marked 'urgent', and we got reviews for that quickly (thanks, persia!)
15:17:20 * SotK doesn't think there is anything
15:17:57 <Zara> okay
15:17:58 <Zara> 'LOTS OF CAKES NEEDED FOR MEETUP, VERY URGENT'
15:18:01 <Zara> moving on
15:18:10 <Zara> #topic In-Progress Work
15:18:29 * SotK will try to cause cake to be generated over the weekend :)
15:18:32 <Zara> :d
15:19:10 <Zara> SotK: I put 'complex priorities-- SotK' on the agenda for inprogress work, but I may have missed things
15:19:13 <Zara> so over to you!
15:19:42 <SotK> I sent a patch for this that you don't like, we can discuss that after :)
15:19:56 <Zara> heehee
15:20:02 <SotK> I'm also in the process of fixing merge conflicts/improving the old api patches for this
15:20:22 <Zara> yeah, I don't have a problem with the overall approach, I just don't like that particular ux for it, but +1 to discussing after.
15:20:26 <Zara> and yes, thank you for those
15:21:14 <Zara> #info SotK is working on visulasing complex priorities, and better worklist+board filtering
15:21:20 <Zara> erm, visualising
15:21:59 <SotK> you can #undo and do it again I think
15:22:15 <Zara> hm, I'm not sure of the exact command
15:22:35 <SotK> I'm pretty sure it is `#undo`
15:23:05 <Zara> #undo
15:23:06 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0xad3f850>
15:23:10 <Zara> hah, just looked it up before I saw that
15:23:11 <Zara> oh well
15:23:21 <Zara> #info SotK is working on visualising complex priorities, and better worklist+board filtering
15:23:28 <Zara> there you go
15:23:43 <Zara> #info Zara is working on creating operator docs for StoryBoard, so people can spin up instances fast
15:23:50 <Zara> we get a lot of requests for playground instances
15:24:10 <Zara> #link https://storyboard.openstack.org/#!/story/2000535
15:24:21 <Zara> I looked at ansible yesterday, hit dead end, trying puppet today
15:24:33 <Zara> well, in theory. I got distracted by other review
15:24:41 <Zara> so that might end up being tomorrow
15:25:12 <Zara> next thing on the list
15:25:44 <Zara> betherly: I have 'flowy tutorial' down as your inprogress work, but I'm not sure how that's going, while I know you patched other UX fails earlier this week
15:25:51 <betherly> i am in the process of splitting out some of my work so that the initial patch will literally just be html fragments and something that could actually be merged and still look ok before all the awesome cool other stuff works. also will make the reviewing of it all less painful and less 'oh my days how many lines of code'. sorry havent made much progress
15:25:51 <betherly> really since disaster #1, decided to focus storyboard wise on more 'fun' (minor) things like that placeholder issue. less depressing ;)
15:25:51 <Zara> so.. over to you!
15:26:02 <Zara> (haha I was too slow)
15:26:11 <betherly> hehe
15:26:36 <Zara> np, I'm glad someone finally got around to those placeholders!
15:26:37 <Zara> thanks for those
15:26:40 <betherly> so basically, there will be something rather than nothing there in the next week but still not a fully functional all bells and whistles doodle bug
15:27:02 <SotK> something is better than nothing :)
15:27:07 <SotK> thanks for the placeholders patch btw!
15:27:34 <Zara> yup :)
15:28:06 <betherly> woot!
15:28:18 <betherly> yay for patches that do a bit more than documentation :D
15:28:36 <Zara> given I still haven't managed to patch ops docs, you're winning! :D
15:28:46 <Zara> anything else in-progress I've forgotten?
15:29:06 <SotK> not that I can think of off the top of my head
15:29:06 <Zara> (aside from the million ongoing threads that don't warrant a mention because they're always there, haha)
15:29:10 <betherly> eating cake?
15:29:21 <Zara> pfft, that's next monday
15:29:27 <Zara> if you eat cake before then, YOU DIE
15:29:31 <betherly> nah its in-progress here
15:29:33 <betherly> whaaaaat
15:29:40 <betherly> :'(
15:29:51 <Zara> sorry :/
15:29:58 <Zara> no discussion topics listed
15:30:03 <Zara> so...
15:30:09 <Zara> #topic Open Discussion
15:30:12 <Zara> DISCUSS
15:32:06 <Zara> :<
15:33:05 <Zara> well, following up on summit things... has anyone heard anything from the product working group?
15:33:23 * SotK has not
15:33:35 <Zara> hm, I haven't either; perhaps someone should poke them on their ML or somesuch.
15:34:10 <Zara> silence suggests that one's all mine
15:34:45 <Zara> #action Zara will prod PWG
15:35:34 <betherly> yay Zara! :)
15:35:40 <SotK> thanks :)
15:38:13 * Zara tries to think if there are other things
15:38:41 <Zara> oh, actually, we've talked about it in channel but not here
15:38:54 <Zara> infra's task-tracking spec is in progress!
15:39:00 <SotK> \o/
15:39:28 <Zara> https://review.openstack.org/#/c/314185/
15:39:37 <Zara> I keep meaning to comment and getting sidetracked
15:40:29 <Zara> I'm not sure if line 135 is applicable any more with private stories, or if a more advanced implementation of ACLs is envisioned.
15:41:39 <Zara> hm, doesn't seem to be an option to link to a line
15:41:52 <Zara> and... I should've linked that spec properly for the logs
15:41:55 <Zara> #link https://review.openstack.org/#/c/314185/
15:42:29 <SotK> Zara: https://review.openstack.org/#/c/314185/2/specs/task-tracker.rst@135
15:42:43 <Zara> ooh, cool, didn't know that
15:42:44 <Zara> evidently
15:42:56 <Zara> I tried clicking '135' but it just gave option to comment
15:42:57 <Zara> ace
15:43:12 <SotK> I have no idea how to do it without manually creating the url :)
15:43:15 <Zara> heh
15:44:11 <Zara> anyway, yeah, I think it may be a good time to see how far the 'project teams' feature got, to see if we can use it for future ACL work.
15:44:19 <Zara> but that's just a background investigation...
15:44:44 <SotK> yeah, we should do that at some point
15:45:56 <Zara> things that fell by the wayside a bit the last few weeks were the python client updates (inc. from gerrit)
15:46:04 <Zara> that's because I was working on it, then I had things to review :)
15:47:52 <Zara> oh, looking at teams in the db schema, the api side looks promising (there are teams, team_permission and team_membership). erm, sorry to jump around (got the schema out to see python client things)
15:49:10 <SotK> yeah, they seem to be implemented in the api
15:49:15 <SotK> idk how much they work
15:49:37 <Zara> yeah, the db side looks similar to other things at a glance, but I have no idea beyond that \o/
15:49:40 <Zara> eh, future things
15:50:19 <Zara> I have a bunch of old patches in review that I hope to go back to since many need reworks
15:50:33 <Zara> so hoping to get to that next
15:55:29 <Zara> anything else?
15:55:34 <SotK> _o_
15:58:02 <Zara> #endmeeting