15:01:20 <Zara> #startmeeting storyboard
15:01:21 <openstack> Meeting started Wed Aug 31 15:01:20 2016 UTC and is due to finish in 60 minutes.  The chair is Zara. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:25 <openstack> The meeting name has been set to 'storyboard'
15:01:51 <Zara> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard#Agenda_for_next_meeting
15:02:04 <Zara> #topic Announcements
15:02:09 <Zara> None here!
15:02:15 <Zara> #topic Urgent Items
15:02:17 <SotK> hey!
15:02:27 <Zara> none listed, again.
15:02:37 <Zara> #topic In Progress Work
15:02:48 <Zara> I didn't get round to updating the agenda with mine
15:03:11 <Zara> I've been documenting the python client!
15:03:20 <Zara> #info Zara has been documenting the python client
15:03:29 <Zara> and misc other things
15:03:46 <Zara> #link https://review.openstack.org/#/c/362878/3
15:04:07 <Zara> we have a couple of patches for the gerrit-storyboard syntax docs awaiting reviews
15:04:17 <Zara> #link https://review.openstack.org/#/c/360668/
15:04:19 <Zara> and
15:04:37 <Zara> #link https://review.openstack.org/#/c/361423/
15:04:55 <Zara> other than that, tiny UI fixes and review from me.
15:05:04 <SotK> I've been fixing bugs in the events timeline patch
15:05:23 <SotK> and am now fixing bugs in the subscriptions for worklists patch
15:05:35 <SotK> and soon I will resend them both containing less bugs
15:05:45 <Zara> \o/
15:05:50 <ricolin> o/
15:06:04 <Zara> hi ricolin
15:06:54 <Zara> the versions with more bugs are more fun to review, but I think it's a fair trade-off :)
15:07:06 <Zara> any updates from anyone else?
15:08:13 <Zara> oh, I also tried to look at task links/notes aliasing last week, to unblock the complex priorities patch
15:08:15 <SotK> The "add to worklist from story view" thing hasn't moved since I've been sidetracked fixing bugs
15:08:35 <Zara> hah, snappish.
15:08:48 <Zara> well I tried to fix the thing blocking it and discovered I'd misunderstood something
15:09:03 <Zara> so I hope to look at it again after the meeting
15:09:39 <Zara> otherwise I'll need to ask about process for renaming something in the db, and I imagine do it as two migrations
15:09:50 <Zara> (that is, rename as one, new thing with old name as other)
15:10:05 <SotK> should be able to do it all in one migration
15:10:23 <SotK> (rename column, add new column with old name)
15:10:47 <Zara> I thought two would be easier to avoid mistakes if I'm not sure of it, but if I can run it by someone before I run it then I'm happy to try it all-in-one
15:11:37 <persia> The problem with two migrations is that it is trickier to ensure the DB is in a consistent state after a commit.
15:11:45 <persia> Doing the transition in a single migration is likely more sensible.
15:12:26 <Zara> but it's a shame; I thought to unblock it all we'd need would be for task links to be called task notes everywhere except the db (and one place in the api that changes the name to 'notes')...
15:12:30 <Zara> but then I couldn't find a way to do that
15:12:37 <Zara> so if there are any pointers on that I can get on that now
15:13:48 <Zara> anyway, that's where that's at.
15:13:55 <Zara> no discussion topics...
15:14:01 <Zara> so if nobody has anything to add...
15:14:10 <Zara> #topic Open Discussion
15:14:57 <Zara> I think that's our record! anybody have anything to discuss?
15:15:28 <Zara> one week later, ish, gerrit integration seems to be working fine
15:16:06 <Zara> though I've just remembered we meant to make sure it could auth for private stories
15:17:21 <Zara> zaro also asked in-channel about the process for adding projects to storyboard, which I wanted to ask about more widely, but he doesn't seem to be about right now
15:18:56 <Zara> still, if any infra folk have some input on that, maybe it's good to have it here for the logs
15:19:13 <Zara> ^ fungi
15:19:20 <Zara> (this is for non-infra projects)
15:20:09 <fungi> basically just adding use-storyboard: true in the gerrit/projects.yaml file in the openstack-infra/project-config repo
15:20:22 <fungi> though if they need existing bugs imported from launchpad that gets trickier
15:20:47 <fungi> we'll have a migration plan at some point for how/when to make that happen properly
15:21:17 <Zara> okay, thank you. :) should I update the storyboard stuff in system-config? there's a note that says only infra projects should go up on storyboard, but I think that's out of date
15:21:49 <Zara> yeah, I have a feeling the lp migration script has some cobwebs
15:21:53 <fungi> yeah, i think it's fine to update that, though the situation is still a little complex
15:22:32 <Zara> heh, okay, I can mention that things are more complex for folks wishing to import existing bugs...
15:23:09 <fungi> even once we get the migration script fixed up for current storyboard, there's still the complication that many projects in launchpad have bug overlap with other projects (bugs affecting multiple projects) so it's fiddly if we import one project and not the others
15:23:09 <Zara> inching forward toward the day when it can say 'GO FOR IT, FULFILL ALL YOUR TASK-TRACKING DREAMS'
15:23:25 <Zara> ah, okay
15:23:47 <fungi> which is why coordinating a migration is touchy... we pretty much need to do a lot of our major projects as a big-bang cutover
15:24:00 <fungi> all-or-none there
15:24:18 <Zara> yeah, especially awkward since the whole strength is how it works for cross-project work.
15:24:40 <fungi> it would be easier if lp didn't also work passably for cross-project task tracking :/
15:25:01 <fungi> but because it does, we have quite a lot of interlinked bug reports in there
15:26:03 <Zara> yeah
15:30:49 <Zara> I hope we can find a way forward with it; so far we've talked to a representative from nova about their blockers and they don't seem too big, but other projects are an unknown.
15:34:44 * SotK hopes so too
15:37:50 <Zara> I intend to make some noise around the python client so people can try interacting with the StoryBoard api
15:37:57 <Zara> since I can guess that that will come up again and again
15:38:01 <Zara> as every project will have scripts
15:39:11 <SotK> that is probably a good start
15:39:58 <Zara> so actually, that reminds me, I think we either need a new home for those docs online, or we put them in wiht hte storyboard odcs
15:40:04 <Zara> erm, put them in with the storyboard docs
15:40:21 <Zara> the python client has docs in its own repo
15:40:57 <persia> Are the python client docs rendered somewhere accessible?
15:41:25 <Zara> not that I'm aware of, that's what I mean
15:41:35 <Zara> I don't think they're on docs.openstack.org, and now sure how things get there
15:42:45 <persia> To follow the example of other projects, I think they belong in different places.
15:43:00 <persia> Contrast the python-novaclient docs to the compute API docs.
15:43:20 <Zara> yeah, the webclient is on storyboard so I wondered if that would stop folks looking elsewhere for python client docs and just assume we had none
15:43:30 <Zara> *webclient docs are lumped in with storyboard api docs
15:43:46 <persia> Personally, I think the webclient docs belong somewhere else, but I'm not sure there's a good default yet.
15:43:59 * SotK agrees that webclient docs belong elsewhere
15:44:06 <Zara> agree, though storyboard is a lot smaller than nova so I'm not sure it matters so much.
15:44:07 <persia> I suspect the right place to ask is the javascript team meeting, to find best practices for other JS UI docs.
15:44:35 * SotK agrees with that too
15:44:56 <persia> Pity that just concluded, so there's 166.25 hours until the next one :)
15:44:56 <Zara> I'm in favour of separating the docs and then making docs for one part to link to the docs for the other parts
15:46:21 <Zara> so to me it's a question for infra about how to put repo-contents on docs.o.o, and then we just move things/link things as necessary.
15:46:59 <persia> Seems a sensible approach.
15:47:35 <SotK> it may be that there is a favoured tool for js projects that is not sphinx
15:49:37 <Zara> yeah, there's been work and discussion on it and I'm not sure where it's up to off the top of my head; krotscheck, wanna fill us in?
15:49:53 <krotscheck> There is, sortof.
15:50:04 <Zara> uh oh
15:50:17 * krotscheck is fighting with an infant for access to the keyboard
15:50:27 <krotscheck> There's a project called jsdoc-sphinx
15:50:44 <krotscheck> It converts JSDoc output into RST, which we then pipe through sphinx
15:50:54 <krotscheck> The tool is not perfect, but it's better than nothing
15:51:30 <krotscheck> For an idea of how to do this, look at this patch: https://review.openstack.org/#/c/358120/
15:52:44 <Zara> ah, thanks
15:53:10 <Zara> I will start experimenting with that though to begin with I'll try to get a home for pythonclient things
15:53:20 <Zara> since we have webclient docs up, albeit in the wrong place
15:53:25 <Zara> whereas we have no pythonclient docs up
15:53:32 <Zara> so that's marked as more urgent in my head
15:53:42 <SotK> that looks helpful, thanks krotscheck
15:54:41 <Zara> I'm happy to see js things getting more independence from python tools in the openstack world
15:56:56 <Zara> #action Zara to ask infra about a home for python client docs
15:57:15 <Zara> 3 mins left
15:57:43 * SotK has nothing else to discuss
15:58:35 <Zara> okay, ending this meeting! Thanks, everyone! :)
15:58:41 <Zara> #endmeeting storyboard