19:00:38 <zara_the_lemur__> #startmeeting storyboard
19:00:39 <openstack> Meeting started Wed Dec  7 19:00:38 2016 UTC and is due to finish in 60 minutes.  The chair is zara_the_lemur__. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:42 <openstack> The meeting name has been set to 'storyboard'
19:00:56 <zara_the_lemur__> #topic announcements
19:01:08 <zara_the_lemur__> None listed on the agenda, but I didn't do a good job of updating the agenda
19:01:16 <zara_the_lemur__> anything I've missed?
19:01:20 <SotK> I don't
19:01:29 * zara_the_lemur__ will move on, then
19:01:34 <zara_the_lemur__> no urgent items, so...
19:01:40 <zara_the_lemur__> #topic In-progress work
19:02:06 <zara_the_lemur__> as mentioned, the agenda is a bit out of date
19:02:15 <SotK> it is
19:02:33 <zara_the_lemur__> I haven't updated webclient components this week; mainly been reviewing
19:02:59 <zara_the_lemur__> we've had lots of patches, thanks everyone!
19:03:34 <SotK> I have actually done things too
19:03:55 <fungi> doing things is awesome
19:03:58 <zara_the_lemur__> yes!
19:03:58 <SotK> I reworked the search endpoint patches that were blocking the "link to search results" patch
19:04:12 <zara_the_lemur__> I'm very happy about that :)
19:04:18 <diablo_rojo> Good work :)
19:04:35 <SotK> and am intending to look at the issues in the "add teams to private stories" patch right after this meeting
19:04:53 <zara_the_lemur__> #link https://review.openstack.org/#/c/389997/
19:04:59 <fungi> bring able to link to search results is almost as good as custom dashboards
19:05:16 <SotK> indeed
19:05:20 <fungi> can at least be used to a similar purpose
19:05:23 * SotK really wants custom dashboards sometime
19:05:27 <zara_the_lemur__> that's the link for one of the the 'link to search results' patches that requires more reviews
19:05:31 <zara_the_lemur__> +1
19:06:48 <zara_the_lemur__> and the teams patch to which sotk refers is:
19:06:52 <zara_the_lemur__> #link https://review.openstack.org/#/c/370287/
19:07:22 <zara_the_lemur__> I found a tiny  bug but it seems pretty-much done
19:07:45 <diablo_rojo> Nice.
19:08:31 <zara_the_lemur__> also, sotk, I think you knew what was going wrong for one of the patches that's failing tests, but I'm not sure it's written up anyway
19:08:36 <zara_the_lemur__> *anywhere
19:09:04 <zara_the_lemur__> (one of jeblair's, maybe the test for users search?)
19:09:34 <SotK> yeah, I think for some reason the SEARCH_ENGINE global variable which is used to find the search implementation isn't being set in the tests
19:09:44 <SotK> *think*
19:09:48 <jeblair> oh neat
19:09:57 <jeblair> i also have one that is *completely* baffling me: https://review.openstack.org/404978
19:10:19 <jeblair> it catastrophically fails in python27 with migration failures.  python35 is fine.
19:10:27 <jeblair> it doesn't do anything with migrations.
19:11:10 <SotK> yeah that one is very confusing
19:11:36 <fungi> wow
19:11:40 <jeblair> (fwiw the code does actually work if you run it, so it's not that kind of error)
19:11:42 <SotK> we've seen the same failure before, but it normally goes away upon recheck
19:11:57 <jeblair> yeah that one is 4/4 :(
19:12:03 <fungi> maybe it's a sign we should make sb python3.5-only ;)
19:12:05 <jeblair> or 0/4 depending on how you look at it
19:12:06 <SotK> I'd assumed it was some weird manifestation of a timeout
19:13:19 <zara_the_lemur__> ah, and three rechecks at this point
19:13:43 <zara_the_lemur__> it's not unheard of to need more, buuuut normally other patches would be failing in the same way, which would be a tipoff...
19:13:45 <SotK> actually, looking at the most recent failure there are a bunch that are timeouts in there
19:13:55 <zara_the_lemur__> The very last are the interesting ones
19:14:04 <SotK> I suspect our testing needs some love
19:15:02 <zara_the_lemur__> hah, +5
19:15:36 <zara_the_lemur__> and rather ironic that one of the patches failing tests is a patch to improve the tests...
19:16:40 <jeblair> oh, also, the particular migration that is running during the timeout varies, so it doesn't seem like it's making just one migration go bad
19:17:17 <zara_the_lemur__> I guess we could try increasing the length of time before timeout, but that's the only thing I can think of.
19:18:31 <zara_the_lemur__> well, that and 'recheck a few more times just in case'
19:18:46 <zara_the_lemur__> ugh. :L
19:19:11 <jeblair> yeah.  also, i could try to dig in to it a bit more, but it's not a huge priority for me right now
19:19:11 <zara_the_lemur__> maybe it doesn't like the tilde operator
19:19:15 <fungi> would using some roll-up migrations for older changes help?
19:19:27 <fungi> or even be appropriate?
19:19:39 <jeblair> probably a good idea in general
19:19:42 <jeblair> there are a lot of migrations
19:19:51 <fungi> just wondering if the set of migrations has grown to the point of untenability
19:19:55 * SotK agrees
19:20:45 <fungi> they're convenient to a point, but increasingly inefficient to maintain them for changes between versions people are unlikely to ever upgrade from/to
19:21:08 <zara_the_lemur__> I think people are very unlikely to want the old ones
19:22:05 <zara_the_lemur__> and when I needed to use a version from > a year ago to debug a problem, it didn't work out well, since the webclient was out of sync
19:23:04 <SotK> I think its probably safe enough to roll up the ones from pre-2015
19:23:58 <fungi> also, if people _really_ need them, this is all in revision control too so it's not like they're _gone_ ;)
19:24:01 <SotK> yup
19:24:02 <zara_the_lemur__> yep
19:24:26 <SotK> anyone with an instance in the wild that is *that* old which we don't know of can face the battle :)
19:25:17 <zara_the_lemur__> hm should I use an #agreed?
19:25:17 <fungi> so might want to make a very prominent release note that they can be found in git prior to that change, and then turn the etch-a-sketch upside down and shake vigorously
19:25:28 <zara_the_lemur__> I don't think I've ever used an #agreed
19:25:30 <zara_the_lemur__> hehe
19:25:53 <fungi> you just #agreed whatever thing you've agreed to as descriptively as you like
19:26:27 <zara_the_lemur__> #agreed storyboard can and should roll up pre-2015 changes
19:26:41 <zara_the_lemur__> #undo
19:26:42 <openstack> Removing item from minutes: <ircmeeting.items.Agreed object at 0x7f63d9964c90>
19:26:54 <zara_the_lemur__> #agreed storyboard can and should roll up pre-2015 migrations
19:27:02 <SotK> \o/
19:27:20 <zara_the_lemur__> I definitely don't advocate rebasing all our 2015 changes :D
19:27:25 <zara_the_lemur__> *pre-2015
19:27:40 <zara_the_lemur__> other in-progress things...
19:27:45 <jeblair> "Initial commit"
19:28:05 <fungi> heh
19:28:09 <fungi> git squash
19:28:24 <zara_the_lemur__> :) tristanC sent a couple of patches relating to email notifications (I think, I haven't had time to look closely yet)
19:28:46 <zara_the_lemur__> #link https://review.openstack.org/#/c/407904/
19:29:02 <zara_the_lemur__> #link https://review.openstack.org/#/c/407915/
19:29:12 <zara_the_lemur__> so as a big hypocrite, I will say: some eyes on those would be good! :D
19:29:38 <zara_the_lemur__> hm, one of those is also failing tests, which might be related to other strangeness, or might not
19:30:11 <zara_the_lemur__> #link https://review.openstack.org/#/c/404979/ from jeblair seems fine to me and needs more eyes
19:30:21 <SotK> that test failure appears to be because the status_code is a string not an integer
19:30:42 <zara_the_lemur__> =D
19:31:51 * SotK will provide eyes later
19:32:03 <zara_the_lemur__> aaaand there are a few other patches in review, but I could list them all or I could leave that to gerrit
19:32:39 <zara_the_lemur__> there is a specific discussion topic noted on the agenda, but that's just because it's out of date
19:32:45 <zara_the_lemur__> #topic Open Discussion
19:33:01 <zara_the_lemur__> discuss things!
19:33:07 <diablo_rojo> If there is a growing list of them maybe we could arrange them by priority in an etherpad so that if people want to know what they should review they can look there?
19:33:14 <diablo_rojo> Thats what CInder does
19:33:25 <diablo_rojo> Just a thought. Gerrit is good too :)
19:33:40 <jeblair> folks might want to take a look at this script: https://review.openstack.org/407229
19:34:11 <jeblair> SpamapS was in here last week discussing how he would like a semi-automated board
19:34:26 <jeblair> i think i implemented it with that
19:35:30 <jeblair> (new tasks show up in the 'new' lane; you can move them to 'backlog' or 'todo'.  if someone grabs a task, it gets auto-moved to 'in progress', but you can also move it to/from blocked.  when it merges, it gets auto-removed)
19:35:42 <SotK> ooh I was meaning to try to locate that script, since it sounded really neat
19:36:25 <jeblair> that way there's a manual triage step (move out of new), and manual indication of blockedness.  but things appear in the board automatically, so there's no time spent making sure you have added tasks to the board as needed
19:36:48 <zara_the_lemur__> diablo_rojo: yeah, it's not part of our workflow at the moment so we'd probably use gerrit or storyboard itself to track review priorities, since adding other things tends to mean those things get out of date for us (see: meeting agenda :D), but an etherpad might work better with loads of patches (I suspect our busy weeks are still a lot less busy than
19:36:48 <zara_the_lemur__> cinder's busy weeks)
19:37:34 <jeblair> i have no idea if/how that could be implemented server side...  but it's a fairly generic approach -- see the MAP definition on line 65 for the rules.
19:38:01 <jeblair> (and hey, at least in the mean time, we're able to accomplish what we want using the api!  yay!)
19:38:10 <diablo_rojo> zara_the_lemur__, True :)
19:39:11 <fungi> also, using storyboard to effectively prioritize reviews for storyboard makes a lot of sense in a eat-our-own-dogfood sort of way
19:40:09 <zara_the_lemur__> jeblair: cool, thanks; we've wondered a lot about how to get a semi-automated board working sensibly (since cards in automatic lanes aren't 'real' so then there's nothing to drag and drop), so if scripts like this can solve that problem, yayyyy
19:40:49 <SotK> we should get perfect at mapping tasks to commits, and use a worklist for prioritising the reviews
19:41:20 <zara_the_lemur__> yep
19:42:56 <SotK> the problem with implementing automatic boards/worklists like that script on the server side is that it'd mean every story change would mean checking every worklist/board and updating their contents to match
19:43:06 <zara_the_lemur__> ah, slowwww
19:43:06 <SotK> s/story/story or task/
19:43:41 <SotK> maybe it wouldn't be too slow, but I felt like that way would lead to even more madness than the current method
19:44:41 <zara_the_lemur__> though this reminds me that I would quite like to have a directory within storyboard of 'sample scripts' for things that come up a lot, that are best implemented client-side
19:45:07 <SotK> that sounds like it might be handy
19:45:11 <jeblair> SotK: yeah... there might be some solutions, but i can't think of any simple ones; i think they would all be somewhat major efforts
19:45:20 <SotK> I think so to :(
19:45:53 <jeblair> zara_the_lemur__, SotK: we can probably clean this one up and put it in there.  we may want to remove the dependency on boartty (i was lazy and did not want to write a config parser)
19:46:32 <zara_the_lemur__> (I did something a bit like that for the python client, but most folks who like apis tend to talk to the api directly, so there haven't been many eyes on it... https://review.openstack.org/#/c/371620/ )
19:46:46 <SotK> on a related note, I would love to see the old pub/sub spec implemented so scripts like that one could be bots which sub to things they care about and react to change events being published
19:47:06 <SotK> but that will also take plenty of time I expect
19:47:19 <zara_the_lemur__> jeblair: heh, sure, I'd be fine with having it in there with the boartty dependency first and then removing it later
19:47:32 <jeblair> fungi: also, if this would be useful for other openstack teams, we could probably run it in an infra cron somewhere and a config file where people can add boards
19:48:55 <fungi> yeah, that's always an option
19:49:32 <zara_the_lemur__> oh, that'd be cool
19:49:44 <fungi> but as SotK points out, we could make it far more efficient with an event stream
19:50:16 <zara_the_lemur__> I can imagine everyone having sliiiightly different requests and it ending up its own project if not
19:50:51 <SotK> an events stream using websockets would let us have a beautiful live-updating board in the webclient too
19:51:52 <zara_the_lemur__> yeah, I'd love for us to have that
19:53:08 <zara_the_lemur__> I don't think I'd have the knowledge to implement it (yet?)
19:55:41 <zara_the_lemur__> so if anyone does want to leap on it, yes please!
19:56:33 <zara_the_lemur__> otherwise I'll have to learn more about python and websockets and things before I feel confident making a guess at whenn we'll get to that.
19:57:07 <zara_the_lemur__> we have 3 minutes
19:57:27 <zara_the_lemur__> any last points?
19:58:20 * SotK would be happy to do it but has no idea when he'd get to it
19:59:02 * zara_the_lemur__ offers SotK ice cream
19:59:14 <SotK> :D
19:59:18 <zara_the_lemur__> oh yeah I think we merged all the fixes for incubated oslo code
19:59:19 <zara_the_lemur__> I forgot that
19:59:23 <zara_the_lemur__> thanks, dhellman!
19:59:31 <zara_the_lemur__> I just saw he quit, which reminded me, oops
19:59:35 <zara_the_lemur__> #endmeeting