19:05:26 <diablo_rojo> #startmeeting storyboard
19:05:27 <openstack> Meeting started Wed Aug  8 19:05:26 2018 UTC and is due to finish in 60 minutes.  The chair is diablo_rojo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:05:30 <openstack> The meeting name has been set to 'storyboard'
19:06:06 <diablo_rojo> Hello people :)
19:06:22 <diablo_rojo> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard Agenda
19:06:57 <diablo_rojo> For those that want to peruse :)
19:07:14 <diablo_rojo> Anywho let's do this thing.
19:07:16 <diablo_rojo> So!
19:07:18 <SotK> o/
19:07:27 <diablo_rojo> #topic Announcements
19:07:47 <diablo_rojo> I think the human readable urls qualifies as an annoucement
19:08:05 <diablo_rojo> No new migrations lately though
19:08:19 <SotK> I think so too
19:08:30 <diablo_rojo> Any other annoucements from anyone?
19:08:48 <SotK> I plan to look at getting the same feature done for project groups and then will send an announcement/update email or something
19:08:55 * diablo_rojo pokes at fungi to make sure he's not sleeping in the back row
19:08:58 <diablo_rojo> SotK, awesome :)
19:09:06 <fungi> oh, right
19:09:08 <fungi> heh
19:09:17 <fungi> sorry, juggling too many things at once
19:09:18 <diablo_rojo> I saw you chatting with mordred about that last night/this morning
19:09:28 <diablo_rojo> fungi, you and me both sir :)
19:09:35 * mordred said some words at some point
19:09:46 <mordred> the human readable urls are SO AMAZING
19:10:05 <diablo_rojo> SotK, happy to review those when you get them out
19:10:13 <diablo_rojo> Any other announcements?
19:10:21 <diablo_rojo> Or shall we move on to migration updates?
19:11:06 <SotK> I don't have any
19:11:31 <diablo_rojo> #topic Migration Updates
19:11:55 <diablo_rojo> So! Not a ton to report- haven't heard back about if Keystone is interested after I did their test migration a while back.
19:12:08 <diablo_rojo> No new projects have asked me to run test migrations in a little bit.
19:12:31 <diablo_rojo> Kinda been focusing more on docs + now fixing up other issues people have had rather than driving migrations.
19:13:09 <SotK> I somewhat worry that we're going to need to implement the attachments thing before some folk will migrate
19:13:25 <diablo_rojo> I think I reran charms (it had failed a long time ago and now succeeded) and pinged jamespage about it but never got a response.
19:13:36 <diablo_rojo> SotK, yeah I think thats going to be the case for at least Cinder and Manila
19:14:05 <diablo_rojo> So once I clean up a few more of the smaller Octavia concerns (topic for the later) I can try to start looking into that.
19:14:21 <diablo_rojo> I imagine that will require a lot of planning discussion though.
19:14:27 <diablo_rojo> Could do it at the ptg...
19:14:31 <diablo_rojo> but you wont be there.
19:14:42 <diablo_rojo> We can do like we did for YVR and hangout you in
19:14:51 <SotK> yeah that could work
19:15:04 <diablo_rojo> Should probably start a planning etherpad at some point.
19:15:24 <diablo_rojo> SotK, I know you said something about a holiday, but which day would work best for you?
19:15:41 <diablo_rojo> I can't do Monday, but the whole rest of the week I can probably make it work.
19:15:57 <SotK> Tuesday would be best then, or Wednesday if need be
19:16:00 <fungi> i'm up for however/whenever we want to give that a shot
19:16:06 <SotK> I can't do Thursday or Friday
19:16:53 <diablo_rojo> Lets plan for Tuesday then.
19:17:08 <diablo_rojo> I can start that etherpad after this meeting, get it added to the wiki, etc.
19:17:19 <SotK> nice, thanks
19:17:28 <diablo_rojo> #action diablo_rojo to create PTG planning etherpad
19:17:55 <fungi> awesome
19:17:57 <diablo_rojo> Okay. Kinda got off topic. Shall we move on to In Progress work?
19:18:50 <SotK> sure
19:19:09 <diablo_rojo> #topic In Progress Work
19:19:26 <diablo_rojo> So, I started working on one of the things in Octavia's list.
19:19:30 <diablo_rojo> The same names issue.
19:19:50 <diablo_rojo> johnsom, fear not, we are working through your list of concerns still!
19:20:18 <diablo_rojo> I put two patches up (one in WIP) for displaying email address with names to help differentiate users with the same name
19:20:33 <diablo_rojo> I updated a few other things on that etherpad with progress as well
19:20:44 <johnsom> Ha, good stuff.  The team will be happy to hear it
19:20:47 <diablo_rojo> #link https://etherpad.openstack.org/p/storyboard-issues Octavia's concerns
19:21:05 <diablo_rojo> johnsom, you saw the project urls and now not just numbers anymore?
19:21:15 <diablo_rojo> SotK, is working on the same for project groups
19:21:26 <fungi> oh, dhellmann noticed that when he was submitting changes to review.openstack.org with just a story header and no task header, he got no story comments (and i found no evidence in gerrit's log that it even tried. i need to attempt to reproduce on storyboard-dev.o.o/review-dev.o.o but think the storyboard-its plugin for gerrit may be misconfigured
19:21:44 <diablo_rojo> Oh interesting.
19:22:01 <fungi> on my to do list since monday, haven't gotten to it yet
19:22:19 <diablo_rojo> Its only Wednesday, still got a whole half a week left
19:22:48 <fungi> SotK: also spotted a failure to comment from a change which _did_ have both story and task footers, so i still need to see if i can find corresponding gerrit log entries for that incident. it did not persist
19:23:01 <fungi> er, SotK also spotted
19:23:30 <diablo_rojo> Noted.
19:24:23 <SotK> meanwhile I started fixing some bugs which we had a bunch of duplicate stories for, around the "jump to" box and linking to tasks
19:24:24 <diablo_rojo> Any other in progress work we want to mention?
19:24:48 <johnsom> diablo_rojo I missed that.  Do we need to update the deliverables files for the releases repo? I know they link to the number still
19:24:57 <fungi> there's a massive stack of SotK work out there for the webclient which i should review
19:25:03 <SotK> I'd appreciate some reviews on that if folk have time: https://review.openstack.org/#/q/status:open+project:openstack-infra/storyboard-webclient+branch:master+topic:bugfixes
19:25:20 <fungi> johnsom: both work, you can use either and update if/when you like
19:25:34 <johnsom> Excellent, thank you
19:25:40 <diablo_rojo> Beat me to it :)
19:25:59 <diablo_rojo> fungi, yeah whenever you can get on some of SotK and fatema's patches for review
19:26:07 <diablo_rojo> I think that would move us forward a ton.
19:26:15 <diablo_rojo> Most are hanging out with one +2
19:26:26 <fungi> absolutely. i think i'm good with the search ordering implementation of fatema's
19:26:34 <fungi> just need to finalize the review
19:26:43 <diablo_rojo> Sweet.
19:27:15 <diablo_rojo> Unfortunately her official internship duration ends soon, but I imagine she will stick around for a while- hopefully even longer than that, but time will tell :)
19:27:34 <diablo_rojo> I already mentioned that she has funding for the PTG right?
19:27:35 <fungi> maybe we can find her more internships ;)
19:27:49 <diablo_rojo> She's just trying to get through some visa bs before its all settled.
19:27:52 <fungi> i missed that if you mentioned it, but awesome!!!
19:27:56 <SotK> nice!
19:28:03 <diablo_rojo> Visa pending.
19:28:17 <diablo_rojo> I told her if there were any letters we needed to get things expedited and that I would be on it.
19:28:37 <diablo_rojo> I have a check in with her end of next week so hopefully that is all panning out by then
19:28:49 <diablo_rojo> Any thing else on in progress?
19:29:14 <SotK> I don't think I have anything
19:29:28 <diablo_rojo> #topic Wiki Overhaul
19:29:43 <diablo_rojo> I did a thing and I already forgot I did that.
19:30:09 <fungi> we spent some time in last week's meeting congratulating you on it
19:30:11 <diablo_rojo> #link https://wiki.openstack.org/wiki/StoryBoard Storyboard Wiki
19:30:13 <diablo_rojo> Oh
19:30:16 <diablo_rojo> ha ha
19:30:24 <diablo_rojo> I missed that in the logs I guess :)
19:30:28 <diablo_rojo> Glad you all like it
19:30:36 <SotK> :)
19:30:40 <SotK> its good, thank you
19:30:46 <diablo_rojo> Okay well then nothing on that topic.
19:30:51 <diablo_rojo> #topic Open Discussion
19:31:01 <diablo_rojo> Anyone got anything else?
19:31:18 <diablo_rojo> Besides begging for reviews and needing a clone of themselves to get more work done?
19:32:01 <SotK> other than that I don't think I have anything
19:32:01 * fungi is feeling spread too thin volunteering for stuff, but it's probably just fallout from two weeks of vacation
19:32:58 <fungi> nothing from me
19:33:13 <diablo_rojo> vacation is wonderful while you're there and terrible after
19:33:26 <diablo_rojo> Okay well I can leave it open for a few min if we think we should..?
19:34:11 <fungi> nobody seems to be chiming in, i'd just #endmeeting now
19:34:19 <diablo_rojo> Coolio
19:34:35 <diablo_rojo> if folks have anything they want to discuss, please join us in #storyboard!
19:34:40 <diablo_rojo> #endmeeting