19:03:05 <SotK> #startmeeting storyboard
19:03:06 <openstack> Meeting started Wed Jun  5 19:03:05 2019 UTC and is due to finish in 60 minutes.  The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:09 <openstack> The meeting name has been set to 'storyboard'
19:03:16 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard#Agenda_for_next_meeting Agenda
19:03:24 <diablo_rojo> o/
19:03:54 <SotK> #topic Migration Updates
19:04:13 <SotK> I don't think there's been anything new this week right?
19:04:15 <diablo_rojo> No negative feedback.. or any feedback for that matter from Swift
19:04:20 <diablo_rojo> Nothing new
19:04:44 <SotK> I guess we just give them a bit more time for now?
19:04:51 <fungi> yeah, wouldn't rush it
19:05:10 <notmyname> the swift team meeting is today. it should be raised there for people to offer comments
19:05:17 <notmyname> (in about 3 hours)
19:05:28 <notmyname> sorry, in 2 hours
19:06:04 <fungi> getting feedback isn't time-sensitive, they should take all the time they need to try stuff out
19:06:25 <SotK> +1
19:06:54 <diablo_rojo> Yeah I agree
19:07:18 <diablo_rojo> Definitely not rushing
19:07:25 <diablo_rojo> More just noting that there isnt any yet.
19:08:11 <SotK> #topic Release Progress
19:09:01 <SotK> so I think we decided on most of the things we needed to after the meeting last week
19:09:09 <diablo_rojo> What are the next steps?
19:09:23 <fungi> well, a recap of that decision would help too
19:09:29 <diablo_rojo> Oh yeah
19:09:33 <diablo_rojo> for logging purposes
19:10:00 <fungi> i mean, it's in the #storyboard channel logs, but for posterity having it mentioned in the meeting would be great
19:10:03 <SotK> :)
19:10:06 <diablo_rojo> SO I think we decided on storyboard-api for pypi?
19:10:18 <fungi> that matches my recollection
19:10:20 <SotK> #info we'll rename the python package to storyboard-api
19:10:50 <fungi> which i think just needs a minor update to the existing patch?
19:10:57 <SotK> yeah
19:11:13 <SotK> #info we'll number the first release 1.0.0
19:11:13 <fungi> i can do that unless someone has already started
19:11:19 <diablo_rojo> And someday...might rename the storyboard repo to storyboard-api
19:11:26 <diablo_rojo> fungi, go for it :)
19:11:31 <diablo_rojo> I haven't touched it.
19:11:34 <SotK> me neither
19:12:00 <fungi> i'll check with tonyb first to see if he wants to
19:12:10 <fungi> since it is his patch
19:12:18 <fungi> i'll leave a review comment real quick at least
19:12:22 <SotK> thanks
19:12:35 <SotK> we didn't firmly decide on when to do a release
19:12:53 <SotK> but I think we should just do it when we've finished planning what we need to do to do a release
19:13:13 <fungi> there was something you wanted merged first... the attachments implementation? security teams?
19:13:29 <fungi> or we could make those 1.1.0 et cetera
19:13:40 <fungi> and just release as soon as the dist name is updated
19:13:45 <SotK> yeah I mentioned attachments, but I ended up preferring the idea of "here's 1.1.0, now with attachments!"
19:14:40 <diablo_rojo> Yeah I think we decided early and often?
19:14:41 <fungi> basically the process (once we're using an available dist name) is to make a 1.0.0 signed tag and push it to gerrit
19:14:57 <fungi> oh, we needed to add jobs ;)
19:15:12 <fungi> i'll check into what jobs we're missing for release automation
19:15:40 <SotK> nice, thanks
19:15:56 <fungi> with the correct jobs added we'll upload an sdist and a wheel to pypi automatically each time a new tag is pushed to gerrit
19:16:57 <SotK> I think that adding jobs is the only other thing we need to do then
19:17:10 <fungi> yep, i concur
19:17:34 <diablo_rojo> Sounds pretty easy
19:17:39 <SotK> on a related note, what about webclient releases?
19:17:49 <fungi> i may also push a manual build to test.pypi.org just to make sure the package metadata isn't going to be rejected by warehouse
19:18:11 <SotK> that sounds like a good idea
19:18:51 <fungi> storyboard-webclient will need different sorts of jobs, presumably
19:19:17 <fungi> i know less about javascript, but i believe we do have some js-based projects doing automatic releases to npm, if that's where it makes sense
19:19:21 <SotK> yep, we'll want jobs to upload to npm I expect
19:19:54 <SotK> I'm not totally sure if that makes sense, but will look into being more sure
19:19:58 <fungi> i can probably work out what those are using to accomplish that, but less sure how to safely test that it'll work ahead of time and not sure what sorts of package registration we need to do
19:20:11 <fungi> mordred might have ideas there too
19:20:41 <SotK> also, do we want to keep version numbers in sync and release them simultaneously?
19:20:43 <diablo_rojo> Do we want to to outline some actions for logging's sake?
19:20:47 <SotK> my initial feeling is "not really"
19:20:54 <fungi> i would not try to sync releases
19:20:57 <diablo_rojo> I would agree with the not really
19:21:06 <fungi> release them whenever makes sense for each project
19:21:15 <diablo_rojo> I feel like there will be more stuff in the api we want to/need to release than in the webclient
19:21:44 <SotK> #action SotK to decide if npm makes sense as a place to release the webclient, and what it entails
19:21:52 <fungi> and if the demo docker image is something we think is useful, i believe we have jobs which could build that and publish to dockerhub too
19:22:45 <SotK> #action fungi to investigate what jobs we are missing for api releases
19:23:16 <diablo_rojo> That would be cool.
19:23:25 <diablo_rojo> (the docker image)
19:23:31 <diablo_rojo> Though I dont think its a priority
19:23:37 <SotK> +1, but I'm not sure it actually exists yet
19:24:13 <SotK> it would definitely be useful, but we can probably wait for an updated version of https://review.opendev.org/#/c/611191/
19:25:50 <SotK> #topic Forum + PTG Summary
19:26:11 <SotK> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006214.html Summary email
19:27:09 <diablo_rojo> So did all the stories we have on the etherpad get added?
19:27:17 <diablo_rojo> I know you were working on that Friday
19:27:21 <diablo_rojo> I didnt have time to circle back
19:27:32 <SotK> #link https://etherpad.openstack.org/p/sb-train-ptg PTG Etherpad
19:27:39 <diablo_rojo> Yeah that etherpad :)
19:27:53 <SotK> I think there are still a couple of story-less things
19:28:15 <SotK> we should do as the agenda suggests and go through tagging things and creating the last couple of stories
19:28:19 <SotK> at some point
19:29:54 <SotK> the missing ones are "Integration tests", "Search is slow", and "Archive tasks/stories"
19:30:58 <diablo_rojo> SotK, I feel like we should schedule a meeting..
19:31:07 <diablo_rojo> Heh
19:31:14 <SotK> heh, that's probably a good idea
19:31:31 <diablo_rojo> Whats the rest of your week look like?
19:31:37 <diablo_rojo> My Friday is very open.
19:32:16 <diablo_rojo> Anywhere from like.. 15:00 UTC onward
19:32:45 <SotK> anything after 16:00 UTC works for me tomorrow or Friday
19:33:37 <diablo_rojo> Lets do like.. 17 UTC on Friday
19:33:42 <diablo_rojo> we can use my zoom
19:33:51 <SotK> wfm
19:34:17 <diablo_rojo> https://zoom.us/j/8341652381
19:34:25 <diablo_rojo> for those interested in participating
19:34:32 <diablo_rojo> I'm sure it will be thrilling
19:35:16 <ankita-2798> diablo_rojo, what is the agenda for the meeting?
19:37:35 <diablo_rojo> ankita-2798, https://wiki.openstack.org/wiki/Meetings/StoryBoard#Agenda_for_next_meeting
19:37:43 <diablo_rojo> Or for Friday?
19:37:50 <diablo_rojo> Which meeting? lol
19:38:04 <diablo_rojo> the wiki link is for the meeting now
19:38:20 <diablo_rojo> SotK, do I need to make an invite?
19:38:28 <ankita-2798> the one you are planning for Friday
19:38:28 <diablo_rojo> Or you just want to write it down
19:38:49 <SotK> if you like, I've added it to my calendar already though :)
19:39:18 <diablo_rojo> ankita-2798, its just to finish a triage of the active stories in the storyboard project group that we started at the Project Team Gathering a few weeks ago
19:39:26 <diablo_rojo> SotK, if you dont need one I wont ;)
19:39:46 <ankita-2798> Oh, okay
19:40:36 <SotK> anything else on this?
19:41:16 <ankita-2798> No, thank you :)
19:42:03 <diablo_rojo> None from me
19:42:19 <SotK> #topic In Progress Work
19:42:42 <diablo_rojo> Did we ever get mkarray's work merged?
19:43:12 * SotK reviewed it and left some comments
19:43:31 <SotK> mostly just some things that I'd like to neaten up before we merge them
19:44:13 <diablo_rojo> SotK, not sure he is around much anymore.
19:44:31 <diablo_rojo> I can take a look and update based on your comments and then you can merge it?
19:44:51 <SotK> me neither, I noted in the reviews that I can make the fixes if he doesn't have time, and was planning to do so if I didn't hear anything
19:44:58 <SotK> but feel free to beat me to it :)
19:44:59 <fungi> or can always add a followup change with the suggested improvements and approve them both at the same time if that's more palatable
19:45:53 <SotK> either works for me, there was nothing too problematic in them
19:47:28 <SotK> diablo_rojo: do you have a preference?
19:48:19 <diablo_rojo> I'll just go make the changes and ping you when I have the patchset up
19:48:30 <SotK> ok, sounds good
19:48:44 <SotK> also, thanks for reviewing the security teams stuff :)
19:48:55 <fungi> i'm almost through the api side of that stack as well
19:49:05 <fungi> should hopefully see it merged by the end of the day
19:49:18 <SotK> excellent, thanks
19:50:12 <SotK> the issues that diablo_rojo noted on the webclient side of that should go away once the api side is deployed on storyboard-dev too I think
19:50:38 <fungi> awesome, and yeah that's why i started on the api stack
19:50:59 <diablo_rojo> YAY!
19:50:59 <SotK> I'll try to continue getting through my review/rework backlog
19:51:05 <diablo_rojo> So excited :)
19:51:44 <SotK> it would also be spectacular to merge https://review.opendev.org/#/c/643323/
19:52:13 <SotK> I think that should help reduce the complexity of that 3 minute long query
19:52:21 <fungi> yes indeed
19:52:25 <fungi> thanks for the reminder
19:53:10 <SotK> same goes for https://review.opendev.org/#/c/643303/ too, but that query is a bit less bad to start with
19:53:36 <SotK> in fact, that isn't much better
19:53:55 <SotK> but its a bit better at least
19:54:14 * diablo_rojo opens tabs
19:54:27 <diablo_rojo> (5 min left)
19:55:35 <SotK> I think that's everything I have to mention for in progress work
19:55:42 <SotK> anyone else?
19:56:20 <fungi> ankita-2798 likely will want to track 643323 and 643303 since that may alter some of the queries in the slow query log data she asked about in #storyboard earlier
19:56:45 <diablo_rojo> Good point
19:56:52 <fungi> we can also grab a fresh log after those are in place and see if they made a difference
19:57:22 <ankita-2798> Regarding the Search Improvement, I have been currently going through the storyboard's backend's codebase, learning the frameworks etc. I am yet to study the logs provided by corvus.
19:57:53 <ankita-2798> fungi, yeah I already took a note of these reviews :)
19:58:40 <fungi> awesome!
20:00:05 <SotK> and with that we're out of time, thanks for coming folks!
20:00:08 <SotK> #endmeeting