19:00:22 <SotK> #startmeeting storyboard
19:00:23 <openstack> Meeting started Wed Jun 19 19:00:22 2019 UTC and is due to finish in 60 minutes. The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:27 <openstack> The meeting name has been set to 'storyboard'
19:00:38 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard Agenda
19:00:42 <SotK> #topic Announcements
19:01:15 <SotK> fungi migrated Karbor's bugs from Launchpad
19:01:35 <SotK> and we released the API (twice because there was a bug)!
19:01:50 <diablo_rojo> o/
19:01:54 <SotK> #link https://pypi.org/project/storyboard-api/
19:02:12 <SotK> anyone have anything further to announce?
19:02:24 <diablo_rojo> Nope, thats all I had :)
19:03:22 <SotK> #topic Migration Updates
19:03:33 <SotK> as noted above, Karbor's bugs were migrated
19:03:41 <SotK> any other updates I've missed?
19:03:43 <fungi> yup, a good time was had by al
19:03:45 <fungi> l
19:03:52 <fungi> (al always has a good time)
19:05:23 <fungi> no other migration updates for which i'm aware, no
19:05:42 <diablo_rojo> I suppose I have some updating of the board/story to do
19:05:57 <diablo_rojo> I think I've fallen behind a bit on keeping ht up to date
19:07:49 <SotK> #link https://storyboard.openstack.org/#!/board/45 Migration Status board
19:07:59 <diablo_rojo> Yeah that one :)
19:08:09 <SotK> #topic Story Triaging
19:08:37 <SotK> so we had a pretty successful time the other week tagging a bunch of stuff and creating some stories
19:08:59 <SotK> we should finish that off with more tagging and updating the priorities board
19:09:05 <diablo_rojo> +2 we should do it again
19:09:10 <diablo_rojo> and then I can document all the tags
19:09:49 <SotK> when is a good time?
19:10:24 <diablo_rojo> an hour earlier than this works or Friday anytime
19:12:42 <SotK> shall we do 17:00 UTC on Friday like last time then?
19:12:49 <diablo_rojo> Works for me.
19:12:55 <diablo_rojo> fungi, did you wanna join the party?
19:13:00 <diablo_rojo> I can add you to the invite.
19:13:35 <fungi> i've added it to my calendar for 1700z on the 21st
19:13:42 <fungi> i should be around
19:14:06 <fungi> if nothing's on fire i'll try to pitch in
19:14:08 <diablo_rojo> fungi, cool :) I'll share my zoom link/number for you to join too.
19:14:16 <fungi> thanks!
19:14:37 <SotK> excellent
19:15:03 <SotK> #agreed More story triaging/tagging at 17:00 UTC on Friday 21st June
19:15:16 <SotK> #topic In Progress Work
19:16:24 <SotK> the attachments is waiting on me updating the patches to use openstack-sdk and form posts rather than the current method
19:16:28 <diablo_rojo> fungi, let me know if you want me to send it to a different email I just did it to your @yuggoth
19:16:35 <SotK> s/attachments/attachments work/
19:16:38 <fungi> diablo_rojo: that'll be perfect
19:17:05 <fungi> i owed an update on production storyboard.openstack.org server backups... confirmed it's working and did a remote restore from the backup server to make sure it contains a current nightly db dump
19:17:38 <diablo_rojo> SotK, noted, I will keep an eye out for those updates
19:18:00 <SotK> openstack-sdk doesn't seem to work with the swift-all-in-one docker image I've been using (since it uses legacy auth), so its also blocked on me finding an image it does work with and/or deploying devstack or something to test against
19:18:26 <SotK> the security teams stuff is pretty much finished now
19:18:58 <SotK> it might be worth adding API support for auto-assigning teams as well as doing that in the UI, to make sure its enforced no matter how folk create the story
19:19:11 <SotK> and there is still outstanding work to subscribe the team members to the story
19:19:12 <fungi> yep, it's on my to do list to set up some security team integration on sb.o.o
19:19:44 <diablo_rojo> SotK, do we have a story for the remaining work?
19:19:46 <fungi> as in configure a couple of existing security teams as associated with projects
19:19:53 <diablo_rojo> Or is that all in the original story?
19:20:30 <SotK> its in the original story
19:20:35 <diablo_rojo> Okay cool
19:20:38 <diablo_rojo> nevermind then :)
19:20:44 <SotK> #link https://storyboard.openstack.org/#!/story/2000568 Private stories story
19:21:32 <SotK> did we get a new set of slow query logs btw?
19:21:44 <fungi> we're still loggging it
19:21:56 <fungi> i don't think any new analyses have been run on it yet
19:22:13 <fungi> corvus: mordred: is that something either of you have time for in the near-ish future?
19:22:35 <fungi> if not, i can follow earlier notes and work it out
19:24:30 <diablo_rojo> Since we no longer have an intern... to work on storyboard search optimizations :(
19:25:27 <fungi> doesn't mean they won't be worked on, but yes that's sad for us (and exciting for our would-be intern!)
19:26:24 <SotK> indeed, someone else will have to find time :)
19:28:09 <SotK> anything else in progress that folks want to raise?
19:28:18 <diablo_rojo> mkarray's patches?
19:28:29 <diablo_rojo> I still have more to fix up again don't I?
19:29:04 <diablo_rojo> Two of the three anyway it looks like
19:29:09 <diablo_rojo> I will try to get those up today
19:30:16 <SotK> thanks, I'll get them reviewed and merged when you do
19:32:16 <diablo_rojo> Oh haha for one of them there was a comment about doing a search with a regex and I had a brain lapse. Havent had to write a regex in like.. 5 years.
19:34:32 * SotK recommends this wonderful thing: https://regex101.com/
19:34:58 <diablo_rojo> Heh, was just playing with something similar, but this one looks better
19:35:04 <diablo_rojo> Will get that done asap.
19:36:09 <SotK> thanks :)
19:36:36 <fungi> my only real recommendation is to not try to write a regular expression parser
19:36:53 <diablo_rojo> Not on my todo list today
19:37:17 <fungi> also, keep in mind that operating on user-supplied regular expressions can be dangerous
19:37:36 <fungi> so choose an expression parser specifically designed for handling user-supplied expressions
19:39:22 <diablo_rojo> We can chat about all that post meeting in the channel
19:39:39 <SotK> anything else in progress?
19:39:47 <fungi> yeah, there's one i'm aware of for python but having trouble remembering the name
19:40:10 <fungi> anyway, don't use the re module from python's stdlib
19:40:17 <diablo_rojo> Noted.
19:40:34 <fungi> it's great for handling statically-defined expressions, dangerous for untrusted user-supplied ones
19:41:57 <diablo_rojo> That makes sense
19:42:19 <SotK> iirc the comment was about matching user input with a regex rather than naively trying to treat everything with a colon in differently, so we shouldn't have to worry too much about that I think
19:42:47 <fungi> ahh, so not accepting regular expressions as a search syntax
19:43:02 <fungi> that should be safe enough with the re module then
19:43:50 <fungi> allowing searches based on regular expressions would also be nice, but that's a in-the-future-when-we-have-a-new-search-language sort of thing
19:43:54 <diablo_rojo> Its in javascript in the webclient though so a python module wont work?
19:44:27 <fungi> right, if this is matching within javascript you'll need to use one of the many regex parsers on npm i suppose
19:44:37 <diablo_rojo> Yeah
19:44:59 <fungi> (unless there's native support for them within the javascript language itself?)
19:45:25 <fungi> ((seems doubtful, but i have no idea))
19:45:45 <SotK> it does: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Guide/Regular_Expressions
19:48:10 <diablo_rojo> Nice
19:48:17 <diablo_rojo> Okay well I got nothing else for the meeting.
19:48:24 <diablo_rojo> We can continue regexing in channel :)
19:49:13 <SotK> lets end it here then, thanks for coming folks :)
19:49:16 <SotK> #endmeeting