18:25:49 <SotK> #startmeeting storyboard
18:25:50 <openstack> Meeting started Thu Dec  5 18:25:49 2019 UTC and is due to finish in 60 minutes.  The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:25:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:25:54 <openstack> The meeting name has been set to 'storyboard'
18:26:33 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard (outdated) Agenda
18:26:59 <diablo_rojo> o/
18:27:08 <diablo_rojo> no worries at all :)
18:27:14 <diablo_rojo> Glad to have you here :)
18:27:31 <diablo_rojo> Yes sorry I should have updated that while I was waiting
18:27:31 <SotK> #topic Announcements
18:27:47 <SotK> don't worry about it, I've had about 4 weeks to update it :D
18:27:51 <SotK> do we have anything to announce?
18:27:57 <diablo_rojo> I saw someone asking about adding OSA to SB but I didnt look for patches to project-config
18:28:02 <diablo_rojo> so idk if that happened
18:28:20 <fungi> yeah, don't know of anything to announce
18:28:34 <diablo_rojo> I dont think theres anything
18:28:50 <SotK> #topic Migration Updates
18:28:55 <SotK> I assume a similar story here?
18:28:59 <fungi> sort of
18:29:08 <fungi> there's this:
18:29:18 <fungi> #link https://review.opendev.org/697201 Declare victory on StoryBoard
18:29:41 <fungi> i figure folks here may have opinions, would be good to get comments on the review
18:30:19 <diablo_rojo> Yeah I will try to get that done in the next day or so
18:30:26 <fungi> mostly a means of getting the standing sb migration spec updates off the weekly infra meeting agenda
18:30:36 <diablo_rojo> Makes sense
18:30:44 <diablo_rojo> I still want to keep pushing for more to migrate
18:30:47 <diablo_rojo> but I get that
18:31:08 <fungi> yeah, and we can do that same as we have
18:31:32 <fungi> it's more of an openstack project scope problem than an infra team scope problem at this stage
18:31:42 <SotK> yeah, I think it makes sense to do that
18:31:49 <SotK> I'll vote on the change to that effect later
18:32:09 <diablo_rojo> I understand.
18:32:12 <SotK> certainly its an openstack problem not an opendev problem
18:32:27 <diablo_rojo> As far as openDev is concerned, its done.
18:32:29 <fungi> yeah, as we transition the infra team efforts further out of openstack itself, making sure the decision on timelines and process for that is more squarely on the openstack tc might help
18:32:36 <SotK> so being documented in opendev/infra-specs doesn't make much sense
18:32:53 <SotK> (documented as an intention I mean)
18:32:56 <diablo_rojo> right
18:33:06 <fungi> having storyboard features documented in infra specs makes fine sense of course
18:33:26 <fungi> but documenting what the openstack project wil or should do is something which should really come from the tc
18:34:20 <fungi> thankfully we probably know someone on the openstack tc
18:36:14 <SotK> #agreed We're happy for https://review.opendev.org/697201 to go through
18:36:55 <SotK> #topic PTG + Forum
18:37:11 <SotK> this is actually our first meeting since the PTG + Forum
18:37:14 <SotK> how was it?
18:37:30 <diablo_rojo> Not a whole lot of interaction
18:37:36 <diablo_rojo> a few hallway conversations
18:37:54 <diablo_rojo> but no one showed up to onboarding for storyboard :/
18:38:29 <fungi> to be fair, the demographic of this ptg was, unsurprisingly, different from what we typically see
18:38:56 <fungi> even nova only had four core reviewers present for their days
18:39:21 <diablo_rojo> this is true
18:39:34 <fungi> and there were basically no new faces at any of the ptg tables
18:40:17 <fungi> and the ones who did make it already had full agendas for the handful of representatives from their teams who did make the tri[
18:40:22 <fungi> er, the trip
18:41:35 <fungi> so while having it in shanghai did mean that it was easier for some of our regular attendees to get to, and helped balance out all the times they've travelled to the far side of the planet to see the rest of us, i don't think there were many people at the ptg who wouldn't have attended even if it were held somewhere else
18:42:47 <fungi> but yeah, as a result, there wasn't much in the way of unscheduled drop-in topics at any table i noticed
18:43:47 <fungi> still, i think having "storyboard something something" on the ptg schedule at least helped remind folks who looked at it that we're still working on stuff
18:43:48 <diablo_rojo> oh well
18:44:09 <diablo_rojo> better luck next time if we want to try again
18:44:19 <SotK> makes sense
18:44:32 <fungi> we've had better luck holding discussions in forum track type settings
18:44:50 <fungi> so maybe we should just keep that in mind for future events
18:44:55 <SotK> yeah, maybe we should look to do that again
18:45:11 <SotK> (hoping that getting the attachments work done gets migrations going again)
18:45:12 <fungi> we can always have a forum session which is a sb inservice/tutorial/whatever
18:47:14 <SotK> I think that kind of thing would make sense
18:47:20 <SotK> but we can think more closer to the time
18:47:32 <SotK> #topic In Progress Work
18:47:50 <fungi> all your glorious attachments api changes merged
18:48:02 <fungi> and better still, nothing has fallen over
18:48:05 <SotK> I saw, thank you for the reviews :D
18:48:09 <fungi> granted, we haven't configured it yet
18:48:24 <SotK> I like it when we merge things and nothing falls over
18:48:28 <fungi> i'm currently trying to work out how we set container-specific credentials in one of our swift providers
18:48:48 <fungi> and will then add that to storyboard-dev's config
18:49:00 <fungi> though that dovetails into mordred's container stuff
18:49:11 <diablo_rojo> SHould we wait on the front end stuff then?
18:49:22 <diablo_rojo> Or can I go review/merge that?
18:50:06 <fungi> well, i mean, we could review it. we can't really exercise the attachments bits against sb-dev with the draft views until sb-dev is configured with an object store
18:50:26 <fungi> you can still test it locally, or just maybe be satisfied it isn't breaking anything
18:51:09 <fungi> the trick with getting the object store config options added to sb-dev is that it means plumbing more variables through puppet-storyboard
18:51:19 <fungi> which i'm happy to do, but
18:51:32 <diablo_rojo> I'll have to go set things up locally again to get it all tested properly..or wait for sb-dev to have the config set
18:51:35 <fungi> also we want to switch to deploying storyboard with ansible from containers
18:52:04 <fungi> so have to configure the swift variable stuff twice if we do it first in puppet and then in ansible/docker
18:52:28 <SotK> how far off is the containers work?
18:52:38 <SotK> just waiting on us actually building images?
18:52:43 <fungi> well, that in turn brings us to your node upgrade patches yeah
18:52:56 <mordred> and my plague
18:53:19 <fungi> as discussed yesterday we ought to probably just go ahead and merge the node upgrade assuming the draft builds of those changes are working fine
18:53:45 <fungi> and yeah, mordred's plague
18:53:55 <mordred> yeah - the webclient stack is all green
18:54:03 <mordred> and the draft build seemed fine to me
18:54:19 <diablo_rojo> I'll take a look and should be able to +2 today
18:54:34 <SotK> I've been using those node changes since I sent them locally and haven't noticed any problems, so I'm fairly confident in them
18:54:38 <fungi> anyway, once i get the credentials worked out, i'll see how close we are to being able to drop puppet-storyboard (at least for storyboard-dev) and decide then whether i add support to puppet-storyboard for attachments stuff
18:54:40 <mordred> https://review.opendev.org/#/q/topic:es6-support and https://review.opendev.org/#/q/topic:node-10-support
18:55:19 <diablo_rojo> thanks mordred!
18:55:49 <fungi> though talking about javascript and upgrades...
18:55:59 <fungi> #link https://storyboard.openstack.org/#!/story/2001850 New Story dialog will not enable Save Changes if full project name types in search
18:56:19 <fungi> diablo_rojo commented there "This is an issue with the typeahead library. We need to update to a newer version and the bug will disappear."
18:56:34 <fungi> what's involved in upgrading that?
18:57:02 <fungi> is that addressed by the es6/node10 stuff?
18:57:54 <fungi> though i guess we can test that on one of the drafts at the end of the change series
18:58:07 <diablo_rojo> Uhhh I dont remember
18:58:15 <SotK> sadly not, we need to update angular-ui-bootstrap and make use of the callback on the input field losing focus that actually exists in more recent versions than the ancient one we use
18:58:23 <SotK> iirc
18:58:26 <diablo_rojo> Presumably something I wrote at the PTG when we did that backlog prune
18:58:41 <fungi> okay, so needs newer bootstrap
18:58:55 <SotK> there might be a short-circuit way to automatically select the top item in the results, its a while since I looked into it
18:59:22 <SotK> the drawback is that we need to modify all of our ui-bootstrap related html attributes because the naming convention changed
18:59:31 <fungi> nevermind, i mostly just wanted to see if that's still going to be an outstanding problem
18:59:37 <SotK> so its a lot of find and replace
18:59:44 <fungi> yep, makes sense
18:59:44 <SotK> short answer: yes, still outstanding
18:59:56 <SotK> one of the many many updates we should really do
19:00:42 <fungi> noted
19:00:42 <SotK> aaand we're out of time
19:00:59 <fungi> thanks SotK!
19:01:01 <SotK> happy to continue discussions in #storyboard if you like
19:01:05 <SotK> #endmeeting