15:00:25 <amrith> #startmeeting swg
15:00:26 <openstack> Meeting started Tue Jul 26 15:00:25 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:30 <openstack> The meeting name has been set to 'swg'
15:00:33 <dhellmann> o/
15:00:34 <amrith> #chair dhellmann
15:00:35 <openstack> Current chairs: amrith dhellmann
15:00:37 <amrith> #chair ttx
15:00:38 <openstack> Current chairs: amrith dhellmann ttx
15:00:42 <amrith> #chair gothicmindfood
15:00:43 <openstack> Current chairs: amrith dhellmann gothicmindfood ttx
15:01:10 * amrith confesses to being totally out of it today; following instructions on the side of the container, will not operate any heavy machinery
15:01:21 <jroll> \o
15:01:25 <carolbarrett> hi
15:01:32 <amrith> hello
15:01:38 <amrith> jroll, dhellmann carolbarrett
15:01:50 <amrith> gothicmindfood sends her apologies, can't attend today
15:01:55 <amrith> has an update for us
15:02:10 <amrith> let's wait a couple of minutes for others to join
15:03:20 <amrith> let's get going, can't see any of the others as being active on IRC
15:03:27 <thingee> o/
15:03:35 <amrith> I suspect that the agenda and meeting date confusion could have contributed to this
15:03:38 <amrith> hi thingee
15:03:48 <thingee> hi hi hi
15:03:59 <amrith> #link https://wiki.openstack.org/wiki/Meetings/SWGMeeting
15:04:15 <amrith> #topic Establish schedule for weekly meeting
15:04:23 <amrith> We currently have a bi-weekly meeting because of scheduling conflicts. Do we need a weekly meeting, how do we go about addressing the availability and time slots when meeting channels are available.
15:04:44 <dhellmann> I think we're probably going to be fine just meeting every other week
15:05:03 <thingee> +1
15:05:07 <jroll> ++
15:05:12 <dhellmann> we can coordinate by email in the interval, and most of what we need to do will be long-term thinking without weekly updates anyway
15:05:47 <amrith> carolbarrett, ok?
15:06:15 <carolbarrett> yup, works for mew
15:06:20 <amrith> #agreed stay with meetings every other week for now
15:06:22 <carolbarrett> oops, me
15:06:29 <amrith> Every two weeks (on odd weeks) on Tuesday at 1500 UTC in #openstack-meeting-3
15:06:47 <amrith> #topic Review items short list from last meeting
15:06:54 <amrith> #link https://etherpad.openstack.org/p/swg-short-list-deliverables
15:07:04 <amrith> This is the short list of deliverables we put together at the last meeting
15:07:14 <amrith> by summarizing the various action items that were taken in Ann Arbor.
15:07:26 <jroll> "short" :)
15:07:45 * amrith wonders what happened to the numbering
15:07:55 <amrith> whoever is fixing it, thank you!
15:08:09 <amrith> so, yes. Short ...
15:08:21 <amrith> Many of the things were written up on the last day
15:08:23 * thingee catches up
15:08:25 <amrith> when everyone wasn't there
15:09:16 <mugsie> amrith: i assume Z == Zingtrain ?
15:09:24 <amrith> mugsie, yes
15:09:31 <amrith> Z ~ Zingerman's
15:09:35 <amrith> Z ~ ZCOB
15:09:37 <amrith> contextual
15:10:34 <mugsie> k
15:11:06 <amrith> So one thing that we want to do is to make a set of things that we're looking to deliver in the very short term
15:11:16 <thingee> there's a whole page of acronyms :(
15:11:34 <fungi> it's secret code for the cabal
15:11:49 <mugsie> yeah - could we do a glossary, or expand them?
15:12:02 <amrith> What's PTL an acronym for? I don't remember that one and it isn't in the training material
15:12:06 <amrith> ;)
15:12:20 <amrith> ok, so the question is this, we have the write-up that dhellmann put together
15:12:26 <thingee> ugh don't go there
15:12:28 <amrith> dhellmann, what's the next step/steps with that?
15:12:38 <thingee> re: ptl
15:12:51 <dhellmann> I'm waiting for mordred's thing to be proposed so I can write mine to refer to the list of principles
15:13:23 <amrith> OK, I'll follow-up with mordred on his thing
15:13:45 <amrith> #action [amrith] to follow-up with mordred on write-up which is a dependency for dhellman's writeup
15:13:49 <mordred> gah. sorry everybody - china ate me much harder than I originally expected
15:13:56 <mordred> there's some great feedback on the etherpad
15:13:59 <amrith> hi monty
15:14:00 <dhellmann> we could spend some time turning the repeated/related items on this list into a shorter list
15:14:54 <amrith> dhellmann, we could give that a start now?
15:15:34 * amrith watches dhellmann update etherpad
15:15:39 <dhellmann> we could also fill in some of the "please explain what this means" comments
15:17:45 <fungi> it's almost as if the meeting is now taking place in that etherpad instead
15:18:02 <mugsie> so number 26 (TC Passport) would be similar to https://about.gitlab.com/handbook/ ? (with more detail)
15:18:20 <dhellmann> mugsie : something like that, yes
15:18:55 <dhellmann> it's a combination of a "you need to learn this" checklist with "here is where you can find the information we've told you to learn"
15:19:23 <mugsie> OK.
15:23:20 <amrith> while we're watching the etherpad change, are there other questions, comments ...
15:24:07 <jroll> idk if it's the colors or my eyes are extra tired today, but that etherpad is incredibly hard to read :P
15:24:43 <dhellmann> jroll : lots of ping
15:24:45 <mugsie> yeah - whoever is white text on black bg, thank you :)
15:24:45 <dhellmann> pink
15:25:01 <jroll> yeah heh
15:25:05 <jroll> BRIGHT pink too
15:25:27 <fungi> you _can_ tell etherpad not to show you authorship colors, for improved readability
15:25:28 * nikhil sneaks in
15:25:47 <fungi> hit the little gear drop-down to set your preference for that
15:25:49 <amrith> jroll, is that better?
15:26:03 <mugsie> fungi: totally forgot about that - much better :)
15:26:17 <jroll> amrith: yes, thanks
15:26:32 <jroll> black on white isn't working for me today either, so I think it's mostly me
15:26:44 <amrith> so, I think we've expanded most of the "need more information" things
15:26:58 <amrith> I guess the question is how we pick a set of things we want to do in the short term.
15:27:39 <jroll> I think there's a natural order for some of this, right?
15:27:50 <jroll> to do any BLC things we need to figure out what our triple-bottom-line is
15:27:54 <mugsie> amrith: yeah, there is a lot stuff there
15:27:55 <alexismonville> jroll: can you explain the natural ?
15:28:21 <jroll> alexismonville: as in, some of these depend on others
15:28:41 <jroll> see BLC above
15:28:56 <dhellmann> I don't remember blc depending on the triple-bottom-line?
15:29:05 <mugsie> some things can happen out of band from the rest - things like Extra-ATC dates
15:29:06 <amrith> I agree with dhellmann
15:29:11 <amrith> but I think there was a meta question here
15:29:18 <amrith> how did Z's bootstrap this beast?
15:29:24 <jroll> dhellmann: mmm, maybe I'm off
15:29:26 <dhellmann> I do think it would be useful to identify which things depend on others
15:29:33 <dhellmann> jroll : you could be right, I just don't remember it
15:29:56 <amrith> dhellmann, I think you are correct. looking at the book it seems to be that BLC is the process for adopting a change
15:30:00 <amrith> it does require a vision statement
15:30:08 <amrith> but not necessarily a triple bottom line
15:30:11 <dhellmann> blc was the process for *communicating* a change
15:30:14 <jroll> yeah, I think doug may be right, I conflated the similar words
15:30:16 <amrith> I guess the tbl flows from the vision
15:30:21 <amrith> as does the blc
15:30:26 <amrith> but not necessarily in the same chain
15:30:49 <jroll> so we need a vision? :)
15:31:00 <nikhil> ++
15:31:43 <carolbarrett> ++
15:31:56 <amrith> +++++++++++++
15:31:57 <mugsie> looks like it
15:32:02 <jroll> I think it's probably important to establish who our customers are early, as well
15:32:10 <nikhil> mhh
15:32:20 <nikhil> I thought that was sup to be research?
15:32:21 <amrith> jroll, you had to go there :)
15:32:34 <nikhil> research from ops/user/dev stories?
15:32:41 <jroll> nikhil: s/establish/figure out/ ?
15:32:48 <nikhil> perfect
15:32:52 <jroll> :)
15:33:34 <dhellmann> when we say who are "our" customers, who do we mean by "our"? this working group? the tc? openstack as a community?
15:34:24 <nikhil> dhellmann: I think the objective from the training was to figure out openstack community's (ecosystems') customers
15:34:29 <dhellmann> ok
15:34:42 <jroll> I think openstack as a community - openstack is the "business" we're trying to "run". the TC is part of the leadership of that "business"
15:34:42 <dhellmann> I'm not sure it's this group's responsibility to do that
15:34:45 <amrith> I think we concluded that each of those constituencies had multiple customers
15:35:15 <jroll> dhellmann: yeah, that's fair
15:35:28 <dhellmann> our mandate is to recommend things to the tc, right? so we should start by focusing on that. If one recommendation is that the TC should identify openstack's customer, then they may ask us to do that, or create another wg, or just discuss it.
15:35:31 <nikhil> I agree, this may not be the perfect place to figure that out but I hope that some subset of individuals from here can take charge on that responsibility?
15:35:50 <jroll> dhellmann: agree
15:35:50 <fungi> it seems to me that determining the tc's "customers" is easy. we have bylaws that define who votes to elect tc members. that should be the end of the matter, yes?
15:35:55 <dhellmann> nikhil: perhaps. but we have a lot of things on this list that are more clearly within our existing charter, so let's work on those
15:36:16 <dhellmann> fungi : customers may not be equal to constituents?
15:36:20 <nikhil> dhellmann: true :)
15:36:40 <fungi> dhellmann: depends on whether you're living in a corporate-owned country i guess
15:36:56 <dhellmann> fungi : fair
15:37:33 <fungi> i will grant that politicians in my home country seem to think their customers are the people who fund their campaigns or give jobs to their friends and family rather than the people who vote for them
15:37:35 <amrith> so do we have a short list of things we want to work on right now?
15:37:39 <dhellmann> amrith : perhaps as a next step we can go through this list and identify things we think this group can/should do vs. those that need to be referred elsewhere
15:37:59 <amrith> ok, sounds like a plan to me.
15:38:12 <dhellmann> shall we take them 1 by 1?
15:38:21 <dhellmann> did we already do #1?
15:38:34 <amrith> 1 is done
15:38:46 <dhellmann> I don't remember if there was a resolution or just a discussion in a meeting
15:38:55 <amrith> resolution was adopted
15:39:01 <amrith> let me find a link and put it in etherpad
15:39:16 <dhellmann> ok,, so that brings us to #4
15:39:22 <dhellmann> there are 2 documents in process there
15:39:33 <dhellmann> are there any other items on the list related to those 2 documents?
15:40:00 <dhellmann> #33 and #34 are related to the thing I'm writing for example
15:40:03 <dhellmann> can we collapse those?
15:40:08 <amrith> the only other things that I recall in terms of writing were blog posts
15:40:13 <amrith> and 'get the word out'
15:40:50 <dhellmann> ok, I've moved 33 and 34 up under 4
15:41:00 <dhellmann> I'm not sure the blog posts are related to those existing documents?
15:41:14 <dhellmann> that was more of a general application of the BLC process?
15:41:22 <amrith> more of the communication thing
15:41:28 <dhellmann> yeah
15:41:38 <amrith> ok, sounds good, then before we go to 5
15:41:44 <dhellmann> item #4 could be retitled "specific recommendations for the TC"
15:41:46 <amrith> mordred, if you are there, pl see 4.2
15:42:33 <amrith> i guess not
15:42:42 <dhellmann> item 5 needs to wait for gothicmindfood so let's skip that for now
15:42:43 <amrith> lets move to 5
15:42:49 <amrith> one second
15:42:50 <dhellmann> item 6 looks like another specific recommendation
15:42:52 <amrith> here's update for 5
15:42:55 <dhellmann> ok
15:43:04 <amrith> Still working with the foundation to secure funding for the next round of training for the 5 TC members who didn't go to the first round (and anyone else who wants to go). Had some great suggestions from Mark and Lauren about who might benefit from attending in the user committee group.
15:43:04 <amrith> If we can secure funding, it looks like Sept 14-16 are currently the best dates, so I'd ask anyone interested to please pencil those off, in anticipation of confirmation for them by the end of the first week in August, when the Foundation has said they'll let me know.
15:43:10 <amrith> that's update from gothicmindfood
15:43:32 <dhellmann> is that for 5 or for 7?
15:43:54 <amrith> one second, that was for 7. sorry
15:44:02 <amrith> the questions for z were about bootstrapping
15:44:04 <amrith> and such
15:44:09 <dhellmann> ok
15:44:12 <amrith> so yes
15:44:17 <amrith> move on because she's not her.
15:44:35 <amrith> she's not here
15:44:39 <dhellmann> ok, so 6 can move up under 4 as another recommendation
15:44:49 <amrith> I thnk we agree to 6, and moving it to 4 seems fine
15:45:17 <dhellmann> ok, 8 looks like part of 7?
15:45:35 <amrith> yes, 8 can merge into 7
15:45:51 <amrith> summit presentation has been submitted
15:45:51 <dhellmann> and the new 8 appears to be one of the questions we wanted answered?
15:46:11 <amrith> yes
15:46:20 <amrith> 9 shoud move under 4
15:46:42 <dhellmann> well, that's a question, not a recommendation
15:46:51 <dhellmann> we could rephrase it
15:47:03 <amrith> yes, I was assuming that since 4 says tc should adopt one
15:47:14 <amrith> we should move it there and figure out who will write one.
15:47:22 <dhellmann> our current recommendation is to have the tc adopt a vision for itself
15:47:27 <amrith> similar for 10; if the recommendation is that we should adopt BLC, then there's dependencies.
15:47:41 <dhellmann> we could also recommend that the tc establish a vision for openstack as a whole, but it may not be solely the tc's responsibility to do that
15:47:43 <amrith> dhellmann, yes. for now; define who its customers are, adopt BLC for itself.
15:48:03 <dhellmann> so i think 9 is best left as an open question on its own for now
15:48:05 <amrith> that is correct; openstack vision is something we'd said the tc could talk with the board about as well.
15:48:10 <amrith> ok, #9 stays
15:48:17 <dhellmann> the blc stuff is a question for us
15:48:21 <amrith> 10 reword as shoudl we adopt blc
15:48:26 <dhellmann> we can make some recommendations about how
15:48:44 <amrith> 11 is part of the questions that gothicmindfood was going to get some answers.
15:48:49 <dhellmann> ok, so move 10 to 4
15:49:43 <dhellmann> agreed, so 11 can move up
15:49:50 <amrith> yes
15:50:13 <amrith> reword 12 as 'define the triple bottom line' but along with openstack vision that has more parties involved in it
15:50:37 <amrith> 13, tc define its customers; make recommendation that openstack customers must be defined as well.
15:50:39 <dhellmann> is that something only the tc would do, or do more parts of our governance need to get involved in that?
15:50:41 <dhellmann> (12)
15:50:58 <amrith> I assume others would be involved
15:51:07 <amrith> as with openstack vision, it is openstack triple bottom line
15:51:09 <amrith> hence others.
15:51:12 <dhellmann> ok, so 12 won't go to 4, then
15:51:31 <amrith> ok. i.e. not a recommendation for the TC. got it.
15:51:57 <amrith> 14 can go to 4, it is a TC thing (for now).
15:52:16 <dhellmann> is our recommendation that they adopt the zingerman's model? or should we have that discussion?
15:52:29 <dhellmann> it's currently phrased as a question...
15:52:33 <amrith> we should have the discussion; it was the recommendation of the people on the last day
15:52:37 <amrith> but not everyone was tehre.
15:52:38 <amrith> there.
15:52:50 <dhellmann> ok, so that's maybe a topic for our next meeting's agenda?
15:52:51 <amrith> I'd be happy saying it was the recommendation that we'd like the TC to consider.
15:53:03 <jroll> we did realize that we're pretty close to the Z consensus model already
15:53:11 <amrith> #action [amrith] add agenda item for next meeting; should we adopt the consensus model
15:53:18 <jroll> but we need a more explicit "live by"
15:53:21 <dhellmann> jroll : true, so it may be a short discussion :-)
15:53:22 <amrith> timecheck ... 7m
15:53:29 <jroll> :)
15:53:38 <dhellmann> 15 should become part of the discussion of 14
15:53:48 <jroll> +1
15:53:50 <amrith> dhellmann, we're half way through the list, want to continue this next meeting?
15:53:55 <alexismonville> I have the feeling that we could all benefit from a great "live by" explanation :)
15:53:55 <amrith> or do this offline?
15:54:03 <dhellmann> 16 is the same as 4.2
15:54:13 * jroll tries to make a tl;dr for alexismonville
15:54:17 <dhellmann> alexismonville : I tried to elaborate on that in 14.2.2
15:54:18 <amrith> yes, 16 = 4.2
15:54:35 <jroll> oh yeah, 14.2.2 is good
15:54:41 <amrith> it translates into "no abstain"
15:54:48 <amrith> among other things
15:55:32 <dhellmann> maybe this is a good place to stop, as amrith points out
15:55:57 <jroll> yeah, agree
15:55:57 <amrith> ok, I will add one more #action in that case
15:56:09 <dhellmann> we can finish reorganizing this list next time, and then pick up with the consensus discussion
15:56:10 <amrith> #action resume updaing etherpad at item #15 at next meeting
15:56:41 <amrith> so, we have a couple of minutes left
15:56:53 <amrith> and in that time, ... anyone have other thoughts
15:56:57 <amrith> #topic Open Discussion
15:57:58 <alexismonville> thank you jroll dhellmann I feel that this definition could be helpful for every contributor to OpenStack :)
15:58:09 <carolbarrett> +1
15:58:09 <jroll> alexismonville: agree :D
15:58:32 <amrith> so we have some action items for next meeting
15:58:33 <dhellmann> alexismonville : thanks :-)
15:58:40 <amrith> and I see nikhil is typing away in the etherpad
15:58:55 <dhellmann> fungi : see my comment about the extra-atc nomination in the etherpad; we should coordinate on a good time then I'll add it to the release schedule
15:58:55 <nikhil> :)
15:59:09 <fungi> dhellmann: agreed
15:59:18 <amrith> #action [dhellmann] [fungi] add extra-atc nomination to release schedule
15:59:24 <nikhil> I'd to, trying to accomplish the same on a smaller scale in glance these days
15:59:28 <amrith> dhellmann, agreed?
15:59:33 <amrith> action item ^^
15:59:38 <dhellmann> amrith : sure, we'll work that out
15:59:43 <amrith> thx
16:00:05 <amrith> ok, so I guess we'll all update the etherpad some more between now and next meeting
16:00:08 <amrith> in two weeks folks
16:00:12 <amrith> thanks for coming
16:00:24 <amrith> and please do vote for the swg related panel at Barcelona!
16:00:52 <amrith> #endmeeting