15:01:45 <gothicmindfood> #startmeeting swg
15:01:46 <openstack> Meeting started Tue Oct 11 15:01:45 2016 UTC and is due to finish in 60 minutes.  The chair is gothicmindfood. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:50 <openstack> The meeting name has been set to 'swg'
15:02:11 <gothicmindfood> #agenda https://wiki.openstack.org/wiki/Meetings/SWGMeeting
15:02:37 <gothicmindfood> we've got a pretty light agenda today
15:02:39 <gothicmindfood> pre-Barcelona
15:02:51 <gothicmindfood> there were no action items, looks like
15:02:56 <ttx> Small remark on action items
15:03:06 <ttx> The SWG dsicussion is now scheduled
15:03:14 <gothicmindfood> ttx: oh yay!
15:03:18 <gothicmindfood> yes, I believe I saw it on the ML
15:03:21 * dhellmann arrives late
15:03:28 <ttx> let me check link
15:03:32 <gothicmindfood> #link https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/16923/cross-project-workshops-re-inventing-the-tc-the-stewardship-working-group-discussion
15:03:37 <ttx> yes
15:04:03 <ttx> The others that happened before but wasn't really recorded is that version 0 of the principles was finally adopted
15:04:13 * gothicmindfood added a little bit to our Barcelona vision to include it in our vision of the day, really, Wednesday, where both the cross project session andt he panel will happen
15:04:18 <gothicmindfood> ttx: awesome!
15:04:59 <gothicmindfood> ttx: is there a final link for that?
15:05:18 <dhellmann> #link http://governance.openstack.org/reference/principles.html
15:05:28 <gothicmindfood> \o/
15:05:50 <ttx> will a pipeline of proposed changes already, which is great
15:06:06 <gothicmindfood> yes, it's awesome to see engagement on that.
15:06:19 <gothicmindfood> ttx: do we imagine we'll be discussing those changes, etc., at the cross project workshop?
15:06:24 <amrith> sorry folks, am late
15:06:56 <gothicmindfood> amrith: np. :) we're just covering what's happened in the last couple weeks
15:07:08 <amrith> thx gothicmindfood; am reading scrollback
15:07:29 <amrith> courtesy ping for dhellmann, gothicmindfood, ttx, jroll, johnthetubaguy, sdague, mordred, carolbarrett, nikhil, mugsie, thingie, alexismonville, edleafe
15:07:47 <amrith> so one thing I noticed is that the cp workshop is before the panel
15:07:59 <gothicmindfood> amrith: yeah, that's all we had, options-wise
15:08:16 <amrith> oh, it's fine; it means that the cp discussions can inform the panel
15:08:28 <gothicmindfood> but also - might not be the worst order - we will certainly understand more before the panel about what people want to talk about
15:09:02 <amrith> though I expect that we may get different audiences to the two sessions
15:09:15 <mugsie> yeah, I was going to say it might be useful to pull in some of the feedback from the workshop to the panel discussions
15:09:16 <gothicmindfood> that's also possible
15:09:59 <gothicmindfood> mugsie: ++
15:10:35 <gothicmindfood> as far as TC member attendance goes, I figured we should probably reach out to everyone just to confirm with them what times we have meetups to see who from the TC can make it
15:10:45 <alexismonville> is there's already a preparation document of the workshop?
15:11:20 * johnthetubaguy is lurking, but has another meeting running over, sorry :(
15:11:21 <gothicmindfood> alexismonville: not yet, we just have our vision for the whole of the summit here:
15:11:37 <gothicmindfood> #link https://etherpad.openstack.org/p/BarcelonaSWGMagic
15:11:39 <alexismonville> gothicmindfood: thank you
15:12:22 <gothicmindfood> to that mind, we can push through to:
15:12:30 <gothicmindfood> #topic Discuss any documents that are available for review
15:12:45 <gothicmindfood> I added a little bit to that Barcelona vision etherpad
15:13:00 <alexismonville> ok we will need to prepare a way for the workshop to deliver something that will feed the panel discussion, that could be something displayed on the wall of the room
15:13:07 <gothicmindfood> should we start a cross project etherpad now, or later?
15:13:38 <ttx> gothicmindfood: can start now
15:13:54 <gothicmindfood> alexismonville: can we make it an etherpad, or should we plan on having post-its/physical drawing-on things?
15:13:55 <amrith> since the topics are proximate, want to use the same one as the panel?
15:13:56 <ttx> and reference it in https://wiki.openstack.org/wiki/Design_Summit/Ocata/Etherpads
15:14:27 <alexismonville> gothicmindfood: I would say that physical drawing can be more effective
15:15:35 <gothicmindfood> alexismonville: the only problem with that is making folks not physically in attendance able to participate/witness what's going on
15:16:09 <alexismonville> gothicmindfood: I agree that the drawing will target only the people in the room, we could duplicate the information on a pad?
15:16:42 <mugsie_> for these discussions, is that a big deal? If it can be captured after, that should be good enough.
15:16:44 <gothicmindfood> any thoughts on whether we should rely on an etherpad only, or whether it would help to have post-its/physical drawing possibilities for attendees in the room?
15:16:56 * gothicmindfood can certainly take pictures and mail it to the -dev list
15:17:11 <dhellmann> will we have the tools to create a drawing? we don't always.
15:17:33 <dhellmann> and what is it we're going to be drawing? that part is still not clear to me.
15:17:33 <mugsie_> I am in favour of physical drawings, if we have the equipment
15:17:47 <gothicmindfood> #link https://etherpad.openstack.org/p/Barcelona-SWG-cp
15:17:55 <gothicmindfood> let's use ^^ for the CP session -
15:18:03 <jroll> I'd say we don't plan on drawing things, but if we happen to have a whiteboard or something, we can draw things if it helps
15:18:15 <gothicmindfood> #action gothicmindfood to update wiki with SWG CP etherpad link
15:18:42 <gothicmindfood> jroll: I'm not sure we'll have whiteboards - it might make sense for me to buy a large drawing pad and bring some markers
15:18:54 <gothicmindfood> or maybe a couple of those?
15:18:58 <jroll> that's fine too, if you think it'll be useful
15:19:08 * gothicmindfood also has a secret stash of post-its she can bring
15:19:26 <dhellmann> maybe we should start with a plan for what will be discussed first?
15:19:39 <gothicmindfood> dhellmann: yeah, I think that would help
15:19:55 <gothicmindfood> I think there's this uncertainty right now about what we want to talk about/cover
15:20:10 <dhellmann> right, and deciding that will help us understand what tools we may want
15:20:14 <gothicmindfood> dhellmann: and I talked a bit about it last week/week before re: what subjects to cover and how
15:20:24 <gothicmindfood> (in #openstack-swg)
15:20:55 <gothicmindfood> do we think we'll be running down basic concepts, and explaining them a lot? do we think we'll just be taking questions from people and kind of forming discussion around that?
15:21:13 <dhellmann> well, the former sounds like a presentation, and we try not to do those in design sessions
15:21:31 <jroll> right, we should go in with a thing we want to solve
15:22:08 <gothicmindfood> that sounds like a good direction
15:22:13 <gothicmindfood> what do we want to solve?
15:22:55 <jroll> and spend the time figuring out how to solve that thing
15:23:10 * dhellmann looks back at https://etherpad.openstack.org/p/swg-short-list-deliverables
15:23:42 <gothicmindfood> I think there was some sense that we were expecting feedback on what we've accomplished on that list, right?
15:23:50 <gothicmindfood> (thanks for the link dhellmann!)
15:24:02 <dhellmann> I would like to solve the problem of people not getting important information because the -dev mailing list is so busy.
15:24:27 <mugsie_> dhellmann: ++
15:24:48 <dhellmann> see line 140
15:24:50 <gothicmindfood> dhellmann: that would be an incredibly huge accomplishment
15:26:28 <dhellmann> the pitch for the cp session also asks a lot of questions that might solicit interesting answers
15:26:38 <dhellmann> https://etherpad.openstack.org/p/BarcelonaSWGMagic line 43
15:28:01 <gothicmindfood> dhellmann: yeah, and I think improving communication fits well with all of that
15:29:05 <dhellmann> as a design session, we want to either come out with a decision or some sort of next-step action we can take. how do we frame these things to support one of those two outcomes?
15:29:38 <ttx> dhellmann: maybe help establish priorities in what we'll work on ?
15:29:49 <dhellmann> ttx: ++
15:29:49 <ttx> (beyond recruitment)
15:29:54 <gothicmindfood> ttx: ++
15:30:01 <jroll> +1
15:30:09 <gothicmindfood> we can hone/create our next list of deliverables based on feedback from the community, for sure
15:30:10 <ttx> I'd like to get out of there with a sense of what matters most
15:30:20 <alexismonville> we could ask the one thing the people want
15:30:30 <ttx> rather than my own idea of what matters most :)
15:30:36 <alexismonville> :)
15:32:14 <johnthetubaguy> +1 on the establish priorities goal, thats a great way to get buy in on the process
15:32:20 <gothicmindfood> so - I like that idea. Do we have anything else we expect to get out of the CP session?
15:32:39 <johnthetubaguy> a plan for the number 1 priority, and who does what?
15:32:42 * gothicmindfood figures we'll learn about context-gaps to fill for our panel session, for sure
15:33:21 <johnthetubaguy> do we have a good crisp description of all the things we want, I guess that deliverables list is close
15:33:23 <dhellmann> yeah, I expect asking "what would you like to see done differently?" will either spur more discussion than we'll have time for or will expose a lack of interest that will itself be useful information
15:34:19 <gothicmindfood> dhellmann: right, I mean, I try to be careful with lack of context or talking around a thing to mean lack of interest, too - sometimes just not having a background or common words to use to frame a discussion can discourage it
15:34:20 <ttx> It's fine to discuss more operational stuff like "who does what" there as well
15:34:23 <gothicmindfood> not necessarily a lack of interest
15:34:28 <ttx> it's a workshop, not a panel
15:35:21 <ttx> if it's only us present in the room, we can use some of the time to get some stuff prioritized and/or started
15:35:36 <gothicmindfood> is it an interesting place to start the discussion of visioning for the TC in particular?
15:35:47 <ttx> maybe. It's only 40min
15:35:54 <johnthetubaguy> ttx: I like the idea of doing that anyways
15:36:12 <johnthetubaguy> in the presence of those that may want to help / have input
15:36:32 <ttx> we'll have different audiences at the panel and the CPW
15:37:07 <ttx> the panel, I see it as an opportunity to reach out beyond our usual constituency and give out signals that we are working on improving leadership in openstack
15:37:09 <dhellmann> right, keep in mind that it's only 40 minutes. if we expect to have to provide a lot of context about what we're even talking about, we're going to want to focus on 1 desirable outcome rather than try to pack it full of a bunch of topics
15:37:43 <ttx> the workshop, as a way to reality-check with contributors and get work prioritized/started
15:38:05 <ttx> the former is a communications exercise, the latter a work session :)
15:38:30 <ttx> if only because only the former is recorded
15:38:42 <johnthetubaguy> +1
15:38:46 <persia> So, avoid the context and focus on coordination for the workshop, and then use that to drive context explanation for the panel?
15:39:03 <gothicmindfood> persia: I was wondering the same thing.
15:39:24 <dhellmann> how many people do we expect to attend both?
15:39:31 <gothicmindfood> I think we'll have to just find a balance for providing context where we need to, but punt to the panel discussion on issues that don't drive us forward to get us an outcome in the cp session
15:40:04 <johnthetubaguy> I would consider the workshop as an in person IRC meeting, where are are likely to be some new folks that turn up, but maybe thats just me
15:40:24 <gothicmindfood> dhellmann: I would assume more people will attend the panel session than the workshop.
15:40:39 <gothicmindfood> (but that's also because the other cpw I wanted to go to is at the exact same time as ours, so maybe I'm biased)
15:41:41 <dhellmann> gothicmindfood : I will be surprised to see many contributors in the panel session. I expect mostly other types of community members there.
15:41:51 <gothicmindfood> dhellmann: ah, okay.
15:41:58 <dhellmann> maybe I'm assuming there are too many interesting design sessions at that time, though
15:42:30 <ttx> unpredictable but yes, a *lot* of upstream devs just skip conference and watch a few talks later on video
15:43:02 * edleafe falls into that group
15:43:02 <dhellmann> right
15:43:04 <gothicmindfood> well - let me flip the question
15:43:15 <gothicmindfood> does anyone want me to target folks for invites to either session?
15:43:20 <gothicmindfood> TC members? PTLs?
15:43:23 <johnthetubaguy> thats certainly my approach, as I generally have one or two design summit sessions I would like to be in, before you look at the conference stuff
15:43:30 * gothicmindfood has a reputation for pestering people to go to things anyhow
15:43:33 <gothicmindfood> :)
15:45:12 <dhellmann> gothicmindfood : I think the design summit session would be useful for tc members who can attend.
15:45:13 <ttx> +1 for considerintg the CPW session a live SWG meetign
15:46:06 <gothicmindfood> dhellmann: okay, I'll make sure to just let each TC member know what we're hoping to get done there. Obvs not everyone will be able to go, but getting a personal ask always helps raise awareness
15:46:36 * dhellmann notes that gothicmindfood is progressing in her conversion to manager by using "ask" as a noun
15:47:02 <gothicmindfood> #action gothicmindfood to give cpw session info to TC members individually
15:47:25 <gothicmindfood> dhellmann: oh no, that's the future fundraiser for training for the whole community coming out in me! :)
15:47:48 <dhellmann> heh
15:48:41 <gothicmindfood> well, we've meandered into open discussion anyhow, but
15:48:48 <gothicmindfood> #topic Open Discussion
15:49:10 <gothicmindfood> looks like we covered a lot of Barcelona already
15:49:18 <gothicmindfood> which was the only listed topic there on our agenda
15:49:23 <gothicmindfood> does anyone have anything else they'd like to cover?
15:49:35 * gothicmindfood is very psyched to see everyone who will be in Barcelona, btw
15:50:11 <ttx> nothing from me
15:50:44 <gothicmindfood> is there anyone that's *not* going to Barcelona in the group who wants us to take notes/make sure we cover anything?
15:50:52 * gothicmindfood will also ask in the swg channel
15:52:07 <gothicmindfood> ok
15:52:19 <gothicmindfood> I'm going to end the meeting a few minutes early then
15:52:23 <dhellmann> ++
15:52:26 <gothicmindfood> thanks everyone!
15:52:40 <gothicmindfood> #endmeeting