19:01:23 <notmyname> #startmeeting swift
19:01:24 <openstack> Meeting started Wed Feb 26 19:01:23 2014 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:27 <openstack> The meeting name has been set to 'swift'
19:01:55 <peluse> hello hello
19:02:10 <notmyname> hello!
19:02:12 <cschwede> hello!
19:02:29 <notmyname> I'm taking a "break" from a day-long swift workshop in new york
19:02:29 <acoles-> hi
19:02:37 <notmyname> glad to see you here :-)
19:02:50 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
19:02:54 <notmyname> agenda ^
19:03:00 <torgomatic> and you're running a meeting on it?
19:03:26 <notmyname> swift meetings on swift? :-)
19:03:44 <notmyname> I'm just sitting down to the side. rdaly is taking over in the workshop now
19:03:53 <torgomatic> I was gonna put something snarky here about the definition of "break", but I see one definition is "to crush the spirit of", so that actually seems applicable to most meetings ;)
19:03:58 <notmyname> lol
19:04:00 <torgomatic> carry on
19:04:37 <notmyname> not mush was added to the agenda, but let's see if we can spur some conversation anyway
19:04:52 <notmyname> #topic next week's meeting?
19:04:58 <notmyname> just cause this will be fast
19:05:27 <notmyname> I'll not be available for next week's meeting. would anyone else like to volunteer to lead it?
19:05:47 <notmyname> if not, we can skip the meeting
19:06:38 <notmyname> hmm...not everyone at once ;-)
19:06:50 <notmyname> ok
19:06:58 <notmyname> #vote meeting next week? yes, no
19:07:00 <luisbg> notmyname, unless there are new topics, it might be an empty meeting agenda like today
19:07:21 <peluse> #vote no
19:07:26 <notmyname> votebot fail ;-)
19:07:54 <torgomatic> if there's nothing to discuss, let's not have a meeting
19:07:55 <notmyname> ok, let's assume no meeting next week
19:08:01 <notmyname> indeed
19:08:18 <notmyname> l#agreed no meeting next week (March 5)
19:08:18 <notmyname> #agreed no meeting next week (March 5)
19:08:28 <notmyname> #info no meeting next week (March 5)
19:08:41 <notmyname> hmm
19:08:45 <notmyname> well then
19:08:55 <notmyname> ok, moving on. I think we got the point :-)
19:08:58 <portante> no bot support
19:09:02 <portante> #no bot support
19:09:03 <notmyname> I'll update the wiki
19:09:14 <notmyname> #topic storage policy status
19:09:27 <peluse> from my end:  2 medium sized in need of reivew (starting to age)
19:09:33 <peluse> 1)  policy support for ssync
19:09:41 <peluse> 2) new feature rol report per policy account usage
19:09:47 <torgomatic> clayg and I keep going back and forth on how to do the reconciler
19:09:51 <torgomatic> turns out it's tricky :)
19:10:11 <peluse> you guys need a reconciler between the two of you?
19:10:15 <notmyname> peluse: can you give links for that?
19:10:20 <peluse> yes
19:10:27 <notmyname> torgomatic: it's simple. just to it the right way
19:10:35 <peluse> https://review.openstack.org/#/c/65347/
19:10:44 <peluse> https://review.openstack.org/#/c/73747/
19:10:54 <torgomatic> notmyname: exactly. https://xkcd.com/722/
19:11:27 <cschwede> peluse: I'll review the last one tomorrow morning - if that helps...
19:11:35 <peluse> and Yuan has a few small swift client changes for policies as well https://review.openstack.org/#/c/73513/ and https://review.openstack.org/#/c/73920/
19:11:47 <notmyname> a, I want to get to the swift client in a bit
19:11:48 <peluse> cschwede:  that would be fantastic, thanks!
19:11:53 <notmyname> cschwede: yes, thanks
19:12:03 <torgomatic> peluse: the account HEAD one may need to be rebased on top of some other stuff I'm doing that omits some of what's in the patch chain... I'll update you once I have working code and not just piles of garbage
19:12:25 <peluse> torgomatic:  OK - can do.  I have your last in the series as a dependency
19:12:40 <notmyname> torgomatic: peluse: I added those patches to https://wiki.openstack.org/wiki/Swift/PriorityReviews (in case anyone looks at that ;-)
19:12:46 <torgomatic> peluse: what I'm working on now keeps 1, 2, 3, and most of 5, but not 4, so...
19:13:06 <peluse> OK, just let me know here to rebase from and I'll do it.  ETA?
19:13:47 * peluse hopes for a small number of rebase based changes
19:14:00 <torgomatic> peluse: shouldn't be too bad... I'm working on it today, so we'll see how that goes
19:14:17 <peluse> torgomatic:  thanks, will keep an eye out
19:14:28 * torgomatic keeps getting interrupted by non-Swift stuff at work
19:14:49 <torgomatic> (not including this meeting; this was *scheduled*)
19:15:10 <torgomatic> that's all I've got for status
19:15:14 <notmyname> thanks
19:15:32 <peluse> notmyname: I think those are all of the remaining policy patches (what we just discussed)
19:15:37 <notmyname> great
19:15:39 <notmyname> good to know
19:15:44 <notmyname> #topic dates
19:15:51 <peluse> also, FYI, trello is up to date
19:15:57 <notmyname> ok a few things here (and following up on storage policies)
19:16:02 <notmyname> peluse: thanks
19:16:31 <notmyname> working backwards, we'll need an RC for Icehouse by March 28
19:17:01 <notmyname> looking at the merge to master of the featre/ec branch, that gives us about 5 weeks, i think
19:17:06 <peluse> tic toc
19:17:10 <notmyname> yes
19:18:17 * torgomatic loves time-based releases
19:18:19 <notmyname> also, looking at that, I marked master as swift 1.13 earlier this week. so we've got the RC for 1.13 out now. if nothing comes up, then tomorrow or friday will mark that as 1.13
19:18:22 <torgomatic> no, wait, not love... the other one
19:18:47 <notmyname> that gives us a checkpoint of features before storage policies land
19:19:20 <peluse> notmyname:  I can come out to SanFran for a day if we want to all clear our calendars and knock out the last reviews and try to come to consensus on the reconclier if that would help
19:19:20 <notmyname> the importance of the icehouse release is the huge availability and marketing boost that the feature gets when it's included
19:19:34 <notmyname> torgomatic: thoughts on that? ^
19:20:11 <torgomatic> notmyname: the splutterings and facial expressions don't serialize well to text
19:20:16 <notmyname> :-)
19:20:36 <notmyname> torgomatic: peluse: ok, we'll discuss that later. let's say "maybe" now
19:20:47 <peluse> OK, via email - let me know
19:21:01 * portante Red Hat would like to see such an effort on review done for acc/con backend
19:21:16 <notmyname> portante: ya, good point
19:21:24 <notmyname> portante: noted
19:21:32 <peluse> portante:  FYI I reviewed it and had some questions, looks like its in need of rebase at the moment
19:21:42 <portante> peluse: great
19:21:53 <portante> hopefully zaitcev will chime in on current state
19:22:05 <portante> when we get to that part of the meeting ... ;)
19:22:13 <notmyname> heh, ok
19:22:17 <peluse> it was good learning and I plan on going over it again after zaitcev's responses
19:22:27 <notmyname> any other questions on upcoming dates?
19:22:50 <notmyname> ok
19:23:02 <notmyname> #topic open reviews
19:23:20 <notmyname> there was a bug reported about swiftclient 2.x not supporting manifests
19:23:30 <notmyname> any news on that?
19:23:44 <torgomatic> just tried it; seems to fix things
19:23:49 <notmyname> when that's fixed, I can cut a 2.0.3
19:23:59 <notmyname> torgomatic: patch in gerrit?
19:24:03 <cschwede> https://review.openstack.org/#/c/76102/
19:24:03 <torgomatic> notmyname: yes
19:24:12 <zaitcev> peluse: I'll redo it today and reply to your questions. I was sadly behind on EC as well... soo... I'll reply you on PBE first and then circle back to policies branch, see what's left.
19:24:18 <notmyname> ah, cool. thanks clayg
19:24:42 <notmyname> and zaitcev just answered my next question :-)
19:24:50 <peluse> zaitcev:  thanks!
19:26:21 * portante apologizes profusely for having to drop off of swift reviews for the last three weeks
19:26:31 <notmyname> portante: looking forward to having you back :-)
19:26:46 <notmyname> what other open reviews do we have now that need to be addressed here?
19:26:49 <portante> can't wait to run up that review queue
19:26:55 <notmyname> :-)
19:27:34 <torgomatic> straw poll on the py3-support ones in Swift: do folks like them, dislike them, or are indifferent to them?
19:27:40 * torgomatic doesn't like them at all
19:28:08 <portante> torgomatic: the ones that are outstanding for review?
19:28:21 <notmyname> I see them as code churn that doesn't do anything effective yet
19:28:22 <torgomatic> portante: yeah, the pile of those that has shown up in the last few days
19:28:30 <torgomatic> notmyname: completely agreed
19:29:08 <zaitcev> I don't mind py3, but they seem like avoiding the really tough problems of unicode, so they do nothing to help us move over to py3 if we ever decide on it.
19:29:17 <notmyname> if we know we can't support py3 because of dependencies, then it's hard to justify code churn of that magnified
19:29:22 <torgomatic> so if nobody really loves them, I'll keep on rejecting them; I just want to make sure there's not strong positive feelings about py3 stuff RIGHT NOW
19:29:29 <portante> I don't mind them, if they ensure changes are 100% covered, and every module touched is brought up to 100% coverage, and functional tests are written to exercise the code changed
19:29:43 <zaitcev> We can convert all the print statements and then fail in the end due to utf-8
19:29:47 <notmyname> I'm scared of similar things that we had with the hacking changes that removed bare excepts
19:29:52 <cschwede> portante: that's a  very long wish list ;-)
19:30:03 <notmyname> cschwede: thanks ok :-)
19:30:08 <notmyname> cschwede: *that's
19:30:13 <portante> I think of it as cost of entry for changes like that
19:30:38 <cschwede> portante: well, i strongly agree on that, more tests first!
19:30:42 <portante> if somebody just wants to refactor code and does not offer real test improvement to offset possible issues introduced with changes, then ...
19:30:54 <zaitcev> Alex brought up the last py3 thing, so I take it his actual position of py3 is that of acceptance despite his blog posturing.
19:31:16 <notmyname> eh
19:31:18 <notmyname> heh
19:31:54 <notmyname> portante: zaitcev: did you want to spend explicit time on the storage backends stuff?
19:32:08 <portante> yes
19:32:12 <zaitcev> notmyname: absolutely, anything that helps
19:32:18 <notmyname> #topic stoage backends
19:32:22 <notmyname> #topic storage backends
19:32:24 <zaitcev> oh
19:32:29 <notmyname> :-)
19:33:04 <notmyname> historically, changes like this have benefited from in-person meetings
19:33:05 <portante> so Red Hat really wants to see this acc/con backends land
19:33:10 <portante> agreed
19:33:25 <portante> this particular patch set has been out for a long time
19:33:34 <portante> we'd like to work how to get it landed
19:33:40 <zaitcev> The status is that we had the patch outstanding for a while and I poked and prodded Luis, the actual consumer of it on Gluster side, to agree to it despite some reservations.
19:33:52 <portante> my management has asked us to convey that priority clearly
19:34:28 <notmyname> portante: thanks
19:34:32 <portante> we can do more work on our end to demonstrate the patch readiness and consumability, too
19:34:41 <notmyname> ok
19:34:51 <portante> but, notmyname, I think you are right, f-2-f really helps with this kind of thing
19:34:53 <zaitcev> I think the patch will serve Gluster's needs, e.g. it's complete as far as APIs go, and thus it should be a good basis for other possible users. Of course I did my best to keep it being generic in mind.
19:35:28 <zaitcev> Luis' desire was for better documentation in that he wanted an abstract class with docstrings.
19:35:59 <zaitcev> Instead, we compromised on mem_backend.py, from which new backends can copy-paste big chunks if they want.
19:36:05 <zaitcev> Even got tests :-)
19:36:08 <notmyname> zaitcev: can you get it rebased against master soon?
19:36:19 <zaitcev> notmyname: I'll get right on it
19:36:32 <notmyname> thanks
19:36:34 <peluse> sorry - who is Luis?
19:36:41 <notmyname> peluse: gluster-swift person
19:36:48 <zaitcev> (althogh my wife is hovering around and prods me to go eat after this meeting)
19:36:57 <peluse> thanks
19:37:09 <notmyname> zaitcev: that's ok, I'm just going to go back to workshop and meetup after this ;-)
19:37:35 <notmyname> ok, anything else on this topic?
19:37:51 <notmyname> portante: zaitcev: ?
19:38:07 <portante> notmyname: not from me
19:38:10 <acoles-> out of curiosity is there any precedence for face to face between summits?
19:38:12 <portante> let's start there
19:38:18 <notmyname> ok
19:38:27 <notmyname> acoles-: yes, we had one last fall in auston
19:38:48 <notmyname> and we'll have another after atlanta (I'm working with peluse on logistics now)
19:39:06 <notmyname> acoles-: and there have been some one-off things
19:39:17 <notmyname> some of which I've been a part of and some I haven't
19:39:25 <acoles-> notmyname: yeah , i wondered if the hackathon thing might repeat
19:39:40 <notmyname> acoles-: ya, I think we all want it to
19:39:56 <notmyname> #topic open discussion
19:40:05 <notmyname> better topic for it, or anything else
19:40:26 <acoles-> another quick question from me...
19:40:47 <acoles-> anyone aware of activity on keystone v3 support in swift
19:40:56 <acoles-> swiftclient?
19:41:06 <notmyname> acoles-: I don't know of any. cschwede?
19:41:20 <zaitcev> Not me. But if anyone brings up a patch, I'll be happy to look.
19:41:22 <notmyname> in swiftclient (there shouldn't be anything in swift itself AFAIK)
19:41:34 <acoles-> yep that was a typo :)
19:41:44 <cschwede> acoles-: notmyname will have a look
19:41:44 <torgomatic> if any of that stuff leaks into swift, we've done something wrong :)
19:42:05 <zaitcev> Well, about that, guys.
19:42:06 <acoles-> cshwede: thanks
19:42:42 <zaitcev> I am not sure that keeping authtoken in Keystone is so great, in view what I had to do to make it webob-free.
19:43:09 <notmyname> zaitcev: isnt' that used by every project?
19:43:39 <cschwede> notmyname: no, afaik only swift?
19:43:51 <zaitcev> well that was the theory
19:43:57 <notmyname> cschwede: that's news to me, then.
19:44:07 <morganfainberg> cschwede, notmyname auth_token only used by swift?
19:44:17 <morganfainberg> auth_token is used by all projects afaik
19:44:29 <notmyname> morganfainberg: that was my assumption
19:44:43 <morganfainberg> it does the decode of tokens/talks to keystone (uuid tokens) to get info for context
19:45:12 <morganfainberg> it is absolutely used by all the integrated projects and many of the others
19:45:16 <notmyname> but there is a 2nd piece that is in swift to map the keystone identity info to swift things (which is right)
19:45:19 <cschwede> keystoneclient / middleware / auth_token.py ?
19:45:30 <zaitcev> well, but there must be something that sets req.environ['swift.authorize'], right? Maybe not the auth_token obviously, but something.
19:45:31 <morganfainberg> cschwede. ye
19:45:42 <morganfainberg> zaitcev, that is likely swift only
19:45:50 <notmyname> zaitcev: that's the keystoneauth middleware inside of swift's codebase
19:45:50 <morganfainberg> sorry was just jumping in :)
19:46:22 <cschwede> hmm, sorry, maybe i'm remembering something wrong.
19:46:23 <zaitcev> In that case, never mind. I realized I'm wasting our time.
19:46:38 <notmyname> zaitcev: don't feel bad. good questions
19:46:46 <notmyname> ok, anything else to discuss here this week?
19:47:06 <luisbg> any low hanging fruit new contributors could help with?
19:47:13 <zaitcev> wait, I realized what I meant to ask
19:47:21 <zaitcev> Does v3 affect keystoneauth?
19:47:30 <notmyname> zaitcev: that I do not know
19:47:43 <notmyname> I would assume no. ie it shouldn't
19:47:48 <notmyname> anyone still here?
19:47:52 <torgomatic> kind of
19:47:53 <luisbg> o/
19:47:53 <peluse> yeah
19:47:57 <acoles-> here
19:47:58 <thurloat> \o
19:48:03 <notmyname> ok
19:48:41 <portante> o/
19:48:47 <cschwede> here
19:48:53 <notmyname> zaitcev: I don't think it should affect keystoneauth
19:49:14 <zaitcev> I'm looking at the code, sorry. Trying to figure out quickly. If it does NOT talk to Keystone, then it does not care, as long as authtoken sets the token for v3 that's like the one before, only maybe longer.
19:49:28 <notmyname> zaitcev: ok. thanks for looking
19:49:34 <notmyname> zaitcev: do you need some help looking there?
19:50:02 <morganfainberg> zaitcev, if keystoneauth middleware also talks to keystone let me know if you guys need help unwinding it - you shouldn't need to talk to keystone two ways (auth_token should provide what oyu need)
19:50:08 <zaitcev> no, I think we need someone try and run with v3 (by modding swiftclient) and see what happens
19:50:13 <notmyname> morganfainberg: thanks
19:50:18 <notmyname> zaitcev: ah, ok
19:50:29 <zaitcev> right, what morganfainberg said.
19:50:55 <zaitcev> I just don't want to be responsible for action item "implement and test v3 in Swift"
19:51:07 <zaitcev> well maybe after PBE lands :-)
19:51:09 <notmyname> heh
19:51:56 <notmyname> so Real Soon Now (tm)
19:51:56 <acoles-> zaitcev: i'll try to dig into it a bit more
19:52:00 <acoles-> but concur that v3 shouldn't have impact on keystoneauth
19:52:00 <notmyname> acoles-: thanks
19:52:04 <notmyname> ok, anything else on this topic or others?
19:52:59 <portante> nothing here
19:53:03 <torgomatic> nope
19:53:05 <peluse> nope
19:53:14 <luisbg> I have a question
19:53:22 <notmyname> luisbg: what's up
19:53:29 <luisbg> what is the policy for people stepping into already assigned bugs?
19:54:15 <notmyname> luisbg: many times the assignee has vanished
19:54:15 <notmyname> luisbg: if you have a fix, don't let lauchpad prevent you from a patch :-)
19:54:16 <luisbg> notmyname, the contrary happened to me
19:54:16 <notmyname> luisbg: and competing code is good
19:54:44 <luisbg> competing code is good when you have work force to spare
19:55:05 <torgomatic> for me, if I'm just looking to fix things, I'll skip over bugs with owners, but if a customer of mine is impacted by something, I'm fixing it regardless of who else is looking at it
19:55:17 <luisbg> nothing big happened, I had only spent 30 minutes on something before somebody else sent a patch to a bug assigned to me
19:55:19 <luisbg> so not complaining, I understand
19:55:41 <luisbg> just realized the policy isn't clearly stated, and new contributors might be pushed away by this
19:55:51 <torgomatic> and if someone submits a patch for something I'm working on, well, between the two of us I hope we have fewer bugs :)
19:55:54 <notmyname> luisbg: good observation
19:56:30 <luisbg> notmyname, stating this since it is more prone to happen with low hanging fruit
19:56:31 <notmyname> right
19:56:32 <luisbg> which is usually the learning ropes of new people
19:56:33 * peluse wishes someone would jump in and do some of my work :)
19:56:33 <notmyname> luisbg: thanks for jumping in as a new contributor :-)
19:56:33 <luisbg> peluse, hahaa
19:56:38 <notmyname> peluse: so I was designing a new CPU....
19:56:52 <peluse> excellent!
19:56:52 <luisbg> notmyname, I am new to Swift but not new to Open Source, which is why it didn't push me away :P
19:57:12 <acoles-> luisbg: well said
19:57:32 <luisbg> but still think some of my experiences could help future new contributors, and making their road easier, which eventually means more contributors
19:57:40 <luisbg> higher keep rate
19:58:08 <notmyname> luisbg: if you want to add something to the swift wiki, that's ok
19:58:17 <notmyname> ok, I gotta run. thanks everyone for attending. see you day-to-day in IRC. reminder that we'll skip next week
19:58:27 <notmyname> #endmeeting