19:03:58 <notmyname> #startmeeting swift
19:03:59 <openstack> Meeting started Wed May 28 19:03:58 2014 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:04:03 <openstack> The meeting name has been set to 'swift'
19:04:20 <notmyname> should be a very short meeting I think
19:04:27 <portante_> K
19:04:40 <notmyname> #info storage policies patches have been proposed to master. swift is in a soft freeze
19:04:55 <notmyname> first patch is https://review.openstack.org/#/c/96026/
19:05:05 <notmyname> last patch (if you want to see the whole thing) is https://review.openstack.org/#/c/96049/
19:05:23 <notmyname> #action everyone review these patches
19:05:45 <notmyname> any questions on how this is working, what to do, or anything else related to storage policies?
19:06:31 <briancline> is the soft freeze to avoid overlapping rebase issues, or to freeze for a release?
19:06:46 <notmyname> two reasons
19:06:54 <notmyname> first, to avoid as much rebasing as possible
19:07:21 <notmyname> second, to prioritize the review of storage policies since it is so big. faster reviews == sooner integration
19:07:50 <notmyname> and there will certainly be a swift release once storage policies have landed on master
19:08:17 <notmyname> raise your hand (o/) if there are other questions
19:09:18 <notmyname> ok, moving on
19:09:26 <notmyname> #topic other post-summit progress
19:09:42 <notmyname> just a brief update on a couple of things
19:09:55 <notmyname> well mostly just the idea of core sponsors
19:10:20 <notmyname> I started building a wiki page for it, and I've worked with -infra some on getting some tools that may be helpful
19:10:42 <notmyname> just to say "nothing to report yet, but it's not forgotten"
19:10:59 <notmyname> swift-specs is also working its way through -infra
19:11:14 <notmyname> both of those are secondary to the storage policy reviews
19:11:36 <notmyname> gvernik: you added to the meeting wiki page concern about triaging bugs
19:12:22 <notmyname> gvernik: aside from "we should be better", did you have anything you wanted to specifically address there?
19:12:36 <gvernik> yeah, well.. I just wanted to raise this issue
19:12:43 <notmyname> and to be clear, I'm not trivializing your concern. I share it
19:13:09 <gvernik> nothing else to add, i think it's big mess with bugs, not clear what is in progress what patches committed
19:13:13 <notmyname> gvernik: my hope is that the core sponsors idea we discussed at the summit will help with some of the logistics like that
19:13:48 <cschwede_> gvernik: sometimes it even happens that the bug is not automatically assigned, even if there is a „closes-bug“ in the commit message for a patch
19:14:20 <cschwede_> that’s no excuse, but happens - unfortunately; don’t know why
19:14:33 <gvernik> the current situation, you see open bug that nobody works on it, but the git already contains patch
19:15:01 <notmyname> gvernik: ya, keeping that in sync is a very manual process. therefore easy to get off track
19:15:33 <notmyname> #topic open discussion
19:15:46 <notmyname> anything else to cover? (go do storage policy reviews)
19:17:18 <notmyname> ok. thanks for coming and for your work on swift :-)
19:17:21 <notmyname> #endmeeting