19:00:48 <notmyname> #startmeeting swift
19:00:49 <openstack> Meeting started Wed Jul 9 19:00:48 2014 UTC and is due to finish in 60 minutes. The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:52 <openstack> The meeting name has been set to 'swift'
19:00:59 <notmyname> welcome everyone. who's here?
19:01:02 <elambert> o/
19:01:02 <mattoliverau> o/
19:01:05 <cschwede> o/
19:01:07 <torgomatic> no, Who's on first
19:01:17 <notmyname> torgomatic: indeed he is
19:01:28 <acoles> here
19:01:46 <dfg> hey
19:01:46 <notmyname> mattoliverau: I'm impressed you've started getting up early for us :-)
19:02:08 <notmyname> ok, let's get started
19:02:09 <mattoliverau> yeah, and am mostly awake :P
19:02:12 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
19:02:25 <notmyname> a few things to go over this week
19:02:38 <notmyname> portante is alive! ;-)
19:02:43 <portante> :)
19:02:53 <portante> poison ivy hasn't killed me yet
19:02:59 <peluse_> howdy
19:03:05 <notmyname> #topic old reviews and auto-abandons [torgomatic]
19:03:16 <notmyname> torgomatic: you were looking in to this. can you give a summary and update?
19:03:22 <torgomatic> so we used to have a bot that would kill these things off for us
19:03:43 <portante> do we know what happened to that bot?
19:03:46 <torgomatic> after N weeks with a negative score (either Jenkins or people), it'd get abandoned... N was either 1 or 2, I don't recall
19:03:58 <torgomatic> after the Gerrit upgrade, that bot was deliberately killed by the infra folks
19:04:00 * portante remembers 2
19:04:13 <notmyname> torgomatic: ah, interesting. did they say why?
19:04:19 <torgomatic> now, core team members can abandon/WIP any patch... before, it was only the patch author
19:04:25 <notmyname> oh
19:04:26 <mattoliverau> Cores have more powers now and can abandon things
19:04:27 <torgomatic> so now that humans can do it, the bot is gone
19:04:38 <portante> oh
19:04:43 <notmyname> so humans are replacing robots in this brave new future?
19:04:49 <peluse_> that seems like technology going the wrong way :)
19:04:54 <torgomatic> :)
19:04:58 * torgomatic liked the bot
19:04:58 * portante is now a bot
19:05:05 <mattoliverau> lol
19:05:07 * peluse_ would like to be abandoned
19:05:11 * portante or a cylon
19:05:47 <clayg> dfg!
19:05:57 <portante> torgomatic: do you want to reinstate a bot for swift reviews?
19:05:58 <notmyname> ok, so what do we do then? add filters to our view of gerrit (I know how to do that)?
19:06:33 <torgomatic> I think we should go back to automatic abandons of old things, whether that's done by a bot or by a person armed with copy+paste
19:06:36 <notmyname> accept that cores need to click more buttons to keep the gerrit views cleaner?
19:06:52 <torgomatic> but it should be a simple, time-based rule that's applied fairly, like the bot used to
19:07:33 <mattoliverau> I'm actually heading over to Germany this weekend to goto the infra mid-cycle, did you want me to bring this up and complain? I can be pretty whiny when need to be :)
19:07:34 <notmyname> torgomatic: ie "I'm abandoning this patch because it hasn't had any activity in the two weeks since the last negative review"?
19:08:07 <torgomatic> mattoliverau: sure
19:08:11 <torgomatic> notmyname: exactly that sort of thing
19:08:30 <notmyname> mattoliverau: the concern is keeping more patches around that have been essentially abandoned by their owners
19:08:48 <mattoliverau> it does sond stupid! it would be better if projects could opt out of the bit
19:08:54 <mattoliverau> sound even
19:09:17 <mattoliverau> bot as well.. did I mention I'm 1/2 alseep :P
19:09:33 <notmyname> are there any concerns with, until mattoliverau get's to GER, letting cores abandon stuff?
19:09:45 <peluse_> none here
19:09:48 <notmyname> portante: dfg: clayg: peluse_: torgomatic: acoles?
19:09:48 <torgomatic> nope... how about a 2-week (14-day) threshold?
19:09:56 <notmyname> I think 2 weeks is good
19:10:01 <portante> not problem by me, a 2 week would be good
19:10:07 <acoles> sounds reasonable
19:10:07 <torgomatic> great
19:10:22 <mattoliverau> Let me know if there is anything else I can fight for for swift while I'm there :)
19:10:23 * portante thinks it was 1 originally, now that he thought about it, but would rather 2
19:11:16 <notmyname> #agreed mattoliverau will ask at the -infra meetup about getting the bot again, and in the meantime cores will manually abandon patches 2 weeks after a negative review
19:11:30 <notmyname> ok, moving on
19:11:36 <acoles> it used to be that WIP would not be abandoned, I think, even if Jenkins had -1
19:11:36 <notmyname> #topic python-swiftclient release
19:11:55 <notmyname> acoles: ya, IMO WIP is just "there"
19:12:09 <acoles> yeah. move on :)
19:12:18 <notmyname> I'd like to make another release of python-swiftclient after we get the storage policies support added
19:12:29 <notmyname> open patches are https://review.openstack.org/#/q/status:open+project:openstack/python-swiftclient,n,z
19:12:48 <notmyname> I think https://review.openstack.org/#/c/73920/ is the only patch that needs to land
19:13:00 <notmyname> are there others that should land before a swiftclient release?
19:13:34 <notmyname> acoles: I really want the keystone v3 support before the juno release, but that can come after a release supporting SP (IMO)
19:13:58 <notmyname> wait, why hasn't https://review.openstack.org/#/c/102510/ landed?
19:14:02 <acoles> notmyname: was about to say...would make me hapy to see that land soon
19:14:19 <notmyname> acoles: ya, me too
19:14:23 <torgomatic> dunno... it seems to have the requisite number of checkmarks
19:14:32 <torgomatic> there
19:14:52 <notmyname> thanks
19:14:53 <cschwede> notmyname: acoles: +1 for the keystone v3 patch
19:15:05 <notmyname> just checking if there were other concerns on it. I didn't see anything
19:15:25 <notmyname> ok, anything else needed for swiftclient before a release?
19:15:32 <notmyname> beyond being able to set storage policies?
19:15:50 <acoles> cschwede: thanks for the review btw, if you get chance could you look at the latest version (small changes)
19:16:44 <notmyname> FWIW, I like the tempurl support one (the concept) and torgomatic sold me on the concept of the SwiftService one (but that one is _huge_)
19:17:04 <cschwede> acoles: np, you’re welcome - just noticed the small changes, was wondering where my +2 has gone :)
19:17:20 <torgomatic> yeah, the SwiftService one is nice, but the API is still a little under discussion... I'd like that one to land, but not for the next release
19:17:29 <torgomatic> that way there'll be a little time to tweak the API before it goes out to the world
19:17:30 <notmyname> but I'll take silence for other patches before a release to mean that jsut getting the one to set a storage policy is all that's needed ;-)
19:17:36 <clayg> torgomatic: that swiftclient help chagne did add a weird regression with 'swift info --help' vs. 'swift capabilities --help'
19:17:37 <notmyname> torgomatic: ack
19:18:21 <acoles> clayg: yeah, i wasn't sure about that
19:18:23 <notmyname> hmm mark isn't here. maybe we can bug him to fix that, clayg
19:18:39 <torgomatic> clayg: you want me to not approve that one, then?
19:18:58 <notmyname> torgomatic: well, clayg did give a +2 with that comment ;-)
19:19:16 <notmyname> acoles: can you ask mark to submit another patch to fix it?
19:19:29 <notmyname> (unless clayg wants to stop the merge train right now)
19:19:30 <acoles> notmyname: yeah, or i will push over
19:19:34 <notmyname> acoles: thansk
19:19:35 <clayg> no no no, it's fine
19:19:37 <notmyname> :-)
19:19:44 <clayg> but that's one more patch that should go in before the release or whatever
19:19:44 <torgomatic> ok, I'll do nothing. easier done than said!
19:20:12 <acoles> actually what would folks think of swift help <command> rather than swift <command> --help to avoid regression
19:20:16 <clayg> acctually I did want to ask why we can't use argparse - either as py27 or a depends if we still care about py26 on that repo (i'm guessing yes?)
19:20:22 <acoles> (Small regresssion mind you)
19:20:30 <clayg> acoles: very small
19:20:31 <notmyname> ok, I think that wraps it up for swiftclient patches for the next release. everyone go review https://review.openstack.org/#/c/73920/
19:20:49 <torgomatic> clayg: yep, we still care about py26
19:20:49 <clayg> notmyname: well and the other patch we're discussing to fix the bug torgomatic just merged :P
19:21:06 <torgomatic> clayg: "the" bug? that seems overly optimistic! ;)
19:21:07 <notmyname> right :-)
19:21:07 <clayg> torgomatic: so do we care about an argparse depends for py26?
19:21:13 <torgomatic> clayg: I don't
19:22:34 <notmyname> I'm ok with moving to using argparse
19:22:43 <clayg> ok, well that would be betterish
19:22:54 <notmyname> thus adding the dependency to py26
19:23:24 <notmyname> #topic priority reviews
19:23:33 <notmyname> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
19:23:34 <clayg> i think it would just be a dependency, like even if your're running py27 you still install it or something... idk
19:23:48 <clayg> anyway, that thing would be better with argparse - so maybe we do that at somepoint
19:24:01 <notmyname> I wanted to go over the sections of the priority review page
19:24:05 <clayg> acoles: if you have an idea for the help fix please catch me offline or w/e
19:24:09 <notmyname> so from the top....
19:24:20 <notmyname> how's the review dashboard working for you?
19:24:35 <notmyname> torgomatic: I think you had some concern that "not everything" is shown?
19:24:45 <acoles> clayg: ack
19:24:58 <notmyname> torgomatic: have you looked in to what's not shown and why it's not?
19:25:22 <torgomatic> notmyname: nope, haven't figured out why... I just star things that I care about and find them that way
19:25:28 <notmyname> ok
19:25:50 <notmyname> should we add a starred section?
19:26:31 <notmyname> (either you're perfectly happy or left speechless at the horribleness of it)
19:26:32 * torgomatic is indifferent
19:27:31 <mattoliverau> I like it, but it would be nice if it showed changes you haven't reviewed yet and changes what have new patchsets (so again haven't reviewed)
19:27:54 <notmyname> mattoliverau: I think I saw some filters for that somewhere...
19:28:10 <notmyname> looking at what's open, I'd like to see some feedback on the specs. we've got 2 submitted, but no comments. and peluse_ will be submitting one soon for the EC work
19:28:31 <mattoliverau> I've have some filters that kind of do it.. I should just polish em up a bit... hopefully
19:28:43 <notmyname> ie it's good to give feedback to people planning some bigger stuff, and if we can't do it for active devs, we wont' do it well for new contributors
19:30:13 <notmyname> ok, looking at the other stuff on the priority review page...
19:30:55 <notmyname> the case changing behavior in eventlet. important for the swift3 middleware and makes use of a feature added to a new version of eventlet https://review.openstack.org/#/c/93780/
19:31:27 <notmyname> needs another +2 to land, but are there any major concerns about this patch?
19:31:43 <notmyname> please say yes, no, or don't know
19:31:48 <torgomatic> no
19:32:06 <mattoliverau> no
19:32:08 <notmyname> I just want to quickly go throught the patches listed to see if there is anything major outstanding on them
19:32:23 <notmyname> torgomatic: mattoliverau: well you two have actually reviewed it and said lgtm ;-)
19:33:43 <notmyname> ...
19:34:09 <mattoliverau> I assume others are in the process of reviewing :)
19:34:42 <notmyname> perhaps. I'm really just curious what people think about it high level now. saying "I don't know" is ok
19:35:46 <elambert> dont know :-)
19:35:57 <notmyname> elambert: :-) thanks
19:36:08 <cschwede> notmyname: no major concern from my side, lgtm
19:36:26 <acoles> just ttok a quick look and seems reasonable
19:36:30 <acoles> took
19:36:38 <notmyname> ok, thanks
19:37:06 <notmyname> we've already looked at the next 2 sections. now for the performance section of the priority reviews page
19:37:28 <notmyname> https://review.openstack.org/#/c/75941/ needs to be rebased (adds mutlithreds to object updater)
19:37:50 <notmyname> anyone know Alex's IRC nick?
19:37:59 <portante> Alex_Gaynor?
19:38:04 <torgomatic> that's the one
19:38:09 <notmyname> not Alex Pecoraro
19:38:17 <notmyname> s/not/no/
19:38:28 <notmyname> author of that patch
19:38:38 <cschwede> apecdown?
19:38:56 <zaitcev> Not sure what exactly the test tests in 93780
19:39:08 <zaitcev> Huh I'm late to the party as usual.
19:39:31 <notmyname> zaitcev: thanks for looking :-)
19:39:50 <notmyname> I'l try to get in touch with Alex to rebase. or I'll rebase it and push it up
19:40:04 <notmyname> torgomatic: anything on the zero copy patch?
19:40:11 <notmyname> or any questions on the zero copy patch?
19:40:51 <torgomatic> the GET patch is ready; the PUT patch still needs some benchmarks, though now that I've beaten $internal_cluster into submission I can see about getting those
19:41:00 <notmyname> cool
19:41:11 <torgomatic> or if anyone else wants to try it out on their hardware, that would be great :)
19:41:42 <portante> torgomatic: both are in my best laid plans ... :(
19:41:53 <notmyname> ok
19:42:07 <notmyname> clayg: anything needed to be brought up about the reconciler patches? https://review.openstack.org/#/q/status:open+project:openstack/swift+branch:master+topic:multi-reconciler,n,z
19:43:22 <notmyname> clayg: other than "go review them" ?
19:44:20 <clayg> no it's fine
19:44:25 <notmyname> ok
19:44:36 <clayg> mattoliverau: had a couple of comments on one of the patches that i'm still milling over
19:44:41 <notmyname> ok
19:44:46 <notmyname> that's all I wanted to cover about what's on the priority reviews page
19:45:07 <notmyname> also, just to experiment with this meeting to see if a walkthrough of patches would be usefule
19:45:20 <clayg> might be nice to have a quick glance at them on 103779
19:45:21 <mattoliverau> clayg I just noticed you had responded to some of my questions (this morning), thanks.. will read them when my brain it a little more awake :)
19:45:35 <clayg> mattoliverau: no worries, thatnks for looking at it
19:45:49 <clayg> notmyname: seemd ok to me!
19:46:00 <notmyname> #topic open discussion
19:46:11 <notmyname> anything else to bring up in the meeting
19:46:17 <gvernik> I would like to ask cores to review those: https://review.openstack.org/#/c/90016/, https://review.openstack.org/#/c/90066/. It resolves two bugs and stuck with reviews for a long long time.
19:46:50 <notmyname> gvernik: looking
19:47:17 <gvernik> thanks
19:47:20 <clayg> gvernik: both of those titles sound reasonable
19:47:30 <notmyname> gvernik: can you check that they still rebase properly?
19:47:35 <clayg> gvernik: but they both have -1's on them currently?
19:48:17 <gvernik> yes, i got some remarks, responded to them immedeately and it's not reviewed anymore. I can rebase them again
19:48:35 <notmyname> gvernik: on the first one, you've got a -1 from cschwede. cschwede can you respond by either removing the -1 or stating that you still have a -1 there?
19:48:36 <cschwede> clayg: gvernik: i think these -1 need some discussions, would be good to have some more eyes on them
19:48:47 <notmyname> mattoliverau: same with you for the second
19:49:14 <mattoliverau> Sure I'll make sure I revisit it today :)
19:49:14 <clayg> cschwede: werd, i'm looking through the comments now
19:49:23 <notmyname> mattoliverau: thanks
19:49:23 <cschwede> notmyname: yep, will review both of them tomorrow morning
19:49:27 <notmyname> cschwede: thanks
19:49:53 <notmyname> that way it's clear (to the author and others) that it's still an issue and not just a "reviewer abandonded" thing
19:49:54 <acoles> i'll try to take alook tomorrow
19:50:00 <notmyname> thanks acoles
19:50:45 <notmyname> gvernik: as you've experienced (unfortunately), we struggle with giving timely feedback. I hope we're getting better, but thanks for bringing those up
19:50:51 <mattoliverau> maybe a starred section of the dash board is a good idea :)
19:50:58 <notmyname> I'm hoping that the dashboard capability can help
19:51:27 <clayg> gvernik: also 90066 doesn't have any tests
19:51:34 <notmyname> and I've still got the "core sponsors" concept on my todo list that we talked about in atlanta
19:52:16 <peluse_> cool
19:52:32 <clayg> wait, max_container_per_account is a config option?
19:52:32 <gvernik> clayg: i will rebase it and add tests. no problem, thought it doesn't need tests
19:52:33 <notmyname> anything else to bring up?
19:52:37 <acoles> notmyname: cool if you can get like mercedes to sponsor us all :)
19:52:48 <clayg> portante: is there such a thing as a change that doesn't need tests?
19:52:51 <notmyname> acoles: wait what?
19:53:00 <portante> no
19:53:03 <portante> :)
19:53:17 <mattoliverau> I wanted to say, If anyone thinks of anything they want me to bring up / fight for at the infra midcycle, let me know :)
19:53:30 <notmyname> mattoliverau: thanks. that's next week?
19:53:34 <acoles> notmyname: 'core sponsors' - sorry, clearly lame joke on my part
19:53:46 <notmyname> acoles: ah. I like that a _lot_ better!
19:53:51 <clayg> and.... we digress
19:53:52 <cschwede> acoles: i like the idea ;)
19:53:53 <mattoliverau> yup, so have a long flight ahead of me, and more jetlag!!
19:54:15 <notmyname> mattoliverau: in january there was talk about limiting the duplicate test runs in jenkins. it would be nice to ask about that
19:54:46 <mattoliverau> notmyname: ok noted :)
19:54:49 <notmyname> thanks
19:54:55 <notmyname> I think we're good then
19:55:02 <notmyname> thanks everyone for attending
19:55:06 <notmyname> #endmeeting