19:01:05 <notmyname> #startmeeting swift
19:01:05 <openstack> Meeting started Wed Sep 17 19:01:05 2014 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:09 <openstack> The meeting name has been set to 'swift'
19:01:25 <notmyname> hello everyone
19:01:30 <notmyname> who's here for the swift meeting?
19:01:32 <elambert> o/
19:01:32 <goodes_> hi
19:01:33 <mattoliverau> o/
19:01:34 <tdasilva> hello
19:01:36 <cutforth> hello
19:01:37 <tsg> hello
19:01:38 <kota_> o/
19:01:38 <torgomatic> hi
19:01:39 <cschwede> hello!
19:01:43 <Tyger> hello
19:02:03 <acoles> hi
19:02:11 <notmyname> I was out yesterday at the openstack SV thingy, so I've been catching up today
19:02:17 <notmyname> agenda for today's meeting
19:02:23 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
19:02:41 <notmyname> #topic general stuff
19:02:50 <notmyname> nothing new here that I know...
19:02:50 <peluse_> yo
19:03:07 <notmyname> any questions about the hackathon, paris summit, or the user survey?
19:03:28 <mattoliverau> nope
19:03:40 <notmyname> hmm..that reminds me that there are some things we need to talk about with paris
19:03:44 <notmyname> the design summit stuff
19:03:49 * notmyname looks for the email
19:03:54 <peluse_> nope, on the subject of Paris though, keving g and I gave our paris talk at SNIA SDC this week as a dry run sorta and it went really well
19:04:36 <notmyname> cool
19:04:40 <notmyname> great to hear
19:04:51 <notmyname> #link https://wiki.openstack.org/wiki/Summit/Planning
19:05:14 <notmyname> ok, so they aren't using the formal CFP site to do summit suggestings this time
19:05:50 <notmyname> there's going to be more focus on cross-project discussions, but there will be time for swift-specific things
19:06:01 <peluse_> hmmm, so all ad-hoc or what?
19:06:07 <notmyname> there's the link
19:06:09 <notmyname> #link http://ttx.re/kilo-design-summit.html
19:06:15 <notmyname> that gives a good overview
19:06:52 <notmyname> so we'll be putting together what we want to talk about in an etherpad. I think that will start coming together this week
19:07:12 <notmyname> but like you, I'm waiting for the mailing list post from ttx for it
19:07:30 <notmyname> but definitely good to read that blog post by ttx to know what's going on
19:07:55 <cschwede> is there a deadline to collect the ideas in the etherpad? ie maybe during/after the hackathon ?
19:08:32 <notmyname> I think we need to start collecting ideas before then, but I'm guessing there won't be a deadline that early
19:09:26 <notmyname> that's pretty much all I know on the paris summit so far
19:09:54 <notmyname> I'll do what I can to keep you informed as we have a place to talk about ideas and as there is more info
19:10:12 <notmyname> #topic python-swiftclient
19:10:53 <notmyname> as I said last week, there is a deadline of the 18th (tomorrow) for *client releases so that distros can do whatever's needed before juno and there is an integration check overall
19:11:15 <notmyname> zaitcev has been kind enough to check over it and proposes that it's ready to go right now
19:11:33 <notmyname> any questions or discussion on that? anything that you think should land today to be included?
19:11:39 <notmyname> #link https://review.openstack.org/#/q/status:open+project:openstack/python-swiftclient,n,z
19:12:05 <notmyname> if there are no objections, I'll cut a release tonight
19:12:38 <acoles> no objections here
19:12:56 <peluse_> cool
19:13:05 <notmyname> great
19:13:16 <notmyname> #action notmyname to cut a python-swiftclient release
19:13:24 <mattoliverau> looks good and nice work zaitcev
19:13:32 <notmyname> #topic EC status
19:13:42 <notmyname> the last 2 weeks we were tracking https://review.openstack.org/#/c/106910/
19:13:59 <notmyname> looks like it's trying to land but having issues. what's the status and blockers on it?
19:14:03 <notmyname> peluse_: acoles?
19:14:39 <peluse_> I believe I need to merge master to EC and then recheck no bug again.  Being out of town my time has been pretty limited though
19:14:53 <peluse_> but its approved, just need to get it shoved in there, will do it tomorrow morn at the latest
19:14:59 <notmyname> ok
19:15:15 <notmyname> peluse_: are you going to do the master->ec merge, or do you need someone else to do it?
19:15:29 <acoles> its failing due to the authenticate header test bug that emerged last week
19:15:42 <peluse_> also, relevant to EC, sat in on Sage's EC talk here at SDC and found that they decided to punt on partial write failures because of the complexities we're dealing with now... decided it wasn't worth it so EC objects are write once
19:15:43 <acoles> so you will need to merge master
19:15:46 <notmyname> acoles: ah, the one where keystone added a header too?
19:15:56 <acoles> notmyname: yup, that one
19:15:58 <notmyname> peluse_: ah, interesting
19:15:59 <peluse_> notmyname, I've already started the merge to feature/ec so will go ahead finish
19:16:16 <notmyname> acoles: ok, cool. so peluse_ will do the merge, then rebase the patch (if needed) and merge it
19:16:22 <peluse_> yeah, some more intersting tidbits also I'll share at the hackathon
19:16:39 <peluse_> yup, I'm on it (well, will be in just a bit)
19:16:39 <notmyname> peluse_: after the merge, I'm ok if you go ahead and merge it to ec based on previous reviews
19:16:48 <peluse_> cool
19:18:13 <notmyname> what's next up for EC after the merge from master to get the current blocker merged?
19:18:27 <notmyname> ie what needs to be on the priority list and next todo off of trello?
19:19:07 <notmyname> peluse_: ^ that one was mostly for you :-)
19:19:28 <peluse_> I haven't sync'd with the rest of the guys this week since I'm travelling so let me update you in the channel later this week.  Mainly reconstructor stuff
19:19:38 <notmyname> ok, good
19:19:39 <tsg> notmyname: I still need to get the "footer" patch (and updated PUT patch) up for review
19:19:43 <peluse_> and I will be specific :)
19:19:55 <notmyname> tsg: ack
19:19:57 <tsg> notmyname: I haven't had time in the last week+ either to do that-
19:20:03 <tsg> will get it up there asap
19:20:07 <notmyname> thanks
19:20:16 <tsg> so we can get a review or two before the hackathon
19:20:17 <peluse_> tsg and I need to take some vacation to work on this stuff :)
19:20:24 <tsg> haha :)
19:20:31 <tsg> peluse_: that's the plan next week ;)
19:20:34 <notmyname> lol
19:20:47 <peluse_> next week == renewed focus
19:20:51 <torgomatic> iv'e been workign on some sort of abstraction for puts that might mkae life easier
19:20:54 <torgomatic> alsso typos
19:21:04 <tsg> :)
19:21:08 <torgomatic> https://github.com/smerritt/swift/tree/putter
19:21:08 <peluse_> ooh, I can help with typos
19:21:32 <notmyname> great!
19:21:33 <torgomatic> has a couple failing unit tests, but I think they were focused on testing a utility method I changed... functests pass, though, which is nice
19:21:48 <notmyname> any questions on EC?
19:21:51 <tsg> torgomatic: do we already have a patch up on gerritt?
19:21:59 <tsg> (proposal)
19:22:00 * notmyname is being bugged about it all the time now
19:22:06 <torgomatic> tsg: no, I wanted to get unit tests passing before going to gerrit
19:22:13 <tsg> torgomatic: ok
19:22:17 <torgomatic> getting a -1 from Jenkins usually makes people ignore stuff, and rightly so IMO ;)
19:22:36 <tsg> torgomatic: I see your github link now - will take a peek
19:22:59 <torgomatic> tsg: sounds good
19:24:12 <notmyname> peluse_: torgomatic: tsg: anything else to go over on ec?
19:24:19 <torgomatic> nothing here
19:24:21 <peluse_> nope
19:24:37 <notmyname> tsg: ?
19:24:48 <tsg> notmyname: liberasurecode stuff is progressing well - some new contributors (Kota)
19:24:55 <notmyname> ah, that's great
19:24:58 <peluse_> go kota!
19:25:05 <tsg> we'll get Thomas to create a Debian package soon
19:25:15 <tsg> and hope zaictev can help with rpm :)
19:25:34 <tsg> Trello page is up to date
19:25:38 <tsg> that's all from my side
19:25:47 <kota_> :)
19:25:52 <notmyname> thanks
19:26:05 <notmyname> #topic reviews
19:26:12 <notmyname> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
19:26:41 <notmyname> still 5 outstanding patches listed for Juno. I'd love to see them land
19:27:11 <notmyname> all of those are to improve existing things
19:27:24 <mattoliverau> The delete affinity patch has merged
19:27:26 <notmyname> if there are other patches that need to land before juno, please add them to that section
19:27:29 <torgomatic> notmyname: affinity + DELETEs landed
19:27:33 <torgomatic> yeah, what mattoliverau said :)
19:27:34 <notmyname> ah! yay!
19:27:47 <notmyname> thanks cschwede and torgomatic for reviewing that
19:27:58 <cschwede> notmyname: np, you're welcome
19:28:00 * notmyname thought he had checked. obviously not
19:28:11 <notmyname> ok, 4 patches left there :-)
19:28:14 <zaitcev> I looked at the unreasonable Ranges
19:28:26 <zaitcev> Had a question to torgomatic about it
19:28:36 <peluse_> I'm good (+2) on torgomatics zero copy get, will look at the put side next week for sure (this week is out for just about anything for me though)
19:28:43 <cschwede> i'm thinking if i should add https://review.openstack.org/#/c/121422/ to that list? (limiting unnecessary partition movement when adding a tier +rebalance)
19:28:47 * torgomatic has been neglecting that patch a bit
19:28:57 <zaitcev> The patch seems simple enough, but it has quadratic code that I would like to limit somehow
19:30:01 <notmyname> cschwede: small process thing, can you change the commit message from "Also-By" to "Co-Authored By"? I think that's how they're checking for it (ie so Florent gets ATC status)
19:30:09 <notmyname> zaitcev: thanks
19:30:24 <cschwede> notmyname: thanks, yes, will do that
19:30:25 <zaitcev> BTW, I have an outstanding bug in python-swiftclient... https://bugs.launchpad.net/swift/+bug/1369546
19:30:26 <uvirtbot> Launchpad bug 1369546 in swift "swift client leaves empty directories when specifiing output file" [Undecided,Confirmed]
19:30:34 <notmyname> cschwede: seems likely that it should be included
19:30:55 <cschwede> notmyname: ok, adding it. thanks!
19:31:00 <notmyname> cschwede: jsut did
19:31:11 <cschwede> nice :)
19:31:40 <notmyname> zaitcev: what's the progress on that?
19:32:14 <notmyname> only reported 2 days ago, so no pressure ;-)
19:32:37 <zaitcev> notmyname: none so far, sorry. I just swear I didn't cause it with pseudo/, just made it apparent
19:32:45 * peluse_ has to run....
19:32:53 <notmyname> peluse_: thanks for coming
19:32:57 <notmyname> zaitcev: ok. no worries. :-)
19:33:04 <torgomatic> doesn't sound like it should block a swiftclient release though
19:33:06 <notmyname> glad you're on it though
19:33:09 <notmyname> torgomatic: agreed
19:33:15 <zaitcev> notmyname: I'm just saying I'm afraid to break something by rushing it
19:33:44 <acoles> notmyname: would be good if the keystone auth doc update could land for Juno https://review.openstack.org/#/c/121481/
19:34:07 <notmyname> acoles: ah, yes
19:34:27 <cschwede> acoles: i'm reviewing that
19:34:45 <acoles> cschwede: thanks
19:35:02 <notmyname> acoles: I'm also looking at donagh's spec on service tokens
19:35:24 <acoles> notmyname: ah, yes, i need to get back to that too
19:36:20 <notmyname> acoles: I'd definitely like some additional input on it. maybe RAX (b/c they have a similar use case) and maybe have a high-level overview from keystone people (ie to make sure we aren't doing something gratuitously different)
19:36:58 <notmyname> acoles: but in general (so far) I agree with the use case and probably the plan
19:37:03 <acoles> notmyname: on the spec you mean?
19:37:07 <notmyname> acoles: yes
19:37:32 <acoles> notmyname: i know donagh has solicited input from RAX guys, he's keen to discuss at hackathon
19:37:37 <notmyname> good
19:37:48 <notmyname> acoles and gvernik have been talking about the migration middleware, I've seen
19:38:00 <notmyname> anything to report there? anything you need from others? what's the status?
19:38:02 <acoles> notmyname: yes, lots of activity there this week
19:38:24 <acoles> tdasilva made a great suggestion to tweak the drive interface
19:38:38 <acoles> i'm trying to increase the test coverage
19:38:49 <acoles> and i think gvernik's happy with that!
19:39:15 <acoles> so we need to do some squashing soon and i'm hoping it will be in good shape
19:39:38 <gvernik> i am happy with it... and I am working on another patch that will include refactoring suggested by tdasilva and better unitests coverage
19:39:41 <acoles> notmyname: it will need another core's eyes at some point of course
19:39:48 <notmyname> ok
19:39:59 <tdasilva> acoles, gvernik: i noticed we have no func tests either
19:40:21 <tdasilva> should we add some?
19:40:23 <acoles> tdasilva: i have func tests, just need to tidy and push to gerrit ;)
19:40:29 <tdasilva> oh ok
19:40:29 <tdasilva> great
19:41:30 <tdasilva> acoles, gvernik: let me know if I can help with anything...i'll keep an eye on new patches to review
19:41:33 <notmyname> any other patches you'd like to specifically bring up this week in the meeting?
19:42:00 <acoles> notmyname: btw, back to keystone stuff, i had the 'don't use swift with keystone v3' warning removed from manuals
19:42:10 <acoles> https://review.openstack.org/#/c/121493/
19:42:13 <notmyname> acoles: ah, good. actually, very good
19:42:19 <notmyname> thanks
19:43:00 <notmyname> #topic open discussion
19:43:09 <notmyname> anything else to discuss this week
19:43:35 <mattoliverau> The abandon report has items in it!
19:43:40 <notmyname> :-)
19:43:48 <mattoliverau> Well did before I went to sleep :P
19:43:53 <notmyname> I need to go through and actually abandon stuff now (right mattoliverau)?
19:44:16 <mattoliverau> notmyname: yup, any core can if they want
19:44:25 <notmyname> ok. I'll take that to start with
19:44:38 <mattoliverau> I can extend it to auto abandon at some point once we are all happy with it
19:45:15 <notmyname> anything else from anyone?
19:45:29 <notmyname> speak now, or wait until next week's meeting
19:46:12 <notmyname> ok :-)
19:46:15 <notmyname> thanks for coming
19:46:18 <notmyname> #endmeeting