19:06:11 <notmyname> #startmeeting swift
19:06:12 <openstack> Meeting started Wed Apr  1 19:06:11 2015 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:06:16 <openstack> The meeting name has been set to 'swift'
19:06:20 <notmyname> who's here for the swift meeting?
19:06:22 <peluse> party on
19:06:25 <jrichli> here
19:06:27 <mattoliverau> o/
19:06:29 <kota_> o/
19:06:30 <tdasilva> hi
19:06:39 <clayg> sorry for the delay!
19:06:43 <clayg> thanks
19:06:44 <notmyname> no worries
19:06:49 <clayg> notmyname: you're too kind
19:07:19 <acoles> hi
19:07:26 <torgomatic> 😎
19:07:32 <peluse> 
19:07:33 <cschwede> hello
19:07:39 <notmyname> so, first up, I want to say how great it is to work with everyone. ec has, by far, been the best community-driven feature in swift--so many people from everywhere spending a lot of time and effort helping out
19:07:46 <ho> hi
19:07:47 <notmyname> thank you. it's great to see
19:08:03 <notmyname> so that said, let's dive in...
19:08:06 <peluse> for sure
19:08:07 <petertr7> o/
19:08:13 <notmyname> #topic EC
19:08:15 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
19:08:24 <notmyname> first, what's the current status?
19:08:30 <peluse> where do we start??
19:08:32 <notmyname> peluse: acoles: clayg: ?
19:08:44 <peluse> clayg, you wanna go first?
19:08:50 <notmyname> well, hang on
19:08:58 <notmyname> first I want to make sure everyone is up to speed
19:09:04 <notmyname> before we cover what's to be done next
19:09:38 <notmyname> so the plan is to get stuff on feature/ec (as we've been doing). then clayg is restructuring it for merge to master on feature/ec_review. then we'll land that on master
19:09:49 <notmyname> as described at https://etherpad.openstack.org/p/ec_merge_plan
19:09:54 <peluse> nice!
19:10:04 * clayg double checks the plan
19:10:07 <acoles> theres a plan? ;)
19:10:12 <clayg> #link https://etherpad.openstack.org/p/ec_merge_plan
19:10:13 <peluse> too late, you already signed up :)
19:10:17 <clayg> is that how it works?
19:10:23 <notmyname> clayg: yup
19:10:32 <notmyname> clayg: now it will be in the official meeting notes
19:10:45 <notmyname> so, does that make sense for everyone? I want to make sure we know what's happening
19:11:24 <acoles> makes sense
19:11:27 <cutforth> hello, my apologies i am late
19:11:38 <peluse> yup, to be clear though we're still cleaning up a lot of last minute stuff - not that the restructuring can't start but don't want to give everyone the impression the feature/ec is "done" right now
19:11:40 <notmyname> cutforth: just getting started
19:11:40 <cschwede> makes sense to me too
19:11:48 <notmyname> peluse: ok
19:11:55 <ho> make sense to me too :)
19:11:58 <notmyname> ho: kota_: mattoliverau: make sense to you?
19:12:14 <cutforth> notmyname: good, not too late
19:12:15 <mattoliverau> yup
19:12:37 <notmyname> great
19:13:02 <notmyname> ok, so peluse, acoles, clayg, where are we on feature/ec (first. later I'll ask about feature/ec_review)
19:13:10 <kota_> notmyname: ya
19:13:12 <peluse> OK, some high level things first:
19:13:25 <peluse> - feature/ec merged from master today so up to date there
19:13:34 <clayg> peluse: thanks!
19:13:42 <notmyname> good
19:13:46 <peluse> - I didn't scrub trello today but it does need scrubbing, a few of the items are done as part of other fine work from acoles and clay over the weekend
19:14:00 <clayg> peluse: you had a long weekend
19:14:29 <peluse> and for my part the guts of the reconstructor are getting close... lots of fantastic comments.  Rework still WIP ETA EOD today.  Lots of related work from acoels and clayg that they can comment on
19:14:43 <notmyname> ok
19:15:01 <clayg> #action scrub trello
19:15:14 <peluse> scrub-a-dub-dub
19:15:15 <notmyname> peluse: there was an issue found with pyeclib/liberasure code. does that impact us?
19:15:21 <peluse> sorta
19:15:30 * clayg is a haX0r
19:15:39 <peluse> if we can squeeze it in it'd be nice if not we have a workaround at a small penatly (perf and overhead)
19:15:45 <peluse> doing a decode instead of reconstruct is all...
19:15:49 <notmyname> clayg is all over the meeting logistics this week
19:16:12 <notmyname> peluse: ok. any requirements changes needed?
19:16:22 <peluse> well, I shouldn't say small since we don't really know - seems like it would be small though :)
19:16:24 <clayg> peluse: didn't kevin and tsg already fix it?  can we sneak in a version bump?
19:16:42 <notmyname> what happens if we can't get a dependency version bump?
19:16:42 <peluse> no quirements change needed until new liberasurecode is available.  they did indeed fix it, I'm not sure where it stands on release
19:16:44 <notmyname> ok
19:17:22 <notmyname> if it's ready soon, I can help work on getting it into global requirments
19:17:26 <clayg> notmyname: it's not needed - we don't change the code to remove the hack until we can get the new depency version - the hack is fine, the failure mode for not working around with a hack is sucks
19:17:27 <peluse> tsg looks away right now, I will send an email and ask for latest status on release
19:17:30 <notmyname> clayg: ok
19:17:36 <notmyname> peluse: thanks
19:18:00 <notmyname> ok, what else on feature/ec?
19:18:12 <notmyname> sounds like peluse will have the reconstructor finished up today
19:18:19 <acoles> for my part i'm focussed on ssync/reconstructor right now. in particular tests for the EC specific behavior are shaping up nicely.
19:18:27 <clayg> #action peluse: change the commit message for ec-probe to not say wip
19:18:38 <peluse> clayg, will do
19:18:41 <notmyname> patch 164291
19:18:42 <patchbot> notmyname: https://review.openstack.org/#/c/164291/
19:18:49 <clayg> #info acoles is awesome
19:18:56 <acoles> and i have added a few discussion cards to trrello where i have questions
19:18:57 <peluse> second that!!!!
19:19:00 <acoles> trrrrrreeellllo
19:19:24 <clayg> i have not looked at trello
19:19:24 <jrichli> third that :-)
19:19:25 <notmyname> acoles: what patch(es)?
19:19:34 <acoles> just slipstreaming you guys;)
19:19:34 <notmyname> acoles: so I can star/track them
19:19:43 <acoles> notmyname: min
19:19:54 <clayg> something something per-policy-functests
19:20:08 <clayg> that could just land on master and merge into feature/ec for all i care
19:20:10 <acoles> patch 169052
19:20:10 <patchbot> acoles: https://review.openstack.org/#/c/169052/
19:20:25 <notmyname> starred.
19:20:58 <peluse> oh sweet, I didn't know that's where you were going to land the rest of the tests
19:21:01 <clayg> acoles: that patch is really just reconstructor-2.0 - it's more of the same
19:21:26 <notmyname> acoles: is that the only one to track?
19:22:07 <clayg> notmyname: torgomatic's multi-range GET is still on my nice-to-have list
19:22:12 <acoles> notmyname: from me yes, theres a ton of tests in patch 169052 that would be great to have reviewed
19:22:12 <patchbot> acoles: https://review.openstack.org/#/c/169052/
19:22:13 <notmyname> clayg: which one were you referring to?
19:22:26 <notmyname> acoles: ok
19:22:31 <notmyname> clayg: yes, same for me
19:22:34 <clayg> notmyname: patch 166576
19:22:34 <patchbot> clayg: https://review.openstack.org/#/c/166576/
19:22:56 <notmyname> ok, so this is how I see this working
19:23:07 <clayg> notmyname: oh acoles reconstrcutor patch - he already pointed it out patch 169052
19:23:07 <patchbot> clayg: https://review.openstack.org/#/c/169052/
19:23:33 <peluse> clayg, do you care if I just squash the EC probe test into the main reconstructor patch?  No conflicts and makes testing a little quicker on ECrecon
19:23:39 <notmyname> the feature/ec_review patches start to be proposed based on what's in feature/ec today. then as the other stuff lands on feature/ec, clayg grabs it and incorporates it onto feature/ec_review
19:24:04 <notmyname> clayg: ^^ does that make sense for you?
19:24:48 <clayg> notmyname: yeah that's basically what's doing - except by tomorrow (at the latest) i'll want to be pulling in the reconstrctor - so acoles and peluse better put a nail in it
19:24:55 <notmyname> ok
19:25:12 <notmyname> and for feature/ec_review, what's the status? I saw you had proposed some ec patches to master
19:25:16 <acoles> clayg: what time tomorrow?
19:25:31 <peluse> great question!  engr time is 11:59 pm
19:25:35 <clayg> peluse: ummm... i think i'd rather acoles patch be mushed in than the probetests - but I dont' really care - when it comes to master i'll probably add the probetest changes seperately
19:26:04 <peluse> OK, will leave as is to avoid confusion.  Its no big deal
19:26:11 <clayg> we'll see what the proxy changes look like today - that will be the upper bound i'm willing to accept in a single change to master ;)
19:26:35 <clayg> peluse: i tend to just checkout the probe test change - then add fixes as git commit -a -m 'squash this to the other'
19:26:43 <peluse> me too
19:26:45 <clayg> then before git review ; git rebaise -i and move the fix into the ec change
19:26:53 <clayg> well paphahhahshshshththththtttt wat are you whinging about!?
19:27:04 <peluse> just making conversation is all :)
19:27:21 <clayg> acoles: it's fine - get your rest - i'll pick up wahtever isn't done after I build the proxy change for ec_review
19:27:28 <clayg> notmyname: LET'S TALK ABOUT EC_REIVEW!
19:27:28 <notmyname> clayg: did you intend to propose https://review.openstack.org/#/c/169614/ to master?
19:27:38 <notmyname> clayg: ya, see my question above :-)
19:27:40 <clayg> notmyname: doubtful - i don't know what i'm doing
19:27:58 <acoles> clayg: wait, i just remembered that your tomorrow is after mine :O
19:28:05 <clayg> i branched from feature/ec_review - did it not get a default push target whatever?
19:28:20 <clayg> notmyname: can you show me how ti gerrit?
19:28:30 <notmyname> clayg: ya, I'll do that after the meeting
19:28:34 <clayg> #active notmyname: teach clay how to feature/ec_review
19:28:39 <notmyname> for anyone wondering why we're doing an ec_review, it's so that we can have a single merge commit for getting EC into swift. makes future debugging and history tracking simpler
19:28:52 <clayg> yeah it'll be great!
19:29:03 <notmyname> ok, so clayg what's up with feature/ec_review?
19:29:03 <clayg> so.... topic is feature/ec_review?
19:29:06 <notmyname> yes
19:29:10 <clayg> ...
19:29:25 <clayg> #topic feature/ec_review
19:29:43 <notmyname> #topic feature/ec_review
19:29:51 <notmyname> openstack likes me more ;-)
19:29:52 <clayg> ummm.... i'm doing some git magic to find differences with master and feature/ec
19:30:11 <clayg> i'm trying to pull them out into logical somewhat "service-level" changes
19:30:44 <clayg> I'm stealing relevant commit messages from feature/ec - but most of the time htere's no one message or author that covers the whole change I end up building
19:31:01 <clayg> I'd like some help in this early stage basically just glancing at the diffs and seeing what needs to be in the commit message
19:31:10 <clayg> summary - bullets - authorship
19:31:17 <clayg> i have so far:
19:31:23 <notmyname> clayg: for authorship, make liberal use of the "Co-Authored-By: <>" stanzas
19:31:33 <clayg> storage policy changes (this is somewhat updated from feature/ec - so it could use some real review)
19:31:48 <clayg> test updates (last time with sp merge i found it's just easier to get them out of the way)
19:32:09 <clayg> diskfile changes (big one - does all the suffix hashing stuff which won't make sense till laster, but made the test_diskfile pull easier)
19:32:24 <clayg> object server changes (this totally "works" - although the proxy doesn't really speak ec yet)
19:32:27 <clayg> docs
19:32:31 <clayg> docs will always be last
19:32:43 <clayg> i'll keep inserting changes between docs and the last change
19:32:46 <clayg> next up is proxy
19:33:12 <clayg> anyone that wants to review docs totally can - but I'd appreciate a push over chnage more than a bunch of todos
19:33:24 <clayg> it's easy for me to grab the latest rev before I update the chain
19:33:30 <notmyname> ok
19:33:33 <clayg> that's it!
19:33:55 <notmyname> clayg: cool
19:34:09 <notmyname> so this afternoon we'll get the first ones in the chain up, and people can start reviewing them?
19:34:26 <clayg> they're "up" now I suppose sp->object-server+docs
19:34:38 <clayg> but appreantly on the wrong branch or something?  so don't merge them :P
19:34:40 <notmyname> (on master, but we're about to abandon those ;-)
19:34:49 <clayg> i can keep the change-ids no?
19:35:03 <notmyname> the different branch makes it weird
19:35:12 <clayg> really?  ok you know best
19:35:35 <notmyname> unique id in gerrit = (changeid, branch)
19:35:51 <acoles> yep, i can confirm that from experience ^^
19:35:53 <clayg> notmyname: ok so but help with structure and commit messages
19:36:14 <clayg> notmyname: these changes were all written by lots of authors so the commit message should be a community effort too
19:36:39 <clayg> for changes in the middle of the change (even commit messages) it's easier to just post a diff/comment
19:37:09 <clayg> docs (the final in the chian) is the only one where a push won't force a bunch of OUTDATED - so there (and only there) you can push push push all over it and and wont' mess me up in the least!
19:37:37 <notmyname> #info push over commits for docs. leave comments for others in the ev_review chain
19:37:39 <clayg> I'll do my best to keep up with review comment fixes as they come in with one rebase per day as we did last time with sp
19:37:54 <notmyname> any questions from anyone on this?
19:38:06 <peluse> clear as a bell
19:38:08 <mattoliverau> nope, maks sense
19:38:18 <notmyname> for people reviewing, leave your review score. if you're core and you're the 2nd +2, then also approve it
19:38:38 <clayg> not yet tho ;)
19:38:38 <notmyname> we'll have the first one with a -2 so nothing will land until that gets pulled
19:38:53 <acoles> so this looks like its on master https://review.openstack.org/#/c/169615/ ? not feature/ec-review
19:38:58 <peluse> notmyname, per tsg new PyECLib due out this Fri
19:39:06 <notmyname> peluse: ok, thanks
19:39:29 <mattoliverau> acoles: that will be abandoned
19:39:38 <notmyname> anything else to cover on anything related to ec this week?
19:39:50 <mattoliverau> i'm guessing
19:39:54 <notmyname> mattoliverau: right
19:39:59 <acoles> ok
19:40:04 <notmyname> clayg: could go ahead and abandon all those
19:40:08 <clayg> sigh
19:40:16 <mattoliverau> once clayg knows how to ec-review :P
19:41:29 <clayg> hey man - i was told feature/ec_review was ready to go - that was a lie!
19:41:58 * notmyname feels bad
19:42:29 <clayg> heh
19:42:42 <notmyname> https://review.openstack.org/169897 fixes it
19:42:51 <clayg> notmyname: s'ok - i don't think we're going to run out of change-ids
19:43:15 <clayg> notmyname: yay!
19:43:30 <notmyname> you can tell git review explicitly which branch to submit to, but that makes it default for that branch
19:43:47 <notmyname> ok, next up (briefly)
19:43:55 <notmyname> #topic code stuff not ec
19:44:09 <notmyname> so the whole reason we're pushing on ec so much is because we've got a release coming up
19:44:18 <notmyname> and, of course, there's more stuff than ec in the release
19:44:29 <notmyname> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
19:44:44 <notmyname> I updated that with a few things that aren't EC that would be nice to get onto master
19:44:57 <notmyname> if you're blocked on EC reviews, then looking at those is nice
19:44:59 <notmyname> however
19:45:12 <clayg> patch 167595 <- Select policy when running functional test
19:45:12 <patchbot> clayg: https://review.openstack.org/#/c/167595/
19:45:21 <notmyname> we don't want a ton landing on master. so don't approve the patches as the 2nd +2
19:45:42 <notmyname> and then after ec_review is landed on master, we can clean up the other stuff that is waiting
19:46:03 <cschwede> notmyname: on not approving - that means soft freeze is in effect?
19:46:27 <notmyname> cschwede: correct. (seeing as clayg is already pushing ec_review patches
19:46:38 <cschwede> ok, thx
19:46:43 <notmyname> I'll update the channel topic with that info
19:47:03 <notmyname> and appropriately star the right patches so the dashboard is up to date
19:47:20 <clayg> the real soft freeze starts when people start reviewing IMHO, if that's today or tomorrow then that's that - if there's some stuff we can land today we should do it IMHO
19:47:22 <notmyname> any other code stuff that doesn't relate to ec?
19:47:33 <notmyname> clayg: +1
19:47:40 <notmyname> cschwede: ya, so use your best judgement :-)
19:48:10 <clayg> cschwede: acctually please by all means tell us what needs to be in kilo and looks ready according to your eyes
19:48:55 <notmyname> #topic open discussion
19:49:00 <cschwede> clayg: iirc nothing needs to be in kilo from master, just a few „would be nice to have“ - but that can land directly after EC landed as well?
19:49:08 <notmyname> two non-code things I wanted to bring up briefly
19:49:39 <clayg> cschwede: depends on how quickly we can approve the ec_review changes
19:49:51 <notmyname> first, PTL elections are upcoming (nominations open next week I think)
19:49:54 <clayg> I think next friday is a good deadline for rc1
19:50:12 <clayg> ooooooooohhhh
19:50:23 <clayg> notmyname: you expecting any competetion?  I can bang some heads if need be.
19:50:27 <notmyname> second, by the end of next week we should have the room assignments for the summit
19:50:38 <notmyname> clayg: no, but I thought it only fair to bring it up :-)
19:51:10 <notmyname> honestly, I don't want to spend too much time on summit prep this week. I'd rather tackle it next week after we've got more of ec_review done
19:51:44 <notmyname> and to clayg's point, yes we're still owrking towards the end of next week (april 10) as the target for RC1
19:51:56 <notmyname> any questions on anything? anything else to bring up?
19:52:06 <clayg> we have a bunch of open sepcs
19:52:08 <clayg> specs
19:52:38 <notmyname> ya, I'd like to clean those up between EC and the summit
19:52:57 <clayg> peluse: wtf is this -> patch 142146
19:52:57 <patchbot> clayg: https://review.openstack.org/#/c/142146/
19:53:34 <notmyname> looks like docs
19:55:08 <notmyname> ?
19:55:17 <mattoliverau> I beleive it's peluse keeping the EC spec up to date :)
19:55:22 <notmyname> ok, seems like we're done here today
19:55:35 <notmyname> thank you everyone for coming, and thanks for working on swift :-)
19:55:39 <notmyname> #endmeeting