19:00:53 <notmyname> #startmeeting swift
19:00:54 <openstack> Meeting started Wed Apr  8 19:00:53 2015 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:57 <openstack> The meeting name has been set to 'swift'
19:01:03 <notmyname> hello, everyone
19:01:06 <mattoliverau> o/
19:01:07 <notmyname> who's here for the swift meeting?
19:01:08 <jrichli> yo
19:01:12 <kota_> hello
19:01:13 <acoles> hello
19:01:14 <ho> hi
19:01:16 <gvernik> hello
19:01:27 <peluse> howdy
19:01:41 <cschwede> hello
19:01:50 <notmyname> agenda for thsi week is at
19:01:51 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
19:02:04 <notmyname> two big things to talk about: EC and the summit
19:02:10 <notmyname> so let's go for EC first
19:02:15 <notmyname> #topic EC status update
19:02:38 <notmyname> #link https://review.openstack.org/#/q/status:open+project:openstack/swift+branch:feature/ec_review+topic:bp/swift-ec,n,z
19:02:44 <notmyname> those are the ec_review patches
19:02:58 <notmyname> looks like there have been a lot of reviews, including some of them approved!
19:03:00 <notmyname> yay
19:03:14 <notmyname> clayg has been driving this train, but he was out yesterday
19:03:26 <notmyname> I expect another push of the patch chain to address comments today
19:03:36 <peluse> awesome
19:03:46 <clayg> i was *mostly* out on Monday too - but I'm back in full swing now
19:03:57 <peluse> watch out!
19:03:58 <clayg> w
19:04:06 <notmyname> :-)
19:04:25 <notmyname> so as for "things to do", clayg anything specifc we should be looking at?
19:04:36 <peluse> just the comments :)
19:04:45 <peluse> what are we doing with multi range GET?
19:05:08 <clayg> ^ that maybe, or the versioned writes/copy middleware extractin
19:05:33 <notmyname> both of those would be nice to get in, if possible (ie if the rest is reviewed, go check those out)
19:05:48 <clayg> someone had commented about the policy handling in the proxy and how much better a bunch of stuff would be if policy was a controller attribute - but that way lies dragons until we get those extractions in place
19:06:07 <cutforth> hello
19:06:29 <notmyname> clayg: you had a comment this weekend I think that seemd to have you worried. is everythign ok? or was something found that is troubling?
19:06:31 <clayg> I tried it - and it's great!  except it doesn't work.  There's another patch something to do with iter_nodes (per policy sort method?)
19:06:37 * notmyname doesn't rememebr the details
19:06:39 <clayg> comes to the same conclusion - but we need to get the other things done first
19:07:12 <clayg> notmyname: a bunch of probetests were broke on friday night if you had a default ec policy
19:07:21 <notmyname> hmm..ok
19:07:41 <clayg> notmyname: I don't think they *ever* worked with that setup (I know functests *did*) - but I didn't go back to feature/ec and verify - because it was simple enough just to fix the probe tests
19:07:41 <peluse> whats the status on those now?  need some of us to dig in?
19:07:50 <clayg> no - they should all work
19:08:04 <notmyname> nice
19:08:31 <clayg> if anyone seems any failures on probes after the end of the chain (intermittent or otherwise) - please engage in channel - they should all work and work reliably
19:08:43 <notmyname> so what I hearing is that we're in pretty good shape right now. does everyone agree?
19:09:03 <peluse> same opinion here
19:09:04 <clayg> just all the slew of comments of stuff I need to fix - but I'm all over that - thank you guys for having faith in me!
19:09:16 <notmyname> keep reviewing. don't hesitate to leave a review. if you're the 2nd +2, then do a +A
19:09:24 <notmyname> now, as to the schedule of things...
19:09:25 <peluse> there's a few things we need to circle back on w/Trello, I'll do that after the next push
19:09:25 <clayg> notmyname: there's some cleanup in the reconstructor wrt to jobs that I've been chipping away at - may also come in tonight
19:09:28 <notmyname> ok
19:09:53 <clayg> I have a plan to directly address acoles concerns about cleanup in the revert case - and the timing on the unlinks in purge
19:09:57 <notmyname> what's the likelyhood of having the ec_review patch all approved by EOD friday? (US West EOD)
19:10:06 <clayg> ... but he hasn't seen it yet - he may think i'm full of it
19:10:11 * peluse forgets what day today is
19:10:19 <notmyname> clayg: acoles: I trust you guys on that :-)
19:10:45 <clayg> notmyname: maybe ~50% - I think monday or tuesday would be the next most likely contender
19:11:07 <notmyname> ya, I've been thinking the same in the back of my mind
19:11:07 <clayg> there's a bunch of stuff that people have found that I should clean up - then people will need time to review my changes to address their comments
19:11:19 <notmyname> which I think is ok, but it does cut into our time for a 2nd RC
19:11:39 <clayg> also, there's some final changes to the reconstructor that haven't been written yet - but it's still mostly cleanup and efficieny - good changes - but code that folks haven't seen yet nonetheless
19:11:48 <notmyname> ok
19:11:54 <peluse> notmyname, maybe you should buy clayg a nice bottle of scotch :)
19:11:57 <notmyname> when will we see it?
19:12:02 <clayg> I think it cirtainly *could* get all done thurday and friday - but people shouldn't feel rushed if they find something else that we should fix
19:12:04 <notmyname> peluse: oh, I'm sure I should ;-)
19:12:28 <clayg> i'm going to work on it today and tonight
19:12:50 <clayg> it will be done tonight along with the rebase from the fixups unless I get sucked into a rabbit hole trying to address some "it would be nice if..." comment ;)
19:12:57 <notmyname> heh
19:13:09 <peluse> clayg, let me know if/how I can help
19:13:10 * clayg looks at "just always use a list for except status in FakeConn"
19:13:33 <acoles> clayg: sorry for that rabbit hole
19:13:46 <notmyname> does anyone have any questions on ec? or more we need to discuss about it here in the meeting?
19:14:16 <notmyname> ok, moving on then
19:14:20 <clayg> the big rabbit hole is the "attach policy to controllers as attribute" - luckily there I know that although it would be great - it's a disaster - so I don't even have to attempt it (again)
19:14:37 <notmyname> #topic other stuff in the 2.3.0 (for kilo) release
19:14:39 <clayg> there was also a TODO in diskfile that mattoliverau asked if we could do now - but I don't think we should
19:14:57 <notmyname> so other stuff that could land on master that shoudl be in this release
19:14:59 <clayg> some cleanup refactoring that looks better in review as it is - but will be better in the long run when cleaned out
19:15:17 <notmyname> (remember we've got a soft freeze on master right now to help with the ec_review process)
19:15:42 <notmyname> but there are a few patches to master that are starred and listed on..
19:15:44 <notmyname> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
19:16:06 <notmyname> and _several_ in the "needs final review" section
19:16:14 <notmyname> those would be great things to look at
19:16:39 <tdasilva> notmyname, clayg: just to clarify...clayg suggest people looking at obj. versioning next, are we still trying to get that in kilo?
19:17:02 <notmyname> tdasilva: the versioning middleware?
19:17:14 <tdasilva> y
19:17:26 <cschwede> i think we should wait with merging anything outside of EC until the feature-branch landed on master?
19:17:31 <notmyname> cschwede: yes
19:17:35 <notmyname> +100
19:17:47 <notmyname> tdasilva: no, I don't think versioning middleware will be in kilo
19:17:52 <cschwede> ok, i was just wondering about reviewing other patches atm
19:18:06 <tdasilva> ok, just wanted to make sure, thanks
19:18:25 <notmyname> cschwede: definitely review them. and bonus points if you check to see if they conflict with anything in ec_review. but don't approve it yet
19:18:54 <notmyname> I'm thinking that after ec_review lands, then we can also land all the pending stuff to master
19:19:18 <notmyname> eg one simple thing will be the authors/changelog patch. I'll be pushing that up before monday
19:20:25 <notmyname> also, I'd like to reiterate that I've never seen such a big feature in swift have such a whole-team effort before. it's been really great to see everyone come together for the EC work. thanks :-)
19:20:51 <notmyname> everyone who is writing code and reviewing patches for it is helping out in a very important way
19:20:58 <peluse> it has been awesome for sure
19:21:14 <peluse> and thanks tdasilva for jumping on docs with me as well!
19:21:31 <notmyname> anything else to bring up about code patches for ec or for master? (before we move on to summit planning)
19:22:02 <clayg> notmyname: just to reiterate that dpending on how much time people have on thursday and friday...
19:22:20 <clayg> notmyname: ... we may seriously have to consider that we might not cut the RC until early next week
19:22:58 <clayg> if everything comes up spades tomorrow and friday in rewviews we might get lucky - but... I'm really not sure it's much better than 50/50?
19:23:11 <notmyname> ack. it's not ideal, but that's ok
19:23:13 <clayg> not the end of the world, but I think it's worth a day or two to get everyhting where we want it
19:23:20 <notmyname> yes, I agree
19:23:30 <peluse> ditto
19:23:43 <notmyname> #topic summit planning
19:23:44 <clayg> OTOH, ya'll make sure you've got time to review tomorrow and friday and we'll be FINE!  :P
19:23:48 <notmyname> ok, vancouver
19:24:17 <notmyname> the summit is coming up, and I've been seeing a lot of questions about "what are we doing" and "what's the schedule"
19:24:33 <peluse> what summit?
19:24:34 <notmyname> I expect to hear from ttx on friday what our room assignments will be
19:25:10 <notmyname> it looks likely that we'll get our 6 "fishbowl" sessions and we'll get 8 or 10 of our requested 12 "working sessions". (if we're lucky, all 12)
19:25:21 <notmyname> here's the difference:
19:25:55 <notmyname> fishbowl sessions are larger and more of what we've had in the past: larger room, lecture style, conversation yes, but more with a single presenter
19:26:11 <notmyname> fishbowl sessions also have a specific name on the schedule
19:26:19 <notmyname> working sessions are a little different
19:26:55 <notmyname> they are a smaller room and their title on the schedule is "swift working session" and they are going to be much more like the hackathons we've had
19:27:29 <notmyname> so imagine a closed off room where we can have a talk about a specific topic, but one that's much more of a discussion and reasoning about code
19:28:06 <notmyname> so a fishbowl session might be about a review of the EC stuff. and a working session might be about some details around how to build the encryption stuff or fast post or large contianers
19:28:36 <torgomatic> that'll be nice; it's always awkward trying to discuss code while there's like 50 people sitting and staring at you
19:28:39 <notmyname> and then on friday at the summit we'll have a "meetup/sprint" just like last time in paris. big ad-hoc discussions for whatever
19:28:51 <notmyname> torgomatic: ya, I think it sounds really good
19:28:58 <notmyname> so, here's what we have to do:
19:29:18 <notmyname> we need to plan what the fishbowl and working sessions are going to be. what are the topics and who's leading them?
19:29:38 <notmyname> most of the other projects are coordinating this via etherpads
19:29:44 <notmyname> which is what we did last time
19:29:56 <notmyname> does anyone have objections to us doing that again this time?
19:30:13 <notmyname> if we agree on that, then I'll put together a template today and make it available
19:30:14 <peluse> we oughtta do EC like "a panel" kinda thing for tech Q&A
19:30:21 <notmyname> peluse: not a bad idea
19:30:52 <mattoliverau> Shall we do what we did last summit, make a list of topics people want to talk./hear about. then decide on where to place them? so etherpads.. +1 EC should be a fish bowl.
19:31:10 <acoles> notmyname: etherpad is ok to gather the ideas for sessions
19:31:15 <peluse> yup
19:31:18 <notmyname> mattoliverau: yup. exactly. we'll coordinate both on the same etherpad
19:31:24 <notmyname> ok, great
19:31:38 <notmyname> #action notmyname to build the session scheduling etherpad template
19:31:53 <notmyname> I'll build that and put it in the -swift channel and the topic message there
19:32:02 <mattoliverau> cool
19:32:10 <notmyname> any other questions about the summit?
19:32:38 <notmyname> #topic open discussion
19:32:41 <notmyname> anything else?
19:32:50 <notmyname> I wanted to mention http://lists.openstack.org/pipermail/openstack-dev/2015-April/060886.html
19:32:55 <mattoliverau> Ops session and EC as fish bowls so people can come, hear and ask questions. (initally I think)
19:33:14 <mattoliverau> yeah, chris was awesome, I'll miss him.
19:33:22 <notmyname> mattoliverau: actually it's better than that (for the ops sessions)
19:33:56 <notmyname> the sched this year will allow a session to be placed in multiple tracks. so we can have an ops session ont he swift track and vice versa. should really help with attendance for those sessions
19:34:03 <mattoliverau> Sorry if I wasn't very vocal in channel yest, I was reviewing but the news didn't make me very talkative.
19:34:14 <notmyname> mattoliverau: understandable. I'm sorry for your loss
19:34:55 <notmyname> is there anythign else to bring up this week in the meeting? if not I propose we adjourn
19:35:36 <notmyname> thank you, everyone, for coming. and thanks for working on swift
19:35:39 <notmyname> #endmeeting