19:00:46 <notmyname> #startmeeting swift
19:00:47 <openstack> Meeting started Wed Apr 22 19:00:46 2015 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:50 <openstack> The meeting name has been set to 'swift'
19:01:04 <notmyname> who's here for the swift team meeting?
19:01:09 <mattoliverau> o/
19:01:11 <jrichli> yo
19:01:12 <cschwede> o/
19:01:13 <cutforth> o/
19:01:13 <gvernik> hello
19:01:14 <kota_> hi
19:01:14 <dmorita> hi
19:01:15 <imkarrer_> o/
19:01:17 <aerwin> hello
19:01:19 <hurricanerix> hi
19:01:21 <acoles> o/
19:01:26 <glange> \o///
19:01:26 <minwoob_> o/
19:01:29 <torgomatic> here for a bit, then running off
19:01:31 <ho> o/
19:02:03 <notmyname> wow. quite a crowd this week. welcome!
19:02:45 <notmyname> just as an FYI, at the summit I want to talk about a different meeting time. perhaps today, but 2 hours later. or perhaps tomorrow at 2000UTC (one hour later).
19:02:50 <notmyname> something to think about
19:03:19 <notmyname> the full openstack meeting schedule is at
19:03:20 <notmyname> #link https://wiki.openstack.org/wiki/Meetings
19:03:32 <notmyname> so you can see if a meeting room is free at a time you want
19:03:40 <notmyname> also, http://www.timeanddate.com/worldclock/meetingtime.html?iso=20150725&p1=224&p2=136&p3=152&p4=248&p5=70&p6=37
19:03:41 <clayg> i'm not here
19:03:47 <kota_> notmyname: so good and I just put the idea to ethepad
19:03:52 <notmyname> :-)
19:04:03 <notmyname> ok, a few things on the agenda this week
19:04:09 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
19:04:14 <notmyname> first up, kilo release
19:04:19 <notmyname> #topic kilo release (swift 2.3.0)
19:04:36 <notmyname> patches just now landed for the ones we had backported for RC2
19:04:50 <notmyname> current HEAD of stable/kilo is at commit SHA f8dee761bd36f857aa1288c27e095907032fad68
19:04:58 <mattoliverau> yay
19:05:07 <notmyname> if this should NOT be our final release, please speak up (like right now)
19:05:22 <notmyname> we do not expect a third RC
19:05:49 <notmyname> if there is no objection, then I'll give that SHA to ttx as the final one for RC2
19:06:04 <notmyname> he'll tag it and we'll keep testing to see if anything comes up
19:06:21 <notmyname> only major issues (eg data loss/corruption) would cause an RC3 to happen
19:06:48 <notmyname> any questions? any objections to doing the RC2 at the current commit?
19:07:14 <clayg> notmyname: what if a failure of both the primary and backup system caused a bug in the secondary backup to delay correction of a previous hardware failure resulting in data loss?
19:07:28 <notmyname> clayg: we'd need to ask Scotty
19:07:38 <clayg> i'm giving it all she's got!
19:08:07 <mattoliverau> lol, sorry been alseep so looking at current state of patches :)
19:08:21 <acoles> lol
19:08:38 <notmyname> no objections...going once...
19:08:53 <notmyname> twice.....
19:09:03 <notmyname> twice and a half...
19:09:08 <clayg> rofl
19:09:10 <glange> this is like my marriage
19:09:15 <acoles> wait...
19:09:19 <notmyname> acoles: ok
19:09:19 <clayg> acoles: stop it
19:09:19 <acoles> no its ok
19:09:24 <notmyname> ok
19:09:40 <mattoliverau> ok
19:09:45 <notmyname> done
19:09:46 <clayg> ok, i'm board with kilo now
19:09:46 <notmyname> #info commit f8dee761bd36f857aa1288c27e095907032fad68 is RC2
19:09:49 <ttx> swift: last to RC1, but first to RC2!
19:09:55 <notmyname> ttx: yay@
19:10:12 <notmyname> ttx: that's the commit to use. thanks
19:10:28 <ttx> notmyname: ack
19:10:48 <notmyname> ok, so looking forward with kilo, just some info on some testing that will be happening
19:11:10 <notmyname> I hope that everyone will be able to of course test previous functionality, but also look at EC
19:11:22 <notmyname> we've got a lot to learn there about EC in prod
19:11:55 <wbhuber_> notmyname: second
19:11:56 <notmyname> over the next few weeks at swiftstack, we'll be using the community QA cluster for testing some EC stuff
19:12:34 <notmyname> filling it up, dropping disks, checking reconstructor times, CPU/mem usage, etc
19:12:41 <notmyname> all that kind of stuff
19:13:10 <notmyname> is anyone else also going to be putting it in a lab to test?
19:13:35 <notmyname> kota_: you have already been looking at deploying EC right?
19:13:46 <cschwede> notmyname: thiago and me want to do some testing before the summit
19:13:49 <notmyname> hurricanerix: glange: any chance RAX can spend some lab time on it?
19:13:53 <notmyname> cschwede: nice
19:14:09 <kota_> notmyname: yes, but my lab environment
19:14:18 <notmyname> kota_: where it should be :-)
19:14:51 <notmyname> it would be awesome to have some preliminary results to talk about in vancouver.
19:14:53 <hurricanerix> notmyname: i don't think we have any plans for EC at this time.
19:14:57 <notmyname> ok
19:15:10 <acoles> notmyname: mseger has been talking about some perf testing
19:15:28 <notmyname> I wonder if there's a way we can aggregate the lab work different companies are working on
19:15:48 <notmyname> probably the first step is to actually start testing. and then try to be as open as possible with any results found
19:15:49 <mattoliverau> I'll throw something up in the cloud. /me is probably the biggest user of rackspace Australian cloud :P
19:16:30 <notmyname> ok, let's move on to summit planning
19:16:35 <notmyname> #topic summit prep
19:16:44 * notmyname got plane tickets yesterday
19:16:47 <notmyname> (finally)
19:17:07 <notmyname> #link https://etherpad.openstack.org/p/liberty-swift-summit-topics
19:17:23 <notmyname> that's where we're collecting our ideas for summit topics
19:18:07 <notmyname> as a reminder, the fishbowl sessions are large rooms (200-ish seats?) designed like previous summit sessions
19:18:24 <notmyname> the working sessions are smaller (30-ish seats) and will all have the same title on the schedule
19:18:50 <notmyname> they are designed to be more about smaller groups of people discussion specific copde and specific ideas' design
19:19:07 <notmyname> and then on friday we have a full day of "open" like we did in paris
19:19:22 <kota_> notmyname: as a reminder, how many slots for each session type?
19:19:31 <notmyname> good question
19:19:42 <notmyname> 6 fishbowl and 10 working, IIRC
19:19:56 <kota_> notmyname: thanks
19:20:00 <notmyname> so we'll be collecting ideas on that etherpad and scheduling from there
19:20:00 * clayg wishes *he* had a good question
19:20:03 <jrichli> you might have said before, but is each session for an hour?
19:20:08 <ttx> notmyname: confirmed
19:20:19 <ttx> each session is 40 minutes
19:20:26 <jrichli> ttx: thx
19:20:29 <ttx> (10 minutes between sessions)
19:20:52 <notmyname> ttx: thanks
19:20:53 <clayg> coffee, pee, argue, repeat
19:20:54 <notmyname> #link https://docs.google.com/spreadsheets/d/1VsFdRYGbX5eCde81XDV7TrPBfEC7cgtOFikruYmqbPY/edit#gid=569963128
19:20:54 <mattoliverau> acoles: Donagh may run a Docs working session, so I finally see you in your alter ego :P
19:21:04 <mattoliverau> lol
19:21:06 <jrichli> lol
19:21:08 * torgomatic has to bail
19:21:25 <notmyname> ttx: that's the right link, right? ^
19:22:12 <acoles> mattoliverau: i have a good make-up artist
19:22:28 <notmyname> the summary is: tuesday for ops, wed-friday for swift
19:23:10 <notmyname> ok, let's go over what's in the etherpad
19:23:15 <ttx> notmyname: looks like it
19:23:20 <scotticus> notmyname: can i get a link to it please?
19:23:33 <ttx> notmyname: ok, rc2 tag and tarball up
19:23:38 <clayg> looks like we start fishbowls on wednesday night and continue on thursday morning
19:23:40 <ttx> pushing announce
19:23:43 <notmyname> scotticus: which one?
19:23:49 <scotticus> etherpad
19:23:53 <cschwede> https://etherpad.openstack.org/p/liberty-swift-summit-topics
19:23:53 <notmyname> https://etherpad.openstack.org/p/liberty-swift-summit-topics
19:24:07 <scotticus> thanks.
19:24:39 <notmyname> ok, looks like I didn't add any detail to any of the ones I rushed to add last week ;-)
19:24:55 <notmyname> but there's a few new ones at the bottom
19:25:14 <jrichli> Did you want me to talk to Dean about doing a fishbowl on tape and swift?
19:25:15 <notmyname> cschwede: metadata search or object notification
19:25:28 <notmyname> jrichli: yes, please. or facilitate an intro
19:25:49 <jrichli> ok, I will talk with him.
19:26:18 <notmyname> for metadata search or object notification. what sort of sessions?
19:26:23 <notmyname> fishbowl or wokring session
19:26:30 <cschwede> notmyname: the metadata/search topic comes up from time to time, and i like to see some progress on it - thus preparing a spec to start some discussions
19:26:36 <notmyname> cool
19:26:46 <cschwede> notmyname: i think working might be better?
19:26:55 <notmyname> heh. everythign is working sessions ;-)
19:27:27 <clayg> probably just means we're anti-social and cliqueish
19:28:10 <cschwede> clayg: or focused on getting s… done…
19:28:10 <notmyname> I think it's a great topic, and yeah it would be cool to start work on it
19:28:39 <notmyname> ok, next
19:28:39 <clayg> notmyname: metadata search?  hrmmm...
19:29:00 <notmyname> clayg: well, notifying another system that will actually do the search ;-)
19:29:09 <notmyname> clayg: actually I'd love for that fucntionality to be in glance
19:29:13 <cschwede> notmyname: exactly like that
19:29:23 <cschwede> (another system)
19:29:38 <notmyname> also, that directly relates to the plea from zaqar on the mailing list this week for more adoption
19:29:38 <jrichli> metadata search: sounds like it wont play well with encrypted metadata
19:29:48 <notmyname> and I think this is one of the best places for it
19:30:07 <notmyname> jrichli: you havne't implemented fully-homomorphic encryption yet? ;-)
19:30:12 <notmyname> anyway, moving on
19:30:15 <notmyname> docs
19:30:19 <notmyname> this one is interesting
19:30:26 * clayg has a doubt
19:30:58 <notmyname> well, I think it's interesting because it's an ops person who submitted it rather than a dev
19:31:17 <notmyname> so, basically, make docs better
19:31:28 <notmyname> or rather, make a plan to make docs better
19:31:29 <mattoliverau> what, acoles is a dev :P
19:31:44 <notmyname> mattoliverau: gotta keep up the facade
19:31:47 * cschwede likes to see a good community-written reference doc on swift
19:31:51 <scotticus> notmyname: where do i put my proposal? at the bottom?
19:31:52 <mattoliverau> seriously tho, yeah, good to hear from another viewpoint
19:31:53 <acoles> mattoliverau: rumours rumours...
19:32:02 <notmyname> scotticus: yeah
19:32:04 <scotticus> k
19:32:37 <notmyname> ok, next up
19:32:46 <notmyname> last modified on container listing
19:32:52 <notmyname> sounds like a filesystem atime
19:32:59 <notmyname> kota_: this one's yours
19:33:19 <kota_> notmyname: yes, this is a first time I put this idea.
19:33:19 <notmyname> can this be covered in the metadata indexer one? is that a viable alternative implementation?
19:33:58 <kota_> notmyname: for now, so many change we don't need
19:34:04 <notmyname> kota_: oh! this is for a container, not on a per-object basis?
19:34:16 <kota_> notmyname: yes, on container.
19:34:36 <notmyname> yeah, I've been asked about a "listing of the stuff that has changed since Timestamp(foo)"
19:35:02 <cschwede> notmyname: that, please!
19:35:11 <notmyname> cschwede: typey typey
19:35:18 <kota_> notmyname: the use case is something like that :)
19:35:23 <notmyname> interesting
19:35:40 <notmyname> so should this be it's own session or should it be combined with another?
19:35:42 <notmyname> thoughts?
19:36:06 <kota_> ethier is fine but currently no idea
19:36:20 * cschwede starts thinking that we need an „OpenStack *Swift* Summit“ to cover all the interesting topics
19:36:58 <acoles> cschwede:paris in june?
19:37:26 <notmyname> :-)
19:37:33 <cschwede> acoles: notmyname: sounds good :)
19:38:03 <notmyname> I made a note about combining this one, but let's leave it separate and see what space is available
19:38:07 <notmyname> ok, next up
19:38:10 <notmyname> meeting time
19:38:15 <notmyname> thanks to who put that down
19:38:44 <notmyname> I'll be happy to lead that one, but I think it's just a friday discusion. no need for a 40 minute session on it
19:38:50 <notmyname> any objections?
19:38:54 <acoles> +1
19:39:01 <mattoliverau> will that take 40 minutes, so friday discussion makes sense
19:39:16 <kota_> +1
19:39:17 <mattoliverau> or in a bar somewhere ;)
19:39:29 <dmorita> +1
19:39:34 <kota_> mattoliveau: nice!
19:39:55 <notmyname> ok, last on one the list right now
19:40:03 <notmyname> scaling swift with go
19:40:09 <scotticus> :)
19:40:14 <notmyname> this is something I've been talking with scotticus for a little bit
19:40:27 <notmyname> and some of you know that RAX has reimplemented some of swift in go
19:40:31 <notmyname> so they want to talk about it
19:40:38 <notmyname> and I think that's great!
19:40:56 <notmyname> scotticus: will you have some code to show before vancouver?
19:41:02 <scotticus> yes.
19:41:04 <notmyname> good
19:41:13 <notmyname> when could we expect it? this week? next?
19:41:18 <scotticus> i think the team will push the object server and possibly a go based replicator and auditor soon.
19:41:30 <scotticus> within the next couple weeks probably
19:41:34 <notmyname> ok
19:41:37 <mattoliverau> +1, it'll be awesome to talk about and see :)
19:41:41 <scotticus> obviously we want to vet it
19:42:02 <scotticus> a bit
19:42:12 <notmyname> if we've got the code to talk about, I think it's a great thing to cover :-)
19:42:18 <scotticus> yup
19:42:30 <notmyname> for those of you who have been paying attention, swift now has a feature/hummingbird branch upstream
19:42:45 <notmyname> that was created to give them a place to push that code in the community
19:42:50 <clayg> i fetch and i fetch
19:43:12 <glange> good boy :)
19:43:13 <notmyname> so should this one be a fishbowl or a working session?
19:43:19 <notmyname> I almost think maybe both
19:43:20 <mattoliverau> a watched branch never commits :P
19:43:43 <clayg> let's just take over the two-day-nova-fishbowl-fiesta
19:43:49 <notmyname> :-)
19:43:56 <clayg> nope go-swift or go-home
19:44:53 <scotticus> notmyname: probably working session?
19:44:55 <notmyname> thoughts on having this in a larger session?
19:45:54 <mattoliverau> I'm happy with either
19:46:03 <notmyname> there's TONS of stuff to go over with the idea of golang stuff in swift. that's the kind of stuff I think would be great in a working sessions. API coverage details, testing, deployments
19:46:38 <notmyname> but the higher-level, "this is what we saw in swift and XYZ is the right answer" might be good in a fishbowl session?
19:46:39 <cschwede> the more the better!
19:47:02 <scotticus> that sounds pretty decent.
19:47:06 <clayg> notmyname: can we defer until we see the code?
19:47:14 <notmyname> heh ok :-)
19:47:18 <scotticus> i think we can tell everyone what we've found at scale and what we've done to help
19:47:36 <scotticus> and we can def have a session to discuss what the community wants to see out of a go based swift implementation.
19:48:02 <cschwede> so fishbowl+working?
19:48:12 <scotticus> workbowl?
19:48:20 <scotticus> fishing?
19:48:28 <kota_> lol
19:48:33 <notmyname> let's figure it out based on what we have to talk about. ie the code
19:48:37 <mattoliverau> lol
19:48:43 <scotticus> k
19:48:46 <notmyname> keep it on the list now with a question mark
19:48:55 <notmyname> decide later
19:49:23 <mattoliverau> yay, leave it to future us :)
19:49:26 <scotticus> k
19:49:29 <notmyname> ok, that's the (current) bottom of the list on the etherpad
19:49:30 <mattoliverau> I like them
19:49:41 <notmyname> anything else to bring up in this meeting for the summit scheduling?
19:50:07 <notmyname> ok, last topic then...
19:50:14 <notmyname> #topic swift-bench release
19:50:22 <notmyname> cschwede: you've got the floor
19:50:31 <cschwede> Sometimes I just want to run swift-bench locally for a quick check if everything works
19:50:32 <cschwede> Unfortunately swift-bench from pypi is broken, probably since a longer time :/
19:50:33 <cschwede> Lots of commits since the latest tagged version
19:50:35 <cschwede> There is also a minor bug, fixed here: https://review.openstack.org/#/c/175285/
19:50:36 <cschwede> It would be great if we could tag a new version after the fix has been committed, and release a new version on pypi
19:50:37 <cschwede> Doing this would make installing it (hopefully) as easy as "pip install swift-bench" again
19:50:38 <cschwede> What needs to be done to get a new version up on pypi?
19:50:39 <cschwede> tada
19:51:16 <notmyname> "lots"? like 8
19:51:33 <notmyname> cschwede: what needs to be done is to kick me in the pants to get it done. takes about 15 seconds
19:51:50 <clayg> notmyname: cschwede: well let's plan to do it like next week or something
19:51:51 <cschwede> notmyname: ok, maybe not lots, but useful/helpful fixes
19:52:02 <notmyname> cool, let's land https://review.openstack.org/#/c/175285/ and then release it
19:52:06 <clayg> notmyname: cschwede: I think I have some local hacks to swift-bench I carry around that I should just see if I need to git review or what
19:52:08 <cschwede> notmyname: clayg: thx, great!
19:52:17 <notmyname> clayg: ok
19:52:42 <notmyname> #action review https://review.openstack.org/#/c/175285/ and release swift-bench
19:52:53 <notmyname> cschwede: anything else there?
19:53:05 <cschwede> notmyname: no, thx!
19:53:08 <notmyname> #topic open discussion
19:53:15 <notmyname> anything else to bring up in the meeting this week?
19:53:25 <clayg> ok, nm - I think the only think i had left got fixed in I2fca4795fc9b3d1637c72616a52a60482d6e853e
19:54:02 <notmyname> ok, if nothing else...
19:54:13 <notmyname> thanks for working on swift and thanks for coming today!
19:54:17 <notmyname> swift isnt' possible without you
19:54:20 <notmyname> #endmeeting