07:02:47 <cschwede> #startmeeting swift
07:02:48 <openstack> Meeting started Wed Jun 28 07:02:47 2017 UTC and is due to finish in 60 minutes.  The chair is cschwede. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:02:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:02:51 <openstack> The meeting name has been set to 'swift'
07:03:16 <cschwede> Hello everyone! Who's here for our biweekly Swift-meeting?
07:03:24 <acoles> I am!
07:03:28 <mahatic_> me
07:03:29 <mathiasb> me too!
07:03:38 <tovin07_> me :D
07:03:42 <hieulq_> o/
07:03:49 <rledisez> i'm here o/
07:03:54 <clayg> o/
07:04:08 <jeffli> o/
07:04:13 <psachin> o/
07:04:24 <acoles> clayg: !
07:04:31 <kota_> hello
07:04:34 <kota_> i'm late
07:04:35 <mahatic_> clayg: hi!
07:04:42 <clayg> mahatic_: hello :D
07:05:13 <cschwede> awesome - so let's get started! our agenda for today is:
07:05:14 <cschwede> https://wiki.openstack.org/wiki/Meetings/Swift
07:05:17 <cschwede> #link https://wiki.openstack.org/wiki/Meetings/Swift
07:05:28 <cschwede> #topic Follow ups from last two weeks
07:06:48 <cschwede> I had a look at the topics from the last two meetings, and most of the followup are on our agenda for today (bugs, prio reviews etc). Has anyone another important follow up that needs to be discussed?
07:07:45 <mahatic_> none from me
07:08:21 <cschwede> alright, so let's continue with the next topic then
07:08:26 <cschwede> #topic Denver PTG - session ideas
07:09:17 <cschwede> PTG is taking place in ~10 weeks, and it's time to collect topic ideas. I duplicated our etherpad from the last time: https://etherpad.openstack.org/p/swift-ptg-queens
07:09:23 <cschwede> #link https://etherpad.openstack.org/p/swift-ptg-queens
07:10:02 <cschwede> i thought this worked well the last time - please feel free to add entries!
07:10:55 <cschwede> also, note that a limited hotel block is already open for reservation - more details on the mailing list post from Erin:
07:10:57 <cschwede> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118002.html
07:11:30 <acoles> cschwede: thanks, etherpad works well usually
07:11:59 <kota_> is it useful to add the etherpad link to meeting wiki?
07:12:10 <kota_> or topic on #openstakck-swift channel
07:12:10 <cschwede> kota_: already done :)
07:12:12 <mahatic_> thanks for the info
07:12:14 <kota_> nice
07:12:25 <kota_> thx
07:12:29 <mahatic_> kota_: yeah, adding to the topic is what is usually done I think
07:13:03 <cschwede> kota_, mahatic_: i'll ping notmyname to change the topic on #openstack-swift - good idea!
07:13:24 <mahatic_> thanks
07:13:28 <cschwede> ok, let's continue
07:13:43 <cschwede> #topic Reminder - Sydney summit: CFP
07:13:57 <cschwede> this is just a reminder, call for presentations is open for the Sydney summit
07:14:06 <cschwede> #link https://www.openstack.org/summit/sydney-2017/call-for-presentations/
07:14:35 <cschwede> #topic Bug triage
07:15:16 <cschwede> as you may have noticed, there were quite a few new open bugs in the last few days for Swift. Some are already in discussion, some not
07:15:33 <cschwede> So I had a look at all bugs for Swift in state New, and that list is quite long:
07:15:54 <cschwede> #link https://bugs.launchpad.net/swift/+bugs?field.searchtext=&orderby=-datecreated&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit
07:15:54 <cschwede> _dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on
07:16:13 <cschwede> link is also on https://wiki.openstack.org/wiki/Meetings/Swift
07:17:46 <cschwede> i'm wondering how we could triage this long bug list in a timely manner. some bugs are more questions, some are actually missing infos, and i'm sure some are important bugs that are not worked on yet
07:17:51 <cschwede> any ideas?
07:18:46 <mahatic_> maybe let ppl know when you're triaging a bug, so there's no overlap? (amongst other things)
07:19:41 <cschwede> for reference, here's a shorter link:
07:19:44 <cschwede> #link https://bugs.launchpad.net/swift/+bugs?orderby=-datecreated&search=Search&field.status%3Alist=NEW
07:19:54 <rledisez> is there rules on bugs like on reviews (eg: if i feel it must be closed i set -1, and someone with -2 rights can approve or not)
07:20:14 <acoles> cschwede: we have talked in the past about having a bug triage day - not sure we have ever actually done it
07:20:27 <cschwede> mahatic_: yes, i think the idea is to change the state then? for example, might be incomplete, or confirmed
07:21:04 <mahatic_> cschwede: correct
07:21:22 <mahatic_> as that's one of the things that needs to be done before getting to work on it
07:21:28 <cschwede> acoles: i remember - maybe we can do that, but split this a bit? for example, have groups of people in the same timezone working on 10 bugs each, instead of doing this for a whole day?
07:21:47 <acoles> rledisez: I *think* only cores can change bug importance but I know i would pay a lot of attention to a comment saying 'this is critical'
07:22:18 <kota_> acoles: correct
07:22:35 <cschwede> acoles: good point! so there needs to be at least one core taking part in each (sub-)triage
07:23:27 <mahatic_> rledisez: I think you could set the "status" per your investigation on the bug
07:24:31 <rledisez> mahatic_: yes, it seems i can edit it (as assigned to)
07:24:56 <mahatic_> great
07:25:13 <acoles> rledisez: ah, so you can change the bug status? or just assign the bug?
07:25:48 <mahatic_> I think he meant both?
07:25:50 <rledisez> acoles: both i think. i'll try on a bug later
07:26:05 <rledisez> i have the "pen" icon
07:26:06 <mahatic_> rledisez: example bug you can try on: https://bugs.launchpad.net/swift/+bug/1700036
07:26:07 <openstack> Launchpad bug 1700036 in OpenStack Object Storage (swift) "Less number of connection retries between proxy-server and container/object-server." [Undecided,New]
07:26:08 <mahatic_> :)
07:26:21 <clayg> I'm interested in the work sdauge is doing - he sent something to the ML - but worried about how an eventual migration to storyboard might effect efforts spent automating against launchpad and defining process for that tool
07:26:25 <acoles> rledisez: how about 'Importance'?
07:26:40 <mahatic_> rledisez: yup, you should see a drop down when you click on the "pen" icon
07:26:45 <mahatic_> for "status"
07:27:04 <mahatic_> I mean, dropdown == set of options
07:27:15 <cschwede> clayg: while there are discussions for some time, i think there is no schedule yet for us to switch over to storyboard?
07:27:23 <rledisez> acoles: i have the dropdown. but not for importance, i guess this one is for coredev only
07:28:12 <acoles> rledisez: for the time being, if you find a bug that should be high or ciritical then tell me or another core and we will bump the importance
07:28:26 <cschwede> ^^ that!
07:29:06 <cschwede> #info ping swift cores if you see bugs that are of critical or high importance
07:29:06 <clayg> I have another idea how we could solve that particular problem...
07:29:17 * cschwede gets curious
07:29:52 <clayg> nm
07:30:04 <clayg> cschwede: yeah i don't know the status of the storyboard migration either
07:30:25 <clayg> I do think that attacking the bug triage problem with automation is the right approach
07:30:59 <acoles> surely a migration to storyboard will preserve bug status etc? or is there a concern our triage would be lost in migration?
07:31:09 <clayg> if it wasn't for the backlog it'd probably be fairly manageable to keep up with bug status if we stayed on top of it
07:32:07 <cschwede> here is the ML post from Sean on the bug triage that clayg mentioned:
07:32:10 <cschwede> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118868.html
07:32:46 <clayg> i was thinking more about usefulness of scripts that push lauchpad statuses around... stuff like "in progress with no open patch"
07:33:11 <clayg> or "new/undecided" > 1 yr old (should => needs information or invalid)
07:33:33 <cschwede> clayg: so, should that become invalid or new (i mean the "in progress with no open patch")?
07:34:01 <clayg> probably go back to new
07:34:27 <mahatic_> seems the default itself is "new" and "undecided"
07:34:35 <cschwede> yeah, that was my thinking as well. however, that would cleanup the state somewhat, but then we'd have even more bugs in state new
07:34:46 <cschwede> that need to be triaged
07:35:35 <acoles> gerrit doesn't reliably update bugs with patch references, especially if the Closes-Bug is not in first patch version IIRC
07:35:58 <cschwede> also, do we need some more precise notes when opening a new bug? i remember there were some bugs a few days ago which lacked some required infos
07:36:05 <clayg> acoles: we could troll our commit log and make sure to push lp to the correct state
07:36:10 <cschwede> and acoles also tried to ping the author on irc without success
07:36:26 <cschwede> clayg: neat!
07:37:08 <acoles> clayg: yes, for merged patches, but for in progress ... cross reference gerrit ?
07:37:58 <acoles> actually, launchpad  does seem to get updated when patches are released, it is the in progress that go AWAOL
07:38:04 <acoles> AWOL*
07:38:31 <cschwede> here's a proposal: i'll have a look at Seans work, and on automating LP in general and will follow up in next weeks meeting? sounds like this also needs a broader coverage within the community?
07:38:40 <cschwede> (ie the other meeting)
07:39:40 <clayg> acoles: ok, i understand - yeah checking gerrit is probably a good idea
07:40:01 <clayg> we could probably use some information about the patch status to help add some tagging
07:40:07 <acoles> does swift have a list of 'common' bug tags? I have used ec, low-hanging-fruit - if we start to tag we need to use a common set of tags
07:40:21 <clayg> "has patch" "patch is +2'd" kind of tagging could help get bugs closed
07:41:01 <acoles> clayg: ^^ nice
07:41:18 <kota_> clayg: +1
07:41:31 <clayg> acoles: seans email talked about trying to classify bugs under various modules/sub-teams
07:41:56 <clayg> we could probably spot a ring bug vs. api?
07:42:00 <mahatic_> patch status tag idea is good!
07:42:15 <acoles> clayg: yes
07:42:36 <clayg> acoles: but I'm not aware of anyone writing down what we think a good list of appropriate tags for swift bugs would look like
07:43:00 <cschwede> clayg: so we have to start with that, right?
07:43:01 <clayg> acoles: maybe we need way-out-reach-fruit
07:43:19 <acoles> clayg: lol ... 'no-hope'
07:43:22 <mahatic_> :D
07:43:44 <clayg> cschwede: maybe... I mean *probably*
07:43:57 <clayg> it would help me if I had some idea how we thought we were going to get these tags onto the bugs
07:44:06 <cschwede> right
07:44:44 <cschwede> i'd say we'll continue this discussion in next weeks meeting? and i start an etherpad with some ideas inbetween?
07:45:03 <clayg> to some extend I think the actual tags themselves can be a somewhat emergent observed set - we could bikeshed over names - but if we know *how* to tag a bug that has a single-plus-2 patch we could name the tag "acoles-look-at-this-one" and that'd be fine
07:45:10 <mahatic_> an etherpad to list out tags we think are appropriate would help
07:45:35 <clayg> ^ yeah or just do that and get the creative juices flowing
07:45:45 <cschwede> acoles will get a lot of extra work if we automate the "acoles-look-at-this-one" tag
07:46:16 <acoles> does it filter ones that have *my* +2 ;) or do I get to go in circles
07:46:41 * acoles imagines becoming infinitely trapped in launchpad
07:47:09 <cschwede> this discussion is great, but let's continue with the next topic and follow up on this one - only 14 mins left
07:47:13 <cschwede> #action cschwede to start etherpad for bug tag ideas, investigate automation of LP bug state changes and report in next meeting
07:47:31 <clayg> cschwede: awesome
07:47:34 <clayg> good work
07:47:50 <cschwede> alright
07:47:53 <cschwede> #topic Priority Reviews
07:47:58 <acoles> I would love it if launchpad 'learnt' the tags we were commonly used an offered them on the UI...I have a vague recollection of there being some way to setup project tags in launchpad...that of course only helps humans
07:48:03 <cschwede> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
07:48:53 <cschwede> there was some progress on the linked prio reviews (thx Tim & Matt!), but the list didn't get shorter from the last time
07:48:55 <acoles> https://bugs.launchpad.net/swift/+manage-official-tags
07:49:01 <acoles> yes! ^^
07:49:09 <acoles> oh, sorry, we moved on
07:49:27 <cschwede> acoles: i'll noted that for the follow up, thx for looking into it!
07:50:58 <cschwede> is the list of prio reviews exhaustive, are there any other patches that need some higher priority when reviewing?
07:51:22 <mahatic_> a couple of bugs on that page are merged, it probably needs some updating
07:52:21 <cschwede> mahatic_: ah, right. i only had a look at the ones i included in the agenda (https://wiki.openstack.org/wiki/Meetings/Swift). updating the prio page should be a ... prio ;)
07:52:46 <mahatic_> :D
07:53:02 <cschwede> #action cschwede will update https://wiki.openstack.org/wiki/Swift/PriorityReviews
07:53:26 <cschwede> ok, if there is nothing special to discuss here, let's continue
07:53:28 <acoles> rledisez: any progress on https://review.openstack.org/#/c/472659/? (needs tests)
07:53:54 <acoles> which fixes https://bugs.launchpad.net/swift/+bug/1652323
07:53:55 <openstack> Launchpad bug 1652323 in OpenStack Object Storage (swift) "ssync syncs an expired object as a tombstone" [Medium,Confirmed]
07:54:26 <clayg> acoles: he's going to be too busy reviewing patch 428408 and patch 478416 to be bothered with tests - you'll have to do it ;)
07:54:33 <rledisez> acoles: no, sadly i've been very very busy
07:54:45 <rledisez> i'll really try to find some time by the end of the week
07:55:13 <rledisez> clayg: noted, on my (too long) todolist ;)
07:55:42 <acoles> rledisez: well, clayg has bullied me now
07:55:55 <cschwede> #topic Open Discussion
07:56:01 <acoles> rledisez: I have a probe test patch that I think can be adapted easily
07:56:17 <tovin07_> I have one patch that need some comments
07:56:17 <tovin07_> #link https://review.openstack.org/#/c/468316/
07:56:21 <acoles> rledisez: I'll try to put some time on it
07:56:24 <cschwede> that already sounds like an open discussion, anything else for this meeting? a couple of minutes left
07:56:51 <clayg> notmyname: is out - this is the only meeting today
07:57:28 <cschwede> #info notmyname is out - no Swift meeting at 2100UTC today
07:57:46 <tovin07_> can anyone take a look at patch 468316? :D
07:59:13 <cschwede> tovin07_: i'll have a look at it at the end of the week
07:59:30 <tovin07_> cschwede, thanks!
08:00:06 <cschwede> Alright, thanks everyone for attending this meeting, your ideas and contributions to Swift! Talk to you soon on #openstack-swift again :)
08:00:08 <cschwede> #endmeeting