21:00:08 <notmyname> #startmeeting swift
21:00:09 <openstack> Meeting started Wed Jul 12 21:00:08 2017 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:12 <notmyname> who's here for the swift team meeting
21:00:13 <openstack> The meeting name has been set to 'swift'
21:00:31 <acoles> here
21:00:33 <jungleboyj> @!
21:00:33 <_pewp_> jungleboyj ( ^_^)/
21:00:39 <torgomatic> hi
21:01:13 <cschwede> o/
21:01:14 <tdasilva> hi
21:01:23 <mattoliverau> o/
21:01:25 <jrichli> o/
21:01:26 <kota_> hi
21:01:29 <mathiasb> o/
21:01:32 <notmyname> hi jrichli!
21:02:05 <jrichli> notmyname o/
21:02:50 <notmyname> ok, so just 9 hours ago, half of you were in the 0700 meeting where I said the 2100 meeting would be exactly the same :-)
21:03:04 <jungleboyj> *Laughing*
21:03:07 <notmyname> welcome :-)
21:03:11 <cschwede> notmyname: shall we leave then? ;)
21:03:20 <notmyname> cschwede: you should stay. everyone else can go ;-)\
21:03:28 <cschwede> lol
21:03:29 <tdasilva> lol, cschwede sounded like that ;)
21:03:48 <notmyname> I just figured you wanted sleep/breakfast/dinner/whatever
21:04:08 <notmyname> ok, let's go through it then
21:04:10 <torgomatic> here's a small difference for you: 3091a594d6dc0bd360f498af5bef4c71
21:04:12 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
21:04:15 <mathiasb> repetition is the mother of all learning!
21:04:18 <torgomatic> that's 128 random bits, just to shake things up :)
21:04:29 <notmyname> torgomatic: whoa!
21:04:37 <jungleboyj> notmyname:  They didn't trust you.
21:04:53 <notmyname> torgomatic: it's unlikely any meeting ever will have that string again
21:04:59 <notmyname> #topic Denver PTG
21:05:10 <notmyname> the PTG is coming up
21:05:15 <clayg> i still haven't signed up - but will today
21:05:16 <notmyname> topic etherpad is at
21:05:19 <jungleboyj> 3091a594d6dc0bd360f498af5bef4c71
21:05:19 <notmyname> #link https://etherpad.openstack.org/p/swift-ptg-queens
21:05:38 <notmyname> if you haven't signed up for the ticket or hotel, please do so soon. today would be good
21:05:55 <notmyname> all the links can be found at https://www.openstack.org/ptg
21:06:02 * tdasilva imagines everybody will copy and paste that string next week
21:06:16 <jrichli> tdasilva, lol
21:06:30 <notmyname> for the week's schedule, monday and tuesday will be more of an emphasis on cross-project topics, and we'll have a room for swift wed-friday
21:06:38 <jungleboyj> tdasilva:  Wondered if anyone was going to comment on me being a smart-a$$
21:06:59 <tdasilva> jungleboyj: heh ;)
21:07:10 <notmyname> and I'm sure that if there are swift people together on mon-tues without something else going on, we'll grab a table, corner, or room
21:07:35 <notmyname> also, please encourage any ops you see to attend the PTG
21:07:52 <notmyname> if you have to make a choice between the PTG and the sydney summit, choose the ptg
21:08:26 <notmyname> I expect to have very light attendance at the sydney summit. the ptg will be far better for contributors (devs and ops) to work together
21:09:00 <notmyname> honestly, it's still an open question if I'll be going to the summit. don't know yet
21:09:18 <notmyname> any questions about the ptg?
21:09:37 <notmyname> ok. moving on then
21:09:44 <notmyname> #topic bug triage
21:10:13 <notmyname> cschwede has been doing some great work on organizing the work that needs to be done to get a handle on our bugs
21:10:38 <notmyname> there's some tools available at
21:10:39 <notmyname> #link https://github.com/sdague/nova-bug-tools#existing-tools
21:10:46 <notmyname> look at the bottom of that page
21:10:59 <notmyname> cschwede: can you give a quick recap of what we got to at the previous meeting?
21:11:04 <cschwede> sure
21:11:45 <cschwede> there is one specific tool that runs over all bugs and can close them if they are too old. i dry-run it and this is the result (ordered by me):
21:11:52 <cschwede> #link http://paste.openstack.org/show/615138/
21:12:21 <cschwede> there are a few more tools that can do some nice tricks like searching for gerrit reviews and attach them to the bugs
21:12:35 <cschwede> or update the state depending on the patch state
21:12:56 <cschwede> however, these tools would only help with a small number of bugs (15-35, depending on what we want to do)
21:13:21 <notmyname> cschwede: nicely cleaned up list :-)
21:13:54 <cschwede> the tool that produced above linked list can be used to shrink the list, but it would be automatically. ie we have only a very limited influence on it
21:14:11 <notmyname> what's the first column in that list?
21:14:16 <cschwede> age in days
21:14:21 <notmyname> ah
21:14:48 <clayg> yeah i could work on a chunk!
21:14:54 <cschwede> so, one idea we had this morning was to paste the list into an etherpad, and everybody grabs a chunk of that list and works on that
21:15:01 <cschwede> to avoid duplicate work
21:15:12 <clayg> *brilliant*
21:15:23 <cschwede> i think most of us are a little bit afraid of closing bugs without reviewing them
21:15:42 <clayg> roughly - terrified - why? - don't know
21:16:00 <clayg> what if the bug report was *the key* - THE KEY!?
21:16:01 <notmyname> clayg: yep, that's exactly what we said this morning :-)
21:16:02 <cschwede> clayg: there might be some "good/nice to have" bugs in that list
21:16:12 <cschwede> and we don't want to autoclose them
21:16:32 <cschwede> (we can exclude bugs with a tag like wishlist or low-hanging-fruit, but thats the minority of bugs)
21:17:09 <cschwede> did i forget anything from this morning?
21:17:09 <clayg> community todo lists are weird... on MY todo lists I can say "nope not today" or even "ah ^&*# it, it's not gunna get done" - it's harder to do that when the "who is responsible for this?" is *wide* open
21:17:41 <notmyname> cschwede: I like the idea of chunking up the list of bugs. assign names to them for triage, and track it every meeting for accountability
21:18:24 <clayg> notmyname: don't forget the part about "grab a list" to avoid duplicate work
21:18:36 <jungleboyj> cschwede:  Cinder has just blanket closed things in the past.  The ones someone cares about get re-opened.  ;-)
21:18:45 <notmyname> right. that's what I mean by assing names for triage. eg you take 1-15, I take 15-30, etc
21:18:53 <cschwede> i mean it's "only" 300 bugs. if all active cores tackle at least 5 bugs per week, we're nearly done in Denver.
21:18:59 <clayg> notmyname: it would help to have some common guidelines tho - so people can feel confidient making decisions independently w/o risk of reprisal?
21:19:11 <cschwede> clayg: good point! +1
21:19:35 <clayg> cschwede: that's a great way to frame it!  I want to do 5 for sure - where is tdasilva ?
21:19:36 <cschwede> we should add a tag "needs-consensus" or sth like that
21:19:39 <notmyname> acoles mentioned that having some sort of voting in LP would be great, to avoid that very situation of one person only seeing or not seeing something
21:19:59 <cschwede> notmyname: add a specific tag for it?
21:20:07 <clayg> tdasilva: you have been *Killing* it on bug triage!?  I see updates form lp and I constantly screaming at my computer "heck yes!  tdasilva!  get some!  go go go!"
21:20:15 <notmyname> what if we assigned overlapping sets? eg I do 1-5, clayg does 3-8, cschwede does 6-10, etc
21:20:19 <acoles> if we're tracking on an etherpad then if I am 50/50 about a bug I'll just mark it on etherpad and throw it back for second opinion?
21:20:31 <cschwede> notmyname: we split it into chunks in the etherpad because of that
21:20:39 <cschwede> notmyname: and write our names to each chunk
21:20:40 <acoles> which is nuts because we have launchpad, so yes maybe a tag would do it
21:20:40 <clayg> notmyname: modulo strategies are subject to ordering issues
21:20:43 <tdasilva> clayg: yeah, but I do fear that I will get yelled at at some point
21:21:07 <notmyname> tdasilva: here's me yelling: "YOU'RE DOING A GREAT JOB! KEEP IT UP!"
21:21:13 <cschwede> tdasilva: don't worry, rock on :D
21:21:16 <clayg> tdasilva: ^ that 100%
21:21:38 <tdasilva> my fear with needs-consensus tag, is that then it forces everyone to look at (almost) everything ??
21:21:47 <notmyname> yeah
21:21:48 <acoles> tdasilva: we will escort you at all times at PTG :)
21:21:54 <tdasilva> acoles: lol
21:22:30 <notmyname> so what acoles just said makes sense. most are likely to not need multiple people. if so, make a note on the etherpad, someone else will look at it on next block assignments
21:22:31 <clayg> tdasilva: i was hoping you could give more guidance like "there are what I see as 3 broad classes of bugs ..."
21:22:36 <tdasilva> maybe instead of assiging chunks to an individual, we can assign chunks to a group of 3 people
21:22:45 <clayg> and tell us a little bit about what's out there - and how you're taking that on?
21:22:56 <clayg> basically - what is your secrets you brilliant man!?
21:23:15 <clayg> then we can all say "yes, that 100% - everyone be like tdasilva - grab 5 and ask 'what would tdasilva do?'"
21:23:43 <notmyname> tdasilva: build a ring. each of us are drives. make the replica count the size of the chunks. part number is mapped to bugs. let get_nodes() sort it out ;-)
21:23:50 <clayg> tdasilva: notmyname: cschwede and this doesn't have to be an on-the-spot thing?
21:24:02 <tdasilva> notmyname: perfect!
21:24:15 <mattoliverau> Lol
21:24:23 <kota_> are we devices? :)
21:24:25 <torgomatic> notmyname: this makes an excellent incentive to lose weight...
21:24:30 <clayg> oh dear
21:24:32 <notmyname> torgomatic: lol
21:24:40 <tdasilva> rofl
21:24:42 <acoles> tdasilva: can i be in your group of 3? ;) I think what notmyname said - if in doubt leave a comment (e.g. I think this is invalid but...) and leave on etherpad, otherwise close it and delete from etherpad??
21:24:43 <notmyname> ok ok ok
21:25:12 <notmyname> can cschwede keep going on his data mining and build an etherpad?
21:25:19 <cschwede> sure
21:25:38 <notmyname> at first glance, I really like the organization in the pastebin
21:25:45 <clayg> I just want some rough guage of what I'm doing when I grab my 5 bugs?  is the goal to... reproduce the issue and add context?  decide if this is a bug or some feature that someone asked for but isn't working on?  Is it *terrible* and everything is mostly bad until it's fixed (think every client disconnect resource leak bug we've ever had and the current open ones)?
21:26:23 <cschwede> notmyname: let me know if we need some other data, different groups or whatever
21:26:34 <notmyname> first goal is to close it if it's obviously no longer valid or already fixed
21:26:45 <clayg> acoles: that's the ticket!  so one goal would be "close invalid bugs" - maybe 50% are invalid at this point?  Maybe it's 70%!?
21:27:01 <clayg> notmyname: good restatement
21:27:02 <acoles> clayg: my 2pence worth - first pass, categorize e.g. wishlists, invalids; second pass, try to confirm
21:27:06 <notmyname> second is to repro it enough to confirm it or put it in needs info
21:27:18 <cschwede> i can add the data from the other tools, like commits that mention that bug etc
21:27:28 <notmyname> third (bonus points) is to repro well enough to easily construct a failing test for it
21:27:38 <acoles> clayg: it's like we need handoffs_only to get rid of the crap ;)
21:27:39 <notmyname> acoles: yeah, that's good
21:27:43 <clayg> tdasilva: have you *found* some of these "obviously invalid" bugs!?
21:28:10 <clayg> tdasilva: or do you have to more or less try and repo to be like "I'm ~80% sure this is fixed because it sure seems to not be a problem as described?"
21:28:30 <notmyname> eg "mirror trans-id to openstack-request-id https://api.launchpad.net/1.0/bugs/1572786" is done and released already
21:28:44 <notmyname> so there's an example
21:28:54 <clayg> I thought I saw some going from "fix released" to like "no srly fix released" or w/e the lp terms are?  Can't we just bot that state change away?  Does it *matter* to anyone what the difference is!?
21:29:09 <tdasilva> clayg: a lot of what I have been closing recently was bugs that were marked as fix committed, but never got set to fix released
21:29:34 <notmyname> "fix committed" was something that used to be used by the openstack bots. don't use that. it's either open, being worked on, or "fix released"
21:29:35 <tdasilva> I think there's a bot to make that change, but it doesn't seem to change the state if the bug is not assigned to anyone
21:30:04 <clayg> wtf is up with hudson-openstack -> "This issue was fixed in the openstack/swift 2.11.0 release."
21:30:15 <clayg> can we just *search* for that message!?  why is that bug still "in progress"
21:31:21 <clayg> tdasilva: yeah - so I don't want my 5 bugs to be 3 of those - that's just lame - is that really where we're at?
21:32:06 <notmyname> so far, what we've discussed/decided from this meeting and the 0700 one is that (1) there's some mapping from gerrit to LP that can happen via script and cschwede is doing that and (2) cschwede will group the old LP bugs of questionable status into an etherpad and we'll start triaging them a block at a time
21:32:10 <notmyname> does that make sense?
21:32:11 <cschwede> tdasilva: i didn't look into them, were the fixes really released?
21:32:15 <notmyname> did I miss something?
21:32:23 <clayg> cschwede: have you looked at the source of any of these scripts you've been running - does it make more sense to apply humans to this or is the raw materials there to do this from the command line?
21:32:45 <cschwede> clayg: these scripts are pretty easy to hack, i already did that a bit
21:32:56 <tdasilva> cschwede: clayg but I think I closed all of the now :)
21:32:56 <clayg> cschwede: hellz yeah you did - awesome
21:33:09 <clayg> tdasilva: ah, ok - that's good!
21:33:09 <tdasilva> I left only one that was related to swift3 and i wasn't sure about
21:34:16 <clayg> notmyname: I think you're summary is correct then - I think i side tracked on a particularlly weird/dumb state that you pointed at and tdasilva has mostly cleaned up - so let's move forward with the blocks - and we all do 5 for next week - then report back and correct!?
21:34:33 <clayg> cschwede: tdasilva: you guys are amazing!?  where's the etherpad link - i want to pick my 5 now - i want good ones
21:34:42 <tdasilva> sounds good
21:34:45 <clayg> torgomatic: don't you try and get my good ones
21:34:53 <notmyname> cschwede is on the etherpad. he's about to go to bed, but he'll put it up tomorrow, I hope ;-)
21:34:54 <cschwede> clayg: there is no etherpad yet, but i will update the list and prepare one tomorrow
21:34:57 <notmyname> (see what I did there?)
21:35:01 <clayg> oh...
21:35:20 <clayg> ok, good call.  cschwede ML/async maybe then?
21:35:30 <cschwede> clayg: sure!
21:35:32 <clayg> and thanks again (and again and again and again!)
21:35:42 <acoles> + thank cschwede and tdasilva
21:35:51 <cschwede> no problem, you're welcome!
21:35:56 <mattoliverau> +1
21:36:09 <notmyname> #topic docs migration
21:36:16 <tdasilva> notmyname: just one more thing
21:36:19 <tdasilva> about bugs
21:36:19 <clayg> #action thank cschwede and tdasilva for amazing efforts and great results for swift bug triage
21:36:19 <acoles> notmyname: are you going to plot graphs of our bug burndown ;)
21:36:34 <notmyname> tdasilva: what's up?
21:37:02 <tdasilva> so, I think doing this fire drill of triaging existing bugs is great, but it's like day1, I think long term we should also thing about some kind of sane process to keep triaging
21:37:29 <tdasilva> once we have (hopefully) gone through this big list, how do we not get into this state again?
21:37:40 <notmyname> good point
21:37:56 <tdasilva> we don't need to answer that now, but maybe a good discussion for ptg
21:38:23 <notmyname> I hope that going through the old ones will help us exercise our triage muscles so it's not as painful as ongoing work
21:38:31 <notmyname> and yes, it's already listed on the topic etherpad :-)
21:38:51 <notmyname> tdasilva: cschwede: I really hope you can help lead that topic at the ptg
21:39:18 <tdasilva> heh, I see what you did there :)
21:39:18 <notmyname> ok, for docs migration...
21:39:27 <notmyname> I said a lot of words this morning at http://eavesdrop.openstack.org/meetings/swift/2017/swift.2017-07-12-07.00.log.html#l-142
21:39:42 <notmyname> but the summary of that summary is that we're taking on a lot more docs, and it's a really really good thing
21:39:48 <clayg> and I also hope we can remember that as much as good ideas/tools/process - effective bug triage takes elbow grease too!  So be prepared to pitch in - it's totally worth it!
21:40:03 <notmyname> but it will result in some more work, of course, and it will result in some existing docs links breaking
21:40:06 <clayg> tdasilva: cschwede: thanks for being doers/leaders!
21:40:42 <clayg> notmyname: from my desk that host is broke?
21:41:05 <notmyname> weird. here too, but I had it pulled up already
21:41:40 <notmyname> it's ok, it's fine to read async later
21:41:59 <notmyname> #topic upcoming releases
21:42:17 <notmyname> I'd like to tag swift and swiftclient as early as next week, if possible
21:42:34 <notmyname> I think swiftclient is possible, swift slightly less likely (but still possible)
21:42:40 <notmyname> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
21:42:51 <notmyname> priority reviews has new "next release" sections
21:43:07 <notmyname> for swiftclient, patch 449771 needs reviews
21:43:07 <patchbot> https://review.openstack.org/#/c/449771/ - python-swiftclient - Buffer reads from disk
21:43:25 <notmyname> patch 475038 will get another patch set from timur, but likely not until late this week
21:43:25 <patchbot> https://review.openstack.org/#/c/475038/ - python-swiftclient - Allow for uploads from standard input.
21:43:38 <notmyname> for swift, patch 448480 needs reviews
21:43:38 <patchbot> https://review.openstack.org/#/c/448480/ - swift - DB replicator cleanup
21:43:53 <notmyname> and keep and eye on clay's new patch 478416
21:43:53 <patchbot> https://review.openstack.org/#/c/478416/ - swift - WIP: Add multiple worker processes strategy to rec...
21:44:02 <notmyname> super awesome stuff, but not quite ready for full review
21:44:14 <notmyname> the bugs are high priority: important, but not blocking
21:44:32 <notmyname> if there's stuff that needs to be added, please addit and let me know or let me know and i can add it
21:44:53 <notmyname> any questions/thoughts on this?
21:45:33 <notmyname> #topic open discussion
21:45:39 <notmyname> anything else to bring up this week?
21:46:50 <notmyname> if you've been looking at contributor trends, you've noticed swift's been down recently. however, the graphs show a recent uptick
21:46:53 <notmyname> http://d.not.mn/active_contribs.png
21:47:00 <notmyname> so that's nice :-)
21:47:12 <notmyname> tdasilva: cschwede: thanks again for the bug triage work
21:47:21 <notmyname> please don't forget to register for the ptg asap
21:47:29 <notmyname> I'm looking forward to seeing everyone there
21:47:46 <notmyname> thanks for all your work on swift
21:47:49 <notmyname> #endmeeting