07:00:27 <kota_> #startmeeting swift
07:00:28 <openstack> Meeting started Wed Jul 26 07:00:27 2017 UTC and is due to finish in 60 minutes.  The chair is kota_. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:31 <openstack> The meeting name has been set to 'swift'
07:00:34 <kota_> Hello
07:00:51 <kota_> who's coming swift meeting?
07:01:00 <mahatic> hello! /me
07:01:14 <acoles> hi
07:02:12 <kota_> notmyname said he is absent this meeting
07:02:28 <kota_> and mkazuhiro is now in summer vacation
07:02:56 <kota_> it looks like today may be small team meeting :P
07:03:09 <mahatic> heh, yeah
07:03:11 <acoles> it'll still be great :)
07:03:17 <kota_> thx
07:03:22 <mahatic> :)
07:03:23 <kota_> meeting wiki was updated
07:03:32 <kota_> #link https://wiki.openstack.org/wiki/Meetings/Swift
07:03:50 <kota_> #topic release schedule
07:04:10 <kota_> notmyname notified me for the release schedule
07:04:22 <kota_> he is now preparing the new release
07:04:53 <kota_> and the important date for the release, swift-client will be in Wed for him and swift release will be in this weekend
07:05:26 <kota_> i'd like to catch up some patches on priority reviews for the release
07:05:37 <kota_> the priority reviews are listed in https://wiki.openstack.org/wiki/Swift/PriorityReviews
07:05:41 <kota_> as you all known
07:06:06 <kota_> does anyone has update for the patches?
07:06:33 * kota_ starting from swift-client
07:06:36 <acoles> I have been working a lot on https://review.openstack.org/#/c/478416 (multi process reconstructor) and hope to get +2 on that today
07:06:48 <kota_> ok, let's start from Swift
07:06:52 <acoles> hehe sorry!
07:06:53 <kota_> thanks acoles
07:07:37 <acoles> we don't seem to have had any activity on https://review.openstack.org/#/c/448480
07:07:38 <kota_> acoles: ok and it looks like timburk also is looking the patch?
07:07:56 <acoles> kota_: yes Tim is working on multi-proc recons too
07:08:13 <acoles> hopefully we have that covered for reviews
07:08:15 <kota_> ok, hope it get merged before cutting the release
07:08:20 <acoles> yep
07:08:46 <kota_> and I'm on https://review.openstack.org/#/c/477000/
07:09:18 <mahatic> I'll look at patch 448480
07:09:25 <acoles> mahatic: thanks
07:09:26 <kota_> timburk already add his +2 and I'm closing to get it to +A. Code looks to be fine to me (thanks acoles)
07:09:40 <kota_> and now under the test for 477000
07:09:44 <mahatic> it's been sitting there a while and no longer WIP, so seems ready for a review
07:09:45 <acoles> kota_: thank you! I would love to have that in the release too
07:10:15 <acoles> if i get some time I will also try to look at 448480
07:10:21 <mahatic> acoles: thanks too
07:10:37 <mahatic> since there is no patchbot :(, "
07:10:38 <mahatic> DB replicator cleanup" is the title of the patch
07:10:51 <kota_> yup, thanks
07:10:56 <mahatic> excuse the formatting
07:11:14 <kota_> how about priority bugs?
07:12:52 <acoles> the first patch in list is ready IMHO https://review.openstack.org/#/c/472659/
07:13:05 <acoles> I know that is causing rledisez some pain in production
07:13:33 <kota_> ok. nice to hear, it's ready for review
07:13:47 <mahatic> the second one status is "won't fix" on launchpad
07:14:26 <mahatic> oh that status is not for Swift I think
07:14:30 <acoles> mahatic: this one https://bugs.launchpad.net/swift/+bug/1572719 ?
07:14:30 <openstack> Launchpad bug 1572719 in OpenStack Object Storage (swift) "Client may hold socket open after ChunkWriteTimeout" [High,Confirmed]
07:14:38 <mahatic> acoles: yeah
07:14:42 <kota_> yup, it's for security advisary
07:14:46 <acoles> OIC
07:15:11 <kota_> and the reason seems from "Since the report is already public,"
07:15:27 <kota_> looking at the last comment #19
07:15:58 <kota_> and it looks like no patch was not proposed yet
07:17:09 <kota_> for the last item, clayg commented it's related to the second one
07:17:42 <kota_> i.e. bug bug/1568650 is related to bug 1572719
07:17:42 <openstack> bug 1572719 in OpenStack Object Storage (swift) "Client may hold socket open after ChunkWriteTimeout" [High,Confirmed] https://launchpad.net/bugs/1572719
07:17:44 <mattoliverau> o/ sorry I'm late, had to pick up the daughter from her grandparents
07:17:57 <kota_> mattoliverau: welcome :)
07:17:59 <acoles> mattoliverau: o/
07:18:05 <mahatic> mattoliverau: o/ welcome
07:18:10 <acoles> mattoliverau: we just ssigned you all the hard work ;)
07:18:17 <mahatic> :D yeah ;)
07:18:18 <acoles> assigned*
07:18:27 <kota_> congrats mattoliverau ;-)
07:19:07 <mattoliverau> Damn
07:19:10 <mattoliverau> :p
07:19:50 <kota_> summarize on the 2 bugs in the list, it seems we want to hear the status to clayg in 2100 meeting. he commented to the lp
07:20:05 <kota_> ok, moving onto the swift client
07:20:28 <kota_> patch https://review.openstack.org/#/c/449771/ got merged, nice
07:20:44 * acoles has been very bad at doing swiftclient reviews recently :/
07:20:45 <kota_> thanks joel and pete
07:20:57 * kota_ is feeling too :/
07:21:39 <kota_> one more patch for swift-client https://review.openstack.org/#/c/475038/ this already has Tim's +2
07:23:02 <kota_> hmm... but swift-client release schedule is too close since now.
07:23:29 <kota_> this may be just a reminder.
07:24:05 <mattoliverau> I'm getting in trouble for working too much on my last week of "holidays" so might be a little light on further reviews and triages before next week.
07:24:19 <kota_> does anyone have priority patch for review?
07:24:23 <kota_> mattoliverau: ok
07:24:55 <kota_> and proposed changelog for the next swift release is https://review.openstack.org/#/c/485839/
07:25:37 <acoles> kota_: nothing other than what is on the wiki
07:25:51 <kota_> ok
07:26:06 <kota_> and proposed changelog for swiftclient is here, https://review.openstack.org/#/c/485859/
07:26:28 <kota_> k, let's move to the next topic
07:26:39 <kota_> #denver-ptg
07:26:42 <kota_> no
07:26:49 <kota_> #topic denver-ptg
07:27:19 <mahatic> kota_: just a question on Swift release
07:27:30 <kota_> mahatic: go ahead
07:27:31 <mahatic> do we have a deadline yet for that?
07:28:25 <kota_> I don't think, it's concrete but basically this release depends on OpenStack schedule
07:28:26 <mattoliverau> I think notmyname said he wanted by end of week or something.. in an ideal world that is.. unless I'm remembering wrong :p
07:28:49 <kota_> it's like Pike-3 so I don't think we could make delay much.
07:29:10 <mahatic> mattoliverau: kota_ okay, thanks
07:29:21 <kota_> #link https://releases.openstack.org/pike/schedule.html
07:29:23 <acoles> I heard end of week is goal too
07:29:48 <kota_> pike-3 milestone is Jul 24 - Jul 28
07:30:57 <kota_> moving back to the ptg
07:31:13 <mahatic> kota_: acoles ack
07:31:42 <kota_> though i don't think you all not yet register the ptg but the registration is https://www.openstack.org/ptg/ and do it asap if you didn't register yet
07:32:12 <kota_> and etherpad for topics is https://etherpad.openstack.org/p/swift-ptg-queens
07:32:36 <kota_> oh sorry, mahatic. I think I heard you won't be there?
07:32:42 <mahatic> yeah :(
07:33:16 <kota_> :,(
07:34:04 <kota_> that was just a reminder for ptg. let me move to the next topic if anyone doesn't have questions
07:34:36 <kota_> ok, next
07:34:57 <kota_> #topic bug-triage-work
07:35:36 <kota_> it have continued from previous weekly meeting
07:35:54 <mahatic> I'm guilty of not signing up for that yet, will do that
07:36:18 <kota_> however, it doesn't look Christian and Thiago working on that, are here?
07:36:35 <acoles> mattoliverau: nice work on triage
07:36:43 <mattoliverau> Thanks :)
07:36:56 <kota_> oh. mattoliverau is doing something?
07:37:10 <mattoliverau> There's and eitherpad, to track, which is easier then the normal LP links
07:37:23 <acoles> kota_: he's triaged 8 or so bugs :)
07:37:33 <mahatic> nice!
07:37:36 <mattoliverau> I just started from the bottom of new and started working up ;)
07:37:37 <kota_> great!
07:37:47 <acoles> #link https://etherpad.openstack.org/p/swift-bug-triage-list
07:38:06 <mattoliverau> Kota_: don't looked too shocked :p
07:38:18 <mattoliverau> acoles: ta (/me is on his phone)
07:38:46 <kota_> lol
07:39:19 <kota_> and tdasilva and acoles had triaged some bugs in the *new* list
07:39:26 <kota_> it looks like
07:39:28 <acoles> I think the idea is that we now all pick off bugs from the etherpad, and aim to reduce New bugs by categorising or closing
07:39:44 <acoles> there are some instructions at top of wiki
07:39:54 <mattoliverau> Yeah just triage is the first sweep
07:40:07 <mattoliverau> Get them out of new
07:40:14 <acoles> yes, that ^^
07:40:28 <kota_> make sense. do it!
07:40:30 <mahatic> okay
07:40:53 <kota_> do we have any deadline for the triage work?
07:41:16 <mattoliverau> But yeah etherpad explains, and if you have questions ask and we'll make it clearer
07:42:17 <kota_> ok
07:42:22 <mattoliverau> Not sure of a deadline.. but I think some people are thinking about doing a triage squash at PTG in the first 2 days of people have nothing else to do
07:42:52 <mattoliverau> But the sooner we clear it up the better.. but then also continue being better as well ;)
07:43:16 <kota_> mattoliverau: ok, thanks for the info. it seems long-term work but the reducing the number of *new* bugs should be great for us anyway
07:43:25 <kota_> thanks
07:44:05 <kota_> before moving to open discussion, I'd love to enter the topic
07:44:10 <kota_> #topic next-chair
07:44:39 <mattoliverau> I'll do it, I think mahatic is *next* but it wasn't long ago she did it :)
07:45:01 <kota_> i think we are rotating the chair by alphabetical order...
07:45:11 <kota_> ok, thanks mattoliverau!
07:45:13 <mahatic> mattoliverau: that's be great! :) I was just gonna say that I'd be taking off towards the end of that week, so I'm a bit unsure of being available on 9th
07:45:15 <mattoliverau> Unless someone else wants too of course ;)
07:45:20 <mahatic> s/that's/tha'd
07:45:22 <mahatic> duh
07:45:33 <mattoliverau> Then that works well :)
07:45:38 <mahatic> mattoliverau: thanks
07:45:40 <kota_> #agreed mattoliverau is the next chair for the next 0700 meeting
07:46:04 <acoles> FYI I will be on vacation on 9th
07:46:13 <acoles> thanks mattoliverau for volunteering
07:46:27 <kota_> acoles: enjoy
07:46:41 <kota_> #topic open-discussion
07:46:42 <acoles> kota_: thanks
07:46:44 <mattoliverau> So it'll be a quiet one then, that's ok, more time for 007 quotes ;)
07:47:10 <mahatic> lol, fire away ;)
07:47:23 <kota_> Dows anyone has something to bring up?
07:47:34 <kota_> we have 13 minutes left
07:47:40 <kota_> ;-)
07:48:30 <mattoliverau> Seems acoles gets an early breakfast
07:48:46 * kota_ is assuming silence is no one has topic with silence
07:48:49 <acoles> mattoliverau: been there, done that :)
07:49:00 <kota_> lol
07:49:14 <kota_> ok, finish up this meeting.
07:49:15 <mahatic> kota_: looks like it
07:49:16 <acoles> kota_: thank you for chairing today!
07:49:22 <mattoliverau> +1
07:49:24 <kota_> thanks for comming and thanks for working a lot
07:49:25 <mahatic> yeah, thanks kota_ for chairing!
07:49:29 <kota_> #endmeeting