07:01:10 <mattoliverau> #startmeeting swift
07:01:11 <openstack> Meeting started Wed Sep  6 07:01:10 2017 UTC and is due to finish in 60 minutes.  The chair is mattoliverau. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:01:15 <openstack> The meeting name has been set to 'swift'
07:01:25 <mattoliverau> who's here for the swift team meeting?
07:01:55 <mahatic> o/
07:02:00 <mattoliverau> It might be a little early for stragglers, so I'll wait a bit
07:02:04 <mattoliverau> mahatic: \o/
07:02:24 <mattoliverau> acoles is in the US, so he's sleeping
07:02:44 <mattoliverau> I haven't heard from kota_ or anyone else today
07:03:29 <mahatic> yeah, let's wait up for a bit
07:03:29 <mattoliverau> We'll give it a few more minutes, and if no one else comes, we'll start.. and it'll probably be quick
07:03:39 <mahatic> yeah
07:03:59 <mattoliverau> today is mainly information, as the PTG is next week
07:04:26 <mathiasb> good morning mattoliverau, mahatic!
07:04:33 <mattoliverau> mathiasb: o/
07:04:45 <mahatic> mathiasb: good morning
07:06:37 <m_kazuhiro> good morning
07:06:49 <rledisez> hi o/
07:06:50 <mattoliverau> m_kazuhiro: o/
07:06:57 <mattoliverau> rledisez: o/
07:07:04 <mattoliverau> cool, I think this will be enough :)
07:07:46 <mattoliverau> As I already mentioned todays meeting is the last 0700 meeting before the PTG. So mainly has info
07:08:01 <mattoliverau> Agenda is:
07:08:01 <mattoliverau> #link: https://wiki.openstack.org/wiki/Meetings/Swift
07:08:26 <mattoliverau> so strangely the first topic is the PTG :P
07:08:35 <mattoliverau> #topic Denver PTG
07:09:01 <mattoliverau> So Denver is next week! I look forward to seeing people there.
07:09:20 <mattoliverau> Seeing as it's next week... I'm sure y'all are all ready, but in case your not...
07:09:39 <mattoliverau> hmm, too many all's in that sentence ^^
07:09:40 <mattoliverau> :P
07:10:25 <mattoliverau> So the etherpad of topics are in the #openstack-swift channel header but:
07:10:27 <mahatic> we didn't notice ;)
07:10:35 <mattoliverau> #link https://etherpad.openstack.org/p/swift-ptg-queens
07:10:39 <mattoliverau> :)
07:10:42 <mahatic> (the all's)
07:10:55 <mattoliverau> If you have a topic on the etherpad, there is a new section called, 'what to review _before_ ptg'. So if you want interested persons ready for conversaions then please add something there.
07:11:24 <mattoliverau> if you don't then be prepared to explain everything again ;)
07:11:54 <mattoliverau> note: I highlighted the _before_ as I need some reading for the long flight :P
07:12:00 <mathiasb> or perhaps regardless ;)
07:12:19 <mattoliverau> lol, yeah, that's probably more to the point.. but we can dream :)
07:13:29 <mattoliverau> As with the last PTG, there will be team photo. So in case you want to 1) look your best or 2) want to aviod it, it'll be on Wednesday at 2:50pm
07:13:47 <mattoliverau> #link https://docs.google.com/spreadsheets/d/18DmI9ydq6dKr4hAcoAN83vYXWn8TV1NEvy09Ll02_Y0/edit#gid=0
07:14:07 <mattoliverau> ^^ there is a link to the photo schedule in case you want to photo bomb anyone elses ;)
07:14:32 <mattoliverau> Swift stuff will run from Wednesday - Friday. But for those of us who will be there on the Monday and Tuesday, this is also a bunch going on.
07:14:33 <mattoliverau> Firstly Monday and Tuesday will be the thematic inter-project rooms, so you can go get involved on more cross OpenStack inititives.
07:14:33 <mattoliverau> If you have done that, and find your self with free time, we are planning a bug triage smash, more on this later.
07:15:12 <mattoliverau> Having the general list of etherpads for the PTG is good, especially if there is other things you either want to know about or participate in.
07:15:12 <mattoliverau> #link https://wiki.openstack.org/wiki/PTG/Queens/Etherpads
07:15:25 <mattoliverau> Feedback from the last PTG that I heard, was that it was hard to know exactly what was happening in other projects, unless you read etherpads... which are in the ether and easily subject to change.
07:16:10 <mathiasb> yes that's true, especially since some working groups had no schedule, or changed it frequently and/or at the last minute
07:16:11 <mattoliverau> So this time there is something new
07:16:49 <mathiasb> last time there was also an IRC channel so you might want to join that as well (#openstack-ptg ?)
07:16:49 <mattoliverau> looks like Openstack Infra have solved it.. in a pretty cool way.. but also in the most Openstack developer way possible..
07:17:09 <mattoliverau> mathiasb: yes! there is that
07:17:24 <mattoliverau> but now there is also the PTGBot!
07:17:30 <mahatic> oic
07:17:39 <mathiasb> awesome! :)
07:17:41 <mattoliverau> but we wont need to deal with it directly
07:18:23 <mattoliverau> The PTLs and/or moderators will have powers to talk to the PTGbot. These will allow them to fire off notices about what happening in their room and what's up next. This way PTGs can be fluid, organic yet people can more easily now whats happening when.
07:18:23 <mattoliverau> The TPGbot will be updating a website
07:18:23 <mattoliverau> #link http://ptg.openstack.org/ptg.html
07:18:23 <mattoliverau> So keep an eye on that, if you are interesting in attending different things, or want to keep track on whats happening.
07:19:07 <mattoliverau> So it's actually an awesome solution.. use the tools we already use.
07:19:15 <mattoliverau> well I think so anyway
07:19:41 <mattoliverau> s/now/know/
07:20:29 <mattoliverau> OK, I know that's alot of links.. but never fear, there is a quicklinks.. one link to remember (or bookmark) to rule them all
07:20:37 <mattoliverau> #link http://ptg.openstack.org/
07:21:13 <mattoliverau> Thats all I have for the PTG, any questions?
07:22:00 <mattoliverau> I hope we'd have a chance to do a Swift dinner, but knowing us, it'll probably be adhoc and happen most nights (at least with a subset of the team) each night ;)
07:22:23 <mahatic> yeah, I'm sure. I'm gonna miss that!
07:22:36 <mathiasb> me too :(
07:23:04 <mattoliverau> mahatic: if you send us a picture, I'll print it out and carry it around with us, and hold it up for the group photo ;)
07:23:12 <mattoliverau> ok, both of you :)
07:23:27 <mahatic> lol, sure
07:23:43 <mattoliverau> If there are no more questions, then..
07:23:48 <mattoliverau> #topic Great bug triage of 2017
07:23:55 <mahatic> I'll photoshop myself into the picture ;)
07:24:02 <mahatic> group photo*
07:24:03 <mattoliverau> mahatic: that works too ;)
07:24:07 <mahatic> oh next topic
07:24:24 * mattoliverau notes the best thing about charing is I can make up the topic names ;)
07:24:43 <mattoliverau> so this is ongoing.
07:24:52 <mattoliverau> #link https://etherpad.openstack.org/p/swift-bug-triage-list
07:25:07 <mattoliverau> there is an etherpad of bugs
07:25:08 <mahatic> I debuted into the bug triaging today. I hope to keep working at it
07:25:25 <mattoliverau> mahatic: nice!
07:25:27 <mahatic> nice work everyone else!
07:25:47 <mattoliverau> For those interested, but not sure whats going on, read the top of the etherpad.
07:25:48 <mattoliverau> But tl;dr is we want to get our bugs in order, we have many, and many are very old.
07:25:48 <mattoliverau> So phase 1 is to triage all the "new" bugs.
07:25:48 <mattoliverau> Bugs marked 'new' are not triaged, and there are some old ones there. So first lets triage them (see top of etherpad).
07:26:32 <mattoliverau> marking them off as you triage them on the etherpad would also be good so we know where people are at.
07:26:40 <mattoliverau> Later we can re-triage other bugs and see if there still relevent.
07:27:01 <mattoliverau> As I mentioned earlier, we plan to talk about bug triage, getting a handle on them and running a triage smash at the PTG, the smash at least will occur during the Monday and Tuesday, but of course you can go and triage whenever you want.. start now :)
07:27:34 <mattoliverau> like mahatic, everyone be like mahatic and go triage ;)
07:28:18 <mahatic> :D, don't be like me, be quick about it!
07:28:26 <mahatic> ;)
07:28:37 <mattoliverau> Hopefully when we come back from the PTG, we'll have more of a plan on stopping the bugs from building up so much again.
07:29:27 <mattoliverau> Any questions?
07:30:07 <mattoliverau> cool, next topic is close to my heart... well close anyway
07:30:11 <mattoliverau> #topic Sydney Summit
07:30:22 <mahatic> not as of now. maybe when you're all back from the PTG and give us an update on it
07:30:40 <mattoliverau> will do!
07:30:51 <mahatic> on whatever brainstorming that takes place
07:30:53 <mahatic> thanks!
07:31:45 <mattoliverau> it'll hopefully be etherpadded and then I'll make sure its reported back
07:31:55 <mattoliverau> or I'll bug notmyname too ;P
07:32:20 <mahatic> heh
07:32:20 <mattoliverau> ok, so Sydney summit
07:32:25 <mattoliverau> The schedule has been released:
07:32:26 <mattoliverau> #link https://www.openstack.org/summit/sydney-2017/summit-schedule
07:32:34 <mattoliverau> Yes I know Sydney is along way away, and it's only 3 days.. but please join me in my neck of the woods :)
07:33:07 <mahatic> Not many talks by the swift team either. I think Kota has one
07:33:20 <mattoliverau> If you need a business case for staying longer, I'm sure we can come up with some excuse.. maybe a swift hackathon at my beach house ;)
07:34:08 <mattoliverau> yeah, the 3 days for a conference on the otherside of the world makes it a big rough
07:34:12 <mahatic> I hope to, as is the case usually, I don't know yet on my summit attendance. Should know about it soon enough though
07:34:31 <mattoliverau> but Australia is a great place to visit (not that I am biased)
07:34:41 <mahatic> mattoliverau: it ain't rough for me ;)
07:34:48 <mattoliverau> You wont regret it.. yes its a long flight but you'll get to have a taste of how my OpenStack trips start and end ;)
07:35:02 <mattoliverau> mahatic: yeah, go team 0700!
07:35:34 <mattoliverau> Thats all I've got
07:35:54 <mahatic> mattoliverau: lol. Openstack team could really use you on their marketing team for the Sydney summit ;)
07:36:09 <mattoliverau> lol
07:36:19 <mahatic> good job, I'm sold. I hope to make it :D
07:36:59 <mattoliverau> so unless you want to discuss more about coming to visit me, or need my address to write a business case, we can move on
07:37:19 <mattoliverau> #topic Open Discussion
07:37:44 <mattoliverau> Anything else anyone want to bring up?
07:38:37 <mattoliverau> I guess not
07:38:55 <mattoliverau> if you do fire away, but in the mean time, I'll move to next meetings chair person
07:39:02 <mattoliverau> #topic Next Meeting's Chairperson
07:39:18 <mattoliverau> Anyone interested in charing
07:39:26 <mattoliverau> *chairing
07:39:44 <mattoliverau> whose next on the name list?
07:40:01 <mahatic> should it be from someone who had been at the PTG, so we have an update?
07:40:27 <mattoliverau> mahatic: yeah, that sounds good.
07:41:03 <mattoliverau> but we don't have much attendance here to come up with chair.
07:41:25 <mattoliverau> so lets say:
07:42:33 <mattoliverau> #agreed chairperson will be someone who attended PTG (or mattoliverau if noone else agrees to it)
07:43:06 <mattoliverau> #action mattoliver to pester Swift PTG attendees next week
07:43:30 <mahatic> thanks mattoliverau
07:43:56 <mattoliverau> nps
07:44:10 <mattoliverau> mahatic, mathiasb I wish you both were coming
07:44:27 <mattoliverau> if there is nothng else to bring up, I think we can call it time
07:44:32 <mahatic> me too
07:44:37 <mahatic> yup
07:44:40 <mahatic> thanks for chairing!
07:44:43 <mattoliverau> nps
07:44:54 <m_kazuhiro_> mattoliverau: thank you!
07:45:15 <mattoliverau> I hope everyone has a great week next week. Either at PTG or not. If you can't make it, we'll miss you.
07:45:31 <mattoliverau> Now to channel my inner notmyname, thank you for your work on swift!
07:45:53 <mattoliverau> #endmeeting