07:01:26 <mattoliverau> #startmeeting swift
07:01:27 <openstack> Meeting started Wed Oct  4 07:01:26 2017 UTC and is due to finish in 60 minutes.  The chair is mattoliverau. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:01:30 <openstack> The meeting name has been set to 'swift'
07:01:52 <mattoliverau> ok, now officially for the log... who's here for the swift team meeting?
07:02:02 <kota_> I'm here
07:02:06 <mahatic> hello
07:02:14 <mattoliverau> Agenda is:
07:02:14 <mattoliverau> #link: https://wiki.openstack.org/wiki/Meetings/Swift
07:02:24 <psachin> me too
07:02:46 <mattoliverau> \o/ I like not talking to myself :)
07:03:05 <acoles> hi
07:03:14 <acoles> sorry my client/bouncer is being weird
07:03:18 <mattoliverau> Wecome everyone
07:03:52 <mattoliverau> acoles: yeah, my internet has been spotty today too.. but looks like in a few days I might get better internet in the area
07:04:08 <mattoliverau> notmyname: for when you read this... yes the NBN
07:04:42 <mattoliverau> So hopefully I've have both a beach and internet that's faster then a wet piece of string ;)
07:05:10 <mattoliverau> Also note, I've had _way_ to much coffee, so please slap me if I go too far off on tangents like this
07:05:26 <acoles> mattoliverau: you're doing great
07:05:29 <mattoliverau> :)
07:05:34 <mattoliverau> first up
07:05:38 <mattoliverau> #topic Denver PTG Recap
07:05:55 <mattoliverau> Denver was a few weeks ago, and not all of use could be there
07:06:34 <mattoliverau> those who couldn't, you were definitely missed
07:06:50 <mattoliverau> we tried to update the etherpad with notes
07:06:54 <mattoliverau> Our etherpad is
07:06:54 <mattoliverau> #link https://etherpad.openstack.org/p/swift-ptg-queens
07:07:41 <mattoliverau> For the benefit of those who weren't around I thought it would be nice for those of us who were to do a recap
07:07:53 <kota_> +1
07:07:54 <mattoliverau> so for those who where there, any comments? what was your favourite bits? How'd it go? What could we do better?
07:08:25 <mattoliverau> Other then the train.. which kept people up
07:08:52 <mattoliverau> For me, I was surprised at the turn out. I didn't expect as many people as there was
07:09:05 <mahatic> that's great to hear
07:09:11 <mattoliverau> The venue was in the middle of nowhere
07:09:20 <mattoliverau> so not good for turing denver
07:09:29 <acoles> we spent some time discussing what people's priorities were, that was useful
07:09:30 <mattoliverau> but I thought it was very productive
07:09:36 <mattoliverau> yeah!
07:09:47 <kota_> yup
07:10:07 <mattoliverau> So on the first day of the Swift days, we started asking people about priorities for people and there repected companies
07:10:16 <acoles> for some of us container sharding is important and we spent quite a bit of time looking at mattoliverau proof of concept
07:10:24 <acoles> there are some notes on that linked off the etherpad
07:10:25 * kota_ is looking for summary page using tag style web page...
07:10:57 <acoles> #link https://etherpad.openstack.org/p/deep-containers
07:11:32 <acoles> we also heard about progress on lots-of-small-file support from rledisez and alecuyer
07:11:32 <mattoliverau> oh yeah and we're calling sharding, sharding but also deep containers, in case you've been wondering about the new feature branch
07:12:04 <acoles> mattoliverau: right, yes, the sharding work is not continuing on feature/deep
07:12:13 <acoles> s/not/now/ oops!
07:12:18 <mahatic> heh
07:12:23 <mattoliverau> wow, phew..
07:12:28 <acoles> it definitely *is* continuing
07:12:43 <kota_> s3api is also one of feature branch work since the ptg
07:12:45 <mahatic> got it :D
07:13:02 <mattoliverau> we decided the speed sharding momentum, it needed a feature branch, and a way of collaborating (trello).
07:13:11 <mattoliverau> and so far I think it's working well
07:13:24 <mattoliverau> timburke and acoles are amazing!
07:13:31 <acoles> kota_: yes, e also spent some time discussing s3 support
07:13:39 <acoles> we*
07:13:44 <kota_> the continuous discussion is on https://etherpad.openstack.org/p/s3api-middleware
07:13:50 <acoles> ugh, my fingers are still asleep!
07:14:03 <kota_> lol
07:14:38 <kota_> we'll freeze swift3 repo in the near future and starting to migrate to the swift repo namespace
07:14:50 <mahatic> acoles: we're able to follow you though
07:14:52 <mattoliverau> Speaking of kota_, he did great in an RDO interview about swift (https://www.youtube.com/watch?v=V7UmrNJ80qc and https://www.youtube.com/watch?v=KeieJDdJ5Q4)
07:15:03 <kota_> mattoliverau: you too!
07:15:25 <acoles> Also, I know people worked on the symlink patch in Denver and since then. It is definitely ready for final reviews as I understand it
07:15:31 <acoles> #link https://review.openstack.org/#/c/232162/
07:15:49 <kota_> acoles: that's what I am going to say!
07:16:40 <mattoliverau> SwiftHLM is moving into the openstack namespace.. which is cool
07:16:58 <mahatic> oic
07:17:01 <kota_> fyi for symlink, I'm starting to address some issues on the patch at https://review.openstack.org/#/c/509149/1
07:17:31 <kota_> I don't find any *BIG* issues right now, just minor bug and style fixes there.
07:17:42 <kota_> (for now)
07:18:41 * kota_ is thinking the patch hit zuul down in the recent days?
07:18:42 <mattoliverau> Also I think they were saying the next PTG might be in Dublin Ireland
07:19:07 <mattoliverau> kota_: oh yeah. I think zuul needed to be rolled back or something
07:19:25 <kota_> mattoliverau: and also we might have virtual hackathon in Nov or Dec?
07:19:37 <acoles> another thing to mention for people who weren't able to be in Denver...there was talk that we might have a 'virtual hackathon' between now and next PTG. Nothing confirmed yet, possibly December or January timeframe.
07:19:49 <mattoliverau> oh yeah, I forgot about that.
07:19:56 <kota_> it's still not decided yet on anything (date, how it works, ... etc)
07:20:00 <acoles> kota_: you beat me that time!
07:20:05 <mattoliverau> I think we were going to see how another teams virtual hackathon went
07:20:11 <mahatic> that's awesome
07:20:26 <kota_> hehe
07:20:46 <mattoliverau> maybe all nighters at home.. the end of hackathon day drinks will be interesting ;)
07:21:16 <mattoliverau> and I'm sure the toddler will let me sleep during the day :P
07:21:38 <mattoliverau> Anything else for the PTG recap?
07:21:45 <acoles> and we're going to try to be better about bug triage (and fixing) so we had a firtst bug triage day last wednesday...which is simply a day on calendar when we all try to give some time to bug work
07:21:58 <mattoliverau> any questions from those who didn't attend?
07:22:37 <mattoliverau> oh yeah. The monday and tuesday we held an informal bug triage smash
07:22:49 <mattoliverau> As I've been calling it the 'great bug triage of 2017'
07:23:43 <mattoliverau> it went really well, we didn't complete the huge list of NEW bugs... but we made a huge difference.. maybe got 2/3s through
07:24:03 <mattoliverau> maybe more
07:24:27 <mattoliverau> tdasilva and cschewde did awesome organising it
07:24:36 <acoles> +1
07:24:44 <kota_> +1
07:25:11 <mahatic> how did the cross group collaboration go? Was it worth it to be there the first two days of the PTG (other than bug triage work) ?
07:25:30 <mattoliverau> good question
07:26:30 <mattoliverau> I can only answer for myself. I thought it was totally worth it. I got to help out the openstack ansible and talk to the release guys a bit. The hallway track on the first 2 days was great, as there was more time to stop and talk.
07:26:35 <acoles> mahatic: I'm not sure - I spent one of those days on bug triage and on the other I needed to deal with some internal work
07:26:36 <mattoliverau> for me, totally worth it.
07:27:25 <mahatic> okay, that's good to know
07:27:45 <mattoliverau> the swift team were involved in the initial discussions of the simplifying openstack cross project group
07:28:00 <mattoliverau> we kinda stole the room because it was empty
07:28:22 <mattoliverau> but some good discussions were had. At least amonst a few of us
07:28:28 <kota_> oh, yeah. release and infra team room was nice
07:28:59 <mattoliverau> kota_: did anything happen on the storelets front?
07:29:09 <kota_> I also visited the room to ask a bit on the storlets release. They had name tag on top of each table, we're working on xxxx
07:29:10 <mattoliverau> I guess you might have your own meeting for that
07:29:24 <mattoliverau> oh cool
07:29:43 <kota_> mattoliverau: it's moving to change the release style to address common openstack rule (i.e. queen-1
07:29:45 <kota_> )
07:30:07 <kota_> and I asked how to manage the release there.
07:30:45 <mattoliverau> nice, since we don't follow it, it's good you asked cause we, or at least I, have no idea :P
07:31:47 <mattoliverau> Anyway, the best part of the PTG was catching up with the Swift team ;)
07:31:55 <mattoliverau> as always
07:32:37 <mattoliverau> there isn't too much else on the ajenda today. So it'll be a shortish meeting if there isn't much else.
07:32:40 <kota_> yup
07:33:04 <kota_> ah,
07:33:23 * kota_ is thinking of who else is the next chair
07:33:38 <mattoliverau> lol, I'll move to sydney summit first :)
07:33:44 <mattoliverau> #topic Sydney Summit
07:33:59 <mattoliverau> this is my reminder that the summit is on and the schedule has been released
07:34:05 <mattoliverau> #link https://www.openstack.org/summit/sydney-2017/summit-schedule
07:34:10 <mattoliverau> I'll be there
07:34:18 <kota_> me too
07:34:19 <mattoliverau> but that probably isn't much of a surprise ;)
07:34:23 <mattoliverau> kota_: \o/
07:34:50 <mattoliverau> I know its far and only for a few days.. unless you sight see/vacation.. which you should
07:34:53 <kota_> i already got the flight ticket and booked my hotel room.
07:34:58 <mattoliverau> nice
07:35:03 <mattoliverau> me too.
07:35:19 <m_kazuhiro> me too.
07:35:41 <mattoliverau> I'm heading into sydney on the Friday night, because I'm planning on helping at the Openstack hackathon on the weekend before as a mentor
07:35:47 <mattoliverau> m_kazuhiro: \o/
07:36:27 <mattoliverau> well, I was asked by people at the foundation, but haven't been confirmed yet.
07:37:33 <mattoliverau> Australia is awesome! just saying ;)
07:37:51 <mattoliverau> so come visit my home country
07:37:53 <kota_> I'm looking forward to being there ;)
07:38:15 <kota_> that will be my first visit to Australia
07:38:40 <mattoliverau> kota_: really! nice. let me know if there is anything I can help with or if you need to place to stay
07:39:08 <mattoliverau> tho, I'm a little out of the way.. but I live on a beach
07:39:32 <mattoliverau> moving on
07:39:34 <kota_> :)
07:39:37 <mattoliverau> #topic Open Discussion
07:40:05 <mattoliverau> Anything else anyone wants to talk about before moving on to the next chair?
07:40:33 <acoles> I hope you all have a great time at the summit
07:41:03 <mattoliverau> acoles: you'll need to come visit me one day
07:41:31 <mattoliverau> right.. lets move to the last topic of the meeting
07:41:34 <mattoliverau> #topic Next Meeting's Chairperson
07:41:49 * acoles heads for the door
07:41:52 <mattoliverau> lol
07:41:58 <kota_> lol
07:42:05 <mattoliverau> do we have any volunteers?
07:42:15 <mattoliverau> or are we going by names?
07:42:42 <acoles> I can do one
07:42:53 <mattoliverau> acoles: great, sold!
07:43:09 <acoles> October 18th right?
07:43:15 * mattoliverau thinks acoles did'nt quite get out of this little office in time ;)
07:43:24 <mattoliverau> yup
07:43:39 <mattoliverau> acoles: that good for you?
07:44:04 <mahatic> thanks acoles!
07:44:10 <acoles> yes. I'll still be on BST so a little easier
07:44:13 <kota_> thanks!
07:44:31 <mattoliverau> #agreed acoles
07:44:39 <mattoliverau> thank acoles
07:44:40 <acoles> it's 8am start, after that I will be on UTC
07:44:43 <mattoliverau> *thanks
07:44:44 <m_kazuhiro> acoles: thank you!
07:45:10 <mattoliverau> acoles: ahh, you'd do the dreaded 7am meetings.. I know it well :)
07:45:36 <mattoliverau> infact, your on my times for the other meeting
07:45:37 <acoles> I didn't say I would be there!! I commit to October 18th and no more :P
07:46:02 <mattoliverau> the other meeting is now 8am (I've moved to day light savings (summer time))
07:46:07 <mattoliverau> and was 7am
07:46:16 <mattoliverau> lol
07:46:19 <mahatic> lol
07:46:53 <mattoliverau> great, well that's all we have.. so if there is nothing else, you can all have an early mark
07:47:02 <acoles> mattoliverau: thanks for charingin today
07:47:10 <mattoliverau> nps
07:47:17 <mahatic> yup, thanks mattoliverau !
07:47:33 <mattoliverau> Now to channel my inner notmyname, thank you for your work on swift!
07:47:33 <mattoliverau> #endmeeting