21:00:03 <notmyname> #startmeeting swift
21:00:04 <openstack> Meeting started Wed May 30 21:00:03 2018 UTC and is due to finish in 60 minutes. The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:08 <openstack> The meeting name has been set to 'swift'
21:00:10 <notmyname> who's here for the swift team meeting?
21:00:11 <timburke> o/
21:00:12 <m_kazuhiro> o/
21:00:17 <rledisez> o/
21:00:23 <kota_> good morning
21:00:28 <torgomatic> o/
21:00:47 <tdasilva> hi
21:00:54 <zaitcev> o/
21:01:11 <notmyname> welcome. thanks for coming
21:01:19 <notmyname> agenda this week is at
21:01:21 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
21:01:40 <mattoliverau> o/
21:01:41 <notmyname> 2.18.0 is done! it's been tagged and released and is available for anyone!
21:01:47 <acoles> hi
21:02:07 <kota_> great
21:02:30 <clayg> o/
21:02:38 <notmyname> I found a funny stat in the code related to the release
21:02:45 <clayg> 2.18 is old news. 2.19 is going to be awesome.
21:02:48 <notmyname> lol
21:03:09 <kota_> lol
21:03:20 <m_kazuhiro> lol
21:03:21 <notmyname> feature/deep was huge and took a lot of concentration. but since it landed (may 18), we've landed 89 commits (including merge commits). 51 not including merges
21:03:48 <notmyname> more than 7 commits per day, on average
21:04:00 <timburke> merge all the things!
21:04:17 <notmyname> (from `git shortlog -nes "@{May 18, 2018}"..`)
21:04:44 <clayg> on a roll!
21:04:49 <notmyname> #topic summit recap
21:05:08 <notmyname> last week I was at the openstack summit in vancouver with kota_ and mattoliverau and m_kazuhiro and rledisez and csatari
21:05:12 <notmyname> * cschwede
21:05:18 <notmyname> and even mahatic was there!
21:05:32 <notmyname> we had a great time
21:05:56 <notmyname> I thought the summit was very good (also, I had no jet lag and wasn't there the whole week)
21:05:56 <mattoliverau> Yeah it was great
21:06:04 <clayg> sounds awesome! what a great group of folks! sorry we missed ya'll!
21:06:16 <notmyname> I've talked to just about all of you, I think, about what happened there
21:06:21 <clayg> see you in Denver, tho I hope!?
21:06:21 <notmyname> lots of interesting conversations
21:06:44 <notmyname> there was a lot of encouraging feedback on what's going on in swift.
21:07:14 <notmyname> lot's of people are using it (and finding more ways to use it more)
21:07:33 <notmyname> and there were even some new faces that turned up at the project onboarding session
21:08:15 <notmyname> I'm not sure what level of participation they'll have, but here's hoping we'll have a few more active contributors :-)
21:08:52 <kota_> +1, hope it
21:08:59 <notmyname> so yeah... like clayg, the next time together is in denver at the ptg
21:09:01 <mattoliverau> Let's keep an eye out for them and support them if and when they turn up :)
21:09:09 <notmyname> mattoliverau: yes!
21:09:20 <notmyname> I hope you've all signed up for the ptg. I think the early registration deadline has passed
21:09:22 <mattoliverau> Not that we wouldn't anyway, great group of peeps here :)
21:09:28 <notmyname> #link https://www.openstack.org/ptg
21:10:19 <mattoliverau> My baby is officially due on the Monday of the ptg (10th) so I won't be there :(
21:10:22 <zaitcev> I paid $199
21:10:36 <notmyname> mattoliverau: I *guess* that's ok
21:10:42 <notmyname> zaitcev: yep. that's the cheap price
21:10:51 <kota_> mattoliverau: congraturations!
21:11:05 <notmyname> #topic proposal for changing reviews
21:11:09 <mattoliverau> Oh yeah, I'll miss seeing you all, but marriage and new baby over work :)
21:11:14 <kota_> congratulations
21:11:34 <notmyname> I've got a proposal I'd like to make and talk about with everyone
21:12:08 <clayg> zaitcev: i also paid the $200 - so hopefully we're all set!
21:12:11 <clayg> mattoliverau: congrats
21:12:22 <clayg> notmyname: sounds ominous
21:12:26 <notmyname> I propose we change our review/approval policy to allowing one core +2 before a +A for merge. (of course, a core could ask for other reviews too, if needed)
21:12:48 <tdasilva> clayg: that was just the first installment
21:13:12 <notmyname> I would like to know your thoughts on changing the review policy
21:13:26 <clayg> tdasilva: lol
21:13:59 <clayg> notmyname: so the question is do we have any cores right now that we don't want to +A any patch they happen to find and like?
21:14:16 <timburke> seems reasonable, particularly given (1) the limited review bandwidth we have and (2) the fact that most changes are coming from people i already trust to write good code anyway
21:14:35 <torgomatic> I think it's a good experiment to try for the next year or so. We've been favoring stability over progress, and IMO the balance is a little too far towards stability.
21:14:35 <notmyname> clayg: it's ok. I can promise not to review stuff, if that helps ;-)
21:14:40 <clayg> notmyname: or is the question - will we in the future have a core that might not know when it's appropriate to +A vs. asking for more eyes?
21:14:49 <torgomatic> If we end up with too little stability, we can always switch back.
21:15:06 <zaitcev> notmyname: I'm against the single +2. I even found mistakes that acoles made, although very rarely.
21:15:23 <clayg> timburke: +2 on a lot of patches from trusted authors that know how to write good swift patches!
21:16:07 <clayg> zaitcev: I'll definately grant that I've had a +2 sitting on a timburke patch that acoles came around and -1'd for good reason (would have been a lp bug #)
21:16:16 <clayg> zaitcev: same goes for you catch stuff I missed as well
21:17:27 <notmyname> zaitcev: even in light of the way torgomatic phrased it?
21:18:51 <zaitcev> I suppose we can try
21:18:54 <notmyname> more reviews will catch more bugs, true. but it's not like we can say "ok, so 5 +2s, and then we'll just not have any bugs at all". it's a balance between catching bugs and being able to land code
21:19:03 <clayg> notmyname: torgomatic: I'm open to running the experiment... but I almost think it's halfway a mind game and halfway just an extension of the "go ahead and +A docs" rule
21:19:09 <zaitcev> okay
21:19:21 <mattoliverau> We could try it, but still a little on the fence. Some patches like aways seem straight forward, yeah 1 +2 would be fine. Others more eyes the better. I guess this is what is meant tho, if more eyes are needed thats just a social/communication thing.
21:19:29 <zaitcev> then I get Thiago to review PUT+POST and voila it's +A
21:19:32 <zaitcev> ?
21:19:43 <kota_> sounds good experiment but i have same concern with zaitcev.
21:19:50 <mattoliverau> clayg: +1
21:19:55 <clayg> we *constantly* say "if it's a good patch just go ahead and land it" but when it comes to putting code on master we're in reality all pretty conservative
21:19:57 <rledisez> i feel like there should be some kind of "risk evaluation". a simple patch in proxy_logging middleware is ok with just one +2, while a patch in ring.py should wait for two +2. I guess you guys a reasonable enough to known when to ask a second opinion
21:21:14 <m_kazuhiro> rledisez: +1
21:21:26 <tdasilva> I'm ok with the change. I agree with statements from timburke (i.e., review bandwidth) and torgomatic (progress vs. stability). More then trust the people that write the code, I trust core reviewers *good judgment* to ask for a second opinion (or a second +2). Yes, mistakes will happen, and we might get some bugs that we wouldn't otherwise, but I'm hoping for more +s then -s with such a change.
21:21:26 <timburke> i suppose there was also a (3) for me: i trust everyone here to recognize when a change is large enough in scope to demand a second review
21:21:41 <acoles> timburke: +!
21:21:51 <acoles> gah I mean +1
21:22:13 <clayg> notmyname: i see two things as being true at the same time "sometimes code that should be +A'd sits there with a +2 instead of on master" and "merging code to master is scary and hard and more eyes is better"
21:22:25 <notmyname> clayg: yeah
21:22:41 <clayg> but w/e - I ain't SKERED!
21:23:03 <notmyname> what if we had a standing agenda item in this meeting for "stuff you've reviewed and need to call out as big enough in scope to need more eyes"?
21:23:26 <notmyname> I'd be worried that we'd be super conservative and a lot of stuff would end up there
21:23:51 <clayg> If nothing else it might help us build some confidence. Look tdasilva merged zaitcev's patch and the sky didn't fall down! torgomatic wrote something good and acoles landed it! some random person wrote something useful and timburke merged it, then wrote 15 followup patches too boot!
21:24:33 <notmyname> lol @ "then wrote 15 follow-up patches". so true ;-)
21:25:12 <mattoliverau> It might, but only till people find their feet, and any new cores in the future I'd expect to be a little more conservative
21:26:14 <notmyname> hmm... how does the vote option work again?
21:27:05 <clayg> honestly after so long with the 2 +2 rule I'm pretty fearful of a change - but I'm pretty sure some of that is just the devil you know... I think notmyname is right to push us to question status quo... but I don't much care for moved cheese if I'm entirely honest
21:27:32 <clayg> luckily - we can do whatever we want and change our mind later - we're running this banana stand!
21:27:53 <notmyname> so many american/english/clay idioms ;-)
21:28:07 <clayg> probably the correct answer is 1.5 +2's
21:28:12 <mattoliverau> I just assume it's a clayism :p
21:28:24 <clayg> acahcahcphap - that's 3!? of course the correct answer is 3!
21:28:26 <notmyname> "wait!? clayg says we're moving the banana stands now?", probably kota_ and rledisez right now ;-)
21:28:32 <torgomatic> It might be worth waiting some time until calling a vote. This idea was only introduced ~25 minutes ago, so I'd bet that proper consideration would take some time.
21:28:32 <acoles> the devil is in the cheesy banana details!
21:28:42 <kota_> lol
21:28:43 <rledisez> :D
21:28:50 <notmyname> torgomatic: yeah, that was one of my options I'm trying to figure out
21:29:53 <clayg> torgomatic: we talk about this EVERY time we look at code inventory and feel bad we don't have more better/mergeable changes
21:30:05 <acoles> It might be worth somehow articulating some expectations e.g. 'API changes ought to require more review than test changes', 'ring.py may require more review than ring.rst'
21:30:09 <tdasilva> heh...
21:30:31 <torgomatic> clayg: in person, yes, but this is the first time I know of that it's been brought up in a meeting.
21:30:42 <torgomatic> If that's wrong, then disregard what I said about waiting.
21:30:47 <kota_> +1 for acoles
21:30:56 <clayg> it's so easy to get caught up trying to fix up something on a patch and forget to check for docstrings...
21:31:02 <notmyname> torgomatic: that's true. but it's also all the same people who are in-person and talk about it
21:31:19 <notmyname> #vote should a single +2 be ok for landing a patch on master? yes, no, wait
21:31:23 <notmyname> bah
21:31:25 <notmyname> that didn't work
21:31:48 <kota_> test and docs are easy to get single +2 and it will work with the rule proposed.
21:32:04 <notmyname> I mean, "yes, I'm ok with this", "no, I'm not ok with this", and "I'd like to wait a week and say yes or no at next week's meeting"
21:32:08 <mattoliverau> To help lower the number of bugs introduced we could require 2 +2s when close to a release, tho we do release often
21:32:08 <notmyname> #startvote should a single +2 be ok for landing a patch on master? yes, no, wait
21:32:09 <openstack> Begin voting on: should a single +2 be ok for landing a patch on master? Valid vote options are yes, no, wait.
21:32:10 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
21:32:10 <tdasilva> notmyname: it's #startvote
21:32:17 <kota_> the design change, I'm still feeling we need more than single +2, IMHO.
21:32:20 <notmyname> yay!
21:32:36 <torgomatic> #vote yes
21:32:52 <tdasilva> #vote yes
21:33:00 <timburke> #vote yes
21:33:05 <m_kazuhiro> #vote yes
21:33:07 <clayg> #vote eys
21:33:08 <openstack> clayg: eys is not a valid option. Valid options are yes, no, wait.
21:33:12 <tdasilva> lol
21:33:14 <kota_> lol
21:33:19 <mattoliverau> Lol
21:33:22 <tdasilva> aye
21:33:26 <kota_> #vote yes
21:33:29 <acoles> clayg: did you mean 'aye' :P
21:33:37 <acoles> #vote yes
21:33:45 <clayg> #yes
21:33:51 <clayg> lol
21:33:55 <clayg> #vote yes
21:33:59 <mattoliverau> Im ok with yes knowing the social conventions we've been talking about
21:34:08 <kota_> but I like that we still have chances to get more reviews for large (or design change) patches.
21:34:10 <notmyname> zaitcev: rledisez: mattoliverau: ?
21:34:13 <mattoliverau> #vote yes
21:34:19 <acoles> mattoliverau: thats a #it_depends
21:34:21 <rledisez> #vote yes
21:34:57 <mattoliverau> Yeah kinda, but I'll get off the fence, we can always go back, and trying just after a release is the best time :)
21:35:02 <zaitcev> #vote yes
21:35:03 <notmyname> #vote yes
21:35:05 <clayg> kota_: mattoliverau: do you think we could articulate some explicit expectations? top-level doc in repo? expand review_guidelines.rst?
21:35:07 <notmyname> #endvote
21:35:08 <openstack> Voted on "should a single +2 be ok for landing a patch on master?" Results are
21:35:10 <openstack> yes (11): rledisez, notmyname, acoles, tdasilva, kota_, torgomatic, m_kazuhiro, mattoliverau, zaitcev, clayg, timburke
21:35:33 <kota_> clayg: review_guidelines sounds nice to write down
21:35:46 <notmyname> TBH, I didn't expect that. I expected to bring it up and then wait a week. I didn't expect it to have broad support like this
21:35:48 <kota_> or something like principle?
21:36:17 <tdasilva> notmyname: just to make it clarify, this would also affect other repos (i.e., python-swiftclient)
21:36:37 <notmyname> #agreed a single +2 s sufficient for landing a patch. core reviewers are expected to use their best judgement as to when other reviewers should be called in to give additional reviews
21:36:38 <notmyname> tdasilva: yes
21:36:50 <notmyname> tdasilva: ie, all the code repos we manage
21:37:08 <clayg> notmyname: can you write something up - email list - or at least follow up to get kota_ or mattoliverau to start on an update to guidelines?
21:37:20 <mattoliverau> Yeah, being clear if great. And I know it isn't a simple rule. This is ok, this isn't. But just so something is written somewhere :)
21:37:31 <notmyname> clayg: yep
21:37:47 <clayg> Like I think we #agree that we should pursue the change - but there HAS to be some sort of ... announcement or something - we've been doing it one way forever
21:37:59 <notmyname> and to be clear, this is really just our social convention we choose to follow. there is no technical enforcement of this or any other review policy
21:38:21 <clayg> notmyname: +A
21:38:54 <tdasilva> and any one should feel free to bring it up again in the future if they think we need to tinker with it again....
21:39:00 <notmyname> yes. I'll write up something. adding it to review and contributor guidelines is good. a ML post is good too, but will need to be a little more carefully worded
21:39:07 <clayg> it's all mind games - it'll be good for us - once we get used to the idea that we can come to a patch with no other reviews and if it makes swift better we can put it on master right then and there (subject gate backlog) - I think it will be empowering to reviews and authors both!
21:39:08 <notmyname> tdasilva: yes, absolutely
21:39:26 <notmyname> clayg: right! that's the way to think! :-)
21:39:47 <notmyname> #topic events
21:39:49 <clayg> tdasilva: in fact we should probably PLAN to have a retrospective
21:39:53 <notmyname> all right. last topic
21:40:03 <notmyname> clayg: tdasilva: at the PTG in denver!
21:40:04 <tdasilva> clayg: good PTG topic
21:40:18 <notmyname> we've already discussed the PTG
21:40:20 <acoles> just after the bugfest ;)
21:40:25 <tdasilva> lol
21:40:34 <notmyname> but tdasilva pointed out another conveference we should consider going to
21:40:38 <notmyname> #link https://mountpoint.io
21:40:50 <rledisez> one question about PTG, do we know the schedule yet? will it be, as usual, 2 days cross-project and 3 days of pure swift stuff?
21:40:50 <notmyname> looks very interesting, and I'll definitely be looking at it more
21:40:57 <rledisez> alecuyer and I got tickets, we are waiting to book plane and hotel
21:40:58 <notmyname> rledisez: likely
21:41:13 <clayg> rledisez: i'm SO sorry you guys missed Dublin - it was a snowy mess
21:41:14 <tdasilva> rledisez: for PTG or mountpoint.io?
21:41:15 <notmyname> rledisez: or rather, I assume so because I have no reason to think otherwise
21:41:28 <notmyname> tdasilva: can you give any more info on the mountpoint conference?
21:41:35 <rledisez> yeah, hopefuly, no snow strom in denver in september. maybe sand storm? :D
21:42:44 <mattoliverau> Oh mountpoint sounds interesting
21:42:50 <tdasilva> notmyname: yeah, that's a new conference being promoted to talk about opensource SDS and they are looking forward to seeing Swift talks proposed
21:43:16 <clayg> tdasilva: cool find bro!
21:43:18 <mattoliverau> I assume it's in the US
21:43:23 <tdasilva> Vancouver
21:43:23 <notmyname> it's in vancouver!
21:43:31 <mattoliverau> Oh cool
21:43:38 <mattoliverau> I love Vancouver
21:43:51 <kota_> lol
21:44:51 <clayg> i suggest that notmyname should go
21:45:09 <tdasilva> #startvote ;)
21:45:09 <notmyname> I suggest you take that up with mrs notmyname ;-)
21:45:10 <openstack> Only the meeting chair may start a vote.
21:45:14 <notmyname> tdasilva: lol
21:45:26 <notmyname> #topic open
21:45:32 <notmyname> anything else to bring up this week?
21:45:39 <acoles> notmyname: I suggest you take mrs notmyname
21:45:42 <kota_> how much cost will it require per person for mountpoint?
21:45:49 <notmyname> acoles: yeah, actually. that's a great idea :-)
21:45:54 <notmyname> kota_: I couldn't find it
21:46:07 <kota_> notmyname: same with me, tdasilva may know something
21:46:11 <timburke> oh yeah, speaking of code review policy, http://lists.openstack.org/pipermail/openstack-dev/2018-May/130802.html seemed to spark an interesting discussion
21:46:12 <tdasilva> i can find that out
21:46:19 <mattoliverau> Sounds great, is love to go, but not till post baby and if I can sell it to SUSE, who aren't really swift focused
21:46:29 <mattoliverau> *I'd
21:46:30 <tdasilva> will mention in #openstack-swift channel when i find out
21:46:37 <notmyname> tdasilva: thank you
21:46:56 <kota_> timburke: i also found the nitpicking thread
21:47:01 <notmyname> thanks again, everyone, for the final push to get 2.18.0 landed
21:47:03 <kota_> timburke: thanks!
21:47:45 <notmyname> so... on the nitpicking thread
21:48:01 <m_kazuhiro> kota_: I found "Registration costs $25 per person. " https://www.regonline.com/registration/dialogs/regtypedetails.aspx?EventId=2447527&RegTypeId=509661
21:48:18 <notmyname> my first reaction is "oh, we don't have a problem with that. that's pretty much what we do anyway (the guidelines)."
21:48:23 <notmyname> m_kazuhiro: thanks!
21:48:52 <notmyname> however, then I realize that of course *I* don't think we have a problem with that. it's actually not my place to say if we have a nitpicking problem or not
21:48:59 <kota_> m_kazuhiro: thx
21:49:05 <mattoliverau> That's cheap, how long does it go for?
21:49:13 <tdasilva> 2 days
21:49:24 <notmyname> that is, we've all got a position of "power" in the community, so it's easy for us to claim there's no problem in the community
21:49:25 <mattoliverau> Oh, that's a long way to go for 2 days
21:49:37 <notmyname> mattoliverau: but, you're in vancouver, so that's nice
21:49:41 <tdasilva> but mind you that it's happening just before ossummit, so most folks stay for that
21:49:48 <tdasilva> and that costs more, i believe
21:49:50 <mattoliverau> That is true
21:50:18 <tdasilva> but i guess one could also propose talks to ossummit
21:50:29 <mattoliverau> Oh yeah, but thats still a good solution, SUSE is pro OSS conferences ;)
21:50:38 <notmyname> so my point is, re the nitpicking, we need to realize there may be a problem. and we need to pay attention when people come into our group to make a contribution and realize what we see as normal others may find quite hostil
21:51:16 <clayg> notmyname: that's fair, but it's also easy for an outsider with less experience to misjudge the cost of "merging w/o a test/doc/etc"
21:51:32 <notmyname> so if someone has an issue, please feel free to say something to me (privately or otherwise) and remember that we were all once new ourselves :-)
21:51:42 <notmyname> clayg: yep. doesn't mean we land bad code
21:52:14 <notmyname> the ML thread reminds me of the late night hackathon conversation we had as a group about talking in IRC and how difficult than can be for some people
21:52:22 <acoles> don't we give a new contributor their first unit test for free?
21:52:35 <mattoliverau> Lol
21:52:51 <notmyname> mostly that we all have very very different perspectives on social cross-cultural interations in potentially non-native languages
21:53:18 <kota_> :P
21:53:22 <notmyname> acoles: lol
21:53:41 <notmyname> all right. anything else? or are we done for this meeting?
21:54:01 <clayg> acoles: that's a good deal!
21:54:12 <mattoliverau> Done, I'm hungry :p
21:54:14 <acoles> I was half serious
21:54:33 <notmyname> mattoliverau: :-)
21:54:40 <acoles> rather than -1 for no test I might rite the test to encourage future behaviour
21:54:49 <acoles> or even *write* a test
21:54:49 <notmyname> acoles: that's really good
21:54:56 <notmyname> write a right test?
21:55:01 <acoles> but I'm not promising ;)
21:55:03 <notmyname> is that your right?
21:55:10 <notmyname> ok ok ok
21:55:13 <acoles> notmyname: right!
21:55:13 <notmyname> #endmeeting