06:27:46 <reedip> #startmeeting taas
06:27:47 <openstack> Meeting started Wed Jan 20 06:27:46 2016 UTC and is due to finish in 60 minutes.  The chair is reedip. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:27:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:27:50 <openstack> The meeting name has been set to 'taas'
06:28:41 <kaz> hi
06:28:44 <reedip> Hello
06:28:55 <reedip> #topic Agenda
06:29:06 <reedip> Agenda for this meeting has been defined in https://wiki.openstack.org/wiki/Meetings/taas
06:30:21 <reedip> Can everyone go through it, if not done already ?
06:31:10 <reedip> As per the discussion which we had in the last meeting, mail has to be dropped so that the Spec can be reviewed in more depth
06:31:52 <reedip> #action Reedip: Drop a mail on the ML inviting Neutron Core to comment and review the Spec and have a discussion on Gerrit/ Next week team meeting
06:32:51 <reedip> yamamoto_ also proposed  https://review.openstack.org/#/c/229869/ , which would allow integration of Tap-as-a-Service into stackalytics. But in my opinion, it would be taken care of once the Spec is confirmed
06:33:26 <reedip> Currently TaaS is not a part of Stackalytics/governance
06:34:48 <reedip> #link  https://review.openstack.org/#/c/229869/
06:37:20 <reedip> Moving on, work has to be initiated for L2 extension of TaaS
06:37:29 <reedip> #link  https://etherpad.openstack.org/p/l2-agent-extensions-api-expansion
06:37:55 <reedip> yamamoto_ suggested in earlier meeting that this link needs to be updated along with the work for L2.
06:38:18 <reedip> Vinay  ( vyadav) and I would be taking up this work .
06:38:40 <reedip> #action : reedip, vyadav : start work on L2 extension for TaaS
06:39:11 <reedip> #link https://bugs.launchpad.net/tap-as-a-service/+bug/1535993
06:39:12 <openstack> Launchpad bug 1535993 in tap-as-a-service "Convert TaaS to a Neutron L2 extension" [Undecided,New] - Assigned to Reedip (reedip-banerjee)
06:44:25 <reedip> Next Item is requirement for an individual IRC channel, but I guess it would need some inputs from anil_rao and vyadav who would be joining us from next week
06:45:05 <kaz> +1
06:46:22 <soichi> Hi! Excuse me, I'm late.
06:46:30 <reedip> hi soichi , no issues
06:46:42 <soichi> reedip: +1
06:47:35 <reedip> moving on , the next topic is a bit important
06:48:01 <reedip> Inclusion of more core reviewers in gerrit and core members in Launchpad.
06:49:07 <reedip> currently several projects follow two +2 rule to get their changes committed. But TaaS uses one +2 only. So we need to implement the two +2 rule here as well so that it allows a better review prospect
06:49:28 <reedip> for that we may need to include more members in the TaaS core team
06:49:30 <yamamoto_> +1 for the desire but i guess it's something for anil and vyadav to decide.
06:50:16 <reedip> yamamoto_ : Yes, they are the current core members. They will decide if the two +2 are required or not. But inclusion of more members in the core reviewer and core member team is necessary
06:51:25 <yamamoto_> sure, let's leave an action for them :-)
06:51:40 <reedip> yamamoto_ : currently TaaS is not able to create feature requirements( Blue prints) . That can be done by only vyadav for now as he is the owner of the project. If the owner is a group of people ( for eg, neutron drivers), then it would be easier for some one to implement these changes
06:52:02 <reedip> #action anil_rao, vyadav: take a call on two +2 rule for Gerrit
06:52:44 <reedip> #action vayad, anil_rao : Discussion for inclusion of more members in the core reviewer for TaaS
06:52:56 <reedip> #action vyadav, anil_rao : Discussion for inclusion of more members in the core reviewer for TaaS
06:53:49 <reedip> Next item is #link https://review.openstack.org/#/c/248043/
06:54:18 <reedip> kaz, yamamoto_ requested an update for this. Is there any inputs to be given for the same ?
06:56:58 <yamamoto_> i guess the implementation ofs this will be simpler once we made the agent an l2 extension,
06:57:38 <kaz> I think so.
06:57:57 <reedip> yamamoto_ : ok, so we would start working on the L2 extension sooner
06:59:28 <reedip> kaz : can you put a -1 on the workflow , with the message that  https://review.openstack.org/#/c/248043/ would be restarted once work on L2 extension is complete? It would help us and other reviewers to track what is required/blocking a patch
07:00:11 <kaz> ok
07:00:27 <reedip> kaz thanks .
07:00:45 <reedip> The topics from the agenda is complete .
07:00:56 <reedip> #topic Open Discussion
07:02:56 <kaz> #link https://review.openstack.org/#/c/257285/
07:02:58 <kaz> yamamoto_: thank you for your "+1" review comment.
07:03:33 <yamamoto_> kaz: do you have any plan on it?
07:04:34 <kaz> Currently, i think no additional update for it.
07:06:37 <yamamoto_> can you reply to rossella and kevin's comments?
07:07:51 <kaz> ok, I will check the comemnts and reply.
07:08:13 <yamamoto_> kaz: thank you
07:08:38 <yamamoto_> is anyone here working on tempest tests?
07:09:10 <reedip> yamamoto_ not on TaaS yet, but can start on it . Have some bandwidth right now
07:10:37 <yamamoto_> one difficulty is that to make meaningful tests for taas we likely need some "tap" functionality in VMs
07:11:07 <yamamoto_> and the default VM image doesn't seem to have tcpdump etc.
07:14:10 <reedip> can such tests be mapped onto the functional tests ?
07:16:15 <yamamoto_> reedip: i guess some parts of it can be
07:16:55 <yamamoto_> but it doesn't replace the need of tempest tests
07:17:06 <reedip> yamamoto_ , yeah thats right
07:19:31 <reedip> 10 minutes left, anything else to discuss, or should we wrap up early
07:20:21 <yamamoto_> nothing from me
07:20:22 <reedip> yamamoto_ : lets discuss tempest tests in depth once the full team is here next week
07:20:34 <yamamoto_> reedip: sure
07:21:12 <reedip> #action reedip, yamamoto_ : discuss testing related scenarios next week
07:22:02 <reedip> kaz, soichi , anything ?
07:22:18 <soichi> no, i don't have.
07:22:33 <kaz> no, i do not have.
07:22:49 <reedip> Ok, then I can wrap it up ..
07:22:54 <reedip> Thanks for your time everyone
07:22:57 <reedip> #endmeeting