06:29:29 <reedip> #startmeeting taas
06:29:29 <soichi> Hi
06:29:30 <openstack> Meeting started Wed Feb 10 06:29:29 2016 UTC and is due to finish in 60 minutes.  The chair is reedip. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:29:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:29:33 <openstack> The meeting name has been set to 'taas'
06:29:44 <kaz> hello
06:29:53 <reedip> As no one was there, I started it...hope its ok
06:30:03 <fawadkhaliq> hi guys
06:30:13 <anil_rao> Hi
06:30:23 <reedip> Hi fawadkhaliq, kaz, anil_rao, soichi, yamamoto
06:30:35 <yamamoto> hi
06:30:51 <reedip> so lets start the meeting
06:30:57 <reedip> #topic : Agenda
06:31:11 <reedip> #link : https://wiki.openstack.org/wiki/Meetings/taas
06:32:07 <reedip> So as per the last discussion, lets pick up the points mentioned in the link
06:32:25 <reedip> a) Review of the l2 extension
06:32:55 <reedip> I have done it a bit, but not too much.  Vinay would also chip in when he is available, I guess .
06:33:01 <fawadkhaliq> reedip: I have it
06:33:04 <fawadkhaliq> done it
06:33:14 <fawadkhaliq> infact been part of the design of l2-gateway :-)
06:33:29 <fawadkhaliq> Let me know what information we are looking for around l2-gateway
06:33:40 <reedip> fawadkhaliq : great , then you can help us with the implementation of TaaS as an L2 extension
06:33:41 <fawadkhaliq> Sorry I missed the last meeting; was out sick.
06:33:50 <fawadkhaliq> reedip: Yes
06:34:11 <fawadkhaliq> l2-gateway has a nice implementation that it uses neutron standard ports for external endpoints
06:34:25 <fawadkhaliq> mapping to vlans/ports on the physical switches behind VTEPs
06:34:45 <reedip> fawadkhaliq: do you have any documentation for the same? would be great and help us understand the model as well
06:35:06 <fawadkhaliq> so from the API/design perspective, we just need to make sure we can support *any* type of Neutron port rather than just compute ports.
06:35:45 <fawadkhaliq> reedip: this will also make sure we align TaaS with container networking work I am working on in parallel and VLAN aware VMs will be introduced and TaaS will work seamlessly there as well
06:35:56 <fawadkhaliq> reedip: sure, let me find something use for you guys
06:36:03 <fawadkhaliq> please assign an action item to me
06:36:09 <fawadkhaliq> s/use/useful/
06:36:44 <reedip> #action : fawadkhaliq to share some of the documents used in L2 gateway, for implementation of TaaS as a Neutron L2 extension
06:36:55 <fawadkhaliq> reedip: thanks
06:37:31 <reedip> anyone else wants to add something to the L2 extension discussion?
06:37:51 <fawadkhaliq> I can share some details on the use case
06:38:19 <fawadkhaliq> so the idea is that the destination can be a virtual instances or a physical appliance behind l2-gateway connections.
06:39:43 <fawadkhaliq> The most common/most requested use case I have seen is actually around devices which are outside the virtual env, so l2-gateway fits perfectly in this area, where a physical machines maps to a VLAN/port and is associated to a Neutron network via standard port construct, which has IP and other metadata.
06:40:30 <fawadkhaliq> this was a quick summary for everyone's benefit :) that's all
06:41:40 <reedip> fawadkhaliq: thanks for the summary :)
06:42:18 <reedip> does anyone else want to add something, or should we move on ?
06:43:31 <reedip> Okay moving on
06:43:32 <reedip> #topic  Addition of Tap-as-a-service to Governance
06:43:50 <reedip> #link  https://review.openstack.org/#/c/229869/
06:44:21 <reedip> yamamoto proposed the above link , for submission of TaaS into Governance , as well as Neutron Stadium
06:45:33 <reedip> now TaaS seems like a good model for the Neutron Stadium, but with the recent discussions about which projects can be a part of the stadium and which should not, I think we can remove the dependancy of TaaS being a part of Neutron Stadium right now, and concentrate on its acceptance into governance
06:45:43 <reedip> thoughts/comments anyone???
06:46:12 <yamamoto> i guess we should wait for the discussion settled
06:46:21 <fawadkhaliq> yamamoto: +1
06:46:24 <yamamoto> #link https://review.openstack.org/#/c/278025/
06:46:30 <fawadkhaliq> Russell has two patches around this
06:46:48 <fawadkhaliq> we can probably wait for those to get finalized so we don't have to change later
06:48:09 <yamamoto> this review covers us i believe.  if you have any opinion how it should be, it's time to chime in.
06:49:02 <reedip> yamamoto: +1
06:49:46 <fawadkhaliq> so maybe action item for TaaS team to review these patches?
06:49:50 <reedip> yamamoto: but I think most of the neutron folks are in favor of  keeping advanced services separate, atleast for now
06:50:03 <yamamoto> fawadkhaliq: yes
06:50:06 <reedip> fawadkhaliq: yes, it would be good
06:50:44 <reedip> #action All: review  https://review.openstack.org/#/c/278025/ and see how it syncs up with TaaS
06:51:17 <yamamoto> my impressions is either in or out are fine for taas.
06:51:50 <reedip> yamamoto: Having it in Neutron would help us with neutron core-drivers team, in a way
06:52:27 <reedip> yamamoto: having it outside neutron gives us an independent scope , and ability to drive it ourselves, with helpful inputs from the Neutron core team
06:53:35 <reedip> if TaaS is to be considered a separately driven team, with its own objectives and goals, but with good amount of inputs from Neutron, then even having it outside works
06:54:43 <yamamoto> reedip: i guess it's the other way around.  governance should just reflect the reality.
06:55:54 <yamamoto> let's go over the rest of topics.
06:56:02 <reedip> yeah moving on
06:56:13 <reedip> #topic : Two +2 voting
06:56:45 <reedip> anil_rao , in the last meeting we considered that Two +2 voting should be good for TaaS patches
06:57:25 <fawadkhaliq> +2 to 2 +2s ;-)
06:57:31 <reedip> anil_rao: I think this has to be enabled by Repository Owner in gerrit itself.... if so, and if everyone agrees with the Two +2 voting, can we enable it in gerrit?
06:57:50 <reedip> ok, I got fawadkhaliq 's vote :)
06:58:21 <vnyyad> spoke to anil_rao over this and we agree to that... we need 2 core reviewers saying yes
06:58:36 <yamamoto> reedip: i don't think it can/should be forced by gerrit.  it's just a policy.
06:59:05 <vnyyad> reedip, fawadkhaliq: +2
06:59:14 <reedip> yamamoto: I dont know how to enable it, just asked it from the tempest team-member :)
06:59:38 <reedip> vnyyad: welcome  :) and I guess you and anil_rao are the 2 core for TaaS, isnt it?
07:00:06 <vnyyad> yes... but i guess we should also expand the core reviewers by another 2
07:00:17 <fawadkhaliq> vnyyad: +1
07:00:35 <reedip> vnyyad : yes, this is something we discussed last week as well, but was cut short due to time lapse
07:00:36 <fawadkhaliq> given we are making progress and there will be work around this area moving forward.
07:01:28 <reedip> does everyone else agree  with increasing the core reviewers?
07:01:37 <vnyyad> fawad, reedip: +1
07:01:42 <yamamoto> reedip: +1
07:01:44 <fawadkhaliq> reedip: +1
07:01:44 <soichi> +1
07:01:46 <kaz> +1
07:02:12 <reedip> Okay, I guess, majority ( reedip +1 ) votes are in favor
07:02:25 <muawiakhan> +1
07:02:25 <yamamoto> vnyyad: anil_rao: you should propose new core reviewers on openstack-dev as other projects do.
07:02:40 <reedip> vnyyad, anil_rao : I think the next step would be proposal from your end as to who would be the new core reviewer
07:02:54 <reedip> yamamoto: you beat me to it :)  +1
07:03:16 <vnyyad> yamamoto: sure, we shall do it by next week, i will speak with anil on this tomorrow in his morning
07:03:29 <reedip> #action : vnyyad, anil_rao to propose new core reviewers in the openstack-dev ML
07:03:56 <reedip> okay, moving on, one important news
07:04:06 <reedip> #link    https://www.openstack.org/summit/austin-2016/vote-for-speakers/Presentation/8529
07:04:20 <reedip> Our summit session is up for vote
07:04:33 <reedip> so I hope everyone knows what to do :)
07:04:39 <fawadkhaliq> reedip: lol
07:04:42 <fawadkhaliq> done!
07:04:52 <soichi> i added "+3"
07:05:09 <kaz> done.
07:05:09 <reedip> for those who dont, do click on the link , and if you consider Tap as a Service to be a good session , provide it the votes :)
07:05:45 <fawadkhaliq> and please do evangelize with your peers from community :-)
07:05:46 <reedip> #action : all : vote for the summit session, if you like it :)
07:06:15 <reedip> okay, thats it for the points in the Agenda .
07:06:23 <soichi> currently, we are under making update Horizon dashbpard for TaaS.
07:06:24 <reedip> #topic : open-discussion
07:06:34 <soichi> we have re-designed to support options offered by TaaS CLI.
07:06:41 <soichi> i wish it is useful for demo.
07:06:50 <reedip> soichi , thats a great idea actually :)
07:07:21 <anil_rao> If its okay with folks I'd like to bring forth a concern I have regarding the TaaS project
07:07:24 <reedip> end users would love to see something graphical, than a black screen with white text :)
07:07:34 <reedip> anil_rao : sure
07:07:52 <fawadkhaliq> anil_rao: please do
07:08:38 <anil_rao> The main issue I see is that the TaaS project, despite being in existence for more than 1.5 years is still not available to customers in an official capacity.
07:09:43 <anil_rao> We constantly get asked by our customers as to what is keeping something as simple as port-mirroring from making it into OpenStack. After some soul seraching, I think we might be overdesigning the project, at least at this juncture.
07:09:52 <vnyyad> anil_rao: +1
07:10:28 <anil_rao> IMHO what we should start out with is simple mirroring of Neutron ports -- source port(s) --> destination port. The existing API is sufficient to support this.
07:10:51 <reedip> anil_rao : +1
07:11:04 <fawadkhaliq> anil_rao: agree with it. should we make it a phased approach to cater for other use cases as well?
07:11:15 <soichi> anil_rao: +1
07:11:26 <vnyyad> fawadkhaliq: yes, in phases
07:11:31 <anil_rao> Yes, I support the idea of a phased implementation.
07:11:36 <vnyyad> anil_rao: +1
07:11:46 <fawadkhaliq> vnyyad: anil_rao so currently we have something that works
07:11:51 <reedip> fawadkhaliq, anil_rao : complicated things can be moved to a differentversion ( like we have for FW and LB )
07:12:12 <fawadkhaliq> i was thinking we could something like phase 1, phase 2 on the design
07:12:14 <anil_rao> that would be the idea.
07:12:34 <anil_rao> If we want the support of the user and provider community then we must deliver something.
07:12:41 <vnyyad> first thing is to build confidence in potential users that we will get something in..
07:12:48 <fawadkhaliq> where we have the current design, we revert to the original design which works and right after we propose the additional changes. Like Policy, Networks etc
07:13:02 <anil_rao> Yes!
07:13:17 <vnyyad> fawadkhaliq: +1
07:13:46 <reedip> so we are looking at delivering the working model for release in Austin Session :)
07:14:34 <anil_rao> That was what we all were thinking when we met in Tokyo. However, I am not sure if that will be possible at this time. What do you all feel?
07:16:03 <fawadkhaliq> anil_rao: I think its ambitious to make a release in Mitaka
07:16:06 <yamamoto> i think it's possible to make a release for M, as far as we concentrate into minimum functionality
07:16:19 <fawadkhaliq> that's my opinion, given we are a few weeks away
07:16:28 <fawadkhaliq> and we have goverances etc still not sorted
07:16:38 <fawadkhaliq> we also have to think about packaging, testing, documentation etc
07:16:39 <reedip> anil_rao: lets checkout the current code, see what is lacking from the minimum functionality, and then fix it up
07:16:45 <fawadkhaliq> so lots of things to be taken care of
07:16:48 <vnyyad> yamamoto: i guess we should aim for that, what do  you say
07:17:27 <reedip> fawadkhaliq: packaging via devstack is already done . Is there anything else we need to do ?
07:18:17 <anil_rao> The minimum functionality IMHO is mirroring traffic from ports beloning to one or more VMs to another VM belonging to the same tenant. The source and destination ports may not be on the same compute node.
07:18:40 <fawadkhaliq> reedip: was thinking more on the lines for deb/rpm for taas, CLI etc.
07:19:02 <anil_rao> We had this working during the Vancouver TaaS demo. There are, however, some hardening aspects that need to be looked into -- failure scenarios and such.
07:19:42 <anil_rao> Let me pull out the latest version and give it a good run. I'll report back with my findings...
07:19:47 <reedip> fawadkhaliq: Oh ok, CLI is also up with neutronclient , for deb/rpm we can discuss later.
07:20:42 <reedip> anil_rao:  do you have any feedback from the Vancouver session ? you can maybe share it with us and we can also have a look at it?
07:21:51 <anil_rao> The main feedback was how soon can this be available in an official OpenStack release. :-)
07:22:07 <reedip> anil_rao : we need to work on the governance patch for that :)
07:22:18 <reedip> along with the actual code
07:22:28 <vnyyad> anil_rao: i still get that feedback :)
07:22:31 <fawadkhaliq> anil_rao: reedip vnyyad so the next step is that anil_rao will play with the current implementation and we revert the spec to its original state and propose the additional API changes on top that can be worked after/in parallel.?
07:22:52 <anil_rao> My main fear is that if TaaS gets more delayed, there will be alternative proposals to essentially solve the same problem and that will further complicate our chances of getting accepted.
07:23:09 <yamamoto> fawadkhaliq: sounds good to me
07:23:13 <reedip> yamamoto: is it necessary for TaaS to be a part of the neutron stadium right now, or can we propose it later on, first focussing on its inclusion in Openstack offciially?
07:23:31 <reedip> fawadkhaliq : +2
07:23:33 <vnyyad> fawadkhaliq: base version first, additional feature next?
07:23:37 <reedip> 4 minutes left....
07:23:44 <fawadkhaliq> reedip: I would say we sort the governance for sure.
07:24:07 <yamamoto> reedip: i guess either ways we need to wait for the staduim concept discussion
07:24:10 <vnyyad> fawadkhaliq: +1
07:24:50 <reedip> yamamoto: okay, lets check it for another 1-2 weeks ,if it doesnt conclude, then we can proceed ourselves for governance for TaaS as a separate project . Sounds ok ?
07:25:40 <reedip> #action: anil_rao to run the latest code, and get back with what features are missing and need to be added for Mitaka Release
07:25:42 <yamamoto> reedip: it's ok, but i guess we'll be told to wait anyway :-)
07:26:37 <reedip> okay, one minute, anything left ?
07:26:44 <fawadkhaliq> yes
07:26:53 <reedip> fire away :)
07:26:58 <fawadkhaliq> reedip: I will update the spec to the original state
07:27:00 <yamamoto> does "openstack official" matter much?  we can say "this is a tap-as-a-service official release" :-)
07:27:09 <fawadkhaliq> please assign the action to me
07:27:18 <fawadkhaliq> and also share the next steps
07:27:37 <anil_rao> yamamoto: Either way is fine. The problem is what will an actual service provider use in their production clouds.
07:27:44 <reedip> #action fawadkhaliq: revert TaaS spec to the original state.
07:28:09 <yamamoto> fawadkhaliq: please keep ideas and feedback in a section, rather than simply reverting.
07:28:19 <fawadkhaliq> yamamoto: great idea
07:28:20 <fawadkhaliq> thanks
07:28:23 <anil_rao> +1.
07:28:23 <vnyyad> yamamoto: +1
07:28:24 <fawadkhaliq> yamamoto: will keep a section
07:28:31 <fawadkhaliq> and add a follow up patch
07:28:35 <fawadkhaliq> yamamoto: and i can work on that
07:28:38 <reedip> yeah thats good, but time to end the meeting now :)
07:28:49 <reedip> yamamoto: +1
07:28:58 <reedip> catch you guys next week
07:29:06 <fawadkhaliq> thanks everyone
07:29:07 <anil_rao> Thanks and bye...
07:29:08 <fawadkhaliq> bye
07:29:10 <soichi> bye
07:29:11 <yamamoto> bye
07:29:15 <reedip> #endmeeting