05:33:05 <yamamot__> #startmeeting taas
05:33:06 <openstack> Meeting started Wed Jun 15 05:33:05 2016 UTC and is due to finish in 60 minutes.  The chair is yamamot__. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:33:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:33:09 <openstack> The meeting name has been set to 'taas'
05:33:33 <yamamot__> #topic agenda
05:33:40 <yamamot__> #link https://wiki.openstack.org/wiki/Meetings/taas#Agenda_.282016-06-15.29
05:34:03 <yamamot__> #topic do we still aim to make a release compatible with mitaka?
05:35:05 <yamamot__> it has been postponed in the last meeting because of the lack of quorum
05:35:25 <yamamot__> but it seems we have even fewer this week :-(
05:35:36 <kaz> yes
05:35:50 <yamamot__> let's bring it on ml
05:36:09 <kaz> ok
05:36:10 <yamamot__> #action yamamoto raise the release topic on ml
05:36:34 <yamamot__> #topic gate blocker https://review.openstack.org/#/c/326231/
05:36:49 <yamamot__> #link https://review.openstack.org/#/c/326231/
05:37:06 <yamamot__> this is a fix for the gate blocking issue
05:37:25 <yamamot__> please review.
05:37:32 <yamamot__> #topic Open Discussion
05:37:41 <yamamot__> anyone has any topic?
05:38:05 <kaz> yamamoto_: thank you for your comment for my patchset.
05:38:26 <yamamot__> np
05:38:28 <kaz> what do you mean "populate" ?
05:38:48 <yamamot__> #link https://review.openstack.org/#/c/324367/
05:38:58 <kaz> thanks
05:39:16 <yamamot__> i meant that, if there are existing rows, their status somehow need to be set.
05:39:39 <kaz> i see
05:40:18 <kaz> i will update it.
05:40:20 <yamamot__> i think ADD COLUMN can specify the default value.  i don't know how it can be specified via sqlalchemy though.
05:41:24 <yamamot__> i guess there are good examples in neutron migration scripts
05:41:40 <muawiakhan> +1
05:41:57 <kaz> thanks, i will see that
05:43:48 <yamamot__> muawiakhan: hi, can you remind me who are you?  my memory is dim.
05:45:22 <yamamot__> fawad's coworker?
05:45:34 <muawiakhan> @yamamot__ :) I think we haven't met before or talked directly. I work with Fawad.
05:45:44 <muawiakhan> yamamot__: you got that right ;-)
05:45:52 <yamamot__> ok, google is great :-)
05:46:01 <kaz> +1
05:46:16 <muawiakhan> lol
05:47:46 <yamamot__> muawiakhan: what's your interest wrt taas? plumgrid support?
05:49:19 <muawiakhan> @yamamot__ yes, and to follow up on the latest and the greatest.
05:49:58 <yamamot__> in that case, i guess you are interested in this patch
05:50:00 <yamamot__> #link https://review.openstack.org/#/c/307708/
05:50:03 <muawiakhan> I can also take some action items if need be.
05:50:13 <yamamot__> it was necessary for midonet, but should be useful for other vendor drivers
05:50:47 <muawiakhan> will take a look. thanks
05:51:56 <yamamot__> there are a lot of todos.  currently we are trying to concentrate to fix the functionality we already have, rather than adding new features.
05:52:47 <yamamot__> a few important bugs are:
05:52:50 <yamamot__> #link https://bugs.launchpad.net/tap-as-a-service/+bug/1501792
05:52:50 <openstack> Launchpad bug 1501792 in tap-as-a-service "lack of automated tests" [Undecided,In progress] - Assigned to YAMAMOTO Takashi (yamamoto)
05:52:55 <yamamot__> #link https://bugs.launchpad.net/tap-as-a-service/+bug/1535993
05:52:55 <openstack> Launchpad bug 1535993 in tap-as-a-service "Convert TaaS to a Neutron L2 extension" [Undecided,New] - Assigned to Reedip (reedip-banerjee)
05:53:02 <yamamot__> #link https://bugs.launchpad.net/tap-as-a-service/+bug/1565622
05:53:02 <openstack> Launchpad bug 1565622 in tap-as-a-service "OSC support" [Undecided,New] - Assigned to Reedip (reedip-banerjee)
05:54:47 <yamamot__> it's great if you can take some of them
05:55:19 <muawiakhan> i will take a look.
05:55:41 <yamamot__> i guess the poor coverage of automatic tests is the most important issue for vendors who want to implement their own.
05:55:50 <kaz> i will consider.
05:55:51 <reedip> hi
05:55:58 <yamamot__> reedip: hi!
05:55:59 <muawiakhan> will need to catch up on some stuff. but will update.
05:56:02 <reedip> sorry I was busy with other tasks
05:56:20 <reedip> now I have a bit of bandwidth available
05:57:25 <yamamot__> kaz: thank you
05:57:29 <yamamot__> reedip: do you have any update on l2 agent extension?
05:57:48 <reedip> yamamot__ : no, sorry
06:01:02 <yamamot__> reedip: alright.  do you still want to work on it?
06:04:07 <reedip> yamamot__ : I need some help, the arch is not clear to me
06:07:39 <yamamot__> which part of arch?
06:08:34 <reedip> How to implement it as an extension
06:08:51 <reedip> davidsa helped but it was still not clear
06:11:18 <reedip> I will checkout the ovs implementation again
06:12:39 <yamamot__> have you looked at qos extension?
06:14:27 <reedip> I didnt check it out completely
06:14:46 <reedip> I will try to complete it today and ping you if I have any doubts
06:15:09 <yamamot__> it comsumes rpcs and handles port events. these are necessary for taas as well i guess.
06:15:36 <reedip> Can you resend the link if possible ?
06:15:57 <yamamot__> link?
06:17:24 <reedip> https://review.openstack.org/#/c/251738/ ??
06:18:27 <yamamot__> yes
06:18:43 <yamamot__> it's better to look at the code in master though
06:19:08 <reedip> umm, I was thinking this would explain what chages they did
06:19:11 <reedip> but ok
06:20:29 <yamamot__> neutron/plugins/ml2/drivers/openvswitch/agent/extension_drivers/qos_driver.py and 	neutron/agent/l2/extensions/qos.py are important files for our purpose
06:21:32 <reedip_> Ok
06:22:43 <yamamot__> 8 mins left.  does anyone have any other topics?
06:23:21 <reedip_> Nope
06:23:24 <kaz> I have no more topics.
06:25:17 <yamamot__> it seems we've done
06:25:23 <yamamot__> thank you for attending!
06:25:30 <yamamot__> #endmeeting