05:31:03 <soichi> #startmeeting taas
05:31:04 <openstack> Meeting started Wed Mar  1 05:31:03 2017 UTC and is due to finish in 60 minutes.  The chair is soichi. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:31:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:31:08 <openstack> The meeting name has been set to 'taas'
05:31:12 <kaz> h
05:31:12 <yamamoto> hi
05:31:14 <kaz> hi
05:31:15 <soichi> hi
05:31:17 <anil_rao> Hi
05:31:44 <soichi> reedip_ ?
05:32:21 <soichi> #topic Work items to get merged into Neutron Stadium
05:32:42 <anil_rao> did you all attend the PTG
05:33:57 <soichi> i think attendees were yamamoto, reedip, and I.
05:34:15 <reedip_> hi
05:34:23 <anil_rao> Anything interesting to report w.r.t. TaaS?
05:34:35 <soichi> reedip_: hi
05:35:51 <soichi> anil_rao: "In Pike , Tap-as-a-Service would like to target inclusion in Neutron Stadium"
05:35:59 <soichi> #link https://etherpad.openstack.org/p/neutron-ptg-pike-final
05:36:09 <soichi> line 92
05:36:45 <anil_rao> Great! :-)
05:38:43 <anil_rao> I think the most important thing for us is to get the failure/error situations handled. I'll work on that.
05:39:07 <anil_rao> Can we discuss the things in this space that we should address.   inputs anyone?
05:39:29 <soichi> reedip_: could you act as host for today's agenda?
05:41:59 <anil_rao> reedip is not responding... must be a connection issue ...
05:42:42 <reedip_> Hi
05:42:47 <reedip_> sorry I was busy on another issue
05:42:47 <soichi> i think there are work items
05:43:20 <reedip_> we can go through the TaaS wiki first
05:43:26 <reedip_> I updated some things in that Wiki
05:43:42 <soichi> #link https://etherpad.openstack.org/p/neutron-ptg-pike-final
05:43:54 <soichi> #link https://wiki.openstack.org/wiki/Meetings/taas
05:44:56 <reedip_> I think most of us have already gone through the items
05:45:01 <reedip_> for governance
05:45:07 <reedip_> http://docs.openstack.org/developer/neutron/stadium/governance.html#when-is-a-project-considered-part-of-the-stadium
05:45:18 <reedip_> http://docs.openstack.org/developer/neutron/stadium/governance.html#checklist
05:45:29 <reedip_> I discussed with Armando and he was very helpful
05:45:49 <reedip_> TL;DR : We need to conform with the current checklist for Governance
05:46:12 <reedip_> Including OSC implementations and Neutron-Lib migrations
05:46:27 <anil_rao> I can 1) look into the error handling and 2) investigate using the L2 extension framework for TaaS.
05:46:39 <reedip_> Once done, we need to drop a mail to the Neutron Team , explaining why we can qualify for Governance project
05:46:55 <reedip_> L2 extension is also a part of our Governance selection
05:47:18 <anil_rao> reedip_: Good to know.
05:47:26 <reedip_> anil_rao : I have a WIP patch https://review.openstack.org/#/c/401258/
05:47:48 <reedip_> we can take it up together if you have time
05:48:20 <reedip_> I made a checklist earlier for Governance
05:48:32 <anil_rao> reedip_: Sounds good. Let me review your patch in detail and we'll go from there. :-)
05:49:24 <soichi> reedip_: +1 for making a checklist for Governance
05:49:32 <reedip_> https://docs.google.com/spreadsheets/d/1SQyOCU1qut1mPZk0KGdz_c0j2suAq6-6_LL0yowl2NQ/edit#gid=0
05:49:40 <reedip_> Please see if it is visible
05:49:46 <reedip_> I will add more things in it
05:49:57 <reedip_> socihi : please add an action item for me in the Meeting Logs
05:51:16 <reedip_> Moving Forward
05:51:49 <reedip_> manikBindlish and I tried to install and run TaaS on Newton
05:52:22 <anil_rao> reedip_: is this a production setup or DevStack?
05:52:50 <reedip_> anil_rao : this was more of a production based setup , using Packstack Newton/Mitaka and https://launchpad.net/ubuntu/+source/neutron-taas/0.0.0+git20160926.675af77-0ubuntu1
05:53:09 <soichi> #action reedip_: made a checklist earlier for Governance
05:53:45 <anil_rao> reedip_: I saw the document you attached in your email today. The install instructions for Ubuntu look extremely painful. Why do we need so much stuff?
05:54:31 <reedip_> anil_rao : That was the mismatch between the Upstream package created for TaaS and packstack/stable deployment of Mitaka/Newton
05:54:48 <manikBindlish> Last neutron version(for Newton release) was release on 3rd Dec, 2016 but the taas package was old from this date.
05:55:43 <reedip_> we put up the question on https://answers.launchpad.net/ubuntu/+source/neutron-taas/+question/460600
05:55:47 <reedip_> No updates on that yet
05:56:08 <anil_rao> Perhaps we should target Ocata for this kind of work. What do you think?
05:56:53 <reedip_> anil_rao : The latest package for TaaS lies between newton and ocata ( release in Mid December)
05:57:08 <reedip_> I think we would face similar issue again
05:57:28 <reedip_> anil_rao : BTW we know how painful it was... took a lot from us :D
05:57:39 <anil_rao> We can request the Ubuntu folks to build a new version of TaaS. Mitaka seems old by comparison.
05:58:11 <anil_rao> If we are planning to get into the Statdium in Pica that Ocata is our best bet for the moment IMHO.
05:58:23 <anil_rao> that --> then
05:58:31 <reedip_> Pica -> pike
05:58:37 <anil_rao> yup
05:58:50 <reedip_> yeah, sure. I have raised the bug for the same reason
05:58:52 <soichi> i think so, too
05:59:38 <reedip_> Moving forward , if there is nothing to add in this for now .....
06:00:13 <reedip_> In PTG I discussed with Igor for the Common Classifier Model. The updated spec is https://review.openstack.org/#/c/333993
06:00:39 <soichi> #topic Important Reviews:
06:00:58 <reedip_> We can review it from the TaaS perspective to identify what are the things we need in the common classifier model
06:01:28 <anil_rao> +1
06:01:40 <reedip_> I have started participating in thier meetings from TaaS and FwaaS perspective
06:02:06 <reedip_> davidsha would share the PoC for CC Model soon
06:02:13 <reedip_> #link http://eavesdrop.openstack.org/meetings/network_common_flow_classifier/2017/network_common_flow_classifier.2017-02-28-17.00.html
06:03:01 <reedip_> anil_rao, kaz, soichi : Please go through the review , so that anything missing can be added to the Spec
06:03:16 <anil_rao> reedip_: Will do.
06:03:40 <kaz> reedip_: sure
06:03:42 <soichi> i will take a look it
06:04:01 <reedip_> thanks....
06:04:18 <reedip_> the next review item is https://review.openstack.org/#/c/320439/ : ajo's L2 extension
06:05:55 <reedip_> anil_rao : I think this was the review you were discussing in the last meeting before the PTG
06:06:04 <anil_rao> I have reviewed this. It is what we need to get past the VLAN limitation that caused me to comment out some code last year in the TaaS Driver.
06:06:17 <vnyyad> +1
06:06:31 <reedip_> anil_rao : Ok, I will also view it tomorrow
06:07:06 <reedip_> I have no more topics to discuss
06:07:38 <manikBindlish> I have a question
06:07:46 <anil_rao> Yes?
06:08:15 <manikBindlish> I sent a mail on devstack mailing list yesterday
06:08:31 <manikBindlish> http://lists.openstack.org/pipermail/openstack-dev/2017-February/113034.html
06:09:17 <manikBindlish> instances are pinging but packets are not captured, so how to debug the issue?
06:09:53 <manikBindlish> as yamamoto san suggested to disable security group, i have tried that but still the problem exist
06:10:26 <anil_rao> For the destination port you will need to disable port-security.
06:10:58 <manikBindlish> security was disabled for both the ports
06:11:27 <anil_rao> Not Security Groups but port-security. And only for the destination port. no change is required for the source ports.
06:13:06 <manikBindlish> hi anil_rao : So should I (a) Enable Port security in Source port or keep it disabled
06:13:20 <manikBindlish> (b) I do not have any SG on Source or Dest Port. Is that ok?
06:13:44 <manikBindlish> (c) How can I veiw the packet transfer from OVS Bridge ? Any suggestions on debugging TaaS?
06:13:47 <anil_rao> The source port does not need any special action. Just leave it as is. It can have Security Groups set ... it does not matter.
06:15:33 <anil_rao> Using ovs-ofctl you can see the count of packets passing through the various OVS bridges for debugging.
06:18:04 <manikBindlish> Ok, I will use dump-flows on br-ex and br-tun and br-tap to see the flows and respond back on the ML
06:18:11 <manikBindlish> anil_rao : hope that sounds ok ?
06:19:15 <anil_rao> Also check in br-int to see if the capture is actually happening for the ports assocaited with the source and if the tap-service is delivering to the destination.
06:19:57 <manikBindlish> Ok
06:20:19 <soichi> I think you may get a hit for debugging from the presentation: https://www.openstack.org/videos/barcelona-2016/openstack-troubleshooting-so-simple-even-your-kids-can-do-it
06:21:10 <soichi> they checks tap devices by using tcpdump
06:21:36 <manikBindlish> ok, I can try by this
06:23:10 <reedip_> we can add this info in the docs I shared yesterday
06:23:47 <anil_rao> reedip_: I was meaning to ask ... what is that doc for?
06:24:26 <reedip_> it was discussed earlier to have a technical document for others, like users and developers to undertsand about taas, how it can be used etc.
06:25:38 <anil_rao> I thought we had already covered that in our different Summit presentations. Is there something that we haven't covered.
06:25:55 <reedip_> Debugging and recovery, for example.
06:26:59 <anil_rao> reedip_: Debugging IMO is more of a Neutron thing. Anyone familiar with debugging Neutron networks should be able to use the same techniques for debugging TaaS after one has studied the traffic flow path in TaaS.
06:27:30 <anil_rao> Recovery we will handle by the stuff I am looking into for error case coverage.
06:27:50 <anil_rao> we have big gaps in this area which makes TaaS unusable in a production environment.
06:28:06 <anil_rao> I wanted to discuss this topic for the last two meetings but never get thetime. :-)
06:28:30 <anil_rao> Perhaps next week. :)
06:28:41 <vnyyad> ani_rao: let make it an agenda for next week
06:28:56 <soichi> +1
06:29:05 <anil_rao> vnyyad: It is on the agenda for the last two meetings...
06:30:14 <vnyyad> :) i mean lets just have it as the first item and stick to it :)
06:30:21 <anil_rao> +1
06:30:27 <soichi> +1
06:30:40 <soichi> it looks run out of time
06:30:45 <soichi> see you next week
06:30:52 <anil_rao> Bye
06:30:55 <yamamoto> bye
06:30:57 <vnyyad> see you bye!
06:30:57 <kaz> bye
06:30:58 <soichi> #endmeeting