16:01:26 <s3wong> #startmeeting tacker
16:01:27 <openstack> Meeting started Thu Jun 25 16:01:26 2015 UTC and is due to finish in 60 minutes.  The chair is s3wong. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:30 <openstack> The meeting name has been set to 'tacker'
16:01:39 <s3wong> #chair sridhar_ram
16:01:40 <openstack> Current chairs: s3wong sridhar_ram
16:02:18 <s3wong> agenda: #link  https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_June_25.2C_2015
16:02:34 <s3wong> #topic announcements
16:03:11 <s3wong> We are helping Comcast doing preliminary installation of Tacker in their lab tonight
16:03:17 <s3wong> 10pm PDT
16:04:09 <s3wong> anyone interested to join?
16:04:16 <Rajkumar_> Hi All  - This Raj and going to work with Stephen for tacker installation in our Comcast setup
16:04:35 <s3wong> Rajkumar_: hello
16:04:46 <sridhar_ram> Rajkumar_: hi, glad you folks are trying out
16:05:02 <Rajkumar_> I hope Sridhar also joining with us. Just sent invite to them as well
16:05:03 <bobh_> s3wong: I'm interested but that's pretty late here - I'll join if I'm still up
16:05:12 <s3wong> Rajkumar_: we will definitely try our best to make installation easy for you guys
16:05:21 <s3wong> bobh_: sure, her is the info
16:05:27 <sridhar_ram> Rajkumar_: yes, I'm planning to join
16:05:36 <Rajkumar_> Thanks Stephen. We're looking forward to it.
16:05:43 <sridhar_ram> s3wong: that's the next item in the agenda!
16:05:50 <s3wong> #info #link https://tcs.webex.com/tcs/j.php?MTID=m7bc6148f7563818da87338bc1df17be1
16:06:01 <bobh_> s3wong: thx
16:06:05 <s3wong> #info Meeting number 868 735 031
16:06:17 <Rajkumar_> Thanks Sridhar.
16:06:28 <s3wong> #info Meeting password: 123  (because no one will ever guess that one if I didn't tell)
16:06:50 <s3wong> Any other announcements?
16:06:55 <sridhar_ram> announcement wise .. it is july 4th weekend next week. Should we plan to skip the mtg for next week ?
16:07:10 <s3wong> sridhar_ram: +1
16:07:37 <sridhar_ram> how abt this - anyone definitely want one next week ?
16:07:57 <s3wong> Everyone OK with skipping the meeting next week?
16:08:03 <s3wong> ... going once
16:08:09 <s3wong> ... going twice
16:08:13 <vishwanathj> ok to skip
16:08:18 <s3wong> ... SOLD
16:08:20 <bobh_> ok
16:09:05 <s3wong> #info there will be no Tacker meeting next Thurs; meeting will resume on July 9th
16:09:39 <s3wong> we can still find each other on #tacker if you want to raise anything
16:09:52 <s3wong> any other announcement?
16:10:12 <s3wong> OK --- moving on
16:10:26 <s3wong> #topic Ease of installation
16:10:56 <s3wong> subtopic #1: devstack
16:11:06 <sripriya> The new devstack repo is at: https://github.com/srics/devstack/tree/tacker-devstack
16:11:20 <s3wong> so two pieces: a sample local.conf, and devstack plugin
16:11:50 <sridhar_ram> note, this is an interim step until we have tacker devstack integration ..
16:11:51 <s3wong> I took the local.conf from the link sripriya gave above, and replace some IP addresses to localhost
16:12:10 <s3wong> so this works, and I will send out a patch to get folks started
16:12:25 <s3wong> for (slightly) longer term, we will do devstack plugin
16:12:33 <s3wong> sripriya has volunteered to do this
16:12:35 <sridhar_ram> s3wong: I think we need a lot simpler local.conf
16:12:41 <s3wong> sripriya: any update?
16:13:00 <sripriya> s3wong: its in a good progress
16:13:05 <sridhar_ram> what we have in the repo is something some yamahata's dev environment
16:13:18 <s3wong> sridhar_ram: agreed --- I wonder if all those MY_HOST == SERVICE_HOST thing is necessary, or checking for neutron_legacy and so on
16:13:30 <sripriya> i will be trying to submit patchset soon
16:13:37 <sripriya> this will be on devstack kilo release
16:13:56 <s3wong> sripriya: very good!
16:13:58 <sripriya> yes i will remove the unwanted lines from local.conf
16:13:59 <sridhar_ram> s3wong: in fact I use a ridiculously simple local.conf to successfully install tacker
16:14:10 <sripriya> sridhar_ram: +1
16:14:22 <sridhar_ram> sripriya: I can share mine w/ you to refer
16:14:40 <s3wong> sridhar_ram: yeah, I looked at local.conf.sample from networking-ovn, it is drop dead simple
16:14:47 <sripriya> sridhar_ram: thanks
16:15:11 <s3wong> sridhar_ram: I can definitely resolve it down to tens of lines as a sample
16:15:19 <sridhar_ram> I also have an install.rst .. it is time to post it in our doc/devref ..
16:15:37 <sridhar_ram> I shared it w/ few folks from ALU
16:15:53 <s3wong> sridhar_ram: OK, cool
16:16:08 <s3wong> anything else on devstack?
16:16:11 <sridhar_ram> yes
16:16:36 <sridhar_ram> I raised this https://bugs.launchpad.net/tacker/+bug/1468568
16:16:36 <openstack> Launchpad bug 1468568 in tacker "Tacker Install: automatically install tacker-horizon as part of devstack" [Medium,New]
16:17:09 <sridhar_ram> tacker devstack should also enable required horizon dashboard automatically
16:17:15 <s3wong> sridhar_ram: that's right. Today you still have to do this manually
16:17:41 <sridhar_ram> We should make tacker install ridiculously simple :)
16:17:57 <sripriya> +1
16:18:33 <sridhar_ram> we can plan this bug after / along w/ the tacker-devstack support
16:18:34 <s3wong> sridhar_ram, sripriya, vishwanathj: is one of you going to take on this bug?
16:18:54 <sripriya> s3wong: i will take care of this as part of plugin development
16:19:03 <sripriya> sridhar_ram: you can assign it to me
16:19:09 <s3wong> sripriya: thanks!
16:19:18 <sridhar_ram> sripriya: sure, will do. thanks
16:19:33 <s3wong> anything else on devstack?
16:19:45 <s3wong> Moving on
16:20:00 <s3wong> #info subtopic #2: heat patch
16:20:38 <sridhar_ram> AFAIK the patch is close to being merged
16:20:44 <s3wong> apparently it was approved  https://review.openstack.org/#/c/179989/
16:20:57 <s3wong> didn't pass Jenkins though
16:21:19 <s3wong> once it passes Jenkins it should be merged
16:21:31 <s3wong> seems like Yalei Wang has taken over the patch from yamahata
16:21:47 <sridhar_ram> yep. thanks to yamahata !
16:22:11 <s3wong> great stuff indeed
16:22:39 <s3wong> although it doesn't seem like it will be back ported to stable/kilo
16:23:06 <s3wong> so for our initial devstack scripts, we may still need to include HEAT_BRANCH variable setting
16:23:30 <s3wong> any other question on Heat patch?
16:23:31 <sridhar_ram> s3wong: that another topic .. we should gently move towards master !
16:23:45 <s3wong> sridhar_ram: we should
16:24:01 <s3wong> sridhar_ram: but NOT before we made tacker installation ridiculously simple
16:24:32 <s3wong> sridhar_ram: we should go from a base that we KNOW works to get the various ease of installation items done, then we can move toward master
16:24:34 <sridhar_ram> s3wong: absolutely
16:24:46 <sridhar_ram> moving to master is non-trivial effort
16:25:15 <s3wong> sridhar_ram: indeed --- I don't expect that to be a simple change in local.conf and everything works :-)
16:25:24 <sridhar_ram> :)
16:25:30 <s3wong> alright, moving on
16:25:46 <s3wong> #info subtopic #3: installation docs
16:26:08 <s3wong> so Rajkumar_ has mentioned that we badly lacked installation documentation
16:26:21 <s3wong> I say we are guilty as charged
16:26:35 <sridhar_ram> s3wong: I'll take an AI to upload usage.rst to doc/devref
16:26:47 <s3wong> sridhar_ram: cool, thanks!
16:27:02 <s3wong> #action sridhar_ram to upload usage.rst to doc/devref
16:27:05 <Rajkumar_> It would be grateful to have installation document like other openstack services.
16:27:45 <sridhar_ram> Rajkumar_: we will get there...
16:28:07 <s3wong> Rajkumar_, sridhar_ram: I have to be honest, we really haven't installed Tacker outside of devstack
16:28:09 <sridhar_ram> Rajkumar_: in fact once your team is confortable w/ Tacker .. it will be great if you can join to help out
16:28:17 <Rajkumar_> if the installation goes well tonight then we can document the same and share it
16:28:56 <s3wong> Rajkumar_, sridhar_ram: so as one of the side benefit of us supporting Comcast to install Tacker, we can also be documenting the steps as we go, and have a true installation document as a result
16:29:07 <sridhar_ram> s3wong: oh yeah, I meant the installation doc only in the context of devstack!
16:29:12 <Rajkumar_> yes.
16:29:13 <s3wong> Rajkumar_: +1
16:29:30 <s3wong> Rajkumar_: hopefully we will make some good progress tonight!
16:29:51 <Rajkumar_> Thanks Stephen. looking forward to it.
16:30:15 <Rajkumar_> BTW, We've issues in tacker installation of devstack
16:30:35 <Rajkumar_> I already mailed you guys with issues description and logs
16:30:45 <s3wong> Rajkumar_: that should be the first item we look to tackle tonight right off the bat
16:31:21 <Rajkumar_> oslo.utils version across glance & keystone services
16:31:42 <Rajkumar_> Ok. Thank you.
16:32:02 <s3wong> Rajkumar_: you are using devstack branch stable/kilo, right?
16:32:05 <sridhar_ram> Rajkumar_: sripriya has an handle on this issue. We sure can help to unblock you folks
16:32:53 <Rajkumar_> yes.
16:33:11 <Rajkumar_> I used stable/kilo
16:33:51 <s3wong> Rajkumar_: hmm... OK... need to take a look at your local.conf to see why oslo versions between glance and keystone do not agree...
16:34:01 <s3wong> anything, will do that offline
16:34:10 <s3wong> *anyway
16:34:22 <s3wong> anything else on documentation?
16:34:28 <Rajkumar_> Sripriya is also looped in mail with logs.
16:35:00 <s3wong> Rajkumar_: yes
16:35:15 <s3wong> alright, moving on to the next topic
16:35:26 <s3wong> #topic Bugs
16:35:45 <s3wong> sridhar_ram: any bugs you want to highlight?
16:35:54 <sridhar_ram> yes..
16:36:19 <sridhar_ram> I went ahead and opened bugs for the issues I've seen so that we have a handle on them
16:36:43 <sridhar_ram> req #1 to the team: please open bugs for the issues you see!
16:37:09 <bobh_> sridhar_ram: If any of the bugs are low-hanging/fairly easy I would like to take on one or two to start to get to know the codebase better
16:37:12 <sridhar_ram> it will help to prioritize beyond what is capable using Action Items in this meeting
16:37:26 <sridhar_ram> bobh_: awesome
16:37:36 <sridhar_ram> that was my req#2 :)
16:38:03 <sridhar_ram> I've marked few of the bugs as low hanging fruit for you to pick
16:38:21 <bobh_> sridhar_ram:  Thanks - I'll take a look
16:38:35 <s3wong> sridhar_ram: you want to list them on the meeting channel?
16:38:35 <sridhar_ram> Folks who are new to Tacker this is an awesome way to understand and contribute back
16:38:45 <sridhar_ram> sure, here are few ..
16:39:05 <sridhar_ram> https://bugs.launchpad.net/tacker/+bug/1468560
16:39:06 <openstack> Launchpad bug 1468560 in tacker "Tacker horizon - Delete VNFD doesn't take effect" [Low,New]
16:39:13 <sridhar_ram> https://bugs.launchpad.net/tacker/+bug/1468563
16:39:14 <openstack> Launchpad bug 1468563 in tacker "Tacker horizon - Terminate VNF doesn't take effect" [Low,New]
16:39:50 <sridhar_ram> even this one should be relatively easy..
16:39:51 <sridhar_ram> https://bugs.launchpad.net/tacker/+bug/1468565
16:39:52 <openstack> Launchpad bug 1468565 in tacker "Tacker: Error during VNF create returns internal error" [Low,New]
16:40:28 <sridhar_ram> Please look at https://bugs.launchpad.net/tacker/ for new bugs and take it up !
16:40:54 <s3wong> sridhar_ram: good QA effort :-)
16:41:21 <sridhar_ram> I've marked the ones related to installation with higher priority
16:41:24 <sridhar_ram> s3wong: thanks!
16:42:27 <s3wong> any other bugs related things we want to discuss?
16:42:55 <s3wong> we will check on bug progress in the next meeting (which is two weeks from now)
16:43:02 <s3wong> hopefully some of them will be fixed by then
16:43:06 <sridhar_ram> s3wong: that's it for now, looking forward for patchset for these bugs!
16:43:24 <s3wong> moving on
16:43:34 <s3wong> #topic Health Monitoring
16:43:55 <s3wong> bobh_, prashantD: anything to update on that front?
16:44:11 <s3wong> spec timeline, more specifically?
16:44:14 <bobh_> We were finally able to get monasca installed locally so we can start looking at that
16:44:32 <prashantD> no update on the spec. before updating the spec we were discussing about putting usecase document
16:44:44 <bobh_> I will have some time next week to start writing a spec.  dgollub suggested a usecasespec for the vtelco-wg so I might combine the two
16:45:07 <s3wong> bobh_: OK. Sounds good
16:45:16 <bobh_> I think we need to define the different layers of monitoring and decide which ones we want to tacke=le
16:45:22 <bobh_> *tackle
16:45:34 <s3wong> bobh_: particularly as it pertains to Liberty timeline
16:45:37 <sridhar_ram> bobh_: prashantD: please keep the current mgmt_driver framework already in place while thinking about monitoring plugin framework
16:46:09 <sridhar_ram> health / KPI monitoring is key for Tacker ..
16:46:14 <s3wong> bobh_, prashantD: keep in mind that the spec is only for Liberty, so we need to take that into account when considering the scope
16:46:35 <s3wong> monitoring is a big area, and will likely evolve over multiple cycles
16:46:40 <bobh_> s3wong: OK - maybe the spec will be a small subset of what I write for the vtelco-wg usecase
16:46:54 <sridhar_ram> I'd like to see something, even a simple framework in place for Liberty
16:46:55 <s3wong> bobh_: +1
16:47:43 <bobh_> sridhar_ram: ok, I should have something basic by the next meeting
16:47:44 <sridhar_ram> bobh_: we can use the spec review to phase this
16:47:55 <sridhar_ram> bobh_: great
16:47:57 <s3wong> bobh_, prashantD: please work together to finalize the scope of what can be done within the cycle
16:48:17 <bobh_> prashantD: I'll send you a draft next week
16:48:36 <prashantD> bobh_ : sure, thanx
16:48:48 <bobh_> prashantD: sorry, I meant updates to the spec you started
16:49:07 <s3wong> looking forward to reading you guys' spec soon
16:49:43 <s3wong> moving on
16:50:00 <s3wong> #topic status update
16:50:21 <s3wong> action items from last week
16:51:04 <s3wong> dgollub: setting up meeting with serg_melikyan for Murano extension point?
16:52:31 <s3wong> apparently a meeting hasn't been scheduled :-)
16:52:43 <s3wong> and TBH it isn't very urgent, so it is fine
16:52:48 <sridhar_ram> s3wong: +1
16:53:08 <s3wong> the other two AIs we already discussed (local.conf.sample and devstack plugin), and they are progressing
16:53:26 <s3wong> going back to the meeting before last week, one AI is for sridhar_ram
16:53:30 <s3wong> functional tests?
16:53:57 <sridhar_ram> yes, I was about to bring it... even though I didn't make much progress ;-)
16:53:57 <dgollub> s3wong: sorry, didn't had time to setup a meeting yet. I try to do something for next week.
16:54:45 <s3wong> sridhar_ram: to be fair, my AI of unit test has also been no progress :-)
16:54:56 <s3wong> dgollub: NP. Thanks!
16:54:58 <sridhar_ram> I'll have an update .. at least the effort + plan (and may be more) to get there by our next meeting
16:55:41 <s3wong> sridhar_ram: yeah --- you should work during ID4 weekend :-)
16:56:26 <sridhar_ram> s3wong: yeah, when things are quite .. without any meetings
16:56:32 <sridhar_ram> *quiet
16:57:01 <s3wong> sridhar_ram: yeah, for me too. When my day job is not on my way :-)
16:57:08 <s3wong> alright, we are onetime!
16:57:14 <s3wong> * on time
16:57:21 <s3wong> #topic Open Discussion
16:57:22 <sridhar_ram> well.. this is turning out to be my day job ;-)
16:57:45 <s3wong> anything anyone wants to discuss?
16:58:29 <s3wong> alright, finish TWO whole minutes early!
16:58:32 <s3wong> Thanks everyone
16:58:43 <sridhar_ram> thanks everyone!
16:58:49 <s3wong> talk to you guys in two weeks, or on #tacker
16:58:53 <vishwanathj> bye
16:58:55 <bobh_> bye
16:58:57 <s3wong> #endmeeting