16:02:21 <sridhar_ram> #startmeeting tacker
16:02:22 <openstack> Meeting started Thu Sep 24 16:02:21 2015 UTC and is due to finish in 60 minutes. The chair is sridhar_ram. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:26 <openstack> The meeting name has been set to 'tacker'
16:02:32 <sridhar_ram> #chair bobh
16:02:33 <openstack> Current chairs: bobh sridhar_ram
16:02:59 <sridhar_ram> #topic Roll Call
16:03:07 <vishwanathj> present
16:03:24 <sridhar_ram> please enter your name
16:03:28 <bobh> present
16:03:40 <sripriya> sripriya
16:03:45 <vishwanathj> vishwanathj
16:03:51 <bobh> bobh
16:03:52 * sridhar_ram trying something new like other meeting :)
16:04:15 <tbh> tbh
16:04:40 <sridhar_ram> thanks!
16:04:46 <sridhar_ram> #topic Announcement
16:05:12 <sridhar_ram> Mitaka OpenStack Summit - just a month away
16:05:37 <sridhar_ram> Started this etherpad to plan for our summit events ...
16:05:39 <sridhar_ram> https://etherpad.openstack.org/p/mitaka-tacker-design-summit
16:05:42 <sridhar_ram> #link https://etherpad.openstack.org/p/mitaka-tacker-design-summit
16:06:05 <sridhar_ram> Please enter your name if you are planning to be there in Tokyo
16:06:56 <sridhar_ram> We can work on topics of interest to discuss in next few weeks to prepare for a productive tacker design summit
16:08:07 <sripriya> sridhar_ram: did we get a slot in design summit?
16:08:33 <sridhar_ram> sripriya: no, only governance projects gets official slots
16:08:52 <sripriya> sridhar_ram: ok
16:09:20 <sridhar_ram> we got plan something adhoc among ourselves .. I'll start a doodle poll to pick a timeslot to chose and meet
16:09:38 <sripriya> sridhar_ram: sounds good
16:10:07 <sridhar_ram> meanwhile, as mentioned in the etherpad, we *might* also get a BoF session on Tuesday 12:05
16:10:25 <sridhar_ram> any other general news / heads up related to tacker ?
16:11:11 <sridhar_ram> btw, here is the Agenda :) #link https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_Sep_24.2C_2015
16:11:25 <sridhar_ram> .. for today's meeting
16:11:50 <sridhar_ram> #topic Liberty Release Status
16:12:30 <sridhar_ram> bobh: tbh: do you want to give a quick update on health-monitoring ?
16:13:13 <bobh> sridhar_ram: I pushed the framework last night - it works as a complete replacement of the existing ping mechanism and also will translate existing templates that use ping into the new driver format
16:13:20 * sridhar_ram likes the rhyming irc handles for this tacker health-monitor subteam :)
16:13:45 <bobh> also fixed the problem with monitoring hanging after a respawn - the thread was waiting on a lock it already had
16:14:11 <bobh> Please review and provide feedback - I'm sure there are optimizations that need to be made
16:14:16 <sridhar_ram> bobh: cool, I was suspecting a run-away lock as well
16:14:44 <bobh> sridhar_ram: and deploying a new VNF while the monitor was locked would lock up the whole server
16:15:07 <bobh> #link https://review.openstack.org/224384
16:15:15 <sridhar_ram> bobh: I see, that's nasty
16:15:42 <bobh> looking forward to all comments - I'm sure I have a lot to learn :-)
16:16:19 <sridhar_ram> bobh: I'm sure we will have a productive review cycle...!
16:16:28 <sridhar_ram> team - please help out
16:16:31 <tbh> I am updating docs
16:16:50 <tbh> And will modify http ping driver to test
16:17:38 <sridhar_ram> tbh: http-ping is important - as it will validate the new loadable health-mon framework
16:18:38 <sridhar_ram> in fact I was thinking if we need to leave a sample_health_mon driver that would .. say send event back to main tacker server and have it react to it
16:18:55 <tbh> sridhar_ram: yeah I am syncing with ping driver
16:19:22 <sridhar_ram> btw, I realized currently the only valid action we have is "respawn"
16:19:46 <tbh> Yeah
16:19:48 <bobh> sridhar_ram: There is also a "log_and_kill"
16:19:49 <sridhar_ram> how easy it is to add a "log" action ?
16:20:15 <bobh> sridhar_ram: Though if it's already dead not sure why we need to kill it...
16:20:15 <sridhar_ram> bobh: that's cool, why kill ?
16:20:36 <bobh> sridhar_ram: It was there already - I just left it in place :-)
16:20:49 <sridhar_ram> bobh: I see :)
16:21:09 <bobh> sridhar_ram: Would be nice to add a heat stack action-check / stack-update
16:21:24 <bobh> sridhar_ram: that adds some additional complexity and relies on Kilo heat
16:21:31 <sridhar_ram> I'm thinking bit generic where a health-mon driver captures a non-catastrophic event
16:21:45 <bobh> sridhar_ram: That's easy to add
16:22:00 <bobh> sridhar_ram: I'll consider that the first comment
16:22:09 <s3wong> hello
16:22:29 <s3wong> for some reason, my xchat client on mac couldn't connect to freenode
16:22:37 <s3wong> so I am now on webclient...
16:22:43 <sridhar_ram> bobh: there you go.. you got the first comment already .. without looking at the code :)
16:22:59 <sridhar_ram> s3wong: hi there
16:23:00 <bobh> sridhar_ram: pretty impressive
16:23:16 * sridhar_ram in the clouds ..
16:24:37 <sridhar_ram> tbh: bobh: are you planning some unit testcase as well ?
16:24:56 <s3wong> seems like freenode is having some problem (just dropped a bunch of people apparently)
16:25:06 <sridhar_ram> s3wong: yep
16:25:23 <bobh> sridhar_ram: I'd like to add at least a few - I'll take a look at the test unit framework
16:25:53 <sridhar_ram> bobh: sure, look at the MANO api for guidance..
16:25:59 <bobh> sridhar_ram: will do
16:26:18 <sripriya> bobh: o/ i can help
16:26:26 <bobh> sridhar_ram: Thanks!
16:26:42 <bobh> sripriya: sorry - thanks!
16:26:59 <sridhar_ram> lets move on...
16:27:39 <sridhar_ram> #topic Liberty Deadlines
16:28:33 <sridhar_ram> just a quick assessment of the where we are ...
16:28:59 <sridhar_ram> we were shooting for 9/25 as the date to shoot for as the target..
16:29:27 <sridhar_ram> I think we have most of things in .. atleast in the review queue. so I'm happy
16:29:55 <sridhar_ram> obviously we need some more time to finish the reviews before we can merge
16:30:00 <sripriya> +1
16:30:55 <sridhar_ram> Lets shoot for next Friday to land most of the items ...
16:30:56 <bobh> +1
16:31:09 <sripriya> +1 again
16:32:09 <sridhar_ram> we also need a solid bug fix cycle / spring before we can pull a stable/liberty branch
16:32:22 <vishwanathj> +1
16:32:49 <bobh> +1
16:32:59 <sridhar_ram> s/spring/sprint/
16:33:48 <sridhar_ram> we can plan a 2-week Oct 4 - 16 bug sprint and pull the stable/liberty at the end of it...
16:34:27 <sridhar_ram> too late ? just enough ?
16:34:54 <bobh> sounds good to me
16:35:02 <vishwanathj> agree with bobh
16:35:43 <sridhar_ram> ack back .. lets go w/ that then
16:35:53 <sridhar_ram> I don't see prashantD here
16:36:17 <sridhar_ram> he is still working thru' the auto-scaling spec and related investigations..
16:36:38 <sridhar_ram> it is unlikely that would land in Liberty .. we need to move to mitaka
16:37:33 <sridhar_ram> I'll work w/ prashantD to re-propose the auto-scaling spec for Mitaka and continue the efforts in the master post stable/liberty
16:38:00 <sridhar_ram> meanwhile I'm looking for s3wong to finish the MANO api review ...
16:38:21 <s3wong> sridhar_ram: yes, should happen around tomorrow
16:38:23 <sridhar_ram> we need to land that first / early so that bobh can absorb the changes early enough
16:38:42 <sridhar_ram> s3wong: thanks!
16:39:15 <sridhar_ram> any other questions on general upcoming deadlines / milestones ?
16:39:47 <sridhar_ram> #topic Bug Sprint
16:40:18 <sridhar_ram> I would request an all-hands on deck bug sprint over next 2 - 3 weeks...
16:40:25 <sridhar_ram> here is the list of unassigned bugs..
16:40:57 * sridhar_ram quickly creating a bitly as the url is huge
16:41:12 <sridhar_ram> #link http://bit.ly/1G4Z9Rq
16:41:55 <sridhar_ram> I'm planning to join the bug sprint as well and squash as many of them as possible :)
16:42:08 <shrinathsuresh> Hello Sridhar
16:42:20 <bobh> sripriya: there might be some overlap in the "create fails" bugs
16:42:20 <shrinathsuresh> am working on #1489189
16:42:27 <shrinathsuresh> almost in completion stage..
16:42:30 <sripriya> sridhar_ram: does this include RFE bugs?
16:43:10 <sridhar_ram> shrinathsuresh: hi, sounds good... keep the fixed coming!
16:43:22 <sridhar_ram> bobh: agree, the root cause might be the same
16:43:31 <sripriya> bobh: let me take a look at them
16:44:15 <sridhar_ram> sripriya: no, we should focus mostly on real functional bugs instance of enhancements
16:44:24 <sridhar_ram> *instead
16:44:49 <sripriya> sridhar_ram: ok
16:44:52 <sridhar_ram> btw - should we announce a Bug Squasher MVP award .. to be given in the summit ? :)
16:45:40 <sridhar_ram> lets move on.. while the team thinks abt it
16:45:46 <sridhar_ram> #topic Documentation
16:46:13 <sridhar_ram> I think we will have some decent devrefs at the end of this release ...
16:46:37 <vishwanathj> I will add some devrefs
16:46:38 <sridhar_ram> a bit more official doc.openstack.org level docs is something we can shoot for the next release
16:46:55 <sridhar_ram> vishwanathj: sounds good..
16:47:37 <sridhar_ram> meanwhile any ideas how can we bring the features like health-mon and parameterization .. to our user community
16:47:58 <sridhar_ram> should we have some stop gap wiki pages - based on devrefs ?
16:48:15 <sripriya> sridhar_ram: agree, i had already thought about that
16:48:27 <bobh> sripriya: Probably some example templates that show different options and configurations would help
16:48:57 <bobh> sridhar_ram: Now I've made the same mistake both ways
16:48:58 <sridhar_ram> sripriya: perhaps there is a .rst to html converter ?
16:49:16 <vishwanathj> per sripriya and santosh suggestion, I plan to add some example vnfd templates and param value files to devstack/samples directory for the parametirazation feature
16:49:39 <sridhar_ram> vishwanathj: cool, that would help
16:49:41 <sripriya> sridhar_ram: i need to dig in a bit on that, i can get back to you
16:50:00 <sridhar_ram> bobh: agree, we haven't focused on documenting the tacker.conf much
16:50:09 <sridhar_ram> sripriya: thanks!
16:50:21 <bobh> vishwanathj: exactly what I was thinking
16:50:51 <sridhar_ram> I can take up documenting tacker.conf
16:51:05 <sridhar_ram> #action sridhar_ram to document tacker.conf in tacker wiki
16:51:21 <bobh> sridhar_ram: Should we look at removing servicevm references from tacker.conf?
16:51:24 <sridhar_ram> #action vishwanathj to add example vnfd templates and param value files to devstack/samples directory for the parametirazation feature
16:51:33 <sripriya> sridhar_ram: as part of bug squashing sprint, we can take up some more cleaning up of tacker ?
16:52:03 <sridhar_ram> sripriya: sure, that's fair to take it up..
16:52:49 <sridhar_ram> tbh_: btw, if your health-mon tasks are done .. please join the bug sprint!
16:53:07 * sridhar_ram notes 8 mins left
16:53:17 * sridhar_ram .. 7 mins
16:53:42 <sridhar_ram> also anyone joining tacker .. this is a nice away to start!
16:53:55 <sripriya> sridhar_ram: i will take up some tacker housekeeping tasks
16:54:05 <sridhar_ram> sripriya: thanks!
16:54:12 <sridhar_ram> #topic Gate Testing
16:54:15 <bobh> sridhar_ram: I have a backlog of bugs that I'll clean up
16:54:42 <sridhar_ram> bobh: much appreciate your efforts!
16:55:03 * sripriya looking at bobh for the bug squash award :-)
16:55:14 <sridhar_ram> on gate testing .. we now have a experimental gate job for Tacker
16:55:39 <bobh> sridhar_ram: sripriya: Award is a trip to Tokya Disneyland :-)
16:55:40 <sridhar_ram> sripriya: :)
16:55:43 <tbh_> sridhar_ram: sure
16:56:31 <sridhar_ram> bobh: let me think abt sponsoring it !
16:56:57 <sridhar_ram> back to gate-testing .. the tests run 'tox -e functional'
16:57:22 <sridhar_ram> do don't be surprised if you see me adding 'check experimental' in your patchsets..
16:57:34 <sridhar_ram> there are still some kinks .. I'm working w/ the infra team..
16:57:39 <sridhar_ram> they are quite helpful
16:57:56 <sridhar_ram> any questions on that ?
16:58:08 <sridhar_ram> #topic Open Discussion
16:58:10 <sridhar_ram> anything else ?
16:58:56 <sridhar_ram> alright .. lets wrap!
16:58:59 <sridhar_ram> thanks all!
16:59:02 <bobh> bye all
16:59:07 <sripriya> thanks everyone, bye!
16:59:09 <shrinathsuresh> bye
16:59:17 <sridhar_ram> #endmeeting