16:01:07 <sridhar_ram> #startmeeting tacker
16:01:09 <openstack> Meeting started Thu Oct  8 16:01:07 2015 UTC and is due to finish in 60 minutes.  The chair is sridhar_ram. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:12 <openstack> The meeting name has been set to 'tacker'
16:01:21 <sridhar_ram> #topic Roll Call
16:01:29 <vishwana_> o/
16:01:30 <sridhar_ram> who is here for tacker mtg ?
16:01:35 <sripriya> o/
16:01:35 <bobh> o/
16:01:48 <tbh> o/
16:02:03 <sridhar_ram> gud' morning co-horts!
16:02:29 <sridhar_ram> lets start then..
16:02:34 <sridhar_ram> #topic Agenda
16:02:43 <sridhar_ram> #link https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_Oct_8.2C_2015
16:02:50 <sridhar_ram> #topic Announcements
16:03:35 <sridhar_ram> A doodle poll is up for Mitaka summit developer meetup time slot..
16:03:38 <sridhar_ram> #link http://doodle.com/poll/yv7mr45z2qeyhtrq
16:04:20 <sridhar_ram> Please pick a slot that you can make it .. hint: there is no main conference events on Friday :)
16:05:01 <sridhar_ram> nothing else from my side ..
16:05:18 <sridhar_ram> any general heads up from anyone ?
16:05:42 <sripriya> sridhar_ram: do you want to update on the gate jobs enabled?
16:06:10 <sridhar_ram> sripriya: sure
16:06:14 <Rajkumar_> Hi Everyone
16:06:34 <sripriya> sridhar_ram: probably also let us know which is voting and non voting...?
16:07:30 <sridhar_ram> folks - we now have many gate tests enabled for tacker repo - the check pipeline (when you upload a patchset) now runs pep8, py27 (unit tests) and dsvm-functional
16:07:51 <sridhar_ram> Rajkumar_: hi!
16:08:25 <sridhar_ram> dsvm-functional  - will bring up a full functional devstack and run 'tox -e functional' which creates vnfd templates and starts vnfs ..
16:08:26 <Rajkumar_> Just curious - Our tacker is on Liberty release?
16:08:45 <sridhar_ram> Rajkumar_: lets touch on that in a bit
16:08:57 <Rajkumar_> Sure. Thanks Sridhar..
16:09:36 <sridhar_ram> whenever you upload a patchset make sure jenkins posts SUCCESS for all these three test runs (pep8, py27, dsvm-functional)
16:10:40 <sridhar_ram> dsvm-functional - is currently marked as non-voting - meaning it won't block us from merging. Cores can decide to give exceptions to merge a patchset even if dsvm-functional reports FAILURE (case-by-case)
16:11:04 <sridhar_ram> once we get confidence, we will switch even that to voting ...
16:11:29 <sridhar_ram> any questions on this ?
16:12:19 <sridhar_ram> this is actually a big deal, we were hoping to get these for a long time... thanks sripriya (for py27) and santosh (for functional) !
16:12:23 <sripriya> sridhar_ram: thanks for the update!
16:12:47 <sridhar_ram> #topic Liberty Release Status
16:13:37 <sridhar_ram> Rajkumar_: we are waiting for health-mon patchset and few critical bugs to fix before we can pull a stable/liberty
16:14:16 <sridhar_ram> the plan is do a release by end of next week.. at least pull the release branch
16:14:29 <Rajkumar_> Ok Sridhar.
16:14:31 <Rajkumar_> Thanks
16:14:32 <sridhar_ram> we still haven't decided on posting the tarballs in pypi
16:15:00 <Rajkumar_> I could not see anything about tacker in the liberty release note
16:15:09 <Rajkumar_> that was the reason asked about it
16:15:25 <sridhar_ram> Rajkumar_: no, given we are not in governance tent we won't be listed there anyway..
16:15:55 <shrinathsuresh> Hello Sridhar and team
16:16:24 <Rajkumar_> ok. Do we have any release notes for tacker?
16:16:34 <sridhar_ram> I'm anticipating after pulling stable/liberty we will still make dot releases ... for stability and other cross-project needs (like OPNFV-SFC needs Tacker-SFC in liberty)
16:16:35 <Rajkumar_> Hi Shrinath
16:16:48 <sridhar_ram> shrinathsuresh: hi there
16:17:02 <sridhar_ram> Rajkumar_: no, but that's a good point..
16:17:29 <sridhar_ram> anyone here know the process to write a release notes for openstack projects ?
16:18:01 <sripriya> sridhar_ram: can we link the tar files of the 3 projects on tacker launchpad page?
16:18:14 <Rajkumar_> Sridhar - we're not sure. but we can help if assistance is provided.
16:18:52 <sridhar_ram> sripriya: I need to find that out .. will take an AI
16:19:29 <sridhar_ram> meanwhile I would nominate the doc sub-team - sripriya & tbh  - to help out here :)
16:20:29 <sridhar_ram> #action - sridhar_ram to follow up with infra how to post tacker release tarballs
16:20:49 <Rajkumar_> Sridhar - Please share us the details in mail and our team will help on release notes.
16:21:13 <sridhar_ram> Rajkumar_: sure
16:21:31 <Rajkumar_> Thanks
16:22:04 <sridhar_ram> Rajkumar_: we are still looking for functional tests on parameterization from your side.. it will be great to get that in before stable/liberty pull (next week)
16:22:19 <sripriya> sridhar_ram: ack, doc sub-team hopefully grows :-)
16:22:31 <shrinathsuresh> yes Sridhar. am working on it. will send few test cases tomorrow
16:22:48 <Rajkumar_> Sure Sridhar. I'll update it shortly
16:22:53 <sridhar_ram> sripriya: I'll help as much I can :)
16:23:07 <sridhar_ram> shrinathsuresh: Rajkumar_: thanks!
16:23:27 <sridhar_ram> anything else related Liberty Release ?
16:24:12 <sridhar_ram> #topic API Deprecation
16:25:10 <sridhar_ram> folks here will know we still have the old servicevm based APIs (and in turn CLI cmds) for "device" and "device-template"
16:25:43 <sridhar_ram> they have now been superceded by new MANO contructs like "vnf" and "vnfd"
16:25:57 <sridhar_ram> it is time to start the deprecation process...
16:26:44 <sridhar_ram> had a discussion with folks from unitedstack (in our #tacker channel) and they are open to switch over to the new MANO apis
16:27:28 <sridhar_ram> I propose we start deprecation process in liberty - by adding the warning headers in API and CLI in liberty - and remove these API in mitaka
16:28:03 <sridhar_ram> anyone have concerns removing it or removing it starting Mitaka cycle ?
16:28:11 <sripriya> sridhar_ram: does that mean we deprecate the servicevm standards from the API layer only or should it be deprecated in servicevm references too in the entire project?
16:28:52 <sridhar_ram> sripriya: first order of business to remove it from our external interfaces - API layer
16:29:16 <sridhar_ram> the rest is more a clean up and tech debt cleanups - IMO
16:29:21 <sridhar_ram> what do you think?
16:29:46 <sripriya> sridhar_ram: sounds good, that affects tacker and python-tackerclient projects
16:30:08 <sridhar_ram> sripriya: agree, it need to removed from both these projects
16:30:22 <sridhar_ram> I'll also send a note on this to the ML
16:30:27 <sripriya> sridhar_ram: we still have the db layer untouched then
16:31:34 <sridhar_ram> sripriya: we can be opportunistic there .. if we can rename our db schema away from "device*" tables we can still do it
16:31:52 <sridhar_ram> but it is not a must for deprecation to complete
16:32:28 <sripriya> sridhar_ram: should be doable, but again it would require db-migration after deprecation on master
16:33:28 <sridhar_ram> sripriya: true, I'd rather do it sooner than later before more tacker adoption w/ real operators
16:33:43 <sripriya> sridhar_ram: agree
16:33:51 <sridhar_ram> lets move to bugs (the topic of the week!)
16:33:56 <sridhar_ram> #topic Bugs
16:34:26 <sridhar_ram> as called out last week ... we need some serious bug squashing...
16:35:09 <sridhar_ram> I've marked some of the critical ones using the tag "liberty-critical" ..
16:35:21 <sridhar_ram> #link https://bugs.launchpad.net/tacker/+bugs?field.tag=liberty-critical
16:36:09 <sridhar_ram> there are bunch of them related to health-monitoring and VNF states / cleanup on deletion
16:37:09 <sridhar_ram> lets discuss few of them here...
16:37:11 <sridhar_ram> https://bugs.launchpad.net/tacker/+bug/1503480
16:37:11 <openstack> Launchpad bug 1503480 in tacker "Deletion of vnf having issues when doing in between Active-->Dead State" [Critical,New]
16:37:34 <sridhar_ram> bobh: tbh: this seems to happen with monitoring code
16:38:06 <sridhar_ram> after a successful respawn .. looks deletion is getting stuck in pending_delete
16:38:19 <bobh> sridhar_ram: I tried to reproduce but could not
16:38:33 <bobh> sridhar_ram: if the delete is happening while the respawn is in progress that may cause the problem
16:38:58 <bobh> sridhar_ram: we might need to have a way to 'lock' the status during the respawn and not allow the delete until it completes
16:39:20 <bobh> sridhar_ram: new state :-)
16:39:28 <sridhar_ram> bobh: make sense, mark it device busy
16:39:48 <sridhar_ram> bobh: nooooo - no  new state allowed !
16:39:51 <bobh> sridhar_ram: :-)
16:40:09 <bobh> sridhar_ram: I'll take a look at it
16:40:11 <sridhar_ram> bobh: just ask the operator to come back later after a coffee!
16:40:33 <sridhar_ram> bobh: cool, thanks!
16:41:10 <sridhar_ram> https://bugs.launchpad.net/tacker/+bug/1501079
16:41:10 <openstack> Launchpad bug 1501079 in tacker "tacker mgmt-driver support in vnf-create flow" [Medium,New] - Assigned to bharaththiruveedula (bharath-ves)
16:41:27 <sridhar_ram> tbh: who have any further questions on this ?
16:41:35 <sridhar_ram> s/who/you/
16:42:05 <tbh> sridhar_ram: Iwant to test with vnf descriptors
16:42:52 <tbh> sridhar_ram: I tried to look at the problem in vnf create, in config_device method, it is unable to get config params
16:43:24 <tbh> sridhar_ram: so, if we correct that, I think we can solve that issue
16:44:18 <sridhar_ram> tbh: yeah, there might be two part problem here .. vnf-config correctly carried over from CLI / horizon to the backend
16:45:09 <sridhar_ram> (2) the backend .. shd wait for ... boot_wait and try to invoke the configured mgmt driver
16:45:17 <tbh> sridhar_ram: I tried with hrizon, I can see the config params reaching the backend
16:46:00 <sridhar_ram> tbh: I don't think horizon has that support yet..
16:46:52 <Rajkumar_> Sridhar - I've few critical requirements. This is very much needed and learnt from our experience 1) Consolidated Physical & Virtual Network inventory  (Standard reconciliation is needed if not consolidated) 2) Interoperability of Tacker Orchestrator across different versions of cloud (hybrid cloud also if possible)  3) Workflow management & dynamic policy management (Convergence workflow & Jboss Drools if possible)  4)
16:47:01 <Rajkumar_> we
16:47:12 <Rajkumar_> we'll discuss it in next topic
16:47:12 <tbh> sridhar_ram: config params from yaml is passed to create_vnf
16:47:37 <tbh> sridhar_ram: and config_device is waiting for 30 sec https://github.com/stackforge/tacker/blob/master/tacker/vm/plugin.py#L243
16:47:38 <sridhar_ram> bobh: btw, I'm realizing the boot_wait ... monitoring delay .. needs to apply for other things as well like mgmt_driver
16:47:56 <s3wong> Rajkumar_: great. User requirements.
16:48:40 <Rajkumar_> without those functionalities zero touch NFV orchestration is tedious
16:49:00 <s3wong> Rajkumar_: "different versions of cloud"? You mean supporting something other than OpenStack?
16:49:07 <sripriya> tbh: config and params are 2 different attributes supported from cli
16:49:15 <bobh> sridhar_ram: agree - there may be a need to monitor different things and trigger config after one of them
16:49:23 <sripriya> tbh: horizon only supports param attribute support
16:49:37 <Rajkumar_> initially within openstack (juno,kilo, liberty) and later like AWS..etc
16:49:47 <sridhar_ram> tbh: sripriya has some insights into these code flows .. perhaps you can sync up to make some progress
16:50:08 <sridhar_ram> Rajkumar_: s3wong: folks - hang in there.. lets have one mtg please
16:50:10 <sripriya> tbh: we can discuss it on tacker IRC after the meeting
16:50:11 <tbh> sripriya: okay using --config ?
16:50:18 <sripriya> tbh: yes
16:50:23 <tbh> sripriya: sridhar_ram sure
16:50:28 <Rajkumar_> Sure Sridhar..
16:50:38 <sridhar_ram> any other high priority bug  ?
16:50:39 <s3wong> 10 minutes left
16:51:13 <sridhar_ram> looks for folks to flag critical / high priority if you see them!
16:51:27 <bobh> sridhar_ram: may be some global issues with delete
16:51:46 <sridhar_ram> bobh: good point.. there is a nasty one there
16:51:49 * sridhar_ram looking up...
16:52:20 <sridhar_ram> here it is ...
16:52:22 <sridhar_ram> https://bugs.launchpad.net/tacker/+bug/1475798
16:52:22 <openstack> Launchpad bug 1475798 in tacker "Deleting a VNF in PENDING_CREATE state does not delete the associated VM" [Critical,In progress] - Assigned to vishwanath jayaraman (vishwanathj)
16:52:34 <sridhar_ram> vishwana_: are you actively working on this ?
16:52:36 <bobh> sridhar_ram: definitely related
16:52:42 <vishwana_> yes
16:53:03 <sridhar_ram> thanks!
16:53:16 <bobh> sridhar_ram: vishwana_  there is no validation done when executing delete, and different things need to happen based on the current state
16:53:59 <sridhar_ram> bobh: yeah.. needs some locks here!
16:54:32 <sridhar_ram> alright .. lets get the floor back to Rajkumar_ & s3wong!
16:54:37 <sridhar_ram> #topic Open Discussion
16:54:58 <s3wong> Rajkumar_ put up some user requirements about 5 minutes ago
16:55:13 <Rajkumar_> 1) Consolidated Physical & Virtual Network inventory  (Standard reconciliation is needed if not consolidated)
16:55:18 <sridhar_ram> Rajkumar_: s3wong: agree, quite useful list there!
16:55:49 <Rajkumar_> Inventory is big issue in our experience
16:56:20 <sridhar_ram> Rajkumar_: there are good inputs.. lets put this in the Mitaka roadmap discussion and talk it out...
16:56:38 <sridhar_ram> Rajkumar_: any one from Comcast going to attend Tacker meetups in Tokyo ?
16:56:52 <Rajkumar_> Sridhar - Do you want us to schedule meeting for those requirement?
16:57:09 <Rajkumar_> Sridhar - Let me check with my team and update you in mail if any of us coming there
16:57:18 <sridhar_ram> Rajkumar_: I'm wondering if anyone from your team going to Mitaka summit ..
16:57:27 <sridhar_ram> we plan to discuss many of these face 2 face
16:57:42 <Rajkumar_> when is this happening and venue?
16:57:57 <s3wong> Oct. 27th, Tokyo
16:58:10 <sridhar_ram> #link https://www.openstack.org/summit/tokyo-2015/
16:58:19 * sridhar_ram 2 mins left
16:58:23 <Rajkumar_> Sure. We'll update it shortly
16:58:37 <s3wong> Our informal design session will be on Friday?
16:58:38 <Rajkumar_> if meeting is needed, I can send out invite for those req?
16:58:59 <s3wong> Rajkumar_: sure... I think it is fair to say we need more detail on the requirements
16:59:00 <sridhar_ram> s3wong: doodle poll is out (discussed earlier in the mtg)...
16:59:31 <sridhar_ram> Rajkumar_: can you stick in these requirements to Mitaka etherpad..
16:59:51 <sridhar_ram> #link https://etherpad.openstack.org/p/mitaka-tacker-design-summit
16:59:57 <Rajkumar_> Sure
17:00:00 <Rajkumar_> I'm doing it
17:00:07 <sridhar_ram> times up...
17:00:13 <sridhar_ram> tty all next week!
17:00:17 <sridhar_ram> bye
17:00:22 <sridhar_ram> #endmeeting