17:00:48 <sridhar_ram1> #startmeeting tacker
17:00:49 <openstack> Meeting started Tue Mar  1 17:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is sridhar_ram1. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:54 <openstack> The meeting name has been set to 'tacker'
17:01:06 <sridhar_ram1> #topic Roll Call
17:01:11 <bobh> o/
17:01:11 <sridhar_ram1> who is here for tacker ?
17:01:13 <tbh> o/
17:01:16 <dkushwaha_> o/
17:01:23 <brucet> o/
17:01:43 * sridhar_ram1 lost my irc nick in the freenode cloud.. will be know as sridhar_ram1 for the this mtg
17:01:43 <Guest7539> o/
17:01:50 <vishwanathj> o/
17:01:55 <Shuaib> o/
17:02:00 <Jim__> o/
17:02:02 <sripriya_> o/
17:02:27 <sridhar_ram1> alright... crowd is here, time to start!
17:02:32 <sridhar_ram1> #topic Agenda
17:02:47 <sridhar_ram1> #info #link https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_Mar_1.2C_2016
17:03:36 <sridhar_ram1> I hope we will have time today for some open discussions ...
17:03:38 <zeih> hi
17:03:41 <s3wong> hello
17:04:00 <sridhar_ram1> #topic Annoucements
17:04:21 <sridhar_ram1> Tacker big tent application review still in progress at #link https://review.openstack.org/#/c/276417
17:04:37 <sridhar_ram1> it couldn't get any more interesting than this...
17:04:47 <bobh> thats one work for it....
17:04:51 <bobh> word
17:05:26 <sridhar_ram1> I truly hope we cross this bridge to recognize all the hard work that had went in so and more to come
17:05:37 <sridhar_ram1> *so far
17:05:54 <sridhar_ram1> next ..
17:06:07 <sridhar_ram1> We are in Mitaka release R-5 week..
17:06:17 <sridhar_ram1> that is ... Release -5weeks
17:06:36 <sridhar_ram1> entering FeatureFreeze part of the  schedule  #link http://releases.openstack.org/mitaka/schedule.html
17:06:58 <sridhar_ram1> now that we are shooting for big tent, it is important to get inline with official release schedule..
17:07:16 <sridhar_ram1> this also means .. it is crunch time *now*...  if a feature looks risky we need to it defer to Newton.
17:08:06 <sridhar_ram1> anyone have questions related to deadline / target dates for their current work ?
17:08:48 <sridhar_ram1> We are shooting for Mar 18 code complete.. with a two week window for bug fixing and release around April 1st
17:09:27 <sridhar_ram1> moving on...
17:09:42 <sridhar_ram1> #topic TOSCA Parser Integration
17:10:03 <sridhar_ram1> first I'd like to land the specs ASAP..
17:10:32 <sridhar_ram1> bobh: anything pending from your side for #link https://review.openstack.org/#/c/275475 ?
17:10:55 <bobh> I have an update I need to push - should be tomorrow
17:11:12 <bobh> I wanted to add the changes to split out Simple Profile from NFV support - for the big tent discussion
17:11:13 <sridhar_ram1> bobh: okay..
17:11:35 <bobh> maybe tonight if I'm lucky...
17:11:46 <sridhar_ram1> bobh: sounds good...
17:12:05 <sridhar_ram1> next spec..
17:12:18 <brucet> bobh: Got a question on this
17:12:25 <sridhar_ram1> tbh: what remaining for #link https://review.openstack.org/#/c/250291/ ? looks close to me
17:12:34 <bobh> brucet: y
17:12:56 <brucet> Is there anything really needed beyond Simple profile support right now??
17:13:00 <tbh> sridhar_ram1, updated the patch based on the comments
17:13:26 <sridhar_ram1> tbh: I had a question on work items.. where you able to capture it ?
17:13:53 <bobh> brucet: if we want equivalent functionality to the current yaml format there is some pre/post processing of the TOSCA template required, along with some custom definitions for Tacker
17:13:54 <tbh> sridhar_ram1, except on functional tests, I am okay with the rest of it :)
17:14:28 <brucet> <bobh> Looks like I'm off topic. Will discuss separately.
17:14:50 <sridhar_ram1> tbh: I'm okay with getting func tests in a follow on patchset... we can find some volunteers to help out here
17:15:17 <sridhar_ram1> next ..
17:15:45 <sridhar_ram1> vishwanathj: EVP spec.. #link https://review.openstack.org/257847
17:15:57 <sridhar_ram1> vishwanathj: what is pending ?
17:16:50 <vishwanathj> I need to update the VNFD definition and examples with bobh and your comments, in the midst of doing it
17:17:18 <sridhar_ram1> vishwanathj: can be wrapped up soon ? any ETA ?
17:18:23 <vishwanathj> I hope to have an update to spec no later than tomorrow morning and would like to wrap up end of this week if I have reviewers bandwidth
17:18:47 <sridhar_ram1> vishwanathj: sounds good.. that's a good lead to ...
17:18:58 <sridhar_ram1> tacker-cores: bobh: s3wong
17:19:04 * sridhar_ram1 oops
17:19:36 <sridhar_ram1> tacker-cores: bobh: s3wong: sripriya_: please plan to review and merge these 3 spec over next couple of days...
17:19:44 <bobh> sridhar_ram1: will do
17:20:00 <sridhar_ram1> if you see any issues, follow up w/ the author asap...
17:20:03 <sridhar_ram1> bobh: thanks!
17:20:04 <sripriya_> sridhar_ram1: i will have sometime this week to go through the specs
17:20:09 <s3wong> sridhar_ram1: sure
17:20:30 <sridhar_ram1> frankly all three looks pretty close to land ..
17:20:54 <sridhar_ram1> bobh: I'm done w/ the spec related round up..
17:21:17 <sridhar_ram1> bobh: do you've anything to update on the code lined in this area ?
17:21:49 <sridhar_ram1> bobh: are you comfortable your patchset with others from tbh and gongysh / vishwanathj gelling well ?
17:22:15 <bobh> just pushed a patchset to heat-translator to get it working for what we need - will be in  0.4.0 release tomorrow
17:22:22 <bobh> sridhar_ram1: yes
17:22:43 <sridhar_ram1> bobh: nice !
17:23:04 <sridhar_ram1> tbh: any tosca integration questions from your side ?
17:23:39 <sridhar_ram1> tbh: I believe the recent change to direct TOSCA-artifact -> HOT glance will reduce the complexity in your side
17:24:26 <vishwanathj> bobh, I am assuming you will have unit tests as part of your patch set that ensures working with older VNFD templates and newer VNFD templates, right?
17:25:13 <bobh> vishwanathj: that's the plan
17:25:25 <vishwanathj> bobh thanks
17:26:22 <sridhar_ram1> any general TOSCA code integration question ?
17:26:33 <tbh> sridhar_ram1, currently no questions
17:26:45 <sridhar_ram1> tbh: sounds good..
17:26:54 <sridhar_ram1> moving on...
17:27:06 <sridhar_ram1> #topic Mitaka fit and finish - RFEs and Bugs
17:27:26 <sridhar_ram1> we have concentrated mostly on new features so far in the cycle...
17:27:53 <sridhar_ram1> alongside we got some nice questions related to deployment in #link https://answers.launchpad.net/tacker
17:28:52 <sridhar_ram1> given Mitaka window is closing fast .. I'd like to take some time and get the community' input to see if there are any deployment related issues / quick fixes we should plan to get it in Mitaka
17:29:31 <sripriya_> sridhar_ram1: do you think displaying monitoring status on Horizon should be planned for Mitaka?
17:29:46 <sridhar_ram1> For e.g. RFE bug like https://bugs.launchpad.net/tacker/+bug/1547284
17:29:47 <openstack> Launchpad bug 1547284 in tacker "Expose port-security knob for all network ports (connection points)" [Medium,New]
17:30:26 <sridhar_ram1> sripriya_: you mean a visual clue indicating an active monitoring driver is active for a VNF ?
17:30:37 <sripriya_> sridhar_ram1: yes
17:30:44 <bobh> sridhar_ram1: that may actually get resolved as part of the tosca work - we need to add it to the CP definition anyway
17:31:26 <tbh> sridhar_ram1,  and this one https://bugs.launchpad.net/tacker/+bug/1525808
17:31:26 <openstack> Launchpad bug 1525808 in tacker "OpenWRT vnf stuck in "PENDING-UPDATE" state." [Medium,In progress] - Assigned to bharaththiruveedula (bharath-ves)
17:31:26 <sridhar_ram1> bobh: I see. Out template need to expose new knob ?
17:32:07 <bobh> sridhar_ram1: we need to add it to the CP definition for our own use anyway, so exposing for use by end users is trivial
17:32:10 <tbh> sridhar_ram1,  couple of people tried tacker using OpeWRT and stuck there I believe , I need to close this asap
17:32:36 <sridhar_ram1> tbh: ah, that's a serious one.. need to be addressed, agree!
17:33:10 <sridhar_ram1> bobh: do you suggest a follow on or you could absorb into your work item ?
17:33:23 <bobh> sridhar_ram1: let me look - can probably absorb
17:33:35 <tbh> sridhar_ram1, sure
17:33:51 <sridhar_ram1> bobh: okay, thanks..
17:34:20 <sridhar_ram1> I'll introduce a new tag for these "must do" Mitaka issues (RFEs & Bugs)...
17:34:43 <sridhar_ram1> feel free to mark other candidate issues for Mitaka
17:35:14 <sridhar_ram1> sripriya_: for the visual aid for monitoring .. we need both API support and Horizon enhancements, correct ?
17:36:00 * sridhar_ram1 thinking about an appropriate launchpad tag and wonders if anyone have a suggestion
17:36:42 <sripriya_> sridhar_ram1: yes.. i think it would be quite involved and may take some time
17:37:10 <sridhar_ram1> sripriya_: yeah, could be tight for this cycle..
17:37:21 <sripriya_> sripriya_: may not be a candidate even though it is very helpful to see the status in horizon than in logs
17:37:49 <sridhar_ram1> btw, there was a related one .. to show VNF details in Horizon..
17:37:58 <sridhar_ram1> mgmt-ip of the VDUs etc..
17:38:20 <sripriya_> yes there was a ask on answers forum
17:38:26 <sridhar_ram1> we now display the template (which is nice!) but we could show more about an active VNF
17:38:44 <sridhar_ram1> sripriya_: yep, those are direct input from our customer base..
17:39:23 <tbh> sridhar_ram1, yes, probably more details about VDU in horizon
17:39:54 <sridhar_ram1> will create a launchpad RFE bug for this.. it seems small enough to squeeze into Mitaka
17:40:30 <sridhar_ram1> #action sridhar_ram1 will create a RFE bug to display runtime VNF instance details in Horizon GUI
17:40:54 <sridhar_ram1> tbh: make sense.. will capture that in this RFE
17:41:12 <sridhar_ram1> btw, any volunteers to pick this work ?
17:41:38 <sridhar_ram1> reach out me if you are interested ...
17:42:04 <sridhar_ram1> other things in "fit & finish" is things like py34 support...
17:42:13 <dkushwaha_> sridhar_ram1, I would like to pick this.
17:42:25 <sridhar_ram1> zeih: thanks for picking it up...
17:42:30 <sridhar_ram1> dkushwaha_: great, thanks!
17:43:03 <sridhar_ram1> py34 will help to keep the project hygiene inline with rest of the active openstack projects!
17:43:27 <zeih_> all: feel free to add missing py27 tests and integrate py34 compatibility :)
17:44:25 <sridhar_ram1> zeih_: agree, we can always use more py27 tests ..
17:45:48 <sridhar_ram1> Documentation is also an important item in this category .. we can get to it after late Mar once most of the code lands
17:46:01 <sridhar_ram1> anything else to discuss in this topic ?
17:46:23 <sridhar_ram1> moving on...
17:46:32 <sridhar_ram1> #topic Open Discussion
17:47:02 <sridhar_ram1> A shout out to SONATA team from EU who are attending this meeting for the first time..
17:47:12 <sridhar_ram1> Jim__: welcome to the team!
17:47:24 <sridhar_ram1> Fyi, #link http://www.sonata-nfv.eu/
17:47:39 <Jim__> thank you!
17:48:29 <sridhar_ram1> Jim__: I believe we have many things common in our goal in the area of NFV orchestration...
17:49:05 <sridhar_ram1> FYI, SONATA team is planning to look into areas related to NFV Catalog (catalog split out, img mgmt, etc...)
17:49:46 <Jim__> We think so, too, we're looking forward to collaborating.  We're working on a Google Doc to introduce that catalog vision to you for next meeting.
17:50:47 <sridhar_ram1> Jim__: great! lets use a slot in next week's mtg to go through that...
17:50:59 <Guest7539> I have a question related to the NVF Catalog and also the descriptors: Who is mainly working on that from your side currently?
17:52:09 <sridhar_ram1> Guest7539: descriptor related work is lead by bobh in the track related to TOSCA parser integration...
17:52:12 <Jim__> Hi Michael, you're Guest7539, right?   If so, you're asking who is working on it from Tacker, no?
17:52:46 <Guest7539> Yes, I am Michael ... did not manage to get a proper name :-)
17:53:21 <sridhar_ram1> Guest7539: we need to discuss that choice of irc-handle as the first thing in the next meeting!
17:53:34 <zeih_> :)
17:53:35 <sridhar_ram1> Guest7539: Hi Michael!
17:54:26 <sridhar_ram1> Guest7539: we haven't done any work related to NFV Catalog beyond what we have .. which is just the VNFD Catalog
17:54:51 <sridhar_ram1> .. which is again today tightly integrated within VNFM component of tacker
17:54:58 <sridhar_ram1> we need to break it out
17:55:18 * sridhar_ram1 5mins left
17:55:57 <sridhar_ram1> s3wong: quick check on the neutron-sfc driver.. any updates from your side ?
17:55:59 <Guest7539> Maybe I can reach out to Bob within the next days. I would like to understand your current status a bit better.
17:56:57 <sridhar_ram1> Guest7539: bobh's hourly consultant charges are reasonable ;-)
17:57:43 <sridhar_ram1> will sync up on SFC w/ s3wong and trozet separately
17:57:55 <sridhar_ram1> anything else team?
17:57:59 <s3wong> sridhar_ram1: spec should be posted in a day or two
17:58:24 <sridhar_ram1> s3wong: thanks.. will discuss w/ you offline..
17:58:32 <s3wong> sridhar_ram1: though I haven't seen much from trozet's side --- so don't know what the risk there is
17:59:13 <sridhar_ram1> Team - as mentioned earlier - get your specs land and code posted ASAP.. next couple of weeks are critical to make it to Mitaka release!
17:59:45 <sridhar_ram1> s3wong: trozet just came back from paternity leave.. lets sync up offline!
17:59:50 <santoshk> sridhar_ram1: apart from multi vim, enhanced placement support and SFC what are other imp features coming next few days...
18:00:03 <sridhar_ram1> that's it folks for this week...
18:00:12 <santoshk> sridhar_ram1: we can continue in tacker channel
18:00:13 <sridhar_ram1> santoshk: that's the main list !
18:00:21 <sridhar_ram1> bye folks!
18:00:24 <santoshk> ok..thankyou..
18:00:28 <sridhar_ram1> #endmeeting