05:30:39 <sridhar_ram> #startmeeting tacker
05:30:40 <openstack> Meeting started Wed Feb  8 05:30:39 2017 UTC and is due to finish in 60 minutes.  The chair is sridhar_ram. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:30:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:30:43 <openstack> The meeting name has been set to 'tacker'
05:30:49 <sridhar_ram> #topic Roll Call
05:30:55 <sridhar_ram> who is here for tacker meeting?
05:31:09 <gongysh> me
05:31:13 <tbh> o/
05:32:02 <YanXing_an> o/
05:32:30 <sripriya> o/
05:32:38 <sridhar_ram> gongysh: tbh: YanXing_an: sripriya: howdy all !
05:32:54 <sridhar_ram> any silent participants want to say hi ? :)
05:32:56 <janki> o/
05:33:10 <sridhar_ram> let's start
05:33:16 <sridhar_ram> #topic Agenda
05:33:27 <sridhar_ram> https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_Feb_8th.2C_2017
05:33:39 <sridhar_ram> Ocata release status is implicit :)
05:33:49 <sridhar_ram> #topic Announcements
05:33:57 <sridhar_ram> few quick things...
05:34:22 <sridhar_ram> First, gongysh is elected as Tacker PTL for Pike..
05:34:34 <sridhar_ram> gongysh: hearty congratulations !!
05:34:46 <YanXing_an> congratulation!
05:35:09 <gongysh> Thanks.  a big load sensed.
05:35:11 <janki> congratulations gongysh
05:35:14 <sripriya> gongysh: congrats!
05:35:15 <sridhar_ram> gongysh: I'm very happy you stepped up to take this project fwd.. will be there to help as needed
05:35:21 <diga> o/
05:35:25 <KanagarajM> hi
05:35:27 <tung_doan> hi all
05:35:30 <tbh> congrats gongysh!
05:35:33 <diga> gongysh: Congrats!
05:35:42 <gongysh> thanks all.
05:35:48 <KanagarajM> Hearty Congratulations Gongysh !!
05:36:00 <tung_doan> gongysh: congrats!!!
05:36:16 <gongysh> tung_doan, KanagarajM , thanks
05:36:47 <sridhar_ram> Next.. Tacker team mascot ..
05:36:56 <sridhar_ram> #link https://drive.google.com/open?id=0B-ruQ8Tx46wSTDRUd0dneW9GZEZXdkVXdkxpRE9FNmtNRUV3
05:37:15 <sridhar_ram> If you've any suggestion to improve please respond to the ML email from me
05:37:37 <sridhar_ram> IMO, Giant 'Tacker' Squid looks cool !
05:38:06 <gongysh> What is the original meaning for 'tacker'?
05:38:07 <tbh> sridhar_ram, yup it's looks very cool than previous version we had
05:38:40 <sridhar_ram> Next.. in case you missed..
05:38:42 <sridhar_ram> #info Boston Call for Papers deadline is extended to  February 8th at 11:59pm PST (February 9th at 7:59 UTC)!
05:38:47 <sridhar_ram> tbh: agree!
05:39:49 <sridhar_ram> gongysh: it is derived from "Tacking" to mean - "Tacking VNFs and Network Services to Telco cloud" :)
05:40:02 <sridhar_ram> gongysh: roughly means "Stapler"
05:40:19 * sridhar_ram checking if s3wong is around
05:40:54 <sridhar_ram> #info Tacker RDO rpm packages are now available ..
05:40:56 <sridhar_ram> #link https://trunk.rdoproject.org/centos7-master/current/openstack-tacker-0.6.1-0.20170203211914.bd52254.el7.centos.noarch.rpm
05:41:19 <sridhar_ram> this helps in quickly deploying tacker in CentOS / Fedora
05:41:25 <gongysh> sridhar_ram, ok. I like the feet of the mascot
05:41:34 <sridhar_ram> gongysh: :)
05:41:48 <sripriya> sridhar_ram: link is broken?
05:42:18 <sridhar_ram> sripriya: works for me, can someone else confirm ?
05:42:45 <gongysh> sridhar_ram, for me, it complains link is broken
05:42:54 <tung_doan> does not work for me. it's broken
05:42:55 <tbh> sridhar_ram, it is opening for me too
05:43:20 <diga> sridhar_ram: its not working for me
05:43:31 <YanXing_an> URL not found on server
05:43:31 <tbh> this is the one https://trunk.rdoproject.org/centos7-master/current/openstack-tacker-0.6.1-0.20170208005202.5b245d6.el7.centos.noarch.rpm i guess
05:43:39 <gongysh> GONGYSH-3:tacker yongshenggong$ wget https://trunk.rdoproject.org/centos7-master/current/openstack-tacker-0.6.1-0.20170203211914.bd52254.el7.centos.noarch.rpm
05:43:40 <gongysh> --2017-02-08 13:43:25--  https://trunk.rdoproject.org/centos7-master/current/openstack-tacker-0.6.1-0.20170203211914.bd52254.el7.centos.noarch.rpm
05:43:40 <gongysh> Resolving trunk.rdoproject.org... 54.81.116.189
05:43:40 <gongysh> Connecting to trunk.rdoproject.org|54.81.116.189|:443... connected.
05:43:41 <gongysh> HTTP request sent, awaiting response... 404 Not Found
05:43:41 <gongysh> 2017-02-08 13:43:27 ERROR 404: Not Found.
05:43:59 <sripriya> tbh: thanks works now
05:44:18 <sridhar_ram> #link goo.gl/xZW3k5
05:44:24 <sridhar_ram> please try ^^^
05:44:53 <tbh> sridhar_ram, the above redorects to tacker mascor
05:45:09 <sridhar_ram> tbh: sounds good..
05:45:20 <sridhar_ram> here is one more from my email .. http://lists.openstack.org/pipermail/openstack-dev/attachments/20170207/663ee9f7/attachment.jpeg
05:45:21 <tbh> s/redorects/redirects
05:45:26 <sridhar_ram> anyways, let's move on
05:45:59 <sridhar_ram> #topic Ocata Release
05:46:03 <sridhar_ram> #link https://releases.openstack.org/ocata/schedule.html
05:46:36 <sridhar_ram> I need to cut final release image by next Wed Feb 15th
05:46:40 <sridhar_ram> No exceptions
05:47:35 <sridhar_ram> All fixes need to merge by coming Friday Feb 10th .. so that we leave few days for critical bug fixes
05:47:45 <sridhar_ram> .. and preparing the final release notes
05:48:11 <sridhar_ram> let's go over the few outstanding items
05:48:32 <sridhar_ram> janki: VNF inline BP
05:48:47 <sridhar_ram> janki: did you had a chance to root cause the FT failure ?
05:48:57 <janki> sridhar_ram, The doc is left and a fix in server patch
05:49:25 <janki> sridhar_ram, yupe, found the cause for FT failure. 2 of them where failing. solved 1, working on the other
05:49:37 <janki> s/where/were
05:49:39 <sridhar_ram> janki: okay, i assume this can be wrapped by Friday?
05:49:49 <janki> sridhar_ram, it will be done by then
05:49:55 <sridhar_ram> janki: thanks
05:50:01 <janki> :)
05:50:09 <sridhar_ram> tbh: VNFC template support
05:50:33 <tbh> sridhar_ram, I hosted the image in github, and FT is passing
05:50:56 <sridhar_ram> tbh: is that the only outstanding item for VNFC ?
05:51:48 <tbh> sridhar_ram, yes, and gongysh comments to provide how softwareconfig works, but it is more of how  heat softwareconfig works
05:52:28 <gongysh> tbh, I want to have a guide to help users to use the tacker VNFC
05:52:37 <sridhar_ram> tbh: okay, let's discuss image hosting in the next topic..
05:53:38 <gongysh> tbh, I don't need the under cover of how it works.
05:54:13 <sridhar_ram> gongysh: agree, we shouldn't "leak" heat through tacker ;-)
05:54:36 <tbh> gongysh, but I gave the instructions for writing VNFC in https://review.openstack.org/#/c/358321/15/doc/source/devref/vnf_component_usage_guide.rst
05:55:19 <sridhar_ram> gongysh: i saw this ^^^ guide as well.. what are we missing in the guide?
05:55:51 <tbh> gongysh, and I need to remove vnfc_driver from that usage guide, so no need to discuss about vnfc_driver in that guide
05:56:08 <gongysh> sridhar_ram, tbh : please write a complete user guide here.
05:56:09 <gongysh> where is the install_vnfc.sh put?
05:56:10 <gongysh> shoudl I use metadata service in NFVI or config_driver?
05:56:10 <gongysh> and the exact steps for this feature.
05:56:27 <gongysh> this is the comments on the review.
05:57:30 <tbh> gongysh, okay I will add the details about placement of shell script and mandatory services to run to support this feature
05:57:36 <gongysh> anyway, I need a guide to set up the test env. but this guide is not enough.
05:57:48 <tbh> gongysh, but I couldn't understand what do you mean by exact steps for this feature
05:57:49 <gongysh> tbh, thanks
05:58:25 <gongysh> I mean the complete guide that can be used set up the env. step by step.
05:58:47 <sridhar_ram> tbh: perhaps the steps how to (a) include heat agent, (2) place install script and (3) writing TOSCA template to invoke the script
05:59:23 <tbh> sridhar_ram, part (1) and (3) are already covered
05:59:38 <sridhar_ram> tbh: okay
05:59:58 <gongysh> tbh, the provided tosca is also not a complete one.
06:00:06 <tbh> gongysh, I don't think we do need any extra setup apart from the image building
06:00:55 <gongysh> tbh, anyway, let's move on.
06:01:06 <gongysh> I can set up a test env even without a guide. :)
06:01:06 <sridhar_ram> gongysh: yes, let's take this offline in the review
06:01:16 <sridhar_ram> tbh: i can help if needed
06:01:27 <sridhar_ram> #topic Hosting VNF images
06:01:52 <sridhar_ram> As you know, VNFC work that tbh is leading needs to host a Fedora image with heat-agent
06:02:31 <sridhar_ram> We also have a need to host openstack friendly openwrt image ..
06:02:50 <sridhar_ram> See https://review.openstack.org/421340
06:03:21 <sridhar_ram> I was wondering if we use this need as a oppurtunity to build a repo of VNF images validated with Tacker
06:03:59 <sridhar_ram> Perhaps a new repo .. github.com/openstac/tacker-images
06:04:15 <tbh> sridhar_ram, yup that would be helpful
06:04:24 <gongysh> sridhar_ram, this came to my mind when you are talking tacker core can control.
06:04:58 <sridhar_ram> I think this will help Tacker's adoption as well.. potential users will find ready to try VNF images
06:05:18 <sridhar_ram> today it is difficult to start using Tacker in a meaningful way after installation
06:05:34 <sridhar_ram> tbh: gongysh: ack
06:06:20 <sridhar_ram> How about if we can host these two images (fedora-heat & openwrt) in a special github that tacker-cores have access
06:06:34 <sridhar_ram> .. and then approach openstack TC to create a repo for us..
06:06:49 <sridhar_ram> .. based on the github repo
06:07:09 <gongysh> sridhar_ram, ok, let's do it if the TC agree.
06:07:53 <sridhar_ram> gongysh: worst case, if TC doesn't agree .. atleast the "external" git repo will be under the control of tacker cores ..
06:08:09 <gongysh> but how about just using a github repo with all core's public key can access
06:08:14 <sridhar_ram> today it is under 3rd party community member
06:08:54 <sridhar_ram> gongysh: well, I'm assuming this interim repo is just a temporary repo until TC gets us going
06:09:19 <sridhar_ram> hopefully once Ocata release is out, we can approach TC
06:10:39 <sridhar_ram> I also learnt projects like Kolla, Ironic use tarballs.openstack.org to host images
06:10:59 <sridhar_ram> http://tarballs.openstack.org/kolla/images/
06:11:22 <sridhar_ram> but looks this is dynamically generated by dsvm runs .. that is an overkill for us
06:11:47 <sridhar_ram> I'll take care of creating the common image repo for now ...
06:12:12 <sridhar_ram> #action sridhar_ram to create a common tacker-images repo
06:12:17 <sridhar_ram> moving on
06:12:41 <sridhar_ram> venkatamahesh here by anychance ?
06:13:04 <sridhar_ram> dkushwaha: are you here?
06:13:39 <sridhar_ram> #topic Ocata Critical Bug
06:13:55 <sridhar_ram> https://bugs.launchpad.net/tacker/+bug/1660960
06:13:55 <openstack> Launchpad bug 1660960 in tacker "ADD_INSTALLED_APPS in _80_nfv.py file" [Critical,New]
06:14:08 <sridhar_ram> this is a critical bug in tacker-horizon ..
06:14:42 <sridhar_ram> when tacker-horizon is enabled some other UI screens (like Project -> Compute -> Images) doesn't render
06:14:53 <sridhar_ram> tbh: looks you stumbled into this as well ?
06:15:11 <tbh> sridhar_ram, yes
06:15:17 <sridhar_ram> tbh:
06:15:34 <sridhar_ram> any volunteers who can help take this up?
06:16:30 <sridhar_ram> I'll find someone offline if there is no interest
06:16:45 <sridhar_ram> anything else related to Ocata release?
06:16:54 <gongysh> I will try to ask horizon guys in 99cloud to tackle it.
06:17:09 <sridhar_ram> gongysh: thanks a lot !
06:17:20 <tbh> sridhar_ram, this line creates the problem https://github.com/openstack/tacker-horizon/blob/master/tacker_horizon/enabled/_80_nfv.py#L18
06:17:50 <sridhar_ram> tbh: I see ...
06:18:15 <sridhar_ram> there is also a related "enhancement" ..  https://review.openstack.org/#/c/429767/
06:18:31 <sridhar_ram> to move NFV under "Project" instead of being at the top-level
06:19:31 <sridhar_ram> Regarding Ocata the door will close soon, if it upto the contributors to actively reach out to core-reviewers to have your patchset merge
06:20:05 <sridhar_ram> moving to the next topic
06:20:18 <sridhar_ram> #topic Pike PTG Topics
06:20:20 <sridhar_ram> #link https://etherpad.openstack.org/p/tacker-pike-grooming
06:20:45 <sridhar_ram> gongysh: I'm assuming you will be driving this meeting
06:21:07 <gongysh> ok
06:21:55 <tung_doan> sridhar_ram, gongysh : abut Life-cycle mgmt for E2E service
06:22:10 <sridhar_ram> To move quickly, may I propose to use Wed Feb 22 (around this weekly meeting time) as the time slot?
06:22:42 <gongysh> sridhar_ram, no problem for me.
06:23:32 <gongysh> all topic there should have a doc to elaborate the in question feature by then.
06:24:06 <sridhar_ram> gongysh: sure
06:24:11 <sridhar_ram> how about we start "Wednesday, February 22, 2017 at 05:00:00"
06:24:18 <sridhar_ram> #link https://www.timeanddate.com/worldclock/meetingtime.html?iso=20170222&p1=283&p2=33&p3=235&p4=176
06:24:37 <tbh> +1
06:24:46 <sridhar_ram> we can go for 4 - 6 hours and finish in one go ?
06:25:07 <gongysh> ok
06:25:10 <diga> yes, that will be good
06:25:20 <sridhar_ram> or .. we can come back to start at the sametime the next day
06:25:38 <sridhar_ram> perhaps 4 hours each day
06:25:47 <sridhar_ram> any preference ?
06:26:36 <sridhar_ram> if no preference, lets shoot to finish in one "day"
06:26:55 <sridhar_ram> gongysh: we can discuss the logistics offline
06:27:03 <gongysh> sridhar_ram, ok
06:27:14 * sridhar_ram we are almost out of time
06:27:22 <sridhar_ram> #topic Open Discussion
06:27:27 <sridhar_ram> anything else?
06:28:10 <gongysh> the mistral server
06:28:26 <gongysh> it should be with tacker, not target NFVI.
06:28:50 <sridhar_ram> gongysh: yes
06:29:06 <sridhar_ram> gongysh: it doesn't make sense to use target VIM / NFVI's creds
06:29:08 <gongysh> so lets' have a test to verify the NSD can work with this intention
06:29:41 <sridhar_ram> gongysh: that is something we need to enhance, to do multi-vim test in CI
06:30:07 <gongysh> sridhar_ram, I will set up a env to do it manually.
06:30:08 <sridhar_ram> openstack CI doesn't have support.. i know tricircle is also looking into this
06:30:16 <sridhar_ram> gongysh: sounds good
06:30:31 <sridhar_ram> i can see this project is going to a very good hands :)
06:30:38 <sridhar_ram> thanks everyone !!
06:30:39 <sridhar_ram> times up
06:30:44 <sridhar_ram> #endmeeting