05:33:02 <gongysh> #startmeeting tacker
05:33:03 <openstack> Meeting started Wed Mar  8 05:33:02 2017 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:33:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:33:07 <openstack> The meeting name has been set to 'tacker'
05:33:33 <gongysh> #topic roll call
05:33:40 <sridhar_ram> o/
05:33:40 <YanXing_an> o/
05:34:02 <gongysh> sridhar_ram, the magic word works in the end.
05:34:08 <JimmyYe2528> o/
05:34:09 <sridhar_ram> gongysh: :)
05:34:30 <gongysh> JimmyYe2528, YanXing_an  hi
05:34:37 <JimmyYe2528> hi
05:35:04 <gongysh> today, core  dkushwaha and tbh are not here.
05:35:21 <gongysh> tung_doan is not either.
05:35:39 <gongysh> so our meeting will be shorter than expected.
05:35:53 <gongysh> #topic agenda
05:36:26 <gongysh> #link https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_March_8th.2C_2017
05:36:59 <diga_> o/
05:37:16 <gongysh> #topic review stats
05:37:19 <gongysh> diga_, hi
05:37:33 <diga_> gongysh: Hi
05:38:14 <gongysh> I have seen the first patch for API
05:38:17 <gongysh> new API.
05:38:43 <gongysh> #link http://stackalytics.com/?module=tacker-group
05:38:56 <gongysh> tacker teams performance is bad
05:39:21 <gongysh> we are very behind the review and commit data.
05:39:28 <diga_> gongysh: yeah
05:40:01 <diga_> gongysh: I haven't added test case yet, but will start pushing those also along with PS now onwards - https://review.openstack.org/#/c/442887/
05:40:32 <sridhar_ram> gongysh: yes, we need to improve.. can we indicate specific review priority and owners
05:40:32 <gongysh> to meet our target in PTG virtual meeting, we need double our review efforts.
05:41:10 <gongysh> current, the non-core YanXing_an is working hard to help review.
05:41:26 <sridhar_ram> gongysh: we shd consider using https://wiki.openstack.org/wiki/StoryBoard
05:41:48 <diga_> gongysh: I think we can handover module wise responsibilities of reviews to team, so that it will be faster
05:41:53 <sridhar_ram> gongysh: it is a Rally / Jira like tool for tracking tasks
05:42:13 <gongysh> diga_, for example?
05:42:39 <diga_> API/CLIENT/VNFTemplate/etc
05:42:54 <diga_> NSD/VNFFG/VIM
05:43:26 <diga_> this way everyone can pick respective PS faster
05:43:47 <gongysh> for example, diga is owning NSD reviewing, gongysh is for API, sridhar_ram is for VIM etc. ?
05:43:55 <diga_> yeah
05:44:43 <gongysh> diga_, it is a good idea. when we have a lot of patches on plate, we can do this.
05:44:48 <diga_> This way we know the respective owners also to ping for reviews, it will be faster in this case
05:45:07 <diga_> :) yeah
05:47:10 <gongysh> diga_,  first our commiter should pay attention to our own quality of codes to reduce the review efforts.
05:47:47 <gongysh> diga_,  I cannot see review stats of you. :)
05:47:49 <diga_> gongysh: yeah
05:48:12 <gongysh> lets move to next
05:48:20 <YanXing_an> gongysh: agree with you
05:48:35 <diga_> gongysh: I don't have yet but I will target daily one PS review
05:48:57 <gongysh> sridhar_ram, about storyboard. I will have a look at it.
05:49:05 <sridhar_ram> gongysh: okay
05:49:27 <gongysh> #action gongysh to learn storyboard to see if we should use it.
05:49:53 <gongysh> #topic features and BPs
05:50:15 <gongysh> first here I want to talk is still the task scheduling framework
05:50:28 <gongysh> #link https://review.openstack.org/#/c/439300/
05:51:04 <gongysh> I have looked at consul, and learned its 'watch' capability is not open to API
05:51:46 <sridhar_ram> gongysh: what you mean?
05:52:04 <gongysh> think about:
05:52:39 <sridhar_ram> gongysh: it doesn't have a callback mech when a key / sub-tree is changed ?
05:53:08 <gongysh> sridhar_ram, it seems there is no such mech.
05:54:18 <sridhar_ram> gongysh: did you go through this ? https://www.consul.io/docs/agent/watches.html
05:54:19 <gongysh> the 'watch' is just a consul agent command.
05:55:10 <gongysh> the agent need to watch a stuff and call a 'command' then.
05:55:33 <gongysh> That is its callback thing.
05:56:40 <gongysh> In our system, we need a API way.
05:57:48 <gongysh> next week I will come up with a poc implementation, and then lets have a scaling test, for example 100 VIMs and its ping task.
05:58:03 <sridhar_ram> gongysh: in the case of consul looks you need an "tacker-callback-handler" to turn it into an API
05:58:21 <sridhar_ram> gongysh: sounds good...
05:58:40 <gongysh> ok, let's move to next BP
05:58:45 <sridhar_ram> gongysh: also, it will be good to find of any other openstack project relies on a JVM / java component
05:58:54 <sridhar_ram> s/of/if/
05:59:11 <gongysh> dragonflows is one.
05:59:50 <gongysh> if we are talking SDN controllers, neutron -> odl will be one too.
06:00:16 <gongysh> I think we will someday to use odl sfc driver of networking-sfc.
06:00:23 <sridhar_ram> no, neutron + ODL is not a good analogy
06:01:01 <sridhar_ram> ODL is an optional component separated by an API boundary
06:01:37 <sridhar_ram> But for us zookeeper will become a basic necessity to run tacker even in its simple form
06:01:54 <gongysh> In fact, I also want to let zookeeper to be pluggable.
06:02:27 <sridhar_ram> again, i'm not hell bent on avoiding zookeeper .. trying to get as many possible issues upfront before we go to implementation
06:03:26 <gongysh> sridhar_ram, can you have a look at consul to avoid my ignorance of its capability?
06:03:29 <sridhar_ram> this scalable task framework shd be eventually used even for basic VNF creation
06:03:46 <sridhar_ram> gongysh: sure, will take a deeper look into consul
06:04:20 <gongysh> sridhar_ram,  next meeting, we can have talk again.
06:04:35 <sridhar_ram> gongysh: sure, .. btw, this is very interesting topic
06:04:40 <gongysh> #topic NSD with vnffg
06:05:11 <gongysh> since tbh and dkushwaha are not here, we will have to skip it.
06:05:13 <sridhar_ram> gongysh: heads up, tim rozet is interested in co-authoring the spec and implementation for this effort
06:05:25 <gongysh> trozet, hi
06:05:42 <sridhar_ram> gongysh: given he is the original author of vnffg it make sense to involve him
06:06:14 <sridhar_ram> it is late night for trozet, he won't be here
06:06:27 <gongysh> sridhar_ram, but I have asked tbh and dkushwaha to involve him. and asked him myself. the result is: trozet has no much time on tacker project.
06:06:59 <sridhar_ram> gongysh: but he reached out to be available to co-author a portion of it ..
06:06:59 <gongysh> #bugs
06:07:40 <gongysh> sridhar_ram,  yes.
06:07:59 <gongysh> #link https://bugs.launchpad.net/python-tackerclient
06:08:45 <gongysh> guys do not forget we have another site to watch (consul watch :) the bugs of tacker client.
06:09:12 <YanXing_an> :)
06:09:18 <gongysh> YanXing_an, hi
06:09:39 <gongysh> talk about the bugs on your plate?
06:10:00 <YanXing_an> https://bugs.launchpad.net/tacker/+bug/1667652
06:10:00 <openstack> Launchpad bug 1667652 in tacker "Remove VIM credential storage problem on local file system" [Medium,New] - Assigned to Yan Xing'an (yanxingan)
06:10:26 <YanXing_an> I add a comment in this bug about gnocchi
06:10:50 <gongysh> YanXing_an, I don't want to store the key via gnocchi.
06:11:10 <gongysh> my original idea is to learn its way to drive ceph or swift.
06:11:24 <gongysh> and save the key on ceph or as swift object.
06:12:38 <YanXing_an> gongysh: seams that i miss the point
06:13:08 <gongysh> sridhar_ram,  we cannot store fernet key into DB, right
06:13:10 <gongysh>06:13:32 <sridhar_ram> gongysh: yes, thats the underlying restriction we are working with
06:14:22 <sridhar_ram> gongysh: i'm wondering if we shd reach out keystone team again to see if there is a solution (it is > 1 year since we got that recommendation)
06:14:53 <gongysh> YanXing_an, can you reach out to keystone team?
06:15:37 <YanXing_an> gongysh: i will ping keystone team in ML.
06:16:18 <gongysh> #action YanXing_an ping keystone team.
06:17:41 <JimmyYe2528> https://bugs.launchpad.net/tacker/+bug/1667236
06:17:41 <openstack> Launchpad bug 1667236 in tacker "get_vim_resource_id() got an unexpected keyword argument 'vim_auth'" [High,In progress] - Assigned to Yan Xing'an (yanxingan)
06:17:50 <gongysh> YanXing_an, one bug is vnffg functional test.
06:18:16 <YanXing_an> Jimmy Ye will talking about vnffg FT
06:18:16 <gongysh> I think we have a few bugs and patches on vnffg feature.
06:18:51 <gongysh> I want the vnffg functional test to be the gate for us to approve other vnffg small bug fix.
06:19:09 <gongysh> JimmyYe2528, hi
06:19:32 <gongysh> JimmyYe2528, are you here?
06:19:37 <JimmyYe2528> hi
06:20:04 <gongysh> will you come up with a patch to do VNFFG FT?
06:20:11 <JimmyYe2528> yes
06:20:41 <JimmyYe2528> but i need get_vim_resoure_id() fix
06:20:59 <JimmyYe2528> otherwise, FT will run failed
06:21:14 <gongysh> a new change about networking-sfc: it supports symmetric chain now.
06:21:41 <gongysh> JimmyYe2528, yes, but the gate tests failed.
06:21:47 <gongysh> I am waiting the gate tests.
06:22:21 <JimmyYe2528> ok, I'll update part1 for vnffg FT
06:22:21 <gongysh> #topic opendiscussion
06:22:32 <gongysh> JimmyYe2528, thanks.
06:22:50 <JimmyYe2528> :)
06:22:51 <gongysh> JimmyYe2528, and can you spend some time on reviewing.
06:23:16 <gongysh> sridhar_ram, hi
06:23:21 <JimmyYe2528> ok, i can try it
06:23:25 <sridhar_ram> gongysh: fyi, nova possibly using zookeeper to track compute nodes .. https://docs.openstack.org/admin-guide/compute-service-groups.html
06:23:29 <sridhar_ram> gongysh: whats up
06:23:31 <sridhar_ram> ?
06:23:56 <gongysh> sridhar_ram, nova zookeeper, great.
06:24:32 <gongysh> sridhar_ram, in fact if I have time, I want to let neutron to use zookeeper for agents heart beats.
06:24:33 <sridhar_ram> gongysh: i can find only the manual, couldn't find the corresponding code :(
06:24:54 <sridhar_ram> gongysh: but if nova indeed uses it .. it will help your case !
06:25:49 <gongysh> do you guys have something to talk?
06:25:58 <sridhar_ram> nothing else from my side
06:26:21 <gongysh> diga_?
06:26:27 <gongysh> YanXing_an, JimmyYe2528 ?
06:26:44 <diga_> gongysh: hi
06:26:58 <gongysh> diga_, anything to share?
06:27:20 <diga_> gongysh: nothing, once I put another patch I will let you know
06:27:40 <diga_> gongysh: I will take some ownership of review if you want I haven't had any yet on tacker
06:27:53 <gongysh> diga_, you are patch generator.
06:27:57 <diga_> gongysh: may be API/VIM related
06:28:08 <gongysh> ok
06:28:09 <gongysh> lets end the meeting
06:28:18 <gongysh> #endmeeting