05:30:11 <gongysh> #startmeeting tacker
05:30:11 <openstack> Meeting started Wed Mar 15 05:30:11 2017 UTC and is due to finish in 60 minutes. The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:30:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:30:14 <openstack> The meeting name has been set to 'tacker'
05:30:23 <JimmyYe2528> hi
05:30:27 <YanXing_an> o/
05:30:37 <gongysh> #topic roll call
05:30:39 <JimmyYe2528> o/
05:30:43 <tung_doan> hi all
05:30:48 <jeremy_chang> ...
05:30:53 <gongysh> who are you guys are here for tacker meeting?
05:31:07 <gongysh> dkushwaha, hi
05:31:23 <dkushwaha> gongysh, hello
05:31:45 <gongysh> JimmyYe2528, YanXing_an , tung_doan , jeremy_chang , dkushwaha welcome to tacker meeting
05:31:49 <YanXing_an> welcome, jeremy_chang. He is also from china mobile.
05:32:03 <JimmyYe2528> hi all
05:32:39 <gongysh> ok
05:32:46 <tbh> o/
05:32:51 <diga> o/
05:32:56 <gongysh> tbh, diga hi
05:33:13 <diga> gongysh: hello
05:33:16 <dkushwaha> gongysh, sorry I missed last 2 weekly meetings. Just joined office now
05:33:21 <tbh> hi gongysh
05:33:29 <tung_doan> welcome jeremy_chang
05:33:37 <gongysh> #topic agenda
05:33:40 <gongysh> https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_March_15th.2C_2017
05:34:07 <gongysh> sridhar_ram is absent from today's meeting.
05:34:43 <gongysh> so if anyone, in particular the core reviewers, are absent, please put names in agenda.
05:34:45 <gongysh> thanks
05:34:51 <tung_doan> miss you dkushwaha :)
05:35:07 <gongysh> #topic announcement
05:35:16 <dkushwaha> tung_doan, :)
05:35:28 <gongysh> we have done a reservation on Project Onboarding Rooms
05:35:58 <gongysh> so who are you guys going to summit?
05:36:08 <diga> o/
05:36:29 <gongysh> none?
05:36:33 <diga> I will be attending summit this time
05:36:48 <gongysh> +1 diga
05:36:51 <tbh> I haven't decided yet
05:37:07 <gongysh> +1 me. I will go.
05:37:15 <tbh> I will let you know, once it is confirmed
05:37:26 <dkushwaha> gongysh, not sure
05:37:44 <gongysh> dkushwaha, once sure, let team know.
05:37:46 <gongysh> thanks
05:38:17 <gongysh> does someone get topic on tacker accepted?
05:38:32 <diga> I think everyone is waiting for OS travel support confirmation :)
05:38:51 <gongysh> diga, :)
05:38:53 <diga> Not for VIM support submission
05:39:24 <gongysh> it seems we have no tacker topic this time.
05:39:29 <dkushwaha> gongysh, tbh our topic on nsd is not selected.
05:39:48 <gongysh> ok, that is for summit subject.
05:40:07 <gongysh> #topic review stats
05:40:30 <diga> gongysh: Tacker is core project & still no submission is accepted by OS team, I think we should raise this to OpenStack support team
05:40:58 <gongysh> hi guys, I want the team know we will promote core members that is active in reviewing.
05:40:59 <dkushwaha> diga, +1
05:41:53 <gongysh> diga, I will try to complain. but I don't think core project topic will be accept.
05:42:37 <gongysh> http://stackalytics.com/?module=tacker-group
05:42:51 <diga> gongysh: Every core project topic has got at least one submission acceptance, may be we should try to reach right person to raise our concern
05:43:17 <gongysh> our data is improving, but need more efforts.
05:43:39 <diga> gongysh: I will try to improve my reviews, as I haven't got time last week
05:43:59 <gongysh> diga, ok, I will try to ask someone for the topic acceptance.
05:44:20 <gongysh> dkushwaha, tbh, about review, please keep up.
05:44:33 <tung_doan> gongysh: multi-VIM and NSD are good candidate for Pike I think
05:45:02 <dkushwaha> gongysh, yes sure, I will improve it
05:45:20 <tbh> gongysh, I am improving from the last week, I will put more efforts for reviews
05:45:37 <gongysh> tbh, dkushwaha , thanks
05:45:46 <gongysh> let's move to next topic
05:45:50 <gongysh> #features
05:45:58 <gongysh> #topic features and bp
05:46:17 <gongysh> First one I want to talk is task scheduling framework
05:46:31 <gongysh> #link https://review.openstack.org/#/c/443719/
05:47:08 <gongysh> please have a look at https://review.openstack.org/#/c/443719/14/doc/source/devref/task_scheduling_framework.rst
05:47:43 <gongysh> I have put steps to show how to run the scheduling
05:47:56 <gongysh> and how to write task agent.
05:48:01 <diga> gongysh: Have we finalized zookeeper for task scheduling ?
05:48:37 <gongysh> diga, I think we will use the zookeeper with 85 chance now.
05:48:56 <diga> gongysh: okay
05:49:07 <gongysh> diga, and need you guys provide more comments if we have better candidates.
05:49:23 <gongysh> if no, we have to move foreward.
05:49:28 <tbh> gongysh, I need to look to zk more, but I have on doubt, if the task is assigned to worker, and worker is dead in between working on the task, does the scheduler assign the task to other worker?
05:50:07 <gongysh> tbh, you can see the design rule at https://review.openstack.org/#/c/443719/14/doc/source/devref/task_scheduling_framework.rst.
05:50:11 <diga> gongysh: no problem, it is strong framework. Kafka and etc tools are already using it behind the scene
05:50:37 <gongysh> any one can go and come easily.
05:51:27 <tbh> ok
05:51:37 <gongysh> tbh, and dkushwaha , we should put the scheduling bp in at P1
05:51:59 <gongysh> and we will start to move vim and vnf related long live jobs.
05:52:32 <tbh> sure
05:52:37 <gongysh> and for short life task, such as scaling job, I think we should move to mistral.
05:53:10 <dkushwaha> gongysh, sure
05:53:30 <gongysh> ok this is for task scheduling bp.
05:53:38 <gongysh> and for NSD BP
05:53:42 <gongysh> dkushwaha, do you have update?
05:54:37 <tung_doan> dkushwaha: I know symmetric chain was update in network sfc. This is also nice to have
05:54:55 <gongysh> tung_doan, that is for vnffgd
05:55:22 <gongysh> if you are interested in it, tung_doan you can put a patch.
05:55:42 <dkushwaha> gongysh, no update. I will put initial patch within 1 2 days
05:55:50 <tung_doan> gongysh: we have plan to support vnffg for nsd. it is nice to go parallel
05:56:05 <dkushwaha> gongysh, I have to resume it
05:56:17 <gongysh> tung_doan, yes.
05:56:37 <gongysh> dkushwaha, wait for your nsd update next meeting. thanks
05:57:00 <dkushwaha> gongysh, sure
05:57:23 <gongysh> diga, do you want to share the progress of API?
05:57:46 <diga> gongysh: I have fixed issues yesterday on falcon,
05:58:07 <gongysh> diga, yes, that is a progress
05:58:20 <diga> gongysh: I am working on attribute validation & wsgi addition, will push PS by today EOD
05:58:58 <diga> gongysh: I had discussion with ttx in the last week, he guided to use apache if possible
05:59:07 <gongysh> diga, you can do a small API, for example VIM register API first.
05:59:16 <diga> gongysh: yeah
05:59:30 <gongysh> diga, let us know what it will look like in your new API framework.
05:59:42 <diga> gongysh: sure
05:59:45 <gongysh> diga, thanks
05:59:52 <diga> gongysh: welcome!
06:00:14 <gongysh> tung_doan, I know you are active at policy part of tacker
06:00:44 <tung_doan> gongysh: yes,, just try my best :)
06:01:07 <gongysh> tung_doan, and please have a look at the new task scheduling framework, and make sure it will meet the needs of policy task.
06:01:32 <tung_doan> gongysh: sure
06:02:01 <gongysh> it is the feature part
06:02:07 <gongysh> #topic bugs
06:02:37 <gongysh> #link https://launchpad.net/tacker/+milestone/pike-1
06:02:55 <gongysh> please review the bugs and patches that is in progress
06:03:15 <gongysh> #topic bugs of vnffg
06:03:51 <gongysh> #link https://bugs.launchpad.net/tacker/+bug/1668838
06:03:51 <openstack> Launchpad bug 1668838 in tacker "add vnffg functional tests" [High,In progress] - Assigned to Jimmy.Ye (jimmy.ye)
06:04:14 <gongysh> I think this bug's patch should guard our vnffgd features.
06:04:53 <JimmyYe2528> I'll try to do it
06:05:07 <gongysh> so keep our resource on this bug to put it merged as soon as possible.
06:05:38 <gongysh> another topic is VNFFC CI test.
06:06:25 <gongysh> the image on tbh's github seems not stable.
06:07:19 <dkushwaha> gongysh, regarding bug https://bugs.launchpad.net/tacker/+bug/1643576
06:07:19 <openstack> Launchpad bug 1643576 in tacker "Wrong value set required when passing parameter to VNFD" [Medium,In progress] - Assigned to dharmendra (dharmendra-kushwaha)
06:07:19 <tung_doan> gongysh: this is also failed: https://github.com/openstack/tacker/blob/master/tacker/tests/etc/samples/sample-tosca-vnfd-image.yaml#L22
06:07:21 <gongysh> I will have a try to put the images to openstack ci site just like the way kolla is doing.
06:07:52 <dkushwaha> gongysh, I had put a comment on https://review.openstack.org/#/c/417752/ please check it once you get time
06:08:21 <gongysh> dkushwaha ok
06:08:37 <tbh> gongysh, yeah, I am getting mail from github LFS team, about maximum usage of the resources :)
06:08:40 <gongysh> #action gongysh to look at https://bugs.launchpad.net/tacker/+bug/1668838
06:08:40 <openstack> Launchpad bug 1668838 in tacker "add vnffg functional tests" [High,In progress] - Assigned to Jimmy.Ye (jimmy.ye)
06:09:07 <gongysh> #action gongysh to look at https://review.openstack.org/#/c/417752/
06:09:37 <gongysh> #action gongysh to look at the way to put tacker vnfc image.
06:10:17 <gongysh> YanXing_an, hi
06:10:25 <YanXing_an> hi
06:10:37 <gongysh> YanXing_an, can you have a talk about the bartican solution for vim fernet key?
06:10:45 <YanXing_an> https://review.openstack.org/#/c/445543
06:11:01 <YanXing_an> I have reported a draft about using barbican to store vim password.
06:12:37 <gongysh> Just like what is said at the https://review.openstack.org/#/c/445543
06:13:07 <gongysh> we can use barbican to store secret stuff.
06:13:31 <YanXing_an> yes, we can use the Secrets API to store the password of VIM
06:13:57 <gongysh> later we will have other service middle ware to interact with.
06:14:18 <gongysh> for example, SDN controller
06:14:48 <gongysh> we also need store the credentials of those components too.
06:15:04 <gongysh> so I think barbican is a good solution.
06:15:54 <gongysh> YanXing_an, please report a BP at launchpad and write the spec. thanks
06:16:45 <gongysh> other bugs are:
06:16:58 <YanXing_an> gongsh, okay, i will
06:17:07 <gongysh> 1. floatingIP ref bug
06:17:46 <gongysh> floatingip needs changes on three projects, tacker, tosca parser, heat translator
06:17:57 <gongysh> 2. address pair
06:18:09 <gongysh> all these are taken by someone.
06:18:32 <gongysh> 3. one more feature I think makes sense the volume feature
06:19:19 <gongysh> #link https://review.openstack.org/#/c/422066/
06:19:37 <gongysh> if someone wants to take this, welcome
06:20:31 <gongysh> the BP is here
06:20:37 <gongysh> #link https://blueprints.launchpad.net/tacker/+spec/persistent-block-storage
06:20:51 <gongysh> YanXing_an, does your team want to take this BP?
06:21:37 <YanXing_an> i will discuss it with our team
06:21:52 <gongysh> YanXing_an, ok, thanks
06:22:07 <gongysh> Let's move to next topic
06:22:17 <gongysh> #topic open discussion
06:22:37 <gongysh> there are still 8 mins until the end of meeting.
06:22:38 <diga> gongysh: As you told, we have got seperate room for Tacker
06:22:55 <diga> gongysh: is there any schedule we have for 2-3 days
06:22:59 <diga> in summit ?
06:23:07 <gongysh> diga, probably. I think.
06:23:22 <jeremy_chang> gongysh,VNF can be created only by a user with administrator role, is right?
06:23:34 <diga> Ok
06:23:40 <gongysh> jeremy_chang, that depends.
06:24:19 <gongysh> normal users can use existed image, flavor to create VNF.
06:24:53 <jeremy_chang> OK
06:25:07 <gongysh> admin user can create VNF which need to create resource on demand: such as flavors
06:25:51 <gongysh> diga, I will ask summit guys to get know what should be done at forum room.
06:26:07 <gongysh> and get you guys synced.
06:26:43 <gongysh> anything else?
06:26:54 <tung_doan> gongysh: it seems containerized NF bp is neglected. It is really good to consider this bp in Pike. Some folks from opnfv are interested in.
06:27:25 <gongysh> tung_doan, not neglected.
06:27:28 <diga> gongysh: sure
06:27:43 <diga> nothing from my side
06:27:50 <gongysh> if you have time, you can upload codes.
06:28:07 <gongysh> but first, put our existing feature stable at top Priority.
06:28:37 <tung_doan> gongysh: got it.
06:29:09 <gongysh> P1, P2 milestones are for essentail stuff.
06:29:30 <tung_doan> gongysh: agree
06:29:38 <gongysh> ok, core guys, please keep up reviewing.
06:29:58 <gongysh> review, review, is core members' main tasks.
06:30:04 <gongysh> #endmeeting