04:30:37 <gongysh> #startmeeting tacker
04:30:38 <openstack> Meeting started Wed Jul  5 04:30:37 2017 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:30:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:30:41 <openstack> The meeting name has been set to 'tacker'
04:30:52 <gongysh> #topic roll call
04:31:02 <trinaths> o/
04:31:14 <gongysh> trinaths, hi
04:31:25 <trinaths> gongysh: hi
04:31:59 <YanXing_an> o/
04:32:19 <gongysh> YanXing_an, hi
04:32:25 <dkushwaha> o/
04:32:26 <tung_doan> hi all
04:32:31 <janki> o/
04:32:42 <gongysh> YanXing_an, heard your team has requirements on tacker project?
04:32:55 <gongysh> my company last week visits your team.
04:34:11 <gongysh> lets wait for other guys until 35
04:34:27 <YanXing_an> gongysh, yes, i am in ShangHai for business yestoday. My leader has requirements
04:35:16 <gongysh> YanXing_an, great,  let talk on telephone then.
04:36:07 <YanXing_an> gongysh, ok
04:37:03 <gongysh> #topic bps
04:37:37 <gongysh> tung_doan, hi
04:37:39 <gongysh> https://review.openstack.org/#/c/434974/
04:37:42 <tung_doan> hi gongysh
04:38:01 <gongysh> there is no big problem now.
04:38:13 <gongysh> do you have a plan to implement it?
04:38:16 <tung_doan> gongysh: it looks like that
04:38:38 <tung_doan> gongysh: last week I tried with tacker-conductor for vnffg-healing
04:38:42 <gongysh> or have you investigated the implementation
04:38:42 <tung_doan> it looks OK
04:39:33 <tung_doan> i will upload my code in some days
04:39:47 <gongysh> tung_doan,  ok, please hurry up.
04:39:51 <gongysh> we have no much time.
04:39:56 <tung_doan> gongysh: got it. thanks
04:40:12 <gongysh> dkushwaha, could you please have a look at https://review.openstack.org/#/c/434974/?
04:40:32 <dkushwaha> gongysh: sure.
04:40:43 <dkushwaha> gongysh: i will review it
04:40:47 <tung_doan> dkushwaha: thanks :)
04:41:16 <gongysh> dkushwaha, https://review.openstack.org/#/c/448109/, it seems we have no time for it in pike release.
04:41:54 <gongysh> dkushwaha, do you have time for https://review.openstack.org/#/c/467479/?
04:41:55 <dkushwaha> gongysh: Sorry I could not work much in this
04:42:17 <gongysh> YanXing_an,   and you?
04:42:37 <dkushwaha> gongysh: you mean to review it ?
04:42:47 <gongysh> to implement it.
04:42:50 <dkushwaha> sure
04:42:53 <gongysh> spec is merged.
04:43:04 <tung_doan> gongysh: dkushwaha: YanXing_an: vnffg in ns is a nice feature. Hope to have it in pike
04:43:13 <dkushwaha> gongysh: sure, i will take it
04:43:48 <YanXing_an> dkushwaha will be more busy :)
04:43:57 <dkushwaha> tung_doan: right, but i could not work in that
04:44:15 <gongysh> #action dkushwaha taks Implement VNF monitor policies with Mistral workflow https://review.openstack.org/#/c/467479/
04:45:01 <gongysh> dkushwaha, are you sure you can take the https://review.openstack.org/#/c/467479/?
04:45:40 <dkushwaha> gongysh: yes, i will
04:46:44 <gongysh> dkushwaha,  great. lets have patches get merged at least one patch by one week.
04:46:53 <YanXing_an> what about https://review.openstack.org/#/c/448109/ vnffg in ns?
04:47:11 <gongysh> YanXing_an, do you have time on it?
04:47:44 <YanXing_an> gongysh, i think i have time
04:47:53 <gongysh> YanXing_an, great.
04:48:09 <tung_doan> YanXing_an: nice!
04:48:20 <gongysh> YanXing_an, lets finish the spec first.
04:48:26 <YanXing_an> ok
04:48:27 <dkushwaha> YanXing_an: great
04:49:24 <gongysh> so, lets work more closer in these days to make these merged as soon as possible.
04:49:54 <gongysh> YanXing_an,  you can have spec and coding at the same time.
04:50:20 <tung_doan> gongysh: YanXing_an: after vnffg-healing gets merged, i will look into vnffg_scaling. It seems we have several use cases
04:50:44 <YanXing_an> gongysh, what time do you expect the first patch?
04:51:08 <YanXing_an> tung_doan, ok, thanks
04:51:19 * gongysh searching the release plan.
04:54:22 <gongysh> YanXing_an, I think pike-3 is on July 24
04:54:32 <gongysh> but we can have it as exception.
04:54:56 <gongysh> so lets get patch get merged one by one week.
04:55:20 <YanXing_an> gongysh, ok, no much time left.
04:55:55 <gongysh> thanks YanXing_an , dkushwaha , tung_doan
04:56:08 <gongysh> #topic code patch.
04:56:37 <gongysh> dkushwaha, https://review.openstack.org/#/c/476449/
04:56:53 <gongysh> I have tested it manually.
04:57:16 <gongysh> we need to set column default at migration script.
04:57:59 <gongysh> dkushwaha, so please update it, and after testing, we can make it merged.
04:59:00 <gongysh> dkushwaha, are you there?
04:59:05 <dkushwaha> gongysh: ok thanks, i will check
04:59:33 <dkushwaha> gongysh: but I think, we are not adding new column so it should not be
05:00:34 <YanXing_an> tung_doan, do you have WeChat app?
05:01:03 <dkushwaha> gongysh: I will check it again, and will update it
05:01:07 * gongysh is thinking
05:01:10 <tung_doan> YanXing_an: i did not try it yet
05:01:41 <tung_doan> YanXing_an: will ping you later about ut
05:02:06 <YanXing_an> tung_doan, ok
05:03:30 <gongysh> dkushwaha, it is my mistake.
05:03:32 <gongysh> it works
05:03:51 <dkushwaha> gongysh: great :)
05:06:10 <gongysh> dkushwaha, https://review.openstack.org/#/c/472045/
05:08:21 <dkushwaha> gongysh: i will check
05:09:04 <dkushwaha> gongysh: I ewill check after meeting
05:09:07 <gongysh> dkushwaha is busy like an ant worker now :)
05:09:49 <dkushwaha> gongysh: not exactly, but needs to look in code :)
05:10:42 <gongysh> https://review.openstack.org/#/c/477171/
05:10:58 <gongysh> from Bharath Thiruveedula
05:11:54 <gongysh> trinaths, hi
05:13:02 <gongysh> seems trinaths is not here yet.
05:13:26 <dkushwaha> YanXing_an: regarding your comment on https://review.openstack.org/#/c/472045/ . why we need to update openwrt/openwrt.py
05:14:34 <YanXing_an> def mgmt_call(self, plugin, context, vnf, kwargs):
05:14:34 <YanXing_an> if (kwargs[mgmt_constants.KEY_ACTION] !=
05:14:35 <YanXing_an> mgmt_constants.ACTION_UPDATE_VNF):
05:14:35 <YanXing_an> return
05:15:13 <YanXing_an> in create_vnf, the action is ACTION_CREATE_VNF
05:15:41 <dkushwaha> YanXing_an: please check line #305 in patch
05:16:11 <YanXing_an> i see, you modify it to ACTION_UPDATE_VNF, it's ok now.
05:16:27 <dkushwaha> YanXing_an: Thanks :)
05:16:39 <gongysh> https://review.openstack.org/#/c/472045/5/tacker/db/vnfm/vnfm_db.py
05:16:57 <gongysh> I cannot see _save_config_attr is used now
05:17:41 <trinaths> hi
05:18:12 <trinaths> gongysh: back now
05:18:43 <dkushwaha> gongysh: right, i will update
05:19:37 <YanXing_an> gongysh, mgmt_call is called at create/update/delete_vnf, if we add "if config", we need add at all these places.
05:19:49 <gongysh> trinaths, will you help to reivew and test https://review.openstack.org/#/c/477171/
05:20:18 <trinaths> gongysh: yes. i will test it now
05:20:45 <gongysh> #action trinaths helps to review and test https://review.openstack.org/#/c/477171/
05:21:32 <trinaths> ack
05:21:37 <gongysh> YanXing_an, I don't see the meanings to call mgmt_call in create if there is not config at all.
05:22:27 <gongysh> #topic open discussion
05:22:36 <YanXing_an> to make plugin clean?
05:22:44 <trinaths> please add your proposals for OpenStack Sydney summit, https://etherpad.openstack.org/p/tacker_sydney_summit_proposals_2017
05:23:13 <gongysh> I have requested one project update slot.
05:23:25 <gongysh> at sydney summit.
05:23:33 <trinaths> ok
05:23:41 <dkushwaha> gongysh: what about PTG? it will be virtual or physical ?
05:24:54 <gongysh> dkushwaha, will you join a PTG at china? if not, we can have a virtual. at Augest.
05:26:05 <tung_doan> gongysh: janki: I am really interested in containerized VNF in Tacker. Sorry, but this feature can keep up with Pike? :)
05:26:26 <dkushwaha> gongysh: Actually I have a feedback from my company, they are saying that it seems Tacker not much active in PTG or summit, and going slow down. So i will suggest to have physical PTG, even if only few member can join physically and others virtually
05:26:27 <gongysh> tung_doan, no. but you guys can work as a poc.
05:26:59 <trinaths> tung_doan: there is a spec in debate for cVNFs
05:27:00 <YanXing_an> i want to talk about something that chinamobile doing in tacker, what do you think?
05:27:10 <janki> tung_doan, gongysh the issue is that tosca can define deeper hardware level configs while dockerfile cann't
05:27:17 <trinaths> YanXing_an: +1
05:27:31 <janki> also there is no definition available to map tosca elements to dockerfile
05:27:33 <tung_doan> YanXing_an: +1
05:28:00 <gongysh> janki, why do you need a dockerfile?
05:28:13 <gongysh> dockerfile is for creating a docker image.
05:28:15 <janki> gongysh, to create a docker container from that
05:28:28 <janki> ya. so that image will be used
05:29:05 <tung_doan> janki: it requires a lot of time. I just hope we merge this bp in Pike and move development part to Queen release
05:29:12 <gongysh> lets talk about PTG at tacker channel.
05:29:17 <trinaths> ok
05:29:32 <gongysh> time is out.
05:29:35 <trinaths> bye
05:29:40 <gongysh> #endmeeting