04:31:10 <gongysh> #startmeeting tacker
04:31:12 <openstack> Meeting started Wed Aug 23 04:31:10 2017 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:31:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:31:15 <openstack> The meeting name has been set to 'tacker'
04:31:19 <trinaths-m> o/
04:31:29 <gongysh> #topic roll call
04:31:35 <YanXing_an> O/
04:31:43 <gongysh> trinaths-m, YanXing_an  hi
04:31:52 <trinaths-m> Hi all
04:31:57 <tung_doan_> o/
04:32:06 <xuanjia> o/
04:32:16 <gongysh> tung_doan_,  hi
04:32:18 <trinaths-m> tung_doan hi
04:32:28 <gongysh> xuanjia,  nice to meet you.
04:32:43 <tung_doan_> xuanjia: big welcome :)
04:32:45 <phuoc_> o/
04:32:59 <gongysh> tung_doan_, which company do you work for?
04:33:08 <YanXing_an> Welcome, xuanjia, PTL from OPNFV
04:33:39 <phuoc_> Nice to see you here, xuanjia :)
04:34:08 <xuanjia> Nice to see all of you :)  I am the PTL of container4nfv in OPNFV .
04:34:35 <trinaths-m> Hi xuanji
04:34:36 <xuanjia> looking forwarding to seeing how tacker supports container vnf in MANO.
04:34:36 <tung_doan_> I am a member of Korea Open Networking project supported by Korea Minster
04:34:50 <tung_doan_> gongysh: i will ask my boss to get official email soon :)
04:35:49 <gongysh> phuoc_, you too?
04:36:38 <tung_doan_> s/Minster/Minister
04:37:18 <gongysh> #topic coding patches
04:37:37 <phuoc_> gongysh, I am colleague of tung_doan
04:37:47 <gongysh> YanXing_an,  where is your beautiful state transition diagram doc?
04:39:01 <YanXing_an> gongysh, already finished vnf diagram, is drawing ns&vnffg's diagram
04:39:30 <gongysh> YanXing_an, ok
04:39:40 <tbh> o/
04:39:47 <gongysh> tbh hi
04:40:18 <trinaths-m> What are those diagram for?
04:40:22 <YanXing_an> https://review.openstack.org/#/c/473861/, I already put it in this patch
04:40:54 <YanXing_an> VNF/VNFFG/NS in PENDING_DELETE status can't be deleted correctly.
04:41:12 <trinaths-m> xuanjia: we have a working vpp vnf on arm .
04:42:28 <gongysh> YanXing_an,  fhttps://review.openstack.org/#/c/473861/4/test-requirements.txt
04:42:34 <xuanjia> trinaths-m, great. we can talk it later :)  YanXing_an you can go on.
04:43:00 <gongysh> it seems you are specifying wrong version or not existed third software in this file.
04:43:05 <trinaths-m> No worries
04:44:12 <YanXing_an> Gongysh, yeh, I saw the CI failure, will update it
04:44:20 <gongysh> how's your patch going?
04:44:28 <gongysh> tung_doan_, how's your patch going?
04:44:52 <gongysh> I have to cut out pike branch this week.
04:45:56 <tung_doan_> gongysh: phuoc_ and I are working locally on it. now we can update chain after scaling out
04:45:59 <tung_doan_> gongysh: I would like to request for releasing tacker in the end of this month. Is is possible, gongysh?
04:46:15 <tung_doan_> or next week. So sorry for that :(
04:46:28 <gongysh> tung_doan_, I am afraid we cannot.
04:46:56 <tung_doan_> gongysh: which day are you planing to release tacker?
04:47:12 <gongysh> at the end of friday.
04:47:18 <gongysh> this friday.
04:47:46 <gongysh> tung_doan_, this is from release team: We haven't seen tacker branch yet for pike. Just a courtesy reminder that that will need to be done this coming week. Please drop in the #openstack-release channel if you have any questions or need any help.
04:48:19 <tung_doan_> gongysh: got it.
04:48:57 <tung_doan_> gongysh: do you know if dkushwaha can keep up with the dealine?
04:49:18 <tung_doan_> gongysh: i will remind him abt it
04:49:24 <gongysh> I don't think dkushwaha will be able to do it.
04:51:18 <gongysh> tung_doan_,  I think we should cut out pike branch without patches from dkushwaha and tung_doan_.
04:51:44 <YanXing_an> I test dkushwaha's patch this morning, reappear the issue that he raised
04:51:50 <tung_doan_> gongysh: let me try to finish util thursday
04:52:00 <gongysh> tung_doan_, ok
04:52:13 <tung_doan_> and on friday we will request you for review
04:52:24 <tung_doan_> i will cherrypick if having any issues
04:52:48 <tung_doan_> gongysh: thanks
04:52:53 <gongysh> tung_doan_, ok, lets have a try.
04:53:43 <gongysh> YanXing_an, what is the problem with 'https://review.openstack.org/#/c/486924/'
04:54:24 <tung_doan_> see you guys,  i need to go back to produce patches :))
04:54:28 <YanXing_an> Mistral can not see the ping_action defined in tacker
04:55:04 <YanXing_an> I think it's code problem
04:55:24 <gongysh> ok
04:56:32 <gongysh> #topic open discussion
04:56:52 <gongysh> just I have said, we will have pike branch this friday.
04:57:10 <gongysh> so please keep hard working if you want the codes merged.
04:57:31 <gongysh> xuanjia, hi
04:57:45 <gongysh> do you have anything to talk about container vnf?
04:58:17 <xuanjia> i want to know how Tosca supports container template or k8s template ?  is there any discussion now ?
04:58:26 <gongysh> not yet.
04:58:34 <gongysh> phuoc_, do you have any plan?
04:58:49 <trinaths-m> janki had a proposal on this
04:58:51 <phuoc_> gongysh, I have plan to use K8s as VIM
04:59:17 <xuanjia> https://docs.google.com/document/d/1zhJxoMc-_nFop8q2aB2mSjXZ_bjMQq1Ju9_P9ppV_Vo/edit# i see phuoc_ 's doc. we also agree use k8s as VIM
04:59:19 <phuoc_> so I and Janki discussed about it
04:59:19 <gongysh> xuanjia, does industry have related standards?
05:00:06 <phuoc_> and I think if we want to deploy c-VNF in Kubernetes, we need Tosca-to-Kubernetes translator
05:00:23 <gongysh> phuoc_, have you seen any related industry standards?
05:00:25 <xuanjia> gongysh, not yet. so my question is how can we collaborate to contribute our requirements to TOSCA and let TOSCA support it . Then we can know how tacker support container vnf.
05:01:18 <phuoc_> gongysh, I think it is the trend and Telco companies are looking for this feature
05:01:55 <xuanjia> and K8S acts like openstack heat and do more things than openstack heat.
05:02:04 <phuoc_> and until now, there are not much standards for container VNF yet
05:02:06 <gongysh> xuanjia, we have no experience to do this kind of stuff (contribute to TOSCA). if you have,  tacker team can help to verify it, and support the standards.
05:02:35 <xuanjia> okay.thanks :)
05:02:53 <gongysh> xuanjia, I got a meesage that huawei is doing the C-VNF standards.
05:02:55 <xuanjia> if tosca support it , the work for tacker will be easiler :)
05:03:13 <trinaths> xuanjia: yes
05:03:13 <xuanjia> oh?  do you know who is working on it ?
05:03:44 <xuanjia> let me verify it for huawei guys :)
05:03:55 <phuoc_> Its better if we can bring the beta feature of containerized VNF in Tacker
05:04:16 <gongysh> do you know bai chang ming of china mobile, the C-RAN team?
05:04:24 <xuanjia> yep.
05:04:36 <gongysh> he told me the message.
05:04:46 <xuanjia> okay, got it .
05:05:04 <xuanjia> and another question is the 'figure 2' in the https://docs.google.com/document/d/1zhJxoMc-_nFop8q2aB2mSjXZ_bjMQq1Ju9_P9ppV_Vo/edit#
05:06:04 <xuanjia> For tacker team, seems you keep openstack heat and k8s infr driver as a seperate VNFM. is it right ?
05:06:36 <phuoc_> xuanjia: sorry  its my proposal :)
05:06:47 <phuoc_> and it can be change
05:07:48 <xuanjia> okay. we need to discuss it in future.
05:07:56 <phuoc_> so, I pretend to K8s as infra driver in VNFM, not the new one
05:08:06 <gongysh> xuanjia, I think it is just a proposal. you can put your comments there.
05:08:58 <xuanjia> okay. will do that.
05:09:11 <phuoc_> xuanjia, gongysh I hope to get more help to figure out things
05:09:24 <xuanjia> i think we need to let TOSCA team to be involved in .
05:09:39 <gongysh> And for k8s cluster itself, I think we just use the cluster, not to manage the cluster.  we should not care if the magnum or not.
05:10:19 <gongysh> just like the heat driver, tacker does not manage the openstack.
05:10:22 <phuoc_> gongysh, me too
05:10:28 <xuanjia> yes. your're right.
05:11:03 <gongysh> xuanjia, TOSCA team, do you have any contact?
05:11:07 <xuanjia> no...
05:11:23 <gongysh> ok
05:11:34 <xuanjia> i think it need both of us to do it :)
05:11:35 <phuoc_> I see the old PTL of Tacker, he joined Tosca comittee
05:12:10 <gongysh> phuoc_, I will try to contact him. thanks
05:12:29 <gongysh> for PTG, https://etherpad.openstack.org/p/tacker-queen-grooming
05:12:39 <phuoc_> gongysh, thanks
05:12:58 <gongysh> the time is coming close. please propose your ideas.
05:13:14 <trinaths> sure
05:13:49 <xuanjia> okay. so if you contact with TOSCA team, please let me know,  i think it's the most difficlut things for this part.
05:14:01 <gongysh> trinaths,  can you have a talk about topicss you got approval from openstack summits?
05:14:35 <xuanjia> gongysh, trinaths thanks :)
05:14:56 <trinaths> sure
05:15:12 <trinaths> 2 talks on Tacker with tacker team
05:15:17 <trinaths> 1 talk on security
05:15:19 <gongysh> #action, gongysh to get contact with sridaram for tosca team about the c-VNF.
05:15:33 <trinaths> its an Ligthning talk
05:15:58 <gongysh> what are your 2 talks on Tacker with tacker team?
05:16:34 <trinaths> https://www.openstack.org/summit/sydney-2017/summit-schedule/events/19242/openstack-tacker-102-hands-on-lab
05:16:42 <trinaths> https://www.openstack.org/summit/sydney-2017/summit-schedule/events/19240/openstack-collaboration-made-in-heaven-with-mistral-neutron-tacker-and-more
05:16:58 <trinaths> https://www.openstack.org/summit/sydney-2017/summit-schedule/events/19044/sdn-and-nfv-integrated-openstack-cloud-birds-eye-view-on-security
05:17:59 <gongysh> great.
05:18:11 <gongysh> thanks for the tacker promotion jobs.
05:18:28 <gongysh> anything else?
05:18:32 <trinaths> gongysh: yes.. all this happened with the support of our PTL, gongysh
05:18:49 <gongysh> trinaths,  :)
05:19:07 <trinaths> at lab we need more tacker devs to help people on tacker lab activities
05:19:24 <trinaths> so that all their debugging and doubts are cleared.
05:19:54 <trinaths> gongysh: you have a session at summit
05:20:16 <gongysh> I will have project update and a SDN hub session.
05:20:59 <trinaths> great sir
05:21:07 <gongysh> https://www.openstack.org/summit/sydney-2017/summit-schedule/global-search?t=sdn+hub
05:21:21 <gongysh> project update is from community.
05:21:32 <trinaths> gongysh:  its your R&D project
05:21:46 <gongysh> sdn hub is a R&D project.
05:21:49 <gongysh> trinaths, yes.
05:22:19 <trinaths> gongysh: nice. a must attend session
05:22:34 <gongysh> anything else?
05:22:42 <trinaths> i'm off
05:22:49 <gongysh> YanXing_an, hi
05:22:52 <gongysh> anything?
05:23:12 <YanXing_an> i will update the vnffg-ns spec when it finished after this week.
05:23:32 <gongysh> YanXing_an, ok,  that will be Queens feature.
05:23:45 <trinaths> gongysh:  i fot got
05:23:45 <YanXing_an> I have an deep research on mistral last week, and have some thoughts about how to deploy vnffg in ns
05:24:08 <trinaths> forgot* my osc support. Please move it to queen. i will complete it by q2
05:24:22 <trinaths> gongysh: sorry i missed it.
05:24:36 <gongysh> trinaths, never mind.
05:24:47 <gongysh> ok, thanks everyone.
05:24:52 <gongysh> #endmeeting