04:30:18 <gongysh> #startmeeting tacker
04:30:19 <openstack> Meeting started Wed Nov 22 04:30:18 2017 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:30:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:30:22 <openstack> The meeting name has been set to 'tacker'
04:30:33 <gongysh> #topic roll call
04:30:35 <diga> o/
04:30:39 <phuoc_> o/
04:30:41 <gongysh> diga, hi
04:30:46 <Dinesh_Bhor> o/
04:30:50 <diga> gongysh: hello
04:30:53 <MinWookKim> o/
04:31:01 <gongysh> YanXingAn, hi
04:31:10 <YanXingAn> Hi
04:31:14 <gongysh> how is the bug smash day?
04:31:45 <YanXingAn> 40 people
04:32:10 <gongysh> a large team.
04:33:10 <phuoc_> hi janki, Dinesh_Bhor
04:33:43 <janki> o/
04:33:45 <gongysh> it seems dk, our bug triager is not here.
04:33:45 <janki> phuoc_, hey
04:34:08 <gongysh> ok, let get started
04:34:15 <gongysh> #topic bp
04:34:29 <gongysh> phuoc_, anything from your bp?
04:34:47 <phuoc_> first, I will start with mardim's bp
04:34:56 <phuoc_> https://review.openstack.org/#/c/516698/
04:35:30 <phuoc_> about vnffg update, what do you guys think about updating flow-classifier and the path
04:35:54 <phuoc_> should we use parameters or put it all in vnffg file
04:36:45 <phuoc_> update flow-classifier, we can add or delete flow-classifiers
04:37:33 <phuoc_> update path, we can change the order vnfs in path or remove/add new vnfs in vnffg
04:37:34 <gongysh> phuoc_, I think we should have command parameter for it
04:38:07 <diga> yes, parameter way looks good to me for updating
04:38:33 <diga> I haven't gone through the spec yet, will review it today
04:38:39 <phuoc_> because there are too much parameters, if we use parameters it can be hard to to it
04:39:17 <phuoc_> I will discuss with mardim later
04:39:51 <phuoc_> About applying containerized VNF, I will upload [WIP] code in this week
04:40:02 <phuoc_> Hope you guys can review it
04:40:16 <diga> yes
04:40:17 <phuoc_> that's all from me
04:40:25 <gongysh> phuoc_, thanks
04:40:54 <diga> phuoc_: you means for this spec - https://review.openstack.org/#/c/511991/
04:41:07 <diga> it is not merged yet I guess
04:41:18 <phuoc_> diga, yes
04:41:35 <diga> wait, we should merge this first then start working on it
04:41:38 <phuoc_> We need to figure out more thing to merge it :)
04:41:44 <diga> gongysh: can we merge this now ?
04:42:23 <gongysh> diga, our new rules are to merge spec when we have code available.
04:42:23 <diga> phuoc_: yes, will work on it, add those reviews comment
04:42:34 <phuoc_> I think we can code and change spec parallel, because I am also not sure the right way to do it :)
04:42:38 <gongysh> author can code along side spec.
04:42:56 <gongysh> phuoc_, https://review.openstack.org/#/c/510749/
04:43:06 <diga> gongysh: :) when we decided that, didn't know
04:43:21 <gongysh> the CI failed due to ci zuul3's change. I will update it.
04:43:49 <diga> hmm
04:43:50 <phuoc_> gongysh, thanks
04:43:54 <gongysh> diga, this is because we have some specs merged, but no implementation at all.
04:44:05 <diga> hmm
04:44:29 <diga> gongysh: I started the implementation on API framework - https://review.openstack.org/#/c/520495/
04:44:55 <diga> gongysh: This work should go to feature/falcon-api-framework branch
04:45:02 <gongysh> phuoc_, do you have any problems with containized vnf?
04:45:24 <gongysh> we will first use pure k8s vim and then maybe have a k8s-kuryer vim
04:45:47 <gongysh> so assume the current kubernetes vim is a pure k8s vim.
04:45:58 <Dinesh_Bhor> diga: Thanks! The blueprint link in the commit message is broken. Need to be fixed.
04:46:29 <phuoc_> gongysh, sure, now I will focus on features, which can be supported by pure kubernetes and k8s-kuryr
04:46:47 <diga> Dinesh_Bhor: okay, will take a look at it
04:47:11 <diga> gongysh: phuoc_ : Are we talking about K8s as VIM or Containerized VNF on k8s ?
04:47:22 <gongysh> diga, shouldn't we rebase the tacker-api-framework branch?
04:47:43 <gongysh> the API branch is too old
04:47:48 <diga> gongysh: I will do that first,yes
04:48:02 <diga> gongysh: didn't get chance to look at that part actually
04:48:43 <gongysh> diga,  what about openstack command spec?
04:48:55 <gongysh> you said your guys will work on it
04:49:25 <diga> gongysh: by the way, I am planning to submit first base framework without test cases for 1st patch
04:49:38 <diga> gongysh: new comers are working on bug fixes now to get understanding of code base
04:49:51 <gongysh> diga, ok, thanks
04:50:03 <diga> gongysh: will then move them to cli, in the queens-2 release
04:51:04 <gongysh> YanXingAn is on chinese bug smash day
04:51:31 <diga> hnmn3: kapil__ : will be working on bugs now
04:52:04 <gongysh> MinWookKim, hi
04:52:07 <phuoc_> hnmn3, kapil__ thanks!
04:52:18 <MinWookKim> gongysh, ho
04:52:20 <MinWookKim> hi
04:52:34 <gongysh> MinWookKim, could you please talk about your BP?
04:52:36 <hnmn3> phuoc_: welcome
04:52:53 <kapil__> phuoc: Thanks
04:53:32 <MinWookKim> gongysh, Currently in progress, we are considering Respawn, Scale Action. There is nothing special about it.
04:53:59 <gongysh> MinWookKim, do you have a demo for this feature?
04:54:40 <MinWookKim> gongysh, I have a video demo. :)
04:55:21 <diga> MinWookKim: share the link then, will go through it
04:55:59 <gongysh> MinWookKim, yes, great, share it if ok.
04:56:47 <MinWookKim> Okay, Wait a moment
04:57:02 <phuoc_> hnmn3, kapil__, I think you guys can upload the code in Tacker review with [WIP] prefix
04:57:17 <gongysh> MinWookKim, you can put it here anytime.
04:57:22 <gongysh> lets move to next topic
04:57:25 <phuoc_> So, other guys can give comments about it :)
04:57:32 <gongysh> #topic bug
04:57:43 <gongysh> #link https://launchpad.net/tacker/+milestone/queens-2
04:57:47 <diga> phuoc_: they will do it by next week, now they are setting up tacker
04:58:33 <gongysh> seems we have no much progress on bug fixing
04:58:41 <diga> gongysh: what's the end date of queens-2
04:58:43 <gongysh> diga, do you guys have any progress?
04:58:58 <gongysh> 2017-12-07
04:59:18 <diga> gongysh: yes, we will finish atleast 3-4 bugs by next weeks but it seems no our bugs tagged for q-2
05:00:20 <phuoc_> https://bugs.launchpad.net/tacker/+bug/1733491
05:00:20 <openstack> Launchpad bug 1733491 in tacker "NS failed to deploy" [High,New] - Assigned to dharmendra (dharmendra-kushwaha)
05:00:20 <diga> gongysh: also I don't see API-framework BP in the release, can you add it there as I am working on it now
05:00:28 <phuoc_> we have a bug related to ns
05:01:19 <diga> dkushwaha should have attended this meeting, he knows the status of bugs
05:02:02 <gongysh> phuoc_, it is strange, we have CI which have passed the NS creation.
05:02:12 <gongysh> it should be environment problem.
05:02:20 <gongysh> diga, ok
05:02:47 <gongysh> #action pull API BP to queens-3 by gongysh
05:03:00 <diga> gr8
05:03:19 <diga> also pull CLI
05:04:14 <gongysh> #topic open discuss
05:04:29 <MinWookKim> gongysh, I uploaded it.  https://youtu.be/X5zEOu1Ai6k
05:04:46 <gongysh> #link https://youtu.be/X5zEOu1Ai6k
05:06:07 <diga> MinWookKim: Thanks
05:06:41 <MinWookKim> diga, :)
05:06:42 <phuoc_> diga, about VMware spec, Is it good progressing ?
05:07:02 <diga> phuoc_: YEs, I am submitting the BP today, first draft by friday
05:07:25 <diga> phuoc_: looks like Vmware has lot of work to do for integration purpose
05:07:27 <diga> :
05:07:29 <diga> :)
05:07:33 <phuoc_> :)
05:07:56 <phuoc_> I also want to learn VMware
05:08:42 <diga> phuoc_: once I submit a spec, will involve you
05:09:35 <diga> phuoc_: let's talk about containerized VNF tasks after this call
05:09:39 <gongysh> I just watched the video.
05:09:42 <gongysh> it is nice.
05:09:44 <gongysh> thanks
05:10:01 <gongysh> do you guys have anything to talk?
05:10:22 <phuoc_> gongysh, we should improve ns
05:10:23 <gongysh> we should merged the k8s vim related codes before q-2 deadline.
05:10:49 <gongysh> phuoc_,  yes.
05:11:03 <phuoc_> currently, ns can't create vnffg
05:11:17 <gongysh> phuoc_,  there is a bp on it.
05:11:58 <gongysh> https://blueprints.launchpad.net/tacker/+spec/vnffg-ns
05:12:16 <phuoc_> Dinesh_Bhor, I think you can help YangXingAn to start with it
05:13:23 <gongysh> Most of time, YanXingan is persuading his boss to use tacker, so no much time to improve tacker.
05:14:10 <gongysh> Hope Yanxingan will make it to make his boss pay more on tacker.
05:14:34 <gongysh> any other stuff?
05:15:14 <gongysh> if no, we can end today's meeting
05:15:25 <diga> yes
05:15:29 <gongysh> I will have a patch to fix the ci staff.
05:15:40 <gongysh> thanks everyone
05:15:44 <gongysh> #endmeeting