08:00:01 <gongysh> #startmeeting tacker
08:00:02 <openstack> Meeting started Tue May 29 08:00:01 2018 UTC and is due to finish in 60 minutes. The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:06 <openstack> The meeting name has been set to 'tacker'
08:00:20 <dangtrinhnt> hi
08:00:32 <phuoc_> o/
08:00:32 <Li_Jiale> hi
08:01:25 <keiko___> o/
08:01:55 <gongysh> #topic roll call
08:02:00 <phuoc_> o/
08:02:14 <gongysh> keiko___, Li_Jiale phuoc_ dangtrinhnt YanXing_an hi
08:02:30 <YanXing_an> gongysh, hi
08:02:43 <nguyenhai_> o/
08:02:48 <nguyenhai_> hi everybody
08:03:12 <gongysh> nguyenhai_, welcome
08:03:38 <gongysh> hope all of you who were at summit enjoyed it.
08:04:09 <gongysh> and the vancouver sea plane too
08:04:16 <keiko___> right
08:04:20 <dangtrinhnt> gongysh, pretty much :)
08:05:10 <gongysh> in fact, we have discussed the current status of bp in plate and its details.
08:05:32 <gongysh> such as port monitoring bp
08:05:41 <gongysh> #topic blueprint
08:06:00 <gongysh> phuoc_, do you have any update on the k8s related bp?
08:06:47 <phuoc_> not for now, I need to revise this patch https://review.openstack.org/#/c/548109/
08:06:49 <dangtrinhnt> gongysh, do you want me to post here the notes from our last discussion?
08:07:17 <phuoc_> and when it is merged, then I will move to the next patch
08:07:53 <gongysh> dangtrinhnt, lets first discuss the top1 bps.
08:07:53 <gongysh> phuoc_, it failed many ci tasks.
08:08:09 <gongysh> we have to fix these failures.
08:08:53 <phuoc_> these errors happen because of this patch https://github.com/openstack/tosca-parser/commit/7f02df197cdcfee98fec20d468a5ab13eda2fcb8
08:08:59 <YanXing_an> failed due to this : https://review.openstack.org/#/c/524260/ ?
08:09:18 <phuoc_> YanXing_an, that's right
08:09:38 <phuoc_> I need to wait heat-translator release new version
08:10:10 <gongysh> joxyuki, hi
08:10:16 <phuoc_> but Bobh is not online for some days
08:10:17 <joxyuki> hi team
08:10:21 <joxyuki> sorry for late
08:11:18 <phuoc_> After heat-translator release and this patch https://review.openstack.org/#/c/524260/ is merged
08:11:34 <phuoc_> I think everything will be fine
08:12:18 <gongysh> phuoc_, Feb 28 11:05 PM, https://review.openstack.org/#/c/522935
08:12:30 <phuoc_> but we can comment all test cases about alarm, it will let other patches pass test
08:13:22 <gongysh> that patch is merged by heat-translator on Feb 28, why our CI failed now, 3 months later?
08:13:32 <gongysh> interesting
08:13:54 <phuoc_> gongysh, https://pypi.org/project/tosca-parser/#history
08:14:17 <phuoc_> because they've just released it few weeks ago
08:15:32 <YanXing_an> i see the heat-translator version is 1.0.0
08:16:27 <YanXing_an> we are now waiting for v1.1.0?
08:16:37 <phuoc_> YanXing_an, we need to wait new version, such as 1.0.1 or 1.1.0
08:16:43 <dangtrinhnt> YanXing_an, phuoc_'s patch that fixes the issue in heat-translator is must merged recently. So yeah.
08:17:16 <dangtrinhnt> *just
08:18:08 <YanXing_an> dangtrinhnt, thanks, okay
08:18:39 <gongysh> phuoc_, can you make sure the 1.0.0 does not include your patch?
08:19:04 <phuoc_> gongysh, yes
08:19:22 <gongysh> ok
08:19:32 <phuoc_> because my patch in heat-translator was merged in 2 weeks ago
08:19:46 <gongysh> which one?
08:19:50 <YanXing_an> https://review.openstack.org/#/c/523021/
08:19:57 <YanXing_an> right?
08:20:04 <phuoc_> that's right
08:20:08 <gongysh> ok
08:20:43 <gongysh> phuoc_, can you send an email to the core reviewer via mail list to ask for newer release?
08:20:56 <phuoc_> gongysh, sure I will do that
08:21:12 <gongysh> phuoc_ thanks
08:21:53 <gongysh> phuoc_, and could you please send me slides of your lighting talks?
08:22:25 <gongysh> next bp is about mistral monitoring
08:22:52 <gongysh> nguyenhai_, hi
08:23:00 <nguyenhai_> YanXing_an, did you look at it?
08:23:06 <nguyenhai_> I have no update about it
08:23:38 <nguyenhai_> However, when I try to work on it, it raise another bug related to Mistral
08:23:47 <YanXing_an> nguyenhai_, yes, i have look at it
08:23:49 <nguyenhai_> I also summit a patch to fix here: https://review.openstack.org/#/c/568300/
08:24:17 <YanXing_an> I have researched on barbican, we can insert one common user to the acl of tenant�s secret, such as the tacker service user.
08:25:23 <gongysh> YanXing_an, can you file a bp or bug to do it?
08:25:35 <nguyenhai_> yes, it is a good idea. Because last time about VIM monitoring, we don't need to call back to Tacker server, however, in this case, it should be like that
08:25:51 <YanXing_an> but it have some problems, it does not work all ways, still need some work
08:26:50 <gongysh> YanXing_an, can you give more about it?
08:28:20 <YanXing_an> when we register a vim, save the token to barbican as a secret, and then create a acl for this secret
08:29:50 <gongysh> any problem with it?
08:30:12 <gongysh> if not, we can use this solution.
08:31:13 <YanXing_an> some times it works normally, some times failed, maybe env problem
08:31:59 <YanXing_an> I think this solution is ok
08:32:06 <gongysh> YanXing_an, if you have code, I think nguyenhai_ can help
08:32:28 <gongysh> YanXing_an, will you file a bp for it?
08:32:51 <YanXing_an> gongysh, ok, i will file a bp
08:32:58 <gongysh> maybe we can finish it at hackthon
08:33:20 <nguyenhai_> thanks YangXing_an, gongysh
08:33:28 <YanXing_an> gongysh, good idea:)
08:33:33 <gongysh> I think next bp is the affinity policy
08:34:05 <joxyuki> gongysh, Dinesh submitted a patch for it.
08:34:08 <gongysh> I have seen some patches are in.
08:34:16 <gongysh> great
08:34:30 <gongysh> those are three bps at top 1.
08:34:41 <gongysh> #topic open discussion
08:34:46 <gongysh> dangtrinhnt, hi
08:35:30 <gongysh> I have to leave in 5 mins.
08:35:48 <gongysh> anything to talk?
08:35:49 <dangtrinhnt> hi
08:36:01 <dangtrinhnt> nothing much. Just need time to finish the bps
08:36:09 <gongysh> dangtrinhnt, yes
08:36:39 <gongysh> anything else?
08:37:01 <phuoc_> I am okie
08:37:05 <phuoc_> xD
08:37:10 <gongysh> nice
08:37:19 <gongysh> joxyuki, hi
08:37:43 <joxyuki> gongysh, hi. I have no topic
08:37:59 <gongysh> dangtrinhnt, can you set up dynamic sfc with our own zabbix feature?
08:38:15 <gongysh> and then finish the doc
08:39:13 <gongysh> just as I commented at your doc patch.
08:39:33 <dangtrinhnt> gongysh, I will do it.
08:40:04 <gongysh> #action to register a bp so that a tacker service account can access tenant's vim in barbican
08:40:41 <gongysh> #action phuoc_ will send an email to ask heat-translator team to have a new release so that tacker CI tasks can pass.
08:40:52 <gongysh> thanks
08:40:58 <gongysh> #endmeeting