17:01:50 <jasonsb> #startmeeting tailgate
17:01:51 <openstack> Meeting started Thu Jul  9 17:01:50 2015 UTC and is due to finish in 60 minutes.  The chair is jasonsb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:56 <openstack> The meeting name has been set to 'tailgate'
17:02:00 <beisner> ooo fancy bot action
17:02:07 <jasonsb> its nice
17:02:10 <jasonsb> yay gema
17:02:25 <malini> & she is green too !!!
17:02:25 <jasonsb> #topic update on last week's actions
17:02:42 <beisner> she's also not here today, so we can assign her all of the to-dos
17:02:49 <malini> +1 ;)
17:02:57 <jasonsb> #link last meeting summary: http://eavesdrop.openstack.org/meetings/tailgate/2015/tailgate.2015-07-02-17.00.html
17:03:03 <jasonsb> exactly
17:03:30 <jasonsb> lets pick up a few actions from two meetings ago
17:03:33 <jasonsb> spyderdyne to talk to boris about rally not cleaning up after itself and ways to mitigate, also talk to him about running again when things go wrong
17:03:56 <jasonsb> spyderdyne: would you mind repeating your rally update?
17:04:06 <spyderdyne> putting together a spec to present to them
17:04:13 <spyderdyne> 50% complete
17:04:54 <jasonsb> should i keep as action?
17:04:59 <spyderdyne> please
17:05:36 <jasonsb> #action spyderdyne composing a spec to present to rally on topic of rally cleanup
17:05:49 <spyderdyne> have produced an external script in another repo that should work for this as well,
17:06:14 <jasonsb> link?
17:06:22 <spyderdyne> but it does not incorporate any of the intelligence in rally and rather just looks for the regex "rally_" in each service and removes entries
17:06:42 <spyderdyne> git clone -b kloudbuster https://github.com/stackforge/vmtp.git
17:07:05 <spyderdyne> its in there somewhere.  will provide the actual code later if oyu want it
17:07:17 <jasonsb> sounds good
17:07:29 <jasonsb> next item
17:07:30 <spyderdyne> i think I can just submit in launchpad and see if they accept it
17:08:02 <jasonsb> doesnt hurt to just put it up on gerrit and mark it WIP
17:08:06 <jasonsb> people can comment
17:08:17 <jasonsb> we have HA discussion from 2 weeks back
17:08:37 <jasonsb> currently accepting volunteers if anybody would like to present anything
17:08:59 <jasonsb> spyderdyne i think is a volunteer, but for a future meeting
17:09:00 <malini> Somebody had started on tht -rt?
17:09:09 <jasonsb> spyderdyne: do i have that right?
17:09:11 <spyderdyne> i was unable to run any of the HA scripts we are using internally for HA testing but shoudl have another opportunity tomororw
17:09:14 <spyderdyne> correct
17:09:46 <jasonsb> next item
17:09:46 <spyderdyne> they are marked as part of my new battery of tests I will be running over the course of the next week in a new deployment
17:10:17 <jasonsb> can i make an action to ask you again in couple of weeks?
17:10:22 <jasonsb> :)
17:10:24 <spyderdyne> yes
17:10:30 <jasonsb> awesome
17:10:45 <spyderdyne> am hpoing for the next meeting, but 2 weeks is comfortable
17:11:08 <jasonsb> #action spyderdyne check back to see if any updates/info for HA testing discussion
17:11:43 <jasonsb> there was a good discussion with hogepodge on defcore last week
17:11:49 <jasonsb> #link http://eavesdrop.openstack.org/#DefCore_Committee_Meeting
17:11:53 <jasonsb> since gema not here keeping her action
17:11:58 <jasonsb> #action gema to submit a few test runs of refstack and get familiar with it
17:12:06 <jasonsb> also keep her tempest action
17:12:10 <jasonsb> #action gema to talk to matthew about stable tempest kilo and report back
17:12:55 <jasonsb> there is a topic for malini on giving a walkthrough of rackspace testing
17:13:01 <spyderdyne> cleanup script: https://github.com/stackforge/vmtp/commit/af1e5ca210b5eec2ceba0aa6caf27993d37f2a9d
17:13:04 <jasonsb> i think this has morphed a bit
17:13:07 <malini> not yet
17:13:07 <spyderdyne> replace KB with rally_
17:13:28 <malini> But as we discussed earlier, it'll be good to tackle on a per project basis
17:13:32 <jasonsb> into capturing testing strategies per project
17:13:44 <malini> & Get into the integration part after we do the per project
17:14:15 <spyderdyne> If this is current it may be useful for the rackspace discussion:  https://wiki.openstack.org/wiki/UnifiedInstrumentationMetering
17:14:15 <jasonsb> so chop it up into bite size pieces to discuss?
17:14:40 <malini> yes
17:15:01 <malini> We can pick the core projects & tackle them one by one
17:15:31 <jasonsb> i think spyderdyne expressed interest in working on a way to capture the test strategies (per project)
17:15:49 <malini> tht sounds like the most efficient way to get info
17:15:54 <jasonsb> google form or similar
17:16:08 <spyderdyne> i propose that it would be more time friendly to create a quiz/form for each member to fill out and submit rather than spending the next year covering each org's methods by project
17:16:14 <jasonsb> who would be willing to contribute?
17:16:46 <malini> We can have each person here hunt down the respective folks in their companies for info
17:16:52 <spyderdyne> by the time we completed an iteration of the reveiw everyone would be doing something different anyway
17:17:13 <malini> eg. I can find all the rax folks in different projects & have the update the surver link
17:17:16 <beisner> i like gdocs for shared braindumps
17:17:26 <spyderdyne> this ideally would also allow anyone to change their responses anytime something changes
17:17:41 <jasonsb> i like it
17:17:48 <spyderdyne> i suggested something like this:  http://justingale.com/2013/09/url-tricks-for-google-forms-pre-populate-and-automatically-submitting-responses/
17:17:49 <beisner> easy to turn into a formatted & arranged collection of info
17:18:05 <malini> if we can also have folks from Cisco, Hitachi, CAnonical etc. get their folks to  contribute, we can have decent info
17:18:14 <spyderdyne> yes
17:18:27 <spyderdyne> the more the merrier without sucking up meeting and projec time
17:18:31 <jasonsb> #action spyderdyne work on a goog doc/form to capture per project testing strategies so we can crowdsource good info
17:18:52 <spyderdyne> im going to need an assistant
17:18:53 <spyderdyne> lol
17:19:07 <jasonsb> i was just thinking that
17:19:20 <jasonsb> i would be happy to help with the goog piece
17:19:25 <spyderdyne> ok
17:19:36 <spyderdyne> call us a breakout team on this item?
17:19:43 <jasonsb> i will circulate it within hitachi
17:20:04 <malini> you might want to actionize all of us to circulate within the respective companies
17:20:34 <spyderdyne> i can at cisco as well
17:20:42 <jasonsb> good idea.  i'll set it as action for next time
17:21:02 <malini> gema for canonical
17:21:11 <malini> he hee..all the actions we can give her
17:21:19 <spyderdyne> i have friends in other large orgs that may have interest as well
17:21:22 <jasonsb> #action malini open topic of actioning tailgate members to circulate test strategy goog doc within respective company
17:21:37 <jasonsb> oh, should i have put gema?
17:21:50 <malini> hmm..I just meant an action tag for each of us :D
17:22:02 <malini> maybe update tht action tag to put all our names?
17:22:04 <jasonsb> oh, you get to make that next week :)
17:22:14 <jasonsb> when we have the goog doc (draft)
17:22:21 <malini> sounds good
17:22:37 <jasonsb> ok thast all i had for updates
17:22:49 <jasonsb> #topic talk@tokyo "testing beyond the gate"
17:23:09 <jasonsb> gema had sent an email about call for speakers for tokyo
17:23:13 <beisner> #link https://etherpad.openstack.org/p/tailgaters-tokyo-summit
17:24:01 <malini> lets vote on the tile/ start updating etherpad
17:24:02 <jasonsb> the response was quite positive i think
17:24:07 <malini> title*
17:24:15 <jasonsb> shall we take a vote?
17:24:23 <jasonsb> any +1's?
17:24:32 <beisner> +1 Testing Beyond the Gate
17:24:36 <malini> +1
17:24:40 <spyderdyne> +1
17:25:06 <jasonsb> +1
17:25:22 <malini> can we get rid of the rest from the etherpad?
17:25:48 <malini> I just did (A)
17:25:52 <jasonsb> malini: move it to goog doc?
17:26:12 <malini> keep it at etherpad for now?
17:26:29 <malini> Once we are all done scratching & scribbling, we can move to gdoc
17:26:33 <malini> sounds ok?
17:26:33 <beisner> i think epad is ok for our purposes on this
17:26:49 <jasonsb> malini: you wanted to nail down title?
17:26:51 <spyderdyne> i prefer EP
17:27:06 <malini> we just nailed down the title rt?
17:27:21 <jasonsb> everybody happy with the title?
17:27:27 <spyderdyne> yes
17:27:30 <beisner> yep
17:27:37 <spyderdyne> very clever
17:27:38 <spyderdyne> :)
17:27:44 <malini> Lets start putting our thoughts into the etherpad, agree, disagree, new stuff etc.
17:27:48 <malini> we can clean up later
17:28:04 <jasonsb> awesome
17:28:24 <beisner> i'd suggest we take Option2 and expand on that.  whaddaya think?
17:28:57 <malini> as long as we take out a lot of the fluff
17:29:14 <malini> we need something crisp & to the point.
17:29:28 <beisner> +1 defluff, distill it
17:29:42 <spyderdyne> what we are testing, how we are testing it, what are the issues, how do we propose to solve
17:29:44 <spyderdyne> ?
17:30:27 <beisner> ok...  so are we wanting to present on testing clouds;  or are we wanting to present on who we are, what we want to do, why this is necessary, and how "you" can help?
17:30:28 <malini> I like the outline better than our abstract
17:30:34 <beisner> i could see two proposals actually
17:30:34 <jasonsb> motivations might be worth discussing too
17:30:48 <spyderdyne> +1 on motivations
17:31:07 <jasonsb> the gate using devstack doesn't cover everything
17:31:14 <malini> anybody has the link handy for call for speakers?
17:31:23 <jasonsb> testing on a production cloud is different
17:31:31 <beisner> #link https://www.openstack.org/summit/tokyo-2015/call-for-speakers/
17:31:50 <jasonsb> i think this means we need to focus on what we will accomplish this cycle and next
17:31:54 <malini> "Real-world user stories and in-the-trenches experiences are favored over sales pitches."
17:32:01 <spyderdyne> yes
17:32:04 <malini> tht is us :)
17:32:18 <spyderdyne> i think there is huge value for anyone using openstack to see what others are doing
17:32:26 <spyderdyne> what works, and what the issues are
17:32:37 <spyderdyne> then the community has something to look at addressing
17:32:49 <malini> jasonsb: I think we'll have a better idea of what we will do, once we go thru the exercise of collecting info from all companies
17:32:56 <spyderdyne> +1
17:33:06 <malini> Despite 2-3 months, we are still cloudy on what we want to do
17:33:15 <spyderdyne> identify commonalities
17:33:31 <malini> not a bad thing, since we are trying to tackle something huge
17:33:52 <spyderdyne> i would like to suggest that we specifically will not be able to address every issue
17:34:01 <jasonsb> i see it as somewhat of a problem of where-to-start
17:34:07 <malini> spyderdyne: exactly
17:34:22 <spyderdyne> and that our value may be greatest in providing a framework where these items can be identified and worked through collectively
17:34:33 <jasonsb> +1
17:34:35 <malini> spyderdyne: agreed
17:34:53 <spyderdyne> 1. identify methods, commonalities, and pain points
17:34:56 <malini> If we identify the problems, interested parties can pool together to address them
17:34:59 <spyderdyne> 2. address pain points
17:35:19 <spyderdyne> imho that is the best way to approach this
17:35:44 <beisner> what if:   We propose 2 talks ... (a) who/what/why/motives/call to arms;  and (b) a cross-section of our actual test approaches ?
17:36:00 <jasonsb> hogepodge also made some interesting comments about defcore testing welcoming tailgate
17:36:13 <malini> beisner: +1
17:36:14 <hogepodge> o/
17:36:17 <hogepodge> Hello!
17:36:22 <spyderdyne> for a July 20th speaker call I think all we can expect to present as of this minute is to provide a framework for the dialogue and demonstrate some of the common solutions
17:36:37 <hogepodge> Yes, please, come to our meetings. Next one is Wednesday.
17:36:49 <jasonsb> hogepodge: oh yay your on
17:36:52 <beisner> with (b) being us each taking 10 min or so to talk about our very specific things
17:36:59 <jasonsb> hogepodge: could you give time and link to meeting?
17:37:01 <malini> sure hogepodge..I tried last time, but wasnt sure how to start without hijacking
17:37:21 <malini> maybe we should add us to the defcore agenda?
17:37:31 <beisner> (b) being determined and collectively agreed upon based on this gdoc circulated info collection thing ;-)
17:38:59 <hogepodge> Looking for the links
17:39:01 <jasonsb> beisner: i like it
17:39:16 <spyderdyne> our subject is all encompassing like defcore, but we are exploring minutia that they probably want to be left out of
17:39:17 <spyderdyne> :)
17:39:19 <malini> I like the two talk idea
17:39:28 <hogepodge> #link http://eavesdrop.openstack.org/#DefCore_Committee_Meeting
17:39:31 <jasonsb> beisner: chop 40 minute time slot into 20 + lightning talks?
17:39:37 <spyderdyne> we have a very narrow focus
17:39:59 <hogepodge> (the link is wrong though, all meetings on Wednesday)
17:40:00 <malini> Testing Beyond the Gate, Fixing beyond the gate :D
17:40:15 <beisner> jasonsb, sure something like that would be a good format i think
17:40:16 <spyderdyne> oiling the gate
17:40:17 <hogepodge> next week is at 1500
17:40:50 <hogepodge> The agenda is published on the defcore-committee mailing list and can be modified in the etherpad
17:41:28 <jasonsb> do we have to decide now about format?
17:41:41 <jasonsb> gema i think said she wanted to submit monday
17:41:58 <malini> July 15th  is the deadline
17:42:02 <malini> So Gema is right
17:42:37 <malini> quoting beisner 'who/what/why/motives/call to arms;  and (b) a cross-section of our actual test approaches ?'
17:43:24 <jasonsb> i wonder how much time we can get
17:43:28 <spyderdyne> we know we need to provide a purpose for the effort, a way to contribute, and maybe show some cool gadgets for getting results
17:43:30 <jasonsb> b almost sounds like a fishbowl to me
17:44:14 <malini> jasonsb: 'like a fishbowl to me' what does tht mean?
17:44:19 <malini> good or bad?
17:44:34 <beisner> So with the deadline being right around the corner, shall we get 2 or more heads on each of the 2 talks to nail down proposals out of band?  then bring those back here on Fri/Mon for final review?
17:44:50 <malini> beisner: +1
17:44:51 <jasonsb> sorry, sounds like a fishbowl session where you present to wide audience
17:44:56 <beisner> i might suggest that those who have been more involved with other projects take (a);  and those who do a ton of testing now, take (b)
17:44:57 <jasonsb> on a technical topic
17:46:36 <jasonsb> beisner: good idea
17:46:46 <jasonsb> beisner: but maybe for submission we only have to do a?
17:46:54 <malini> Sounds like (b) will lead to (a)
17:46:56 <malini> a
17:47:00 <jasonsb> and just list b as "lightning talks"
17:47:09 <spyderdyne> +1
17:48:04 <malini> But there is advantage of b being one single talk
17:48:14 <spyderdyne> there is
17:48:25 <malini> It will highlight how all of us testing the same thing differently
17:48:36 <malini> & why there is value in joining forces
17:48:50 <jasonsb> +1
17:48:56 <jasonsb> yes you are right
17:49:20 <beisner> i think 2 submissions: (a) proposed under "How to Contribute" or "Community";  and (b) proposed under "Enterprise IT Strategies"
17:49:51 <malini> good idea
17:49:55 <beisner> or (b) in "User Stories" ?
17:51:08 <spyderdyne> Enterprise IT Strategies
17:51:12 <malini> beisner: where are u seeing these sections?
17:51:25 <malini> The 'Enterprise IT Strategies' might be like the walmart stories -rt?
17:51:47 <beisner> you may have to be logged in
17:51:50 <beisner> #link http://paste.ubuntu.com/11850138/
17:51:54 <malini> where we have the CTO of so & so come tell us how they make more money
17:52:04 <malini> I think we are much lower in the food chain :/
17:53:12 <malini> I think we are almost out of time
17:53:25 <jasonsb> community?
17:53:39 <malini> Community —> for why we shud join forces talk
17:53:48 <jasonsb> exactly
17:53:49 <malini> User Stories —> How each of us are testing
17:53:51 <beisner> i'd go (a) community & (b) user stories
17:54:40 <malini> How each of us are testing will have more details once we do the spreadsheet exercixe
17:54:55 <malini> But we can just create a small gist for the topic submission
17:54:58 <jasonsb> who/what/why/motives/call to arms -> community
17:55:10 <malini> Anybody has prior experience submitting accepted talks?
17:55:10 <beisner> for the proposal, we just need an abstract that states what cool stuff we will be talking about.  we don't have to have the whole thing figured out this week.
17:55:18 <malini> beisner: exactly
17:55:31 <malini> I can start working on the who/what/why/motives/call to arms -> community
17:55:50 <malini> I will send out the etherpad link for folks to start adding ideas
17:56:00 <spyderdyne> good
17:56:04 <jasonsb> beisner: were you intending the single cross-section talk to go to user stories?
17:56:05 <malini> Well we dont necessarily need tht maybe?
17:56:28 <malini> We can split some of the sttuff in existing etherpad into two?
17:56:38 <malini> We already have a good pool of ideas there
17:56:52 <spyderdyne> sounds like a winner
17:57:02 <beisner> jasonsb, i think the session (b) where we talk about our specific test approaches is either operations or user stories.  retract my enterprise it suggestion ;-)
17:57:22 <jasonsb> beisner: got it
17:57:37 <jasonsb> i like the idea of submit to operations or user stories
17:58:02 <jasonsb> it shows we have technical depth
17:58:07 <spyderdyne> :)
17:58:18 <malini> Operations as per  definition sounds good too - though the name sounds like …well 'operations'
17:58:20 <jasonsb> can always collapse into 1 talk
17:58:20 <beisner> ok let's determine the 2 submitters
17:58:57 <malini> gema can do one & somebody else can do the other.
17:59:08 <malini> We can have multiple ppl listed as speakers
17:59:09 <beisner> and the 2 people who submit those will need email addresses for "other speakers" in order to list them, and i believe those ppl must have already created a speaker bio etc
17:59:26 <malini> sounds like work now :(
17:59:50 <jasonsb> any volunteers?
17:59:51 <beisner> i'd be happy to submit (b).  i submitted a handful of things on different topics today.
18:00:14 <jasonsb> awesome
18:00:15 <malini> gema can possibly do a
18:00:32 <malini> She already started tht -rt?
18:01:00 <jasonsb> #action beisner to do talk submission for operations or user stories track
18:01:00 <malini> we will keep the existing etherpad for a
18:01:14 <malini> beisner: can u send the etherpad link when you have it?
18:01:55 <jasonsb> maybe we should spread out submission between companies
18:02:07 <jasonsb> to show the collaboration aspect
18:02:11 <beisner> definitely
18:02:11 <malini> good point
18:02:24 <beisner> malini, you're doing a, right?   if i do b, we have different companies.
18:02:37 <malini> lets check with gema tht she is ok
18:02:50 <malini> She did bulk of the writing up
18:03:00 <jasonsb> when is she back?
18:03:00 <malini> If she is, I can submit tht
18:03:08 <malini> need to run to another meeting
18:03:16 <jasonsb> yes, we are out of time
18:03:19 <malini> But feel free to actionize me for anything
18:03:22 <jasonsb> can i put action to check with gema?
18:04:19 <jasonsb> #action malini check with gema to coordinate who should do talk submission for community track
18:04:29 <jasonsb> ok, any other topics or close it out
18:04:59 <jasonsb> ok, closing out.  thanks all!
18:05:02 <jasonsb> #endmeeting